New issue
Advanced search Search tips
Starred by 9 users

Issue metadata

Status: Duplicate
Merged: issue 8606
Owner: ----
Closed: Aug 2009
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: ----
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 18608: 64bit flash plugin does not work

Reported by oliver.g...@gmail.com, Aug 6 2009

Issue description

Chrome Version       : <include svn revno; e.g. dpkg -s chromium-browser>
OS + version : Ubuntu 9.04
CPU architecture (32-bit / 64-bit): 64
window manager : metacity
URLs (if applicable) : youtube.com
Behavior in Firefox 3.x (if applicable): works as expected
Behavior in Chrome for Windows (optional): n/a

What steps will reproduce the problem?
1. place libflahsplayer.so in plugins directory
2. start chrmoe with --enable-plugins
3. all flash sites state I need the latest flash plugin..  I cannot (don't 
want to) try with the 32-bit plugin as it installs all kinds of other 32-
bit dependencies that make my default firefox much slower...

Thanks

What is the expected result?


What happens instead?


Please provide any additional information below. Attach a screenshot
and backtrace if possible.
 

Comment 1 by oliver.g...@gmail.com, Aug 6 2009

Architecture: amd64
Version: 3.0.196.0-r22005

Comment 2 by dinyar.r...@gmail.com, Aug 8 2009

I can confirm this, though I'm not sure if the problem isn't on the user-side I found 
the following console-output:

dinyar@dinyar-notebook:~$ google-chrome --enable-plugins
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-
2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
[27740:27748:755890261843:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/opt/google/chrome/plugins/libjavaplugin.so: 
/opt/google/chrome/plugins/libjavaplugin.so: wrong ELF class: ELFCLASS64
[27740:27748:755890262279:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/flash-mozilla.so: /usr/lib/mozilla/plugins/flash-mozilla.so: 
wrong ELF class: ELFCLASS64
[27740:27748:755890262365:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/libjavaplugin.so: /usr/lib/mozilla/plugins/libjavaplugin.so: 
wrong ELF class: ELFCLASS64
[27740:27748:755890262446:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: 
/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: wrong ELF class: 
ELFCLASS64
[27740:27748:755890262535:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/libtotem-complex-plugin.so: 
/usr/lib/mozilla/plugins/libtotem-complex-plugin.so: wrong ELF class: ELFCLASS64
[27740:27748:755890262618:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: /usr/lib/mozilla/plugins/libtotem-
gmp-plugin.so: wrong ELF class: ELFCLASS64
[27740:27748:755890262702:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: /usr/lib/mozilla/plugins/libtotem-
mully-plugin.so: wrong ELF class: ELFCLASS64
[27740:27748:755890262790:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: 
/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: wrong ELF class: ELFCLASS64
[27740:27748:755890262869:ERROR:/b/slave/chrome-official-
linux/build/src/base/native_library_linux.cc(19)] dlopen failed when trying to open 
/usr/lib/mozilla/plugins/npPicasa3.so: /usr/lib/mozilla/plugins/npPicasa3.so: wrong 
ELF class: ELFCLASS64


Note that Chrome apparently looks for plugins in the Firefox/Iceweasel folders 
aswell. I suspect there is no need to place the plugins in the dedicated plugins 
directory, am I right about this? In any case I tried both, placing the plugins in 
the dedicated directory and leaving them out, both led to the same results.

Comment 3 by dinyar.r...@gmail.com, Aug 8 2009

I'm sorry, I'm using the latest build (that is 3.0.197.11-r22553), also amd64 and 
Debian sid.

Comment 4 by oliver.g...@gmail.com, Aug 8 2009

I also get all of the same errors for each of my installed mozilla plugins...

I assume it is 32 vs 64 bit

Comment 5 by dinyar.r...@gmail.com, Aug 8 2009

yes, I guess chrome needs 32-bit plugins whereas we have the 64-bit ones installed. 
seeing as i don't feel like installing all plugins in 32-bit aswell we'll just have to 
wait for a native chrome..

Comment 6 by niel...@gmail.com, Aug 10 2009

fix:

locate the chromium lib folder...
in my ubuntu:  /usr/lib/chromium-browser/
now... sudo ln -s /usr/lib/flashplugin-installer/libflashplayer.so

and...
cd /usr/lib/chromium-browser/
mkdir plugins
cd plugins
sudo ln -s /usr/lib/flashplugin-installer/libflashplayer.so

THANAM... flash works, but no sound :(

:D  ~

Comment 7 by oliver.g...@gmail.com, Aug 10 2009

That's 32-bit flash..  Ubuntu does not offer the 64 bit version..  You have to get it
manually from Adobe's website and install the lib youorself..  When you install flash
plugin, notice all of the ia32 libs that get installed with it..  That is so flash
can run...

I don't use the ubuntu supplied stuff for that....

Comment 8 by niel...@gmail.com, Aug 10 2009

reporting...

work only with root, even using 'sudo' the flash-plugin doesn't work.

:D  ~

Comment 9 by stephen....@gmail.com, Aug 10 2009

It seems that the deb version
(http://dl.google.com/linux/direct/google-chrome-unstable_current_amd64.deb) is in
fact a 32 bit version.

I've just installed it on my computer, had the same problem.

stephenamar@electron:~$ file /opt/google/chrome/chrome
/opt/google/chrome/chrome: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped

Comment 10 by stephen....@gmail.com, Aug 12 2009

I think this bug is directly related to 8606

Comment 11 by oliver.g...@gmail.com, Aug 13 2009

64amd extension on their debs does in no way mean they are 64 bit versions..  Just
means they run on 64 bit OS, like you discovered...

Oh well, have to wait till the chromium dev decide that all NEW computers for the
last 5 years are 64 bit and get up to spped in the game and disregard all of their
old 32 bit building tools that they are familiar with....

Sucks that you can rarely buy a compouter with a 32bit OS anymore, but your
webbrowser has to be so it can run plugins...  What a shame..  Figured someone like
google with $$ in the bank would have grown some balls...  changes are trivial
especially since the majority of plugins have 64 bit versions now..  java, flash.. 
(what else is reazlly needed)..  anything else can be run external to the browser.. 
I mean really, who likes using the mplayer or totem plugin ina browser - only idiots!!!!

Comment 12 by ger...@gmail.com, Aug 13 2009

Agree with Stephen (comment 10) this is a dup of 8606

Comment 13 by est...@chromium.org, Aug 15 2009

Mergedinto: 8606
Status: Duplicate

Comment 14 by adman....@gmail.com, Aug 16 2009

You could try compiling your own 64bit Chromium as instructions at 
http://code.google.com/p/chromium/wiki/LinuxChromium64 . I would try it myself, but 
900mb just for the source code is a bit too much for me to download now.
I'm not sure how complete the 64bit version is, but I would assume that with a bit of 
work, you could get 64-bit plugins to work this way.

Comment 15 by felix.sa...@gmail.com, Aug 20 2009

Is there any change that this will help?
http://queleimporta.com/en/how-to-install-flash-10-rc-on-ubuntu-64-bits-with-2-clicks/ My
attempts failed with Chrome, but my linux-fu is weak.

Comment 16 by oliver.g...@gmail.com, Aug 20 2009

It works fine when I compile my own 64-bit cromium with the 64 bit plugin from adobe...

Thanks

Comment 17 by arbran...@gmail.com, Aug 20 2009

If you're on Ubuntu, use the Daily Chromium PPA.  The amd64 debs are native 64-bit, and 
the Flash plugin works fine with them.

https://launchpad.net/~chromium-daily/+archive/ppa

Comment 18 by oliver.g...@gmail.com, Aug 20 2009

Yeah, but to get backtraces for bugs, I would have to download 150MB per new daily
build..  I can svn the minor changes and compile in way less time...

When it starts to get more stable, I will re-enable the PPA and start using it of
course..

Thanks

Comment 19 by dinyar.r...@gmail.com, Aug 20 2009

fyi the Daily Chromium PPA also works on Debian. i used the jaunty repo for Sid and 
there were no problems.

Comment 20 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Sign in to add a comment