New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 8606
Owner: ----
Closed: Aug 2009
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: ----
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 18398: amd64 version is 32-bit binary

Reported by reinaldo...@gmail.com, Aug 4 2009

Issue description

Chrome Version       :  google-chrome-unstable_current_amd64.deb 2009-08-04
OS + version : Slackware64 -current
CPU architecture (32-bit / 64-bit): 64-bit
window manager : KDE4
URLs (if applicable) :
Behavior in Firefox 3.x (if applicable):
Behavior in Chrome for Windows (optional):

What steps will reproduce the problem?
1. Download unstable_current_amd64 version
2. Unpack with ar, lzma and tar, because have only .deb packages (why?)
3. file opt/google/chrome/chrome

What is the expected result?
Something like: ELF 64-bit LSB executable, x86-64, version 1 (SYSV),
dynamically linked (uses shared libs), stripped

What happens instead?
ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically
linked (uses shared libs), stripped

Why amd64 is not 64-bit binary? It's never run at a pure 64-bit system.
 

Comment 1 by est...@chromium.org, Aug 4 2009

Mergedinto: 8606
Status: Duplicate
we are working on it

Comment 2 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Sign in to add a comment