Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 181367 Error 15 (net::ERR_SOCKET_NOT_CONNECTED): Unknown error when trying to reach google.com
Starred by 12 users Reported by hagayb...@gmail.com, Mar 9 2013 Back to list
Status: Duplicate
Merged: issue 179709
Owner: ----
Closed: Mar 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment
Chrome Version       : 27.0.1430.3 (Official Build 186327) dev-m
URLs (if applicable) : https://www.google.com ; https://www.google.co.il
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:-
  Firefox 4.x:-
       IE 7/8/9: OK

What steps will reproduce the problem?
1.typing google.com address in the omni bar / trying to make a search in the omni bar.
2. the browser automatically change to https://

What is the expected result?
 getting the google.com / google.co.il websiter.

What happens instead?

 recieving this error - Error 15 (net::ERR_SOCKET_NOT_CONNECTED): Unknown error.

Please provide any additional information below. Attach a screenshot if
possible.

trying to enter google.fr / google.jp goes just fine (it goes to the unencrypted version (http://).
the issue started after the last update of the dev channel.

 
Project Member Comment 1 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Undefined
Labels: Cr-Internals-Network
If it won't leak anything private, can you follow the instructions on https://sites.google.com/a/chromium.org/dev/for-testers/providing-network-details to get us a net-internals dump and attach it here?
Mergedinto: 179709
Status: Duplicate
Comment 4 by kra...@gmail.com, Mar 11 2013
Hello,

I got the same error message on https versions of google.com website.
I usually use the google.be version which gives no problem, however when going to the calendar, it redirects to https://www.google.com/calendar?tab=Xc  which fails (Error 15 (net::ERR_SOCKET_NOT_CONNECTED): Unknown error.)

To be noticed: one week ago I had the same problem with google reader and saw that the certificate for google.com was in the 'untrusted publishers'. I removed it and it worked again.

For the calendar, if I uncheck 'check for revocation' (what I feel unsafe), it works again.
So I think the certificate is maybe revoked for any reason?

Rgds


Comment 5 by Deleted ...@, Mar 14 2013
I have the same problem with the omni-bar!! 
It also happens when I try to report this as a bug, which is rather frustrating as you can imagine. 
Comment 6 by cyber...@gmail.com, Mar 18 2013
I am getting this as well, except that it mostly happens on the usual Normal Mode, but happens way less on the Incognito mode.
Karim's solution worked for me, "uncheck 'check for revocation'" and ping the calendar works again now.
Comment 8 by cyber...@gmail.com, Mar 18 2013
I found that mine was unchecked, so I rechecked it, and it works now :)
Comment 9 by evo...@gmail.com, Mar 22 2013
Getting this error also. Happens ofter when only turned on my PC and starting Chrome. When I try to search in omni bar or clicking on google reader toolbar icon (official extension) which opens https://www.google.com/reader/view/ I'm getting this net::ERR_SOCKET_NOT_CONNECTED error. If I restard the browser the error will gone.

Tried uncheck 'check for revocation' option, seems like working now. Will see how it will work next days.
Comment 10 by evo...@gmail.com, Mar 25 2013
Today got this error opening Google Reader (and then just Google) with 'check for revocation' turned off, also got 'net::ERR_SOCKET_NOT_CONNECTED' so checking revocation isn't a reason for this error. But after I turned it on again, sites started to work.
Same error, flushing the socket pool fixed it for now.

http://productforums.google.com/forum/#!topic/chrome/rfDGhN_CAXw
Comment 12 by evo...@gmail.com, Apr 2 2013
I disabled 'Asynchronous DNS' in chrome://flags and few days I didn't see the problem. Maybe it's a bug in it.
Google.com was not working for me until I checked the checkbox - Check for server certificate revocation. 
Comment 14 Deleted
Comment 15 by Deleted ...@, Apr 8 2013
I get this problem every time I restart my computer.  I've tried all the solutions (flushing sockets, clearing cache, etc.), and most all of them work to get it going that one time, then I restart my machine, and I'm right back where I started.  It's kind of ironic that it's only the Google sites (Google.com, Gmail, etc.) that don't work in Chrome, the Google browser.  I hope this gets fixed quickly, as I have loved Chrome, but I'm one or two days away from going back to Firefox.
Comment 16 Deleted
Comment 17 Deleted
Flushing the socket pool fixed for a day and then the problem began again. 

Then I saw the post about revocation.  I selected check, refreshed, and then unchecked again. Now all is working again.

Sign in to add a comment