New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 181331 link

Starred by 25 users

Issue metadata

Status: Verified
Owner:
Closed: Mar 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 1
Type: Bug

Blocking:
issue 221946



Sign in to add a comment

Can't flip flags on CrOS Canary

Reported by gideonwald@chromium.org, Mar 9 2013

Issue description

OS: Chrome
Version: 27.0.1433.2

What steps will reproduce the problem?
1. Go to about:flags and try to flip a flag

What is the expected output? What do you see instead?

For On/Off flags, you can click Enable and it looks like it worked, but it has no effect. For multi-valued flags, you can't change the value in the drop-down (it just immediately goes back to whatever it was before).

I'm on a Lumpy. Happy to give more details!
 
Project Member

Comment 1 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-UI -Mstone-27 M-27 Cr-UI

Comment 2 by ddrew@chromium.org, Mar 11 2013

Cc: -ddrew@chromium.org
Labels: -Pri-2 Pri-1 ReleaseBlock-Beta Noteworthy
Owner: zelidrag@chromium.org
Status: Assigned
Labels: Iteration-77
Owner: r...@chromium.org
it's happening on all platforms on TOT builds

Comment 4 by r...@chromium.org, Mar 12 2013

Status: Started

Comment 5 by r...@chromium.org, Mar 12 2013

Cc: pastarmovj@chromium.org mnissler@chromium.org
This is caused by a combination of these CL's,
https://chromiumcodereview.appspot.com/12452003
and,
https://chromiumcodereview.appspot.com/12330137

Reverting them both fixes the issue. Julian, could you look at this and see if this is an easy fix or if I should revert both the CL's for now? I'll try to sync with you tonight (your tomorrow morning) before reverting.

Comment 6 by r...@chromium.org, Mar 13 2013

Cc: joshwoodward@chromium.org zelidrag@chromium.org
Cc: -pastarmovj@chromium.org r...@chromium.org
Owner: pastarmovj@chromium.org
I think I see the reason for that. Please don't revert the commits yet.  I will try to fix this and if I can't do so until tomorrow your time I will revert them myself. 
Project Member

Comment 8 by bugdroid1@chromium.org, Mar 13 2013

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=187881

------------------------------------------------------------------------
r187881 | pastarmovj@google.com | 2013-03-13T17:00:56.684486Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/sync/profile_sync_service.h?r1=187881&r2=187880&pathrev=187881
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/sync/profile_sync_service.cc?r1=187881&r2=187880&pathrev=187881

Revert 187669 "Adjust the profile sync service to properly set p..."

NOTE:Will recommit this one after we get session manager to change flags on ChromeOS.

Adjust the profile sync service to properly set per user or per machine flags.

Since flags are handled differntly on ChromeOS now the sync service needs to
change the way it stores its flags until those are moved to proper prefs.

BUG= chromium:181331 
TEST=Sync service experiments should still work.
> 
> 
> Review URL: https://chromiumcodereview.appspot.com/12549017

TBR=pastarmovj@chromium.org
Review URL: https://codereview.chromium.org/12426009
------------------------------------------------------------------------
The offending CLs should be reverted by now.
is this now resolved?
 Issue 196427  has been merged into this issue.
27.0.1439.3, which is at r187956, is still broken and flags cannot be flipped. So, looks like the revert from two days ago did not address the issue (r187881).
Ping. Any progress on this?
i am in MTV this week i will look into it today. 

Are you sure you were trying to change flags as an owner? The code right now will allow you to see the about:flags page even as non-owner but you can't still apply flags until all the rest is in.
I'm trying to flip as owner, and it wasn't working. When you restart, the flags you've just enabled are disabled.

Comment 16 by r...@chromium.org, Mar 19 2013

Flags seem to flip fine for me. The only issue is, the flags seem to be per user (don't seem to require an owner, any user can change them - they seem to be set only for that user).

Though this is a great end-user experience but this makes me wonder about flags that need to be set at startup? If flags are per user, they would only be set inside Chrome 'once' the user has logged on. This can only happen once Chrome has finished startup. Hence flags that need to be set 'during' startup, I am assuming are not set till it is really too late for them?

This is what we are working towards in the end. The owner will be able to set flags that will apply on system level - meaning both the login profile and the owners self profile and non-owners will be able to set flags that will be applied only after they sign in and apply to them only.

The current state though is - the owner works like before and sets flags for all profiles system and after login and the other users see and can change the flags ui but it will not get applied until I get the change that restarts the browser with the flags in committed (Which still isn't) after this change is in the owner's powers over flags will get limited to the login profile and his own profile.
Status: Fixed
Just tested this and about:flags are sticking after restart now. We're back to normal!

For the issue raised in c#16 and c#17, I talked to @rkc. We think a small % of users will use about:flags and an even smaller % will use it from the non-owner account. Thus, I'm marking this bug as Fixed.
Will this make it into the dev build for this week?
The reverts are in for quite a while now so it should be in for the next dev build.

Comment 21 by proppy@google.com, Mar 22 2013

after updating to 27.0.1446.5 (Official Build 189399) dev w/ pixel, enabling a flag as a user still has no effect after restarting (ex: NaCl).

Let me know if I could provide more information.
Blocking: chromium:221946
Status: Verified
Google Chrome	27.0.1453.9 (Official Build 191205) dev
Platform	3912.6.0 (Official Build) dev-channel link
I cannot still do screen capture with the screen capture getusermedia flag on via getusermedia on version 28.0.1500.11 dev (4100.7.0 lumpy). 

I tried to enabled loads of different flags but to no avail. Do I need to do something else?
@jansson - I'm on a slightly older build (28.0.1500.4 / 4100.1.1), and changes to chrome://flags seem to take effect for me. Two things you might need to check:
1) Can you make sure you're logged in with the machine owner's account? Non-owners will see this text near the top of chrome://flags - "Flags that apply system-wide can only be set by the owner: $owner_email"

2) If you are logged in as the owner, and the machine came configured with corp access, you might need to reflash the device before you can change chrome://flags. This is because managed devices, or at least ones configured with corp access, still don't let any account change flags. There's a reference to that in https://code.google.com/p/chromium/issues/detail?id=238317#c4 and probably other bugs. Note that reflashing the device will break access to internal corp resources, but there are instructions on how to restore that access.
I see, I think the owner part is the issue as I only have a "." where the email address is supposed to be. Thanks for your help!
If there is no email there this means that the machine is enterprise enrolled. Don't you see the "This machine is managed by google.com" on the login screen or the system tray menu as well?
Sure do.

Sign in to add a comment