New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 180459 link

Starred by 20 users

Issue metadata

Status: Verified
Owner:
Closed: Mar 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug-Regression



Sign in to add a comment

On first run, Your profile could not be opened

Project Member Reported by tapted@chromium.org, Mar 6 2013

Issue description

Chrome Version       : 26.0.1410.19
OS Version: 6.2 (Windows 8)
URLs (if applicable) :
Other browsers tested:
  Chrome Windows 7 (26.1410.19 beta): OK

What steps will reproduce the problem?
1. Uninstall Chrome, remove ~/AppData/Local/Google/Chrome
2. Install Chrome beta from https://www.google.com/intl/en/chrome/browser/beta.html
3. first-run import process crashes, "Your profile could not be opened" popup

What is the expected result?

Import process should not crash

UserAgentString: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.19 Safari/537.31

Screenshot and sawbuck log attached, with some stack traces thrown in.

This is a bit of an elusive bug... It may be racy and/or depend on master_preferences, registry settings, system-level vs user, current default browser, etc. And the bisect is really annoying because of other overlapping bugs. We also don't seem to have any win8 bots running browser_tests (nor import, which is #ifdef'd out on USE_AURA last I checked).

I think the following is correct:

Last known good build: 26.0.1395.1
Earliest bad build that is good on Windows 7: 27.0.1425.2 && 26.0.1310.19

Windows 7 (and 8) went bad in http://crrev.com/179101 ( Issue 174590 ), and went worse in http://crrev.com/179578 ( Issue 174864 ). Windows 7 then became good in http://crrev.com/184116 ( Issue 174864 ), but Windows 8 seems to have stayed bad.

So I can't narrow down the bisect window to fewer than 5000 revisions using builds. http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=%2Ftrunk%2Fsrc&range=179101%3A184116&mode=html
 
Attachments got eaten by backbutton (who decided that backspace should do that :|).
sawbuck_stacks_m26.0.1410.19_beta.txt
48.1 KB Download
screenshot.png
219 KB View Download
Cc: robertshield@chromium.org gab@chromium.org
Ick. Robert/Greg/Gab, any clue what's going on here?
sorry, a correction:
> Earliest bad build that is good on Windows 7: 27.0.1425.2 && 26.0.1310.19
* 26.0.1310.19 --> 26.0.1410.19

Also, I came here from an m25 bug,  Issue 163925 , which might have some links.

Comment 4 by gab@chromium.org, Mar 6 2013

Mergedinto: 171475
Status: Duplicate
Isn't this a dup of  issue 171475 ?
Cc: caitkp@chromium.org
It's possible they are related. However,  Issue 171475  has only been seen on m24 -- the underlying cause went away in m25 (and a fix is applied to m24, so that bug should probably be marked fixed).

Comment 6 by gab@chromium.org, Mar 6 2013

Ah okay, feel free to de-dup/re-assign as you think makes sense.
Labels: -Type-Bug Type-Regression
Mergedinto:
Status: Available
(de-dup for now). I tested removing /c/Program\ Files\ (x86)/Google/Chrome/Application/master_preferences and it still repros, so I'm pretty sure there is no overlap.

There's a regression test in http://crrev.com/184807 that might help with a git-bisect on win8. However, it will need to be patched in for most of the window.
tapted@ is correct.  The profile keyed service factory (VisitedLinkMasterFactory) that caused  Issue 171475  does not exist in m26.

Comment 9 by gab@chromium.org, Mar 6 2013

Owner: atwilson@chromium.org
Status: Assigned
I think Drew was looking at the generic set of problems caused by the import process which keep bringing this issue back.
Cc: mhx...@motorola.com
Might also be worth looking at http://crrev.com/181826 -- It sets the ThemeService to be created at the same time as the profile, which seems to be the common theme (no pun intended) with these bugs. 

Looks like it was fixed in http://crrev.com/184340 but not in time for the m26 beta branch.
Owner: ----
I have a CL here which is a more general fix for this issue:

https://codereview.chromium.org/12330073/

However, some of the tests seem to fail now after tapted landed r184807, and I suspect it's because I need to start up at least one of the services on the import process (history?)

I'll look at this today and land that CL on M27, and we can look at merging back.
OK, I have that CL passing browser tests now:

https://codereview.chromium.org/12330073/

I'm not quite comfortable landing it until I get at least another pair of eyes (erg/gab) on it. And then perhaps people can see if it addresses the issue.
Owner: atwilson@chromium.org
Putting this back on my plate, but if this must be fixed before Monday then feel free to reassign.
I'm fairly confident that https://codereview.chromium.org/12461010/ will resolve this - it's less scary than http://crrev.com/12330073/ and addresses a different side of the problem, but I think it will be enough.
Project Member

Comment 16 by bugdroid1@chromium.org, Mar 8 2013

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=186990

------------------------------------------------------------------------
r186990 | tapted@chromium.org | 2013-03-08T18:16:34.791613Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/policy/user_policy_signin_service.cc?r1=186990&r2=186989&pathrev=186990

Delay loading the SigninManagerFactory until the first-run Import process has completed.

SigninManagerFactory depends on services that initialize databases
accessed by the import process. This change ignores profile added
notifications that occur while the import process is still running,
instead waiting for the import finished notification to complete signin
initialization.

BUG= 180459 

Review URL: https://chromiumcodereview.appspot.com/12461010
------------------------------------------------------------------------

Comment 17 by gab@chromium.org, Mar 8 2013

Labels: -Hotlist-Windows8
Summary: On first run, Your profile could not be opened (was: [win8] On first run, Your profile could not be opened)
This is not Win8 specific; let's try to keep the discussion about this to this thread only.

Comment 18 by gab@chromium.org, Mar 8 2013

Cc: blumberg@chromium.org jeffreyc@chromium.org pastarmovj@chromium.org
 Issue 174591  has been merged into this issue.

Comment 19 by gab@chromium.org, Mar 8 2013

Hey all, I think the general fix I put up at https://codereview.chromium.org/12463030/ will fix this once and for all :)!!! (the only better solution being the OOP import on Windows, but that looks like a more involved task: tracked in  issue 22142 )

I'm going on vacation for a week now so please take it, tweak it, throw it, commit it.. do as you please with this CL :)!

Cheers!
Gab
Project Member

Comment 20 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-Internals -Mstone-26 -Feature-FirstRun -Feature-Import -Internals-Install Cr-UI-Browser-FirstRun Type-Bug-Regression Cr-UI-Browser-Import Cr-Internals M-26 Cr-Internals-Install
Labels: Merge-Requested
Owner: tapted@chromium.org
Status: Fixed
I've checked on a windows 8 computer that had produced this error previously: a fresh install of the 27.0.1435.0 canary, and with an official build 27.0.1435.0_chrome_installer.exe. 4x iterations of the latter. No errors.

It would be great to get some verifications on other machines from QA in m27, but I'm pretty sure this is fixed in http://crrev.com/186990 and fit to merge to m26.
Labels: -Merge-Requested Merge-Approved
Project Member

Comment 23 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Merge-Approved merge-merged-1410
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=187381

------------------------------------------------------------------------
r187381 | tapted@chromium.org | 2013-03-11T21:53:22.888859Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/chrome/browser/policy/user_policy_signin_service.cc?r1=187381&r2=187380&pathrev=187381

Merge 186990
> Delay loading the SigninManagerFactory until the first-run Import process has completed.
> 
> SigninManagerFactory depends on services that initialize databases
> accessed by the import process. This change ignores profile added
> notifications that occur while the import process is still running,
> instead waiting for the import finished notification to complete signin
> initialization.
> 
> BUG= 180459 
> 
> Review URL: https://chromiumcodereview.appspot.com/12461010

TBR=tapted@chromium.org
Review URL: https://codereview.chromium.org/12692006
------------------------------------------------------------------------

Comment 24 Deleted

Hi everyone,

I've been experiencing this issue on a Windows 7 PC I'm working on. Initially, it only happened in Stable, and upgrading to Beta fixed the issue. However, it seems that it's now happening in Beta, and upgrading to Canary, which tapted@chromium.org did as well, fixes the issue again.

However, this issue is presenting itself on a production PC, and we can't justify using a Canary build there, however the Beta is acceptable due to it's proven stability.

Approximately how long will it take for this fix to make it's way to the Beta channel? 

Thank you.
M26 beta will be out tomorrow. Please verify it in the latest beta build.
Status: Verified
I Uninstall Chromed, removed ~/AppData/Local/Google/Chrome
Ran the installer for 27.0.1439.0 (Official Build 187789) m on user-level
"Your profile could not be opened" popup is not seen. Marking as Verified.
Verified in M27 based on comment #21
Also verified in 26.0.1410.33 (Official Build 187744) m
Project Member

Comment 30 by bugdroid1@chromium.org, Apr 5 2013

Labels: -Cr-Internals-Install Cr-Internals-Installer

Comment 31 by Deleted ...@, May 19 2013

It sure as hell has not been fixed yet

Comment 32 by d...@sodmail.com, May 19 2013

Nope, it hasn't.

Comment 33 by gab@chromium.org, May 22 2013

Which version of Chrome are you seeing this on? (You can force Chrome First Run with chrome.exe --force-first-run to try to repro).

I have a global fix coming for this recurring issue @ https://codereview.chromium.org/12670013/ -- it has been hard to get in, but I think I have the final hammer to fix the only remaining broken tests @ https://codereview.chromium.org/15736014/.

Cheers,
Gab

Comment 34 by gab@chromium.org, Jul 2 2013

 Issue 174591  has been merged into this issue.

Comment 35 by laforge@google.com, Jul 24 2013

Cc: -jeffreyc@chromium.org

Sign in to add a comment