New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 180100 link

Starred by 7 users

Issue metadata

Status: Verified
Owner:
Closed: Mar 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 1
Type: Bug-Regression



Sign in to add a comment

[Daisy] Keyboard: brightness up/down keys no longer work

Project Member Reported by h...@chromium.org, Mar 5 2013

Issue description

Seems to be a recent chrome regression between 185350 and 185930

Problem: brightness adjustment keys (F6, F7) do not work. When pressed, no UI pops up that shows adjustment of brightness.

Meanwhile, mute and volume adjustment keys (F8, F9, F10) do work fine.
 

Comment 1 by h...@chromium.org, Mar 5 2013

185425 ... 185500

Comment 2 by h...@chromium.org, Mar 5 2013

185462 ... 185481

Comment 3 by h...@chromium.org, Mar 5 2013

Owner: h...@chromium.org
Status: Started

Comment 4 by h...@chromium.org, Mar 5 2013

Cc: osh...@chromium.org
Oshima@ - I believe the regression is your CL:

http://src.chromium.org/viewvc/chrome?view=rev&revision=185479

Remove GetOutputNames from x11_util
Move the logic to find internal display's id to
chromeos specific display_change_observer_x11.cc

BUG=none
TEST=none

Review URL: https://chromiumcodereview.appspot.com/12377035

Comment 5 by h...@chromium.org, Mar 5 2013

Oshima - the brightness control delegate depends on the display manager reporting HasInternalDisplay:

void AcceleratorController::SetBrightnessControlDelegate(
    scoped_ptr<BrightnessControlDelegate> brightness_control_delegate) {
  // Install brightness control delegate only when internal
  // display exists.
  if (Shell::GetInstance()->display_manager()->HasInternalDisplay() ||
      CommandLine::ForCurrentProcess()->HasSwitch(
          switches::kAshEnableBrightnessControl)) {
    brightness_control_delegate_ = brightness_control_delegate.Pass();
  }
}

Now that you have moved the SetInternalDisplayId, I wonder if the timing has changed, such that the internal display ID is not yet initialized when we set the brightness control delegate?
Cc: -osh...@chromium.org h...@chromium.org
Owner: osh...@chromium.org
Timing should be the same, but I may be missing something. Thank you for bisecting.
I'll take it over and look into it.

Comment 7 by h...@chromium.org, Mar 5 2013

Labels: -Feature-Input-Keyboard Feature-Ash

Comment 8 by h...@chromium.org, Mar 5 2013

It seems that ui::GetOutputDeviceData had regressed prior to Oshima's CL. Even before revision 185479, the function just returns false and sets both manufacturer ID and product code to 0, but the old code ignored that error and set internal display ID to 0, so the problem was not exposed.

I definitely remembered this was working before.
I tested this on TOT + arrow (dvt) and brightness key does work for me.
Maybe be specific to a device? Which device has this issue? 
Cc: mukai@chromium.org
+mukai in case he has some idea about ui::GetOutputDeviceData issue.

Comment 11 by h...@chromium.org, Mar 5 2013

Re:#9 you're correct - this is only reproduced on daisy. I just tried a parrot with ToT and it worked fine.

Comment 12 by h...@chromium.org, Mar 5 2013

Summary: [Daisy] Keyboard: brightness up/down keys no longer work (was: Keyboard: brightness up/down keys no longer work)
Just tried an Arrow, also confirmed ui::GetOutputDeviceData returns valid manufacturer/product code values.

So it seems the failure is specific to daisy.
It sounds like similar to crosbug.com/38160 (and  crbug.com/176011 ), ui::GetOutputDeviceData may fail for some specific device (or cable?) in Daisy.  Can you copy&paste the xrandr section of chrome://system ?

According to crosbug.com/38160, the internal display doesn't have EDID section itself (I didn't notice this...) That's highly likely the reason why we miss 'internal display' in the system.
I see. I'll implement fallback for the time being. (as before)

Comment 15 by h...@chromium.org, Mar 5 2013

xrandr session on daisy:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 4096 x 4096
eDP-1 connected 1366x768+0+0 (0x44) normal (normal) 0mm x 0mm
	Identifier: 0x42
	Timestamp:  24158155
	Subpixel:   unknown
	Gamma:      1.0:1.0:1.0
	Brightness: 0.0
	Clones:     HDMI-1
	CRTC:       0
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
  1366x768 (0x44)   70.5MHz *current +preferred
        h: width  1366 start 1406 end 1438 total 1478 skew    0 clock   47.7KHz
        v: height  768 start  780 end  786 total  796           clock   59.9Hz
HDMI-1 disconnected (normal)
	Identifier: 0x43
	Timestamp:  24158155
	Subpixel:   unknown
	Clones:     eDP-1
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
Cc: ka...@chromium.org
 Issue 180281  has been merged into this issue.
Labels: ReleaseBlock-Beta
 Issue 180281  has been merged into this issue.
Project Member

Comment 19 by bugdroid1@chromium.org, Mar 6 2013

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=186322

------------------------------------------------------------------------
r186322 | oshima@chromium.org | 2013-03-06T01:43:50.363640Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/ash/display/display_change_observer_x11.cc?r1=186322&r2=186321&pathrev=186322

Fallback to use output_index when searching for internal display

BUG= 180100 
TEST=manual


Review URL: https://chromiumcodereview.appspot.com/12491005
------------------------------------------------------------------------

Comment 20 by h...@chromium.org, Mar 6 2013

Status: Fixed
Thanks for landing this quickly! I've locally verified that it fixed the problem on daisy.
Project Member

Comment 21 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Mstone-27 -Feature-Ash Type-Bug-Regression Cr-UI-Shell Cr-UI M-27
I am also having this issues. I thought it is hardware problem. I have cleaned my chromebook from dust through Vacuum. But I am still facing the problem. My screen brightness is 40% and when I put my ChromeBook in chargin then brightness goes to 100%. so it is definitly OS problem!! Please fix this issue!! 
Status: Verified
Verified on build : 3833.0.0
Brightness keys work again.
How to update chromebook to build: 3833.0.0? I dont see any update about 3833 build on googlechromereleases.blogspot.com?

Comment 25 by krisr@chromium.org, Mar 14 2013

Labels: ContestedBug

Comment 26 by krisr@chromium.org, Mar 14 2013

Labels: -ContestedBug AdjustedPriority
The brightness up/down keys don't work on a ChromeBox 27.0.1453.83.  This has been broken since somewhere mid-m26.

Sign in to add a comment