New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 175638 link

Starred by 18 users

Issue metadata

Status: Duplicate
Merged: issue 225563
Owner:
Email to this user bounced
Closed: Apr 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 1
Type: Bug-Regression
Gfx



Sign in to add a comment

[Daisy only] - Hardware video playback exhibits wrong frame from popular Flash sites

Reported by nhuyhl@chromium.org, Feb 12 2013

Issue description

Google chrome: 26.0.1408.1
Platform: 3691.0.0
Flash version: 11.6.602.169

What steps will reproduce the problem?
1. Play any video from following sites:
www.spiketv.com
www.gamespy.com
video.yahoo.com

What is the expected output? 
1. Video played smoothly

What do you see instead?
1. Video played stutteringly.

Please use labels and text to provide additional information.

 
Labels: ReleaseBlock-Stable

Comment 2 by h...@chromium.org, Feb 12 2013

Status: Available
Consistent repro with URL (need to wait ~15 seconds to skip the Ads):

www.spike.com/video-clips/wnw0ux/the-joe-schmo-show-the-lap-dance-frisk

Comment 3 by h...@chromium.org, Feb 12 2013

Cc: sheu@chromium.org

Comment 4 by h...@chromium.org, Feb 12 2013

Does not repro when hw acceleration is disabled for video decode

Comment 5 by h...@chromium.org, Feb 12 2013

Because the symptom of the out-of-order frames look so similar to  bug 175011 , I was tempted to build a CrOS image with the culprit CL reverted (http://www.crrev.com/180578) and hoped that would make the problem disappear.

Unfortunately, the frame order is still wrong on my Daisy device. So this does not look like a duplicate of  bug 175011 .

Comment 6 by ihf@chromium.org, Feb 13 2013

Labels: -Feature-Flash Gfx
Summary: [Daisy only] - Hardware video playback exhibits wrong frame from popular Flash sites (was: Daisy - Video playback exhibits wrong frame from popular Flash sites)
I checked with some machines that I had at hand and it seems to have been introduced somewhere in
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=%2Ftrunk%2Fsrc&range=177173%3A180747&mode=html
Also non-issue with Intel.

Comment 7 by h...@chromium.org, Feb 13 2013

Doesn't look like a Chrome regression. I just tried chrome 177174 + ToT R26 chromeOS and can still reproduce this.

Comment 8 by h...@chromium.org, Feb 13 2013

Reproduced with canary release 26.0.1387,0 (177587) + Platform 3575.0.0.

Comment 9 by h...@chromium.org, Feb 13 2013

Issue does not repro with the R25 beta (25.0.1364.68 180609) + Platform 3428.127.0

Comment 10 by h...@chromium.org, Feb 13 2013

Issue does not repro with R26 canary (26.0.1384.2 176931) + Platform 3565.0.0

Comment 11 by h...@chromium.org, Feb 13 2013

Owner: sheu@chromium.org
John, this looks like related to your change (enable exynos VDA for snow):

https://gerrit.chromium.org/gerrit/#/c/41496/2/session_manager_setup.sh

This is the only suspicious CL between 3565.0.0 and 3575.0.0.

Also as a confirmation, on ToT if I disable the EVDA_FLAGS in session_manager_setup.sh then I can get correct video playback.
Cc: posciak@chromium.org
Status: Assigned

Comment 14 Deleted

Seeing issue from youtube.com as well. 

Labels: Feature-Flash

Comment 17 by ihf@chromium.org, Feb 20 2013

Labels: -Feature-Flash
Project Member

Comment 18 by bugdroid1@chromium.org, Feb 21 2013

Project: chromiumos/third_party/kernel
Branch : chromeos-3.4
Author : John Sheu <sheu@chromium.org>
Commit : 935b9a49f7778d7c9f6015d377b52dbbb7cfb0ef

Code Review +2: Pawel Osciak
Verified    +1: John Sheu
Change-Id     : I0bfd3cfbb3ec312c073eed5e39bfd2e1637bee3c
Reviewed-at   : https://gerrit.chromium.org/gerrit/43677

CHROMIUM: s5p-mfc: fix DISPLAY_DELAY

V4L2_CID_MPEG_MFC51_VIDEO_DECODER_H264_DISPLAY_DELAY_ENABLE is being
ignored, and the display delay is always being applied.  Fix this.

Signed-off-by: John Sheu <sheu@google.com>

BUG= chromium:175638 
BUG=chromium-os:38121
BUG=chromium-os:38376
BUG=chromium-os:38693
TEST=local build, run on snow
Commit-Queue: John Sheu <sheu@chromium.org>

M  drivers/media/video/s5p-mfc/s5p_mfc_opr_v6.c

Comment 19 by dharani@google.com, Feb 25 2013

is this fixed?
Still seeing issue from Nbc.com/video.
-Chrome version: 26.0.1410.15
-OS: 3701.30.0
-Flash version: 11.6.31.171

Comment 21 by sheu@chromium.org, Feb 26 2013

There is a revert in the tree right now that reverts back to using OVDA for video decode on daisy, which according to comment #11 should fix things for now.  I am working on fixing EVDA so we can use it again.
Labels: Iteration-77
I also see the issue when playing Angry Birds game from Facebook page.
-Google chrome: 27.0.1430.0
-Platform: 3797.0.0
-Flash version: 11.6.602.177

Comment 24 by h...@chromium.org, Mar 6 2013

nhuyhl@ - this bug is about HW video decode.

Please file a separate bug for Angry Birds and be very specific about what issue you're seeing. For instance, "stuttering" is very different from "wrong frame order". In a stuttering case, all the frames are in correct temporal order, but they are not present in an even pace. In the "wrong frame order" case, you see objects move back and forth because some old frames get presented after a new frame.
Project Member

Comment 25 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Mstone-26 Type-Bug-Regression Cr-UI M-26
P2, punting to M27.  Move back if a fix will fall out of your current work.
Labels: Cr-Content-Plugins-Flash
Labels: -M-26 M-27

Comment 29 by sheu@chromium.org, Mar 13 2013

Status: Fixed
EVDA was re-enabled at ToT, and this issue should be fixed by the backport of the upstream driver (https://gerrit.chromium.org/gerrit/#/c/42957/).  Marking fixed.
Status: Untriaged
Issue is still there due to blocking bug: 
http://code.google.com/p/chromium/issues/detail?id=180332
Issue is still repro. easily from youtube & spike video from comment #2.
-Google chrome: 27.0.1441.1
-Platform: 3844.0.0
-Flash version: 11.6.602.180-r3
Labels: Iteration-78
Status: Assigned
Project Member

Comment 34 by bugdroid1@chromium.org, Mar 20 2013

Project: chromiumos/third_party/kernel
Branch : chromeos-3.4
Author : John Sheu <sheu@chromium.org>
Commit : defe6fd83a9b658d08a71cd365718c8aecefd560

Code Review +2: John Sheu
Verified    +1: John Sheu
Change-Id     : I0b098d021d656197d058e573cf66a3b1f624a275
Reviewed-at   : https://gerrit.chromium.org/gerrit/45655

CHROMIUM: s5p-mfc: fix DISPLAY_DELAY

V4L2_CID_MPEG_MFC51_VIDEO_DECODER_H264_DISPLAY_DELAY_ENABLE is being
ignored, and the display delay is always being applied.  Fix this.

Signed-off-by: John Sheu <sheu@google.com>

BUG= chromium:175638 
BUG=chromium-os:38121
BUG=chromium-os:38376
BUG=chromium-os:38693
TEST=local build, run on snow

Commit-Queue: John Sheu <sheu@chromium.org>

M  drivers/media/video/s5p-mfc/s5p_mfc_opr_v6.c
Labels: Iteration-79
Cc: zelidrag@chromium.org
ihf@ can you please try to repro this

Comment 38 by ihf@chromium.org, Apr 2 2013

I am not sure I have seen out of order frames yet. But movies.yahoo.com shows video that seems maybe 8-10fps. Traces are showing sudden congestion which probably leads to restart video with a different resolution. Not sure what causes this in the first place. Furthermore there are gscaler corruptions quite visible. I spoke to John and he is going to enable the YUV path in Chrome again which should fix the gscaler.
Labels: -Pri-2 Pri-1
Labels: -ReleaseBlock-Stable ReleaseBlock-Beta

Comment 41 by sheu@chromium.org, Apr 5 2013

Labels: Merge-Requested
Requesting merge to M27.
Labels: -Merge-Requested Merge-Approved
CL https://gerrit.chromium.org/gerrit/#/c/47483/ is approved for merge to R27 branch. Per Zel, this was enabled in 27 so disabling to see if this resolves some of the playback issues.
Project Member

Comment 43 by bugdroid1@chromium.org, Apr 5 2013

Labels: Cr-Blink
Project Member

Comment 44 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash
Labels: -ReleaseBlock-Beta ReleaseBlock-Stable

Comment 46 by ihf@chromium.org, Apr 11 2013

Mergedinto: 225563
Status: Duplicate
Labels: -Merge-Approved Merge-Merged

Sign in to add a comment