New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 12 users

Issue metadata

Status: Verified
Owner:
Email to this user bounced
Closed: Mar 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 1
Type: ----



Sign in to add a comment
link

Issue 172276: Pages not displayed on Chrome 25.0+ if Adblock plus is installed

Reported by stalker....@gmail.com, Jan 25 2013

Issue description

Device name: Nexus 7

From "Settings > About Chrome"
Application version: any beta version
OS: Android 4.2.1

URLs (if applicable): livejournal.com, bash.im

Behavior in Android Browser (if applicable):
Does not display the page, only white background, favicon is displayed too. However, when a page has colored background, the page is displayed correctly (like this page:
http://hyaenidae.narod.ru )

Steps to reproduce:
1. Open http://bash.im in Chrome beta for Android
2.
3.

Expected result:
Normal page contents

Actual result:
White background only
 

Comment 1 by krav...@chromium.org, Feb 1 2013

Labels: Action-FeedbackNeeded
could you please re-test on latest version of beta - 25.0.1364.64

Comment 2 Deleted

Comment 3 by stalker....@gmail.com, Feb 16 2013

Update:
I found the cause of this strange behaviour, AdBlock Plus for Android is to blame. I turned it off accidentally and started Chrome beta - it worked fine, all pages could be opened without any problems. What _is_ strange, however, is that the regular version of Chrome for Android worked perfectly with AdBlock turned on.
So I guess this is not an issue anymore, please close it.

Comment 4 by jasonlking@chromium.org, Feb 28 2013

Cc: kamakshi@chromium.org vinodkr@chromium.org
Labels: Action-Evangelism Hotlist-ConOps Mstone-25
Status: Untriaged
I received confirmation from a user in the Chrome forum that the Adblock Plus app also is blocking all content from rendering in 25.0.1364.123 stable, but worked fine on the previous m18 release.

If we can repro this, could be an area of outreach to Adblock.

Comment 5 by stalker....@gmail.com, Feb 28 2013

Yep, the new version of stable Chrome for Android now cannot display page contents because of AdBlock Plus.

Comment 6 by kamakshi@chromium.org, Feb 28 2013

Cc: aska...@chromium.org

Comment 7 by aska...@chromium.org, Feb 28 2013

Cc: jasonlking@chromium.org
We could repro this bug on Nexus 10 and a Galaxy Nexus.

Steps to repro:
1. Install 'AdBlock Plus' app
2. Using the port no. mentioned in the app, set the manual proxy setting
3. Force quit and launch Chrome
4. try to navigate to any site

Observed:
All pages load blank

Logs @ http://go/chrome-androidlogs/172276 

*Pages load fine on M18

Comment 8 by vinodkr@chromium.org, Feb 28 2013

Labels: ReleaseBlock-Stable
Owner: klo...@chromium.org
Status: Assigned
Good find.

Comment 9 by klo...@chromium.org, Mar 1 2013

Cc: felipeg@chromium.org
Labels: -Mstone-25 -ReleaseBlock-Stable Mstone-27
Owner: pliard@chromium.org
Please investigate.

Comment 10 by srikanth@chromium.org, Mar 5 2013

Summary: Pages not displayed if Adblock plus is installed (was: Does not display most pages)
Making this bug to specifically track blank pages when Adblock Plus is installed.

Comment 11 by srikanth@chromium.org, Mar 5 2013

Summary: Pages not displayed on Chrome 25.0+ if Adblock plus is installed (was: Pages not displayed if Adblock plus is installed)

Comment 12 by dpolukhin@chromium.org, Mar 5 2013

Labels: -Action-FeedbackNeeded
I think it should be P1 issue because it affects significant amount of users. Moreover from user's point of view it is regression after autoupdate from M18 to M25 and there is no way to return back to M18 from Google Play. It is 100% reproducible so I removed feedback needed label.

Comment 13 by jasonlking@chromium.org, Mar 6 2013

Based on volume in the forum, I also recommend bumping to P1.

Comment 14 by pliard@chromium.org, Mar 6 2013

Cc: pasko@chromium.org digit@chromium.org p...@chromium.org clamy@chromium.org
Labels: -Pri-2 -Mstone-27 Pri-1 Mstone-25

Comment 15 by pliard@google.com, Mar 6 2013

I can reproduce this on a Galaxy Nexus 4.2.2. Investigating now.

Comment 16 by pliard@chromium.org, Mar 6 2013

I'm going to attach DevTools to investigate what happens at the network layer. To have as many chances as possible to fix this today, I think we should do a bisect in parallel assuming we can find a good revision on m25.

Comment 17 by pliard@chromium.org, Mar 6 2013

We should see if we can reproduce this on trunk with content shell. It will make the bisect easier.

Comment 18 by pliard@chromium.org, Mar 6 2013

If we can't find a good m25 revision, we can see if we can reproduce this on trunk with an old revision of content shell. The bisect would then be easy.

Comment 19 by digit@chromium.org, Mar 6 2013

FWIW, we can reproduce the problem on http://news.ycombinator.com which is fortunately a very simple page (i.e. only 1 document + 1 stylesheet + 3 images, no scripts).

Comment 20 by pliard@chromium.org, Mar 6 2013

While David is investigating with DevTools, I'm instrumenting http_network_transaction.cc to produce dump files of the HTTP requests/responses. I will then do a diff.

Comment 21 by clamy@chromium.org, Mar 6 2013

I reproduced the bug with cnn.com (which is not very heavy either). The page load fine with m18, but we cannot see anything with m25. I'm going through previous releases to try to find a timeframe when the problem appeared. Also, if you need a page that is not affected, lemonde.fr loads fine on m25 on my Galaxy Nexus.

Comment 22 by p...@chromium.org, Mar 6 2013

Attached is what Chrome for Android m25 fetches form http://news.ycombinator.com (nice case, David!).

Interestingly, this renders blank when opened on Desktop as well, although the content definitely seems not-empty.
y.html
110 KB View Download

Comment 23 by pasko@chromium.org, Mar 6 2013

reproduced this with ContentShell on trunk, (both news.ycombinator.com and google.com)

Comment 24 by clamy@chromium.org, Mar 6 2013

I went through archives of the release builder, and the problem seems to be much older than m25. Using cnn.com as a tests, it appears between the build 192 and the build 194 of the release builder, which correspond to version 23.0.1232192 and version 23.0.1234194.

Comment 25 by p...@chromium.org, Mar 6 2013

Attached is what Chrome for Android m25 grabs for  http://news.ycombinator.com and what desktop Chrome gets.
mobile.html
110 KB View Download
desktop.html
22.3 KB View Download

Comment 26 by pasko@chromium.org, Mar 6 2013

it is reproducible with mobile.html on desktop, let's bisect it:

good revision: 39eae2b7c5118b8700b2c1de964774b155e31fe6
bad revision: b307141fd2cefca639c0982cfef30e5d8e6dcd84

Comment 27 by pasko@chromium.org, Mar 6 2013

offending commit: [a7effa7fe2bb8527545e913fc4bf7c75b6f06853] Webkit roll 125281:125330
let's bisect webkit?

Comment 28 by pasko@chromium.org, Mar 6 2013

offending WebKit commit: b22dc75c02d3c0f543b5db8dc2ad0d667d34659b

Comment 29 by pasko@chromium.org, Mar 6 2013

Cc: abarth@chromium.org wangxianzhu@chromium.org
abarth@, wangxianzhu@, can you please take a brief look at the WebKit commit touching CSS stuff and find who might be the most relevant person to address this?

Comment 30 by pliard@google.com, Mar 7 2013

I sent this for review on the webkit side: https://bugs.webkit.org/show_bug.cgi?id=111663

Comment 31 by pliard@chromium.org, Mar 7 2013

Cc: srikanth@chromium.org
The fix is going through WebKit's CQ. Do you guys know when the next WebKit roll will happen? I understood Srikanth that we would also cherry-pick the fix to m26 to get some feedback before we do so for m25. Am I correct?

Comment 32 by pliard@chromium.org, Mar 7 2013

Labels: -Mstone-25 Mstone-26 Merge-Requested
Requesting merge to m26 after I talked to Srikanth offline.

Comment 33 by srikanth@chromium.org, Mar 7 2013

Labels: -Action-Evangelism Area-Internals ReleaseBlock-Beta
Thanks all for pinning this down so quickly. Lets try to pull this in for the next M26 Beta update.

Comment 34 by pliard@chromium.org, Mar 8 2013

Ping for the merge request :)

FYI, The WebKit fix landed as r145034 and the WebKit roll pulling past r145034 landed as r186763.

Comment 35 by tanyarad@google.com, Mar 9 2013

Has this been validated in the latest canary build?

Comment 36 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-Internals -Mstone-26 Cr-Internals M-26

Comment 37 by toni.m.k...@gmail.com, Mar 10 2013

This bug now appeared in Chromium 27.0.1435.0 (187204) too, if Adblock Plus is installed and enabled it causes Aw Snap in multiple websites, disabling this extension will fix the problem.

I have Windows 7 x64 SP1 and Chromium 27.0.1435.0 (187204) (trunk).

Comment 38 by not...@gmail.com, Mar 10 2013

It's now appeared in the latest Canary build. I'm on Windows 8 x64

Chrome version:
27.0.1435.0 (Official Build 187188) canary

Comment 39 by k...@google.com, Mar 11 2013

Labels: -Merge-Requested Merge-Approved

Comment 40 by pliard@chromium.org, Mar 11 2013

toni/notrtq, can you please point me to some URLs resulting in the crash you mentioned? It's possible that you are seeing a different issue.

Comment 41 by not...@gmail.com, Mar 11 2013

I first noticed the issue on https://www.google.com/intl/en/chrome/browser/

Comment 42 by toni.m.k...@gmail.com, Mar 11 2013

This bug got solved today at least after 27.0.1437.0 (187274).

Comment 43 by pliard@chromium.org, Mar 11 2013

Indeed, I didn't observe the issue you mentioned on 27.0.1437.2 Mac (thanks clamy@!).  So I will proceed with the merge to m26 now.

Comment 44 by not...@gmail.com, Mar 11 2013

Working fine for me now after I've updated to 27.0.1436.2 in Canary

Comment 45 by pliard@chromium.org, Mar 12 2013

Status: Fixed
FYI, the merge in WebKit landed as r145434 (thanks Xianzhu).

Comment 46 by srikanth@chromium.org, Mar 12 2013

Labels: -Merge-Approved Merge-merged-1410

Comment 47 by aska...@chromium.org, Mar 13 2013

Status: Verified
Verification Attempt:
Chrome version: 26.0.1410.33/ 27.0.1439.0
Device: Nexus 10/JDQ39

Verification Succeeded: Yes

Comment 48 by jasonlking@chromium.org, Mar 14 2013

Will this be merged into m25?

Comment 49 by srikanth@chromium.org, Mar 14 2013

Nopes. Bug is tagged only for M26.

Comment 50 by pliard@chromium.org, Mar 14 2013

Srikanth/Vinod, should we merge this into m25 now that we have a reasonable feedback for m26?

Comment 51 by pliard@chromium.org, Mar 14 2013

Ok, thanks.

Sign in to add a comment