Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 1 user
Status: Duplicate
Merged: issue 159879
Owner:
Closed: Jan 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment
chrome.alarms doesn't work for component extensions
Project Member Reported by vadimt@chromium.org, Jan 8 2013 Back to list
Version: Trunk
OS: Windows 7

What steps will reproduce the problem?
1. Apply this patch: https://codereview.chromium.org/11819010/
2. Build
3. Run Chromium

What is the expected output? What do you see instead?
Expected: alert pop-ups saying first "On Installed!", then, periodically, "Time's up".

Actual: only "On Installed!" pop-up happens.

So, alarms don't work for component extensions. If you load extension in the patch 11819010 as a normal extension, alarms will work.
 
Cc: yoz@chromium.org
I see 

[3628:3628:0109/125658:INFO:CONSOLE(22)] "Error during alarms.create: Delay is not an integer value.", source: sendRequest (22)
[3628:3628:0109/125658:INFO:CONSOLE(22)] "Error during alarms.create: Delay is not an integer value.", source: sendRequest (22)

Does  Issue 159879  hold the answer?
Comment 2 by yoz@chromium.org, Jan 9 2013
Cc: jyasskin@chromium.org
jyasskin is working on this at this very moment.
Mergedinto: 159879
Status: Duplicate
Please reopen if fixing 159879 doesn't fix this.
Project Member Comment 4 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-UI Cr-UI
Sign in to add a comment