Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 3 users
Status: Invalid
Owner:
Closed: Feb 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Chinese page font too small and there is no easy way to change it per site or globally
Reported by xji@chromium.org, Jul 15 2009 Back to list
What steps will reproduce the problem?
1. Open popyard.org
2. some user might think the default font in the page is too small. You can 
use ctrl++ to enlarge the font of current page. But the enlargement will 
not work if you open the same page in a another tab. By comparison, when 
using ctrl++ to enlarge page font in both IE and FF, the preference is 
preserved.
 


What is the expected output? What do you see instead?
font issue is very important for Chinese users. Ordinary users might not 
notice or care the speed/simplicity of Chrome, but they care the look and 
feel of the pages they browsing.
Chrome should preserve user's font preference per page, or per site, or 
globally, instead of asking user to set it for every single page. And/or 
Chrome should set appropriate minimum font size and re-rendering the page 
when minimum font size changes.


Please use labels and text to provide additional information.
Following page has user complains:
http://www.google.com/support/forum/p/Chrome/thread?
tid=389f306a52817110&hl=en


 
Comment 1 by xji@chromium.org, Jul 15 2009
Comment 2 by js...@chromium.org, Jul 15 2009
Labels: -Area-Misc Area-WebKit
Xiaomei, your report is not concrete enough, I'm afraid.  

Looking from another direction,  it deals with multiple issues at a time. 

issue 1: we don't set the webkit preference for the minimum font size large enough. 
We can change them easily. It's a known issue. I'll just fix them after figuring out 
differences between two webkit pref. 

 issue 2 : we don't offer a UI for setting the minimum font size as Firefox does. We 
may or may not want to add the UI for this

 issue 3 : we don't have a UI nor a pref to set the default zoom level. That's issue 
11321

 issue 4 : zoom-level is not preserved across pages in a site: That's  issue 567 

(see also  issue 4368 ). 

If you have a specific Chinese web page that works fine on IE/Firefox but not on 
Chrome in terms of the font size, it'd be great if you list them here. 

Thanks

P.S. I'll file bugs for issue 1 and  issue 2 . 


Comment 3 by xji@chromium.org, Jul 15 2009
Chinese website: 
http://popyard.org/
http://www.wforum.com/

The main problems are issue 1 and  4 , I think. 
Since people have different preference on font size, preserve the preference is 
pretty important. Both IE and FF preserve the font size after user enlarge it using 
ctrl++. 


Comment 4 by js...@chromium.org, Jul 15 2009
The 1st issue is now dealt with in  issue 16875 . 

As for  issue 567  and  issue 4368 , why don't you make your case there?  I'll also 'root 
for you' :-)


Comment 5 by bugdro...@gmail.com, Jul 20 2009
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=20987 

------------------------------------------------------------------------
r20987 | jshin@chromium.org | 2009-07-17 13:15:40 -0700 (Fri, 17 Jul 2009) | 19 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_ar.xtb?r1=20987&r2=20986
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_ja.xtb?r1=20987&r2=20986
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_ko.xtb?r1=20987&r2=20986
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_th.xtb?r1=20987&r2=20986
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_zh-CN.xtb?r1=20987&r2=20986
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/resources/locale_settings_zh-TW.xtb?r1=20987&r2=20986

Set the default minimum font size webkit pref to 12 for Chinese and 10 for ja,ko,ar and th.

This will partly resolve [2] one of frequent complains of Chinese users (as long as they use Chinese Chrome). 
See http://www.google.com/support/forum/p/Chrome/thread?tid=389f306a52817110&hl=en

Leave alone other UI language versions alone for now (Firefox has per-script/per-language min font size [1]). Eventually, there need to be per-script which requires the webkit change. 


[1] http://mxr.mozilla.org/seamonkey/search?string=font.minimum-size
(note that Firefox does not set these values by default except for Thai, but offers a UI for a user to adjust). 

[2] See other issues (feature requests) mentioned in  http://crbug.com/16868 

BUG= 16875  ( http://crbug.com/16875 )
TEST=Open Chrome with '--lang=zh-CN' and 
  go to http://www.popyard.org/ and Chinese characters are larger than before.


Review URL: http://codereview.chromium.org/155607
------------------------------------------------------------------------

Comment 6 by js...@chromium.org, Jul 20 2009
Status: Invalid
Unless we want to have a meta bug about the issue, I guess we can close this. Not 
having a good category to close this with, I chose 'invalid', but that does not mean 
that this isssue is invalid. 

See  issue 2685  and issue 17078 for two other related issues. 

But the English font is still too small to look,like this page,I can't even see very 
clearly here if I didn't zoom in.
Project Member Comment 8 by bugdroid1@chromium.org, Oct 12 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 9 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-WebKit Cr-Content
Project Member Comment 10 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Sign in to add a comment