New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 164800 link

Starred by 46 users

Issue metadata

Status: Fixed
Owner:
Closed: Mar 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug-Regression



Sign in to add a comment

adobe flash text render blurry (not pepper flash)

Reported by pixiel...@gmail.com, Dec 7 2012

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.21 (KHTML, like Gecko) Chrome/25.0.1349.2 Safari/537.21

Steps to reproduce the problem:
1. open url
2. see text content
3. 

What is the expected behavior?
text should render clearly

What went wrong?
text render blurry

Example URL:
http://www.google.com/finance?q=NASDAQ%3AGOOG&ei=d3XBUMivEueniAKXJw

Does it occur on multiple sites: Yes

Is it a problem playing media? No

Is it a problem with a plugin? Yes adobe flash (not pepper flash)

Did this work before? Yes dont know, maybe 3 dev version before

Does this work in other browsers? Yes IE10

Chrome version: 25.0.1349.2  Channel: dev
OS Version: 6.2 (Windows 8)
 
1.JPG
0 bytes Download
Cc: pavanv@chromium.org nyerramilli@chromium.org
@Pavan,Can you please check this issue on Win8

Note: Not able to repro this issue on Latest Canary 25.0.1351.0 ,Dev 25.0.1349.2 on Win7
fix attachment
office computer with ATI Radeon HD2400 XT suffers from same issue, remember to disable pepper flash and only enable adobe flash enabled
Labels: -Type-Bug Type-Regression Action-BisectNeeded
Status: Untriaged
Reproducible on 25.0.1349.0 but not on 24.0.1312.35 for Win7. 

Unable to reproduce it on Mac 10.8.2.

Regression window:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=164863:171160&mode=html

I will update the bisect info.


Comment 5 Deleted

Reproducible on 25.0.1353.0~25.0.1322.0 but not on 25.0.1321.0 for Win XP, NPAPI Flash 11.5.502.110.

Not able to repro this issue on pepper flash.

Comment 7 by mbollu@chromium.org, Dec 10 2012

Attaching file.
blurry.png
293 KB View Download

Comment 8 by mbollu@chromium.org, Dec 11 2012

Labels: -Action-BisectNeeded Mstone-25
Bisect info:
You are probably looking for a change made after 167032 (known good), but no lat
er than 167053 (first known bad).
CHANGELOG URL:
  http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/tru
nk/src&range=167032%3A167053

Comment 9 by geki...@gmail.com, Jan 14 2013

think have the same bug on the adobe flash test page (http://www.adobe.com/software/flash/about/)

Comment 10 by geki...@gmail.com, Jan 14 2013

... have also an ati/amd video-card
Labels: Feature-Flash

Comment 12 by kareng@google.com, Jan 28 2013

Owner: viettrungluu@chromium.org
Status: Assigned
vtl any ideas?
Cc: viettrungluu@chromium.org
Owner: cpu@chromium.org
-> cpu

(though I have no idea what would cause this)
I was having this issue under one chrome "user" but not another.  I figured out it was related to the flash version that was in use.  I fixed it by going to chrome://plugins/ and enabling the other version of flash (the one that was enabled under the user account that worked fine).

The bad version of Flash:
Name:	Shockwave Flash
Description:	Shockwave Flash 11.5 r502
Version:	11,5,502,149
Location:	C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_5_502_149.dll
Type:	NPAPI

The good version of Flash:
Name:	Shockwave Flash
Description:	Shockwave Flash 11.6 r602
Version:	11.6.602.171
Location:	C:\Program Files (x86)\Google\Chrome\Application\26.0.1410.12\PepperFlash\pepflashplayer.dll
Type:	PPAPI (out-of-process)
Hi bpphilips
the working flash for you is the pepper flash, no the one we are trying to fix here
we are talking about the original flash provided by adobe, not the google one
thank you

Comment 16 by cpu@chromium.org, Feb 23 2013

Let me forward this issue to adobe. 

Comment 17 by dedr...@adobe.com, Feb 25 2013

I was able to narrow it down further. The injection should be in here: http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=167032:167042

Tested on Win 8 x64 with Flash 11.7.700.75. (GPU is nVidia Quadro FX 1800, for those who may have thought this was some kind of ATI thing)
Cc: jeffreyc@chromium.org
 Issue 172592  has been merged into this issue.
@Carlos 
Will you have time to look into this? 

It looks like the rendering issue is causing the player settings ui to be unresponsive. 
same issue here with blurry text/graphics and unresponsive. enabling pepflashplayer fixes the problem. vitals:

Google Chrome	25.0.1364.97 (m)
OS	Windows 7 or Server 2008 R2 SP1 64 bit
Flash plugin	11.6.602.171 C:\Users\zzz\AppData\Local\Google\Chrome\Application\25.0.1364.97\PepperFlash\pepflashplayer.dll (disabled)
Flash plugin	11,1,102,63 C:\windows\SysWOW64\Macromed\Flash\NPSWF32.dll
--- Crash data ---
Crash Reporting	Enable crash reporting to see crash IDs
For more details	https://support.google.com/chrome/?p=ui_usagestat
--- GPU information ---
Graphics card	NVIDIA Quadro FX 880M
Driver display name	nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver name (strong)	oem67.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section014:8.17.12.6883:pci\ven_10de&dev_0a3c&subsys_1521103c
Graphics card	NVIDIA Quadro FX 880M
Driver display name	nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver name (strong)	oem67.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section014:8.17.12.6883:pci\ven_10de&dev_0a3c&subsys_1521103c
--- GPU driver, more information ---
Vendor Id	0x10de
Device Id	0x0a3c
Driver vendor	NVIDIA
Driver version	8.17.12.6883
Driver date	6-5-2011
Pixel shader version	3.0
Vertex shader version	3.0
Cc: anthony....@adobe.com josewong...@gmail.com dedr...@adobe.com nikeda@chromium.org
 Issue 178140  has been merged into this issue.
 Issue 178140  has been merged into this issue.
Cc: danakj@chromium.org jam@chromium.org cpu@chromium.org
Owner: ----
Status: Available
Adobe has narrowed the regression range to here: http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=167032:167042

Adobe thinks crrev.com/167040 or crrev.com/167042 might be responsible.

danakj@ or jam@, what do you think?

thanks,
Jeff
If it's not pepper flash then AIUI the compositor is not involved at all, ruling out 167040.

Comment 26 by Deleted ...@, Feb 28 2013

I was having the same issue.. to fix it all I did was enable pepflashplayer.dll. 

go to chrome://plugins/
click "enabled" under pepflashplayer.dll




Comment 27 by snata...@gmail.com, Feb 28 2013

reproducible on Version 25.0.1364.97 m (Windows 7 32 bit)
switching to pepflashplayer fixes it
Switching to pepflashplayer doesn't fix the problem, it works around the problem. The problem itself still exists, scoped to NPAPI.
An Adobe engineer who was investigating  issue 177621  (which I believe is the same bug, so maybe this is helpful?) said the following:

"When we call GetValue on NPNVcontentsScaleFactor to get the scale factor in HiDPI mode, the browser returns a value of 1 instead of 2. The issue in Chrome is that the contentScaleFactor is getting initialized to a value of 1 but then is not getting set because the GetValue() function call to get NPNVcontentsScaleFactor is returning an error of type NPERR_GENERIC_ERROR."

Comment 30 Deleted

Comment 31 by Deleted ...@, Mar 1 2013

We received complains of users using Google Chrome of text blurry on Flash elements.
We have tried with the latest version of Flash 11.6.602.171 and Chrome 25.0.1364.97 and Windows 7 Professional 64bits and we have been able to reproduce the same problem in our site and on http://helpx.adobe.com/flash-player.html
After disabling the PepperFlash at chrome://plugins/ we have been able to solve the problem and see correctly all texts, but this is an advanced work around and we cannot tell to all our users to do that.
I'm attaching the Flash Player Help page with the blurry texts.
Thank you
Flash-Player-Help-Page.png
130 KB View Download

Comment 32 by div@chromium.org, Mar 1 2013

Labels: Hotlist-ConOps
Hi there,

We are seeing this issue reported in the Help Forum with the latest version of Chrome. I am adding Hotlist-Conops to this thread.

Help Forum Link: https://productforums.google.com/forum/#!category-topic/chrome/report-a-problem-and-get-troubleshooting-help/U2AcctJ2esM

Thanks,
Divya

Comment 33 by Deleted ...@, Mar 2 2013

Other symptoms exist. See all bugs marked as duplicate of this one.

Symptoms I experience are: right click menu popping up completely out of the Flash frame (actually, at the same horizontal coordinate as it should, but at the topmost position on the document), and Flash frames actually don't get the mouse clicking events (such as clicking the play button on a video) when the player is embedded.
Actually, I have found any Adobe Flash Player text is blurry in this
version.
Chrome 25.0.1364.97. Windows 7 64-bit. Both PPAPI and NPAPI Flash versions 11.6.602.171, and also went back to 11.5 NPAPI to test, with the problem still remaining there. Only solution was to disable NPAPI Flash (which I still have to use to workaround a different bug) and enable Pepper Flash, whenever viewing Google Finance charts. It's odd that at least one person here, #31, is experiencing the text blurring issue when Pepper Flash is ENABLED (which is the opposite of what others and myself are reporting).

Comment 36 by Deleted ...@, Mar 4 2013

with chrome  Version 25.0.1364.97, and pepper flash enabled, this seemed to solve the blurry text for me
Cc: srihariraju@chromium.org telukuntak@chromium.org mangalampalli@chromium.org dpete@chromium.org ranavdk@chromium.org joycel@chromium.org
 Issue 178485  has been merged into this issue.
Re jeffreyc's comment 29: This is true (we don't implement the npapi bits for hidpi plugins on mac -- the reasoning being that we do support hidpi in pepper flash) but unrelated to this bug. This bug is about regular text rendering on windows, while the hidpi parameter is a mac thing as far as I know. (And the screenshots on this bug are all single-resolution too).

jam@'s cl looks most related to me in the regression range above.

Comment 39 by Deleted ...@, Mar 4 2013

Disabling and re-enabling adobe flash from chrome://plugins fixed it for me.

Also using Adobe Flash Player
Version: 11.6.602.171

Comment 40 by kareng@google.com, Mar 4 2013

Owner: jam@chromium.org
Status: Assigned
giving to jam@ since consensus seems to be that it might be http://src.chromium.org/viewvc/chrome?view=rev&revision=167042 

Comment 41 by jam@chromium.org, Mar 6 2013

Status: Started
I have a fix on the way: https://codereview.chromium.org/12487003/
Project Member

Comment 42 by bugdroid1@chromium.org, Mar 6 2013

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=186446

------------------------------------------------------------------------
r186446 | jam@chromium.org | 2013-03-06T16:26:55.917695Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/plugins/npapi/plugin_instance.cc?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/plugins/npapi/plugin_instance.h?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/plugins/npapi/webplugin_delegate_impl.h?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/plugin/webplugin_proxy.h?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/renderer/webplugin_delegate_proxy.cc?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/common/plugin_messages.h?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/renderer/webplugin_delegate_proxy.h?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/plugin/webplugin_delegate_stub.cc?r1=186446&r2=186445&pathrev=186446
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/plugin/webplugin_delegate_stub.h?r1=186446&r2=186445&pathrev=186446

Fix painting glitch with text and NPAPI plugins. This was a regression from r167042. The problem was that for non-transparent windowless plugins we were combining the data below the plugin with the data that the plugin creates. We could just copy directly and not do any alpha-blending.

BUG= 164800 
Review URL: https://codereview.chromium.org/12487003
------------------------------------------------------------------------

Comment 43 by jam@chromium.org, Mar 6 2013

Cc: tanyarad@chromium.org
Labels: -Mstone-25 Mstone-26 Merge-Requested ReleaseBlock-Stable
Status: Fixed
Seems like we should get this in for M26. The fix is pretty low risk.
Thanks for the fix, John!

Does anyone know when this regressed? Was it a regression in M25 Stable? Should we consider merging to M25?

Comment 45 by jam@chromium.org, Mar 6 2013

jeffreyc: it regressed in r167042 so it's in M25. However M25 has gone to stable a while ago so it seems too late to hit that.
While this only affects NPAPI flash, PPAPI flash is not yet working flawlessly for everyone. We should request a merge to 25 (after the merge to 26 is approved and live). An update to 25 isn't that unlikely.
Cc: kerz@chromium.org
+kerz to assess risk and whatnot.
Pavan: could you please get this bug verified in 27.0.1432.0 build? thanks!
Labels: TE-Verified-27.0.1432.1
Tested this issue with Latest Canary#27.0.1432.1 on Win7 - Working as intended.

Attached the screenshot for your reference.

Thank you!
Adope Flash_Working.JPG
118 KB View Download
Can we merge this to 26?
Status: Started
Reverting to "started" to get TPM eyeballs. 
Labels: -Merge-Requested Merge-Approved
This is great news!
Cc: -viettrungluu@chromium.org

Comment 55 by jam@chromium.org, Mar 8 2013

Status: Fixed
Project Member

Comment 56 by bugdroid1@chromium.org, Mar 8 2013

Labels: -Merge-Approved merge-merged-1410
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=186977

------------------------------------------------------------------------
r186977 | jam@chromium.org | 2013-03-08T17:52:42.735053Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/plugin/webplugin_proxy.h?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/renderer/webplugin_delegate_proxy.cc?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/common/plugin_messages.h?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/renderer/webplugin_delegate_proxy.h?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/plugin/webplugin_delegate_stub.cc?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/content/plugin/webplugin_delegate_stub.h?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/webkit/plugins/npapi/plugin_instance.cc?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/webkit/plugins/npapi/plugin_instance.h?r1=186977&r2=186976&pathrev=186977
   M http://src.chromium.org/viewvc/chrome/branches/1410/src/webkit/plugins/npapi/webplugin_delegate_impl.h?r1=186977&r2=186976&pathrev=186977

Merge 186446
> Fix painting glitch with text and NPAPI plugins. This was a regression from r167042. The problem was that for non-transparent windowless plugins we were combining the data below the plugin with the data that the plugin creates. We could just copy directly and not do any alpha-blending.
> 
> BUG= 164800 
> Review URL: https://codereview.chromium.org/12487003

TBR=jam@chromium.org
Review URL: https://codereview.chromium.org/12510010
------------------------------------------------------------------------
pavan or manoranjanr: could you verify this in 26 when it catches up the CL?
Project Member

Comment 58 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-Webkit -Type-Regression -Mstone-26 -Feature-Flash Cr-Content Type-Bug-Regression Cr-Content-Plugins-Flash M-26
Labels: TE-Verified-26.0.1410.30
Verified the issue on chrome 26.0.1410.30 and is working fine. Attached a screen shot for the same.

Thanks.
Rendering.png
324 KB View Download

Comment 60 by jam@chromium.org, Mar 14 2013

 Issue 189118  has been merged into this issue.
i have 10,000 companies hoping that this fix also fixes this rendering issue:

http://code.google.com/p/chromium/issues/detail?id=178156



This issue is still recurring and only works after i enabled the Flash Plugin which i disabled due to Adobe Shockwave crashing Chrome most of the time.

I am using Windows 7 and running Chrome version 25.0.1364.172 m . I have attached an image. I am not looking forward to Adobe Shockwave crashing Chrome as often as it does.

3-25-2013 10-53-58 PM.png
42.5 KB View Download

Comment 63 Deleted

@62 I don't think this was upstreamed into 25 (the fix is in Chrome 26). You can try beta if you want to see the fix. Please open a new bug with crash IDs for your other issues. http://support.google.com/chrome/bin/answer.py?hl=en&answer=107348 
Correct - the fix is in Chrome 26, not Chrome 25.

Chrome 26 Stable will be released very very soon. Sit tight.
Project Member

Comment 67 by bugdroid1@chromium.org, Apr 5 2013

Labels: -Cr-Content Cr-Blink
Project Member

Comment 68 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash

Comment 69 by Deleted ...@, Jun 14 2013

My Chrome is still blurry on a second monitor when I maximize Chrome. If I restore the window to a size less than maximum, it's better.

I also can't get a screen capture of the symptom. When I hit PrtSc to activate my screen capture utility, it restores the screen to normal. Escaping out of the PrtSc app makes it go back to blurry.
@69, please open a new bug with full details. This issue has been closed already. 

Comment 71 by laforge@google.com, Jul 24 2013

Cc: -jeffreyc@chromium.org

Sign in to add a comment