Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
This site will be undergoing maintenance today: Thursday, 04:30PM PDT
Issue 163553 Mouse Wheel and fonts not showing up properly in Pepper Flash on Latest Chrome 24 beta
Starred by 2 users Reported by jeff...@gmail.com, Nov 30 2012 Back to list
Status: Duplicate
Merged: issue 158506
Owner: ----
Closed: Dec 2012
Cc: nyerramilli@chromium.org
Components:
OS: Windows
Pri: 1
Type: Bug-Regression


Sign in to add a comment
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11

Steps to reproduce the problem:
1. Visit: http://blog.flexexamples.com/wp-content/uploads/DataGridColumn_editable_test/bin/main.html

What is the expected behavior?
Look at the datagrid headers, should be a Verdana-looking font in bold

You should be able to scroll using the mouse wheel

What went wrong?
Headers don't display at all and scroll wheel does not work.

Example URL:
http://blog.flexexamples.com/wp-content/uploads/DataGridColumn_editable_test/bin/main.html

Does it occur on multiple sites: N/A

Is it a problem playing media? No

Is it a problem with a plugin? Yes Flash (default pepper version)

Did this work before? Yes Stable version 23

Does this work in other browsers? Yes IE9, Firefox 16.0.2 and 17.0

Chrome version: 24.0.1312.27  Channel: beta
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

This is a pared down test case I found on the web.  I have a few apps that exhibit this same problem.  Please fix it before releasing version 24 stable.

I had to downgrade to version 23 stable to get this to go away.

It also works like it's supposed to in Version 25.0.1338.0 canary.

Given that, chances are you guys probably fixed this already, but just in case you haven't, I hope this narrows it down for you.
 
Labels: -Area-Compat -Type-Bug Area-WebKit Type-Regression Mstone-24
Status: Untriaged
Labels are displayed properly but mouse wheel doesn't function

This doesn't reproduce on Chromium builds

Regression range:

You are probably looking for a change made after 24.0.1312.24 (known good), but
no later than 24.0.1312.25 (first known bad).
CHANGELOG URL:
http://omahaproxy.appspot.com/changelog?old_version=24.0.1312.24&new_version=24.
0.1312.25

Labels: -Pri-2 Pri-1 ReleaseBlock-Stable
Comment 3 by dharani@google.com, Nov 30 2012
Owner: ananta@chromium.org
Status: Assigned
ananta: could it be your change - http://src.chromium.org/viewvc/chrome?view=rev&revision=169451
Comment 4 by pavanv@chromium.org, Nov 30 2012
I ran the bisect using official builds between 23.0.1271.95 (stable) and 24.0.1312.26 (beta) with following results.

Revision 24.0.1285.0 is [(g)ood/(b)ad/(u)nknown/(q)uit]: b
You are probably looking for a change made after 24.0.1284.2 (known good), but n
o later than 24.0.1285.0 (first known bad).
CHANGELOG URL:
http://omahaproxy.appspot.com/changelog?old_version=24.0.1284.2&new_version=24.0
.1285.0
Dharani, my fix  http://src.chromium.org/viewvc/chrome?view=rev&revision=169451
only comes into play for ChromeFrame. Should not affect Chrome.


Comment 6 by dharani@google.com, Dec 3 2012
Owner: ----
Status: Untriaged
Pavan, thanks for checking again! Ananta: looks like the bisect window was wrong initially.

Webkit changlog: http://trac.webkit.org/log/trunk?action=follow_copy&mode=follow_copy&rev=130232&stop_rev=130046&limit=500&verbose=on
Comment 7 by dharani@google.com, Dec 3 2012
This bug could be related to 158506. I have merged the fixes to M24 build. Probably it should be fixed in tomorrow's build.
Cc: nyerramilli@chromium.org
Tested on 24.0.1312.32 on Win7 with the URL http://blog.flexexamples.com/wp-content/uploads/DataGridColumn_editable_test/bin/main.html

able to scroll using the mouse wheel and showing the Headers.

Please find the attached screenshot.
163553_M24_Win7.JPG
17.3 KB View Download
Comment 9 by dharani@google.com, Dec 4 2012
Mergedinto: 158506
Status: Duplicate
Project Member Comment 10 by bugdroid1@chromium.org, Mar 9 2013
Labels: -Area-WebKit -Type-Regression -Mstone-24 Cr-Content Type-Bug-Regression M-24
Project Member Comment 11 by bugdroid1@chromium.org, Apr 5 2013
Labels: -Cr-Content Cr-Blink
Sign in to add a comment