Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 161481 ConnectionTesterTest Uses Unused Directory as TestServerWroknig Directory
Starred by 1 user Project Member Reported by csharp@chromium.org, Nov 16 2012 Back to list
Status: Verified
Owner: mar...@chromium.org
Closed: Nov 2012
Cc: csharp@chromium.org
OS: ----
Pri: 2
Type: Bug

Blocking:
issue 98637


Sign in to add a comment
ConnectionTesterTest uses the net/data/url_request_unittest directory as the working directory for its test_server, which works when the machine has a full checkout.

With the Isolation testing (http://www.chromium.org/developers/testing/isolated-testing), the machines only have the files used, and since ConnectionTesterTest doesn't do anything other than check for the directory, it is not copied to the machine and the test fails.

ConnectionTesterTest should be modified to either access a file in the directory (so that it exists) or just use ScopedTempDir to create the working directory.
 
Comment 1 by csharp@chromium.org, Nov 16 2012
Blocking: chromium:98637
Comment 2 by csharp@chromium.org, Nov 16 2012
Owner: eroman@chromium.org
eroman@, could you find someone to fix this issue? Thanks (I picked you since you have some TODOs in the file).
Comment 3 by maruel@google.com, Nov 17 2012
It's in unit_tests.
Comment 4 by mar...@chromium.org, Nov 20 2012
And the test cases are:
ConnectionTesterTest.DeleteWhileInProgress
ConnectionTesterTest.RunAllTests
Comment 5 by mar...@chromium.org, Nov 20 2012
Cc: -mar...@chromium.org
Owner: mar...@chromium.org
Status: Started
Project Member Comment 6 by bugdroid1@chromium.org, Nov 20 2012
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=168864

------------------------------------------------------------------------
r168864 | maruel@chromium.org | 2012-11-20T20:33:05.857700Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/net/connection_tester_unittest.cc?r1=168864&r2=168863&pathrev=168864

Fix test that was reading in a directory that is not used at all.

Was probably the result of a copy-paste.

R=mmenke@chromium.org
BUG= 161481 


Review URL: https://chromiumcodereview.appspot.com/11415072
------------------------------------------------------------------------
Comment 7 by mar...@chromium.org, Nov 20 2012
Status: Verified
http://build.chromium.org/p/chromium.swarm/builders/Linux%20Swarm%20Tests%20%281%29/builds/31563

unit_tests_swarm was 100% green, yay!
Project Member Comment 8 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Build Build
Sign in to add a comment