New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 162207
Owner: ----
Closed: Feb 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

Flash audio has a slight delay before playing using the PPAPI version of Flash plugin.

Reported by m...@noiseandheat.com, Nov 15 2012

Issue description

Chrome Version       : 23.0.1271.64 (Official Build 165188)
URLs (if applicable) : http://noiseandheat.com/blog/2012/11/chrome-and-ppapi-flash-audio-syncing-bug/#example
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 6.0.2: OK
  Firefox 16.0.2: OK

What steps will reproduce the problem?
1. Ensure you using the PPAPI version of the Flash plugin
2. Visit the URL http://noiseandheat.com/blog/2012/11/chrome-and-ppapi-flash-audio-syncing-bug/#example
3. Move mouse cursor over the blue rectangle.

What is the expected result?

The rectangle should turn red and a BZZZ sound should play simultaneously.

What happens instead?

The sound plays fractionally after the rectangle turns red.

Please provide any additional information below. Attach a screenshot if
possible.

Testing in other browser, or disabling the PPAPI version of Flash fixes the problem, so it seem likely there is something odd with the sound playback for the PPAPI version of Flash.

The problem is easier to spot if you try using a version in another browser a few times to get a feel for how the colour change and sound playing should behave.

The source for the Flash movie and the compiled movie may be downloaded from: https://gist.github.com/4077864
 
Labels: Feature-Flash
Mergedinto: 162207
Status: Duplicate
Project Member

Comment 3 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-Undefined -Feature-Flash Cr-Content-Plugins-Flash
Project Member

Comment 4 by bugdroid1@chromium.org, Apr 5 2013

Labels: Cr-Blink
Project Member

Comment 5 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash

Sign in to add a comment