Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 160025 Clicked links are not being marked as 'Read' during Navigation
Starred by 20 users Reported by jmjjeff...@gmail.com, Nov 8, 2012 Back to list
Status: Fixed
Owner: caitkp@chromium.org
Closed: Mar 2013
Cc: telukuntak@chromium.org, jayakrishnat@chromium.org, pavanv@chromium.org, nyerramilli@chromium.org, dpete@chromium.org, smokana@chromium.org, ligim...@chromium.org, ranavdk@chromium.org, nikeda@chromium.org, tkonchada@google.com, mnarula@chromium.org, joycel@chromium.org, vyalla@chromium.org, vandanashah@chromium.org
OS: All
Pri: 1
Type: Compat


Sign in to add a comment
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.5 Safari/537.17

Steps to reproduce the problem:
1.  Visit CNN.com or nbcnews.com 
2.  click any link to read the story 
after reading click the 'back navigation arrow', or use Alt+left arrow or back button on your mouse
3. Note on return to the main page that the link is NOT dimmed or any indication you have already been to this link.

What is the expected behavior?
Link should be dimmed or change color to indicate you have already have read this link.

What went wrong?
Link NOT marked or showing any indication that the link has been visited.

Did this work before? Yes 

Chrome version: 24.0.1312.5  Channel: dev
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

I have tried turning off 'Do NOT Track' option, and this did not change be behavior, i.e. links are still NOT marked.
 
Comment 1 by dharani@google.com, Nov 8, 2012
Labels: Action-BisectNeeded
Cc: nyerramilli@chromium.org
Labels: -Action-BisectNeeded Action-FeedbackNeeded
Not able to repro this issue on Latest canary 25.0.1320.2 and Dev 24.0.1312.5 on Win7

Please find the attached screenshot for the same.

Can you please check again and let us know if the issue still persists.
sorry.. screenshot missed in previous comment.
160025_M24_Win7.jpg
298 KB View Download
Comment 4 by vyalla@chromium.org, Nov 12, 2012
Cc: vyalla@chromium.org
Not able to repro this issue on Latest Canary #25.0.1323.0 and Dev #24.0.1312.5 on Win7

Please find the attached screenshot.

Regards,
Venkat Yalla
160025.png
773 KB View Download
Comment 5 by jmjjeff...@gmail.com, Nov 12, 2012
Sorry, didn't get any email indicating anyone responded.  Yes the issue persists, inks are not being marked as 'read'. 



Comment 6 by jmjjeff...@gmail.com, Nov 14, 2012
The issue still continues even after the latest update to Google Chrome 25.0.1323.1, and two restarts of the computer. 

CNN, NbcNews do not properly mark links as 'read'.  Firefox 19.0a1 and IE 10 preview on win7 x64 also work properly.

I can't believe I'm the only one with this issue.  If I am, what would you suggest I try?
Comment 7 by jmjjeff...@gmail.com, Nov 14, 2012
More testing:
1.  removed ALL my user data - problem remained
2.  created a new Profile - problem remained
3.  uninstalled Chrome dev version and installed Release version
4.  Now, it is working as it should, links are being marked as 'Read'

Interestingly - when I installed the Release version all the links I had previously 'read' with the dev version were now marked as 'read', even though on uninstall I told the uninstaller to 'remove' all my data.  I then removed manually the left over 'Chromium' folder before installing the Release version, and yet... strangely...
previous read links were now marked as 'Read'..  some funky stuff there me thinks.


Comment 8 by jmjjeff...@gmail.com, Nov 15, 2012
Even more testing:

I just noticed that if I open a 2nd instance of the browser, Ctrl+N, links clicked on in the 2nd instance are 'marked as read'... 

Also, testing latest Canary build - links clicked are NOT marked, prior to an update just a few minutes ago, don't know what build I was using at the time, it was working OK< but now it too is not marking links 'read'... *sigh*

Something is very wonky....  


Comment 9 by jmjjeff...@gmail.com, Nov 15, 2012
from comment 8 above, Canary build is: Version 25.0.1326.0 now that is also not working...
Comment 10 by vyalla@chromium.org, Nov 16, 2012
Cc: pavanv@chromium.org
Not able to repro this issue on Latest Canary # 25.0.1326.0.
Please find the attached screen shot.

@Pavan, Can you please look into this.

Thanks,
Vyalla
160025_Update.png
1.4 MB View Download
Comment 11 by smokana@chromium.org, Nov 16, 2012
Cc: smokana@chromium.org
@ jmjjeffery, Can you provide a video recording of this behaviour. I tried to reproduce  but couldn't replicate the issue.
Comment 12 by jmjjeff...@gmail.com, Nov 16, 2012
No, sorry... I don't have any means to make a recording of the problem.  I'm on a desktop, not a laptop with a  webcam, nor do I have any capture software. 


Labels: nomedia
Cc: ligim...@chromium.org
Labels: -Area-UI Area-Compat
Unable to reproduce this issue using the current stable - 23.0.1271.64,Beta - 24.0.1312.14 and 25.0.1327.0 canary in Mac @ Win 7.

@ jmjjeffery  Are you using any extensions ? If yes could you navigate to chrome://extensions and update the thread.

Also if possible send us the screen recording of the issue .
You can download free software screencast from the below link .

http://download.cnet.com/Screencast-O-Matic/3000-13633_4-75734109.html?part=dl-&subj=dl&tag=button

Thanks for the co operation .

Comment 15 by jmjjeff...@gmail.com, Nov 16, 2012
Reply to Comment 14:

I am not using any extensions.  As I've stated above, current 'stable release' is working as it should.  Its only appearing in the dev builds, and Canary.

I have on several occasions now deleted all profiles, and nuked install directory and the directory in 'local' under my Profile on Win7.  

My workweek has started, so will be a few days more than likely before I can try the recommended software.  

As stated above, I can install the dev-builds, see the issue, uninstall the dev build and install the 'release stable' and low an behold the links are 'marked as read'...  So I'm at a total loss as to why I see it and you guys are not able to repo.

Not sure what a screen-cast will prove, but will try again, sometime mid-week.
Comment 16 by jmjjeff...@gmail.com, Nov 16, 2012
More testing: 

On my work PC running WinXP SP3 I just downloaded the latest dev version:
25.0.1323.1
No Extensions
Only change made was:  Start Where I left off (been setting that pref in all testing)
At first links were being marked 'read'... 
Then.. Closed/restarted the browser and the links that were marked were NOT anymore.
Reading other stories on CNN.com including the one that was marked 'read' before are not being marked correctly. 
Doing Ctrl+N to open a new window, then opening cnn.com in the new Window, shows the links as 'read', just as I've stated above in my other testing on my home machine which is running Win7 x64.


Comment 17 by jmjjeff...@gmail.com, Nov 17, 2012
Using the Win7 built-problem Recorder I have recorded steps in a zip-file to repo the problem.


Chromedevlinkissue.zip
2.2 MB Download
Comment 18 by jmjjeff...@gmail.com, Nov 17, 2012
Seems that setting the 'Continue where I left off' in 'Settings' is part of the problem as well.  Enabling that setting and opening a tab-set will show none of the links as 'read', nor are new one marked. 

Pinning a tab in 1st position, say:
1. https://www.google.com/intl/en/chrome/browser/welcome.html
2. Then Open CNN
3. Open nbcnews 

all is well, but... enabling 'Continue where I left off'  will once again break
the pages in that links are not showing or getting marked as 'read'.

At this point I don't know what more I can to prove that something is broken.




Cc: tkonchada@google.com
Labels: -Action-FeedbackNeeded
Status: Untriaged
Tested the above issue on Win7 in the following way:

1.open Chrome://settings in first tab, select the option "Open the new tab page" under "On Startup".
2.Open "www.cnn.com" in second tab and click on any link in the web page.
3.After reading the story Click on browser back button or use Alt+left arrow to go back to the home page and observe the link clicked previously.
4.The link appears dimmed indicating that it is read.Now close the second tab.
5.Now in the first tab(ie, Chrome://settings) change the option to "Continue where i left" under "On Startup" and exit the browser.
6.Again open the browser(the browser opens with first tab showing Chrome://settings).In second tab repeat the steps 2 & 3 and observe that the link doesn't appear dimmed.

The issue is observed only in latest canary 25.0.1331.0 on Win7 OS.
Unable to repro the same in current dev 25.0.1323.1, dev 25.0.1331.0

Please find the screenshots for reference.

Thanks!
Links not dimmed after reading.png
979 KB View Download
160025.png
104 KB View Download
160025 - canary.png
104 KB View Download
Links dimmed indicating read.png
1005 KB View Download
Comment 20 by nman...@gmail.com, Dec 29, 2012
I don't get this with cnn.com, but I have been seeing the problem on the following site:

http://www.mail-archive.com/vortex-l@eskimo.com/index.html

I seem to remember the problem appearing about a month or so ago in the Chromium nighlies I'm following. Right now I'm on 26.0.1373.0 (174757) and have the problem with the site I just mentioned. I think the prior build I was using,174592, was showing visited links correctly, but it was the first of many builds which did and now I see the defective behaviour is back.

Should I open another issue for this or is this the same problem?
Comment 21 by nman...@gmail.com, Dec 29, 2012
I forgot to mention that I'm on Windows 7 64 bit, for what it's worth.
Comment 22 Deleted
Comment 23 by nman...@gmail.com, Dec 29, 2012
Looks like the issue I'm facing is actually https://code.google.com/p/chromium/issues/detail?id=167035
Comment 24 Deleted
I am using Chrome stable 24.0.1312.52 on Windows 7 32 bit and experienced this issue.

It looks like the issue exists in the first page we navigate to after opening chrome. It happens in google search results page also, even with omnibox search. After navigating to other page everything works fine. Opening new tab also works fine. Issue exists only with first tab at beginning. I have new tab page as my home page.

To reproduce this issue just close all the chrome windows first and open one new window. Then navigate to a page where you expect visited links exist. or just use omnibox to search something that you already searched and clicked a link before.

64 bit Linux, stable Chrome 24.0.1312.52

I confirm this issue, and it's kinda nasty and critical.
And no way for downgrade to 23 without erasing profile.

Comment 27 by dharani@chromium.org, Jan 14, 2013
Labels: Action-BisectNeeded
Bisection result:

==============
You are probably looking for a change made after 163865 (known good), but no later than 163872 (first known bad).
CHANGELOG URL:
  http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=163865%3A163872
==============

The following commit looks relevant:

  r163871: Convert VisitedLinkMaster to a ProfileKeyedService

  http://src.chromium.org/viewvc/chrome?view=rev&revision=163871

Reverting r163871 on top of Chromium 24.0.1312.52 appears to fix the problem and the first page opened inside a new Chromium instance correctly styles visited links once again.
Comment 29 by dharani@chromium.org, Jan 14, 2013
Labels: -Pri-2 Pri-1 Mstone-24
Owner: caitkp@chromium.org
Status: Assigned
Thank you so much evangelos@! caitkp@: Once you fix it, please request for merge.
Labels: -Action-BisectNeeded
Removing 'Action-BisectNeeded' label, as the Bisect window has been provided in comment#28.

Thank you!
Labels: -OS-Windows OS-All
Assuming OS-All, feel free to re-scope if wrong.
Cc: nikeda@chromium.org
Comment 33 by dharani@chromium.org, Jan 16, 2013
caitkp@ already has a fix and its under review - https://codereview.chromium.org/11928004/
Cc: joycel@chromium.org ranavdk@chromium.org jayakrishnat@chromium.org vandanashah@chromium.org dpete@chromium.org mnarula@chromium.org telukuntak@chromium.org
Issue 169856 has been merged into this issue.
Project Member Comment 35 by bugdroid1@chromium.org, Jan 17, 2013
Labels: merge-merged-1312
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=177279

------------------------------------------------------------------------
r177279 | caitkp@chromium.org | 2013-01-17T00:11:25.889855Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/browser/visitedlink/visitedlink_master_factory.cc?r1=177279&r2=177278&pathrev=177279
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/browser/visitedlink/visitedlink_master_factory.h?r1=177279&r2=177278&pathrev=177279

Create Visited link service with profile to make sure all visited link events are captured.

BUG= 160025 

Review URL: https://codereview.chromium.org/11928004
------------------------------------------------------------------------
Comment 36 by Deleted ...@, Jan 17, 2013
if I close the browser and re-open, this problem remains..

if I close the tab, open an new tab  and cut and paste the url of the page I was in, then the problem is fixed (for that session anyway),

Comment 37 Deleted
Comment 38 by athigle@chromium.org, Jan 18, 2013
Status: Assigned
Comment 39 by athigle@chromium.org, Jan 18, 2013
Status: Verified
Verified fixed in 24.0.1312.56 on Windows 7, OS X 10.7.5 and Linux Ubuntu 10.04

Visited links on Google search results, cnn.com, nbcnews.com are differentiated from other links. Also working good on restarting the browser (with "continue where I left off" checked)
Comment 40 by smo...@gmail.com, Feb 22, 2013
Problem went away in stable 24 series has re-occurred in latest stable. 

Google Chrome	25.0.1364.97 (Official Build 183676) 
OS	Linux 
WebKit	537.22 (@143379)
JavaScript	V8 3.15.11.15
Flash	11.6.602.171
User Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22
Command Line	 /opt/google/chrome/google-chrome --flag-switches-begin --flag-switches-end
Executable Path	/opt/google/chrome/google-chrome
Profile Path	/home/smooge/.config/google-chrome/Default
Status: Unconfirmed
I am indeed seeing user reports about this.
caitkp@: can you help finding what's going on? Do you need anything to troubleshoot this?
Comment 42 Deleted
I had the problem in 24 as in this 25 release. This is a webpage from which links will not change the colors after visiting even if on Firefox and IE they do.

http://osm.stilpu.org/osmaware/romania/

Version 25.0.1364.97 m
Windows 7
Comment 44 by caitkp@chromium.org, Feb 22, 2013
Labels: -Mstone-24 Mstone-25
The fix for this which landed on the M24 branch fixed this bug, but caused a crash (crbug.com/171475), and as such, didn't get merged to M25 or trunk.

I am working on https://codereview.chromium.org/12221069/, a temp fix for M25, and will update once it has landed.

Comment 45 by supreme...@gmail.com, Feb 22, 2013
Version 25.0.1364.97 link colour not changing. 
Comment 46 by 19722...@gmail.com, Feb 22, 2013
Yes, same thing for me...it was recently fixed and here we are again? Why?
Status: started
Marking as started as per #44.
Thanks caitkp@


30+ users have reported this issue in 'GoogleFeedback'.

Version :  25.0.1364.97

User's reports that visited links are not marked as its has been visited. Purple color stopped appearing on clicked links. Users have reported this issue since the Stable update to Chrome 25

Additional Info: 
1. Users says that issue was resolved in M24 but it reappears after the update of M25 stable.

NOTE: We could not reproduce the issue on Chrome (25.0.1364.45) M25 Dev version on Linux.

Sample user reports:
http://goto.google.com/642253745
http://goto.google.com/715135219
http://goto.google.com/642163333
http://goto.google.com/656575952

For more user reports refer the cluster URL:
http://goto.google.com/3489857
Comment 49 by 19722...@gmail.com, Feb 26, 2013
I am using Chrome Ver. 25.0.1364.97 m and have this problem....when do you
expect a patch?
to #48
How to reproduce this issue:

1. Configure browser to restore last session at startup.
2. Open some pages in new tabs and click some links. Visited links are colored.
3. Close browser.
4. Start browser with restored session. Visited links are not colored.
5. Refresh pages - doesn't help.
6. Close tabs and undo with ctrl+shift+t. Links in reopened tabs are ok.
Project Member Comment 51 by bugdroid1@chromium.org, Feb 26, 2013
Labels: merge-merged-1364
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=184687

------------------------------------------------------------------------
r184687 | chrome-bot@google.com | 2013-02-26T19:15:02.191721Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1364/src/chrome/browser/chrome_browser_main.cc?r1=184687&r2=184686&pathrev=184687

Temporary fix for installer/visitedlink crash (crbug.com/171475)

Force VisitedLinkMaster to be created after installer is finished (to avoid crash), but before browsing starts, to ensure visited link events on the first tab are caught.

TEST= no crash when installing from installer, visited links still work.
BUG= 171475 ,  160025 
Review URL: https://codereview.chromium.org/12221069
------------------------------------------------------------------------
Comment 52 by lipich@google.com, Mar 4, 2013
I'm seeing quite a few reports about this in our RU Chrome forum. When do we expect to release a fix?

Users are on  25.0.1364.97.


Status: Fixed
Comment 54 by 19722...@gmail.com, Mar 6, 2013
Yes, updating to Version 25.0.1364.152 m has corrected the issue, thanks...
Corrected in Version 25.0.1364.152 m 

Great - thanks all.
I don't know why this is marked as fixed because I still have the same problem and I already have 25.0.1364.152 m . Nothing has changed
Project Member Comment 57 by bugdroid1@chromium.org, Mar 10, 2013
Labels: -Area-Compat -Type-Bug -Mstone-25 Type-Compat M-25
Comment 58 by Deleted ...@, Mar 25, 2013
Having issue in "Version 25.0.1364.172 m"
I'm still having the issues but it seems that the problem was marked as Fixed and closed even if there are a lot of people that are still having the issue. I had to go back to FF because this issue was very bad for me.
Comment 60 by 19722...@gmail.com, Mar 25, 2013
No problem here with clicked links are not being marked as 'Read' during
Navigation and this is with Version 25.0.1364.172 m, working as it should.
Well, the problem is that on some pages is working and on some it does not.
For example on this one it doesn't and it drives me nuts. It's working with FF and IE but not on chrome so the problem is with Chrome. And as you can see there are a lot of links and it's very important for me to know which links I've already visited and which not.

This is the link: http://osm.stilpu.org/osmaware/
Comment 62 by Deleted ...@, Mar 27, 2013
also the tabs don't know what the other tabs are doing. If I visited a link on one tab, the other tabs should update. It works perfectly on firefox.

1. ctrl+click a link twice to open two tabs: tab#1 and tab#2. 
2. click a link on tab#1
3. tab#2 should reflect that that link has been visited.

current behavior on Version 25.0.1364.172 m:
same link on tab#2 remains blue, only when you hover on the link and it changes purple (visited)



Comment 63 by Deleted ...@, Apr 11, 2013
Сейчас появился жирный шрифт 
scrin1.JPG
88.1 KB View Download
scrin2.JPG
54.1 KB View Download
Comment 64 by Deleted ...@, Oct 7, 2014
I'm having a similar problem but only with Google's search page when using Safari.  If I use Firefox, then links turn from blue to purple when I read them.  If I use Safari, they stay blue.  This has been the case for about six months; prior to then, they turned purple as they should.  I have this problem only with Google's search page, nowhere else.  I don't use Chrome so don't know whether this issue would occur with that browser.  Is this a Google problem or a Safari problem?
Comment 65 by 19722...@gmail.com, Oct 8, 2014
Issue has long been fixed for me and when it did occur it was confined to
just the Chrome browser, IE & Firefox were unaffected. Currently running
Chrome (Version 38.0.2125.101 m) and do not have any such issues.
Sign in to add a comment