Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 159896 Chrome 23 some plugins stopped working - Google Voice, Unity Player
Starred by 39 users Reported by, Nov 7 2012 Back to list
Status: Verified
Closed: Nov 2012
NextAction: ----
OS: Windows
Pri: 2
Type: Bug

  • Only users with EditIssue permission may comment.

Sign in to add a comment
Chrome Version       : 23.0.1271.64 (Official Build 165188) m
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:   OK
  Firefox 4.x:   OK
       IE 7/8/9: OK

Google voice plugin failing (which was installed and worked perfectly in Chrome version 22 and older):

What steps will reproduce the problem?
1. Go to gmail
2. Click on "Call phone" icon
3. See the window that says "Please download the voice plugin to make a call."
4. Follow the link to
5. Click on "Install voice and video chat", which initiates the download of GoogleVoiceAndVideoSetup.exe
6. Run GoogleVoiceAndVideoSetup.exe, no errors
7. Restart the browser
8. Go to step 1, same exact thing

Pretty much the same happens with the Unity player.

What is the expected result?

Plugins working

What happens instead?

Plugins missing, and unable to install

Please provide any additional information below. Attach a screenshot if

OS: Win 7 Home Premium SP1, 64 bit

Computer: 8GB RAM, tons of free space on disk.

Labels: nomedia
Comment 2 by, Nov 8 2012
Labels: Feature-Plugins
Labels: OS-Windows
Is the plugin listed and enabled on chrome://plugins ?
No, neither of the plugins are listed. However some other ones are there:

Adobe Flash Player

Chrome Remote Desktop Viewer

Native Client

Chrome PDF Viewer

Java(TM) (disabled)

Labels: -Area-Undefined Area-Internals
I'm also affected by this issue.

At work I'm developing a plugin. Since today, when I got upgraded to 23.0.1271.64 (Official Build 165188) m, our plugin is not detected anymore on 2 of the computers in our office. Other plugins on my machine are also not detected anymore, including Google Voice, Quicktime, Unity3D and some Yahoo Messanger State plugin.

I only see the following 7 plugins in Chrome's chrome://plugins as opposed to 16 in Firefox's Tools/Addons/Plugins:
Adobe Flash Player - Version:
Location:	C:\Program Files (x86)\Google\Chrome\Application\23.0.1271.64\PepperFlash\pepflashplayer.dll

Windows Media Player - Version: (Disabled)
Location:	C:\Program Files (x86)\Mozilla Firefox\plugins\np-mswmp.dll

Chrome Remote Desktop Viewer
Location:	internal-remoting-viewer

Native Client
Location:	C:\Program Files (x86)\Google\Chrome\Application\23.0.1271.64\ppGoogleNaClPluginChrome.dll

Chrome PDF Viewer
Location:	C:\Program Files (x86)\Google\Chrome\Application\23.0.1271.64\pdf.dll

Adobe Reader - Version: (Disabled)
Location:	C:\Program Files (x86)\Adobe\Reader 10.0\Reader\Browser\nppdf32.dll

Java(TM) - Version: 6.0.370.6
Location:	C:\Windows\SysWOW64\npdeployJava1.dll

Looking with Process Monitor from SysInternals I can see that chrome.exe is enumerating the MozillaPlugins registry key and is finding our plugin and npgoogletalk.dll and is even doing successful CreateFileMapping and Load Image operations on them.

I found an entry in HKLM\Software\Wow6432Node\MozillaPlugins\,version=1.6.0_37 which has a Path key with a value of C:\Windows\SysWOW64\npdeployJava1.dll which would explain why the Java plugin above gets loaded. However HKLM\Software\Wow6432Node\MozillaPlugins has more entries, including our plugin and they don't get loaded.

If I change the Path of HKLM\Software\Wow6432Node\MozillaPlugins\ to an invalid value (change the dll extension to test for example) than I get 11 plugins instead of 7 in Chrome, so certain entries in MozillaPlugins can influence whether other entries get loaded or not. The 11 entries are the 7 above without the Java one I just disabled, plus these:

Google Talk (2 files) - Version:
Location:	C:\Users\catalin.CEBRA\AppData\Roaming\Mozilla\plugins\npgoogletalk.dll
Location:	C:\Users\catalin.CEBRA\AppData\Roaming\Mozilla\plugins\npgtpo3dautoplugin.dll

QuickTime Player (7 files) - Version: 7.7.2 (1680.56) (Disabled)

Java(TM) - Version: Download Critical Security Update
Location:	C:\Program Files (x86)\Mozilla Firefox\plugins\npdeployJava1.dll

Google Update - Version:
Location:	C:\Users\catalin.CEBRA\AppData\Local\Google\Update\\npGoogleUpdate3.dll

VirtuoCity 2.6 - Version: 2,6,0,8
Location:	C:\Users\catalin.CEBRA\AppData\Roaming\VirtuoCity Browser Plugin 2.6\NPV3DComponents.dll

The last one is an older version of our plugin. However, this is still not the complete list, Unity, our newer versions of the plugin and the Yahoo plugin are still missing. Presumably another one of the entries in this new list is blocking the others. Any idea why the presence of the C:\Windows\SysWOW64\npdeployJava1.dll would stop Chrome 23 from loading other plugins?

Since this affects our company's product I'm highly interested in getting it solved as soon as possible so I'm available for anything you want me to test or extra information you want me to provide.
Comment 8 by, Nov 14 2012
Issue 147634 has been merged into this issue.
Comment 9 by, Nov 14 2012
Status: Untriaged
Here are 2 logs for starting Chrome with --debug-plugin-loading --enable-logging --v=1 and loading chrome://plugins in the 2 cases:

* 7 plugins listed because npdeployJava1.dll in in the registry in MozillaPlugins
* 11 plugins listed because I renamed npdeployJava1.dll to npdeployJava1.dll.test in the registry

If I diff the 2 logs they look quite similar but both of them have:
[1784:828:1114/] Loading plugin C:\Windows\SysWOW64\npdeployJava1.dll
and then these suspicious looking messages:
[1784:828:1114/] Loading plugin disabled
[1784:828:1114/] Could not get version info for plugin disabled

60.5 KB View Download
30.8 KB View Download
Interesting. In both cases, we inspect the same set of plug-ins, but renaming Java somehow removes the other plug-ins. And looking for a file "disabled" is also weird, although that might just be garbage in the registry.
Indeed, the "Loading plugin disabled" message appears because in HKLM\SOFTWARE\Wow6432Node\MozillaPlugins\ I have a Path with a value of disabled.

So all in all, the logs don't seem to show anything wrong. Is there more logging that I could enable?
Labels: OS-Mac
After Issue 147634 was merged into this one, I want to make sure it is noted that Silverlight does not work at all in chrome 23.
Labels: -OS-Mac
Status: Started
Vivian, could you file a separate bug for the Mac issue? I have a fix, but it's for a Windows-only bug.

Chrisobrien89, can you elaborate? I know that not everyone can reproduce that Silverlight is broken, so if your issue is not Windows-only, please also file a new bug.
windows 8 

Microsoft Silverlight is installed on my computer and works with other browsers. Silverlight does not appear in the list of plugins, and any site that uses silverlight (such as netflix) says it is not installed.
I only have access to Windows, so I could not say if it occurs on other systems. This was already detailed in issue 147634, but it was merged into this one.
Ok, that looks like it's this issue, so it's being taken care of :)
I reinstalled windows on an unrelated matter, before i installed Chrome, I installed silverlight first. After doing this I noted silverlight as indeed in the plugins list, and netflix is working.
Hi I am having a similar issue with the plugins. It started after upgrading to windows 8. I am not in metro ui and none of the plugins load.

I tried it with v23 and v25 but I had no luck with neither of them.
74.6 KB View Download
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Google\Chrome\Application\25.0.1323.1\PepperFlash\pepflashplayer.dll
[12088:11384:1115/] Loading plugin internal-remoting-viewer
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Google\Chrome\Application\25.0.1323.1\ppGoogleNaClPluginChrome.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Google\Chrome\Application\25.0.1323.1\pdf.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Local\Google\Chrome\User Data\Default\Extensions\aepeildmfnnehghlknddebgjghlompfe\1.0_0\npwebsitelogon.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Adobe\Reader 10.0\Reader\Browser\nppdf32.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Roaming\Mozilla\plugins\npgoogletalk.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Roaming\Mozilla\plugins\npgtpo3dautoplugin.dll
[12088:11384:1115/] Loading plugin C:\PROGRA~2\MICROS~1\Office14\NPAUTHZ.DLL
[12088:11384:1115/] Loading plugin C:\PROGRA~2\MICROS~1\Office14\NPSPWRAP.DLL
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\CCM\Utilities\npAdobeAAMDetect32.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\DivX\DivX OVS Helper\npovshelper.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\DivX\DivX Plus Web Player\npdivx32.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Google\Update\\npGoogleUpdate3.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Java\jre7\bin\plugin2\npjp2.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Microsoft Silverlight\5.1.10411.0\npctrl.dll
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\WildTangent Games\App\BrowserIntegration\Registered\0\NP_wtapp.dll
[12088:11384:1115/] Plugin WildTangent Games App Presence Detector has bad MIME types, skipping
[12088:11384:1115/] Loading plugin C:\Program Files (x86)\Windows Live\Photo Gallery\NPWLPG.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Local\Google\Update\\npGoogleUpdate3.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Roaming\Mozilla\plugins\npgoogletalk.dll
[12088:11384:1115/] Loading plugin C:\Users\alper\AppData\Roaming\Mozilla\plugins\npgtpo3dautoplugin.dll
[12088:11384:1115/] Loading plugin C:\WINDOWS\SysWOW64\npDeployJava1.dll
[12088:11384:1115/] Loading plugin C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_4_402_287.dll
[12088:11384:1115/] Loading plugin C:\Windows\system32\Adobe\Director\np32dsw.dll
[12088:11384:1115/] Loading plugin D:\Program Files\Adobe\Acrobat 10.0\Acrobat\Air\nppdf32.dll 

I have a fix for it that should land soon.

In the mean time, you can work around this issue by uninstalling unnecessary plug-ins. In your case, it looks like you have two versions of the Adobe Reader plug-in installed (D:\Program Files\Adobe\Acrobat 10.0\Acrobat\Air\nppdf32.dll and C:\Program Files (x86)\Adobe\Reader 10.0\Reader\Browser\nppdf32.dll), so you could try uninstalling one of them, which is not a bad thing in general.
Project Member Comment 22 by, Nov 15 2012
The following revision refers to this bug:

r167979 | | 2012-11-15T19:16:12.441954Z

Changed paths:

Remove PluginList::RemovePlugin() and directly remove old plug-ins from plug-in list instead.

In the old version, removing the plug-in would modify the contents of the passed in parameter (which is a reference!), so we would keep on removing other plug-ins after it. Face, meet palm.

BUG= 159896 

Review URL:
Comment 23 Deleted
Aha. :) Uninstalling acrobat reader fixed my problem. Thank you Bauerb. I had tried everything.

Great to see that it's solved!

Do you have an estimate when the fix will be available in an update that is pushed to everybody? I would say it should qualify for inclusion in 23.something since it potentially affects a lot of people and a lot of plugins.
Labels: ReleaseBlock-Stable Mstone-24
Not sure if we can get it into an M23 update, but M24 should be out soon :) I think it qualifies as a stable release blocker for 24.
Labels: Merge-Requested
Also, the fix is super-easy :)
Once QA verifies the fix in tomorrow's canary, I'll approve the merge.
Thanks! It's a bit tricky to verify (or reproduce) if your system doesn't happen to have the right configuration of plug-ins though, as you need to have two different versions of the same plug-in installed. Ping me if you need help.
Labels: QA-Verified
Works fine in the current canary - 25.0.1329.0( Official Build 168464)
Comment 31 by, Nov 19 2012
Labels: -Merge-Requested Merge-Approved
Comment 32 by Deleted ...@, Nov 20 2012
So I'm having the same problem and the work-around you've mentioned has failed to work for me. I've gone and removed all unnecessary plugins and a few plugins that should be in the list are still not appearing. Hopefully the fix will be pushed to the masses soon but any ideas in the mean time?
Project Member Comment 33 by, Nov 20 2012
Labels: -Merge-Approved merge-merged-1312
The following revision refers to this bug:

r168781 | | 2012-11-20T10:56:03.148739Z

Changed paths:

Merge 167979 - Remove PluginList::RemovePlugin() and directly remove old plug-ins from plug-in list instead.

In the old version, removing the plug-in would modify the contents of the passed in parameter (which is a reference!), so we would keep on removing other plug-ins after it. Face, meet palm.

BUG= 159896 

Review URL:
Review URL:
Comment 34 by, Nov 20 2012
Status: Fixed
Comment 35 Deleted
Status: Verified
Works fine using 24.0.1312.25 (Official Build 169562)
Should we try to merge this back to 23?

Any idea about the likelihood of being hit by the bug (this seems to be triggered by multiple versions/instances of the same plugin)?

siedeen: any significant clusters on this issue from Google Feedback? 
We did see reports of this issue in M23, but for the Silverlight plugin.
Pageviews to this main forum thread is ~100/day, so if the fix is safe to be merged, we should do it.

Google Feedback Reference:
Labels: Hotlist-ConOps
bauerb@: is this safe enough for a merge to M23? If yes, can you add the right label?Thanks.
Labels: -Mstone-24 Mstone-23 Merge-Requested
Sure, the fix is almost trivial.
Comment 42 by, Nov 29 2012
Labels: -Merge-Requested Merge-Approved
ok sg pls merge to 1271
Project Member Comment 43 by, Nov 29 2012
Labels: -Merge-Approved merge-merged-1271
The following revision refers to this bug:

r170234 | | 2012-11-29T19:43:28.508600Z

Changed paths:

Merge 167979 - Remove PluginList::RemovePlugin() and directly remove old plug-ins from plug-in list instead.

In the old version, removing the plug-in would modify the contents of the passed in parameter (which is a reference!), so we would keep on removing other plug-ins after it. Face, meet palm.

BUG= 159896 

Review URL:
Review URL:
Issue 147634 has been merged into this issue.
Comment 45 by Deleted ...@, Dec 5 2012
i'm not all into this technical stuff, i just want my silverlight to work again..... it was fine until today? makes no sense to me
Comment 46 by, Dec 5 2012
The way I fixed mine was to download Chrome beta at

Or you could download Canary

Everything I want to do can be done in Canary. I installed both of them. Silverlight works in both. My Facebook thumbnails still won't open with a click in beta but they will in Canary.
Comment 47 by, Dec 5 2012
And now the beta version is working for Facebook. Go figure.
Works fine with 23.0.1271.97, Verified using bug using Steps provided in initial bug report.
Comment 49 by Deleted ...@, Dec 10 2012
Latest Silverlight plugin NOT detected on Chrome 23.0.1271.95 m

Then I tried Chrome beta and it worked.
The DivX Web Player is also not working for me, I think also since version 23. I can't watch these Twit videos for example:

And I think some Flash videos weren't working either. I've noticed it on tumblr, and also on Twit before when they had another Flash/HTML5 player. It never worked on Flash, and it would only work when I was switching to the HTML5 player.

It's been 2 new versions since this started happening. Please fix this already! The videos work fine on Firefox.
Project Member Comment 51 by, Mar 10 2013
Labels: -Area-Internals -Feature-Plugins -Mstone-23 Cr-Internals M-23 Cr-Content-Plugins
Project Member Comment 52 by, Apr 5 2013
Labels: Cr-Blink
Project Member Comment 53 by, Apr 6 2013
Labels: -Cr-Content-Plugins Cr-Internals-Plugins
Version: Version 42.0.2311.22 beta-m
OS: WIN 7 professional 64bit

What steps will reproduce the problem?
1. Go to
2. Try to play the video
3. You get an interstitial that says you need to install silverlight (which is already on the computer)
4. You try to install Silverlight again
5. Going through the Silverlight process fails because it says you already have a version of it
6. Try to watch the video on Chrome again and it still claims that you don't have Silverlight.

Note: I don't see Silverlight showing up in about:plugins

Comment 55 by Deleted ...@, Apr 15 2015
Chrome Version 42.0.2311.90 m
OS: Win 7 Pro 64bit

Chrome behaves as if Silverlight isn't installed.
- When browsing any Silverlight content, a prompt to install Silverlight appears.
- In chrome:plugins, Silverlight doesn't appear on the plugins list.


- When following the prompts and attempting to install Silverlight, the installer complains that "this version of Silverlight is already installed".
- Silverlight does appear in the Control Panel:Programs & Features installed programs list.
- Internet Explorer is able to successfully view Silverlight content.
- Uninstalling & Reinstalling Silverlight results in no change to any of this behavior.
Labels: Restrict-AddIssueComment-EditIssue
Locking. This is an old bug, about version 23, and totally unrelated to the recent NPAPI deprecation (
Sign in to add a comment