New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 15959 link

Starred by 13 users

Issue metadata

Status: Fixed
Owner:
Email to this user bounced
Closed: Jul 2009
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 1
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Spellcheck swallows words

Reported by kojot...@gmail.com, Jul 5 2009

Issue description

Chrome Version       : 3.0.192.0 (Developer Build 0)

What steps will reproduce the problem?
1. right click underlined word

What is the expected result?
It swallows the word.

What happens instead?
Don't swallow my word.

Ubuntu 9.04 64bit

 
Labels: -OS-All OS-Linux
for your next reports, please note there is a special template for Linux in the new 
issue page

thanks
Labels: -Area-Misc Area-WebKit Icebox
doesn't happen here. You're gonna have to get a mite more specific if you want us to 
have any chance of figuring out what's happening.

Comment 3 by kojot...@gmail.com, Jul 7 2009

No problem, just tell me what you need and I'll provide you the information. 
Honestly i have no idea what info would be useful. 
I'll try to compile chromium from trunk and see what happens. 

And one more thing, I've just checked and it turns out that when you right click on 
any word (not just underlined) it got swallowed (disappears) and even when the 
editing cursor (the vertical line) is next to a word or dot or coma and you click on 
any empty space in the text box, it disappears too, so it doesn't have to be spell 
checker issue. Interesting thing is that when you have e.g. (the | is editing cursor)
"word,|" and you click on an empty area, only coma disappears.

Another thing that can be useful maybe is that when you click on the underlined word,  
it disappears, but proposed correct words appears in the context menu.
relevant details:
- the site you tried it on
- the type of input field
- whether it's 100% repeatable
- Do you have some sort of third party clipboard helper program running?

And lastly, it can be very helpful to screencast it (sudo apt-get install gtk-
recordmydesktop) and attach an .ogv here, but first you should try it on trunk to 
make sure you're still getting it.

Comment 5 by kojot...@gmail.com, Jul 8 2009

- the site you tried it on
code.google.com, gmail.com, digg.com

- the type of input field
all sort of text areas, line edits are not affected (maybe due to lack of spell-
check)

- whether it's 100% repeatable
yes

- Do you have some sort of third party clipboard helper program running?
no, i didn't added any helpers. and it doesn't happen in other programs. I only have 
gnome-do, awn, guake, and exile running by default.

I use Ubuntu PPA nightly chromium builds updated daily. I can try to build it from 
sources though, to confirm.

I've noticed that behavior changed slightly yesterday, it no longer swallows dots and 
comas after the word when empty area is clicked.

I attach a screencast. I don't know why but while recording, chromium doesn't display 
red underlines and my gnome panel was covered with weird lines :F
out.ogv
7.2 MB Download
Labels: -Icebox
Status: Available
looks pretty weird

Comment 7 by kojot...@gmail.com, Jul 10 2009

This may be helpful: I've noticed that unlike on the other text areas, this text area 
in which I'm typing now behaves different (and somehow similar) - see the screen cast.

I behaves similar but instead of deleting the words it selects them and no context 
menu is displayed.


bug.ogv
583 KB Download

Comment 8 by kojot...@gmail.com, Jul 10 2009

Now I'm confused. The same text area, one restart (of the browser) later and it works 
different. There must be some sort of state that is changing or something.

Check the attachment.
bug-1.ogv
1.7 MB Download

Comment 9 by est...@chromium.org, Jul 13 2009

 Issue 16418  has been merged into this issue.

Comment 10 by gke...@gmail.com, Jul 15 2009

I don't know if this a different but is related so putting it here.

If you have some text selected in text area, like the one this bug report has, or 
input box, like the two searches at top of this page, you select some existing or 
typed text and switch tab, the selected text is removed when tab is restored.

Another test case, is when you select and right click in input box, like two search 
boxes on top of this page, the selected text is removed.  If you don't have anything 
selected, then it is not removed.  In text area, the word is removed even if it is 
not selected.

Comment 11 by kojot...@gmail.com, Jul 15 2009

@Comment 10

Yes, I've noticed it too.

1. Select text in a input box or text area
2. use some global shortcut like alt+tab, alt+f2
3. text is gone

And it can be related, since it seams that in text area right clicked text is
auto-selected somehow.

I was wondering about filling a separate bug report, but I forgot/didn't have time to
do it :|
 Issue 17239  has been merged into this issue.
Status: Assigned
Evan and I decided it was an ime misbehavior.

Comment 14 by jon@chromium.org, Jul 20 2009

Labels: Mstone-4
Labels: -Mstone-4 Mstone-LinuxBeta
this bug makes chrome essentially unusable for certain languages we are targeting for 
beta

Comment 16 by evan@chromium.org, Jul 20 2009

Labels: -Pri-2 Pri-1
Agreed.  This is higher priority than many other bugs.
 Issue 15964  has been merged into this issue.
 Issue 16894  has been merged into this issue.
 Issue 17364  has been merged into this issue.

Comment 20 by gke...@gmail.com, Jul 26 2009

This seems to be fixed in 3.0.196.0~svn20090724r21527-0ubuntu1~ucd2~jaunty
Status: Fixed
Project Member

Comment 22 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 23 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit Cr-Content
Project Member

Comment 24 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment