New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 26 users

Issue metadata

Status: Verified
Owner:
Closed: Nov 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug



Sign in to add a comment
link

Issue 152893: Garbled header and footers on Print output

Reported by kenjibaheux@chromium.org, Sep 28 2012 Project Member

Issue description

Chrome Version       : 22.0.1229.79
OS Version: Windows XP SP3 (Japanese), Windows 7 (although different: header is either missing or garbled, footer seems fine)

URLs (if applicable) : confirmed on various Chinese, Japanese and Korean websites.

What steps will reproduce the problem?
1. Go to a CJK website (e.g. https://www.google.com/intl/ja/chrome/browser/ )
2. CTRL + P
3. Make sure you have header and footer enabled.
4. Look at the Print preview and the Print ouput

What is the expected result?
5. Readable headers and footers


What happens instead?
5. Garbled headers and footers.

Attaching a screenshot and the resulting PDF (windows XP). Note: there are other issues such as the garbled text on the download button of the page, I am assuming that the root cause is similar but let's split things up if we find out that there is no relation.

Pri-1 for M24 with the hope that we can get a relatively safe patch in time for M23.

This needs confirmation but I believe that this is a regression.
 
sample.png
67.4 KB View Download
Chrome ブラウザ.pdf
381 KB Download

Comment 1 by abodenha@chromium.org, Sep 28 2012

Labels: Action-BisectNeeded
Please provide a bisect if you think this is a regression.

Comment 2 by thestig@chromium.org, Sep 28 2012

Is it the same behavior on Canary?

Comment 3 by pavanv@chromium.org, Sep 28 2012

Labels: -Action-BisectNeeded
same behavior in stable (M22), Beta and Dev/Canary

Comment 4 by vitalyb...@chromium.org, Sep 28 2012

Why Action-BisectNeeded was removed, we don't know the first release with bug?

Comment 5 by vitalyb...@chromium.org, Oct 8 2012

Mergedinto: 152889
Status: Duplicate
152889 hangs when printing header/footer on some Japanese sites, on other sites it's just print garbage. I see that both problems are in font related code. I believe reason is the same.

Comment 6 by vitalyb...@chromium.org, Oct 12 2012

Mergedinto:
Status: Started

Comment 7 by vitalyb...@chromium.org, Oct 16 2012

Owner: vitalyb...@chromium.org

Comment 8 by bugdroid1@chromium.org, Nov 13 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=167311

------------------------------------------------------------------------
r167311 | vitalybuka@chromium.org | 2012-11-13T06:21:54.723607Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/print_web_view_helper_win.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/browser_resources.grd?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/print_web_view_helper_linux.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/print_web_view_helper.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/print_web_view_helper.h?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/print_web_view_helper_mac.mm?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/printing/print_settings_initializer.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/printing/print_job_constants.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/printing/units.cc?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/printing/print_job_constants.h?r1=167311&r2=167310&pathrev=167311
   M http://src.chromium.org/viewvc/chrome/trunk/src/printing/units.h?r1=167311&r2=167310&pathrev=167311
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/print_preview/print_preview_page.html?r1=167311&r2=167310&pathrev=167311

Print headers and footers with WebKit.

Old implementation with gfx::RenderText had issues with fallback fonts. Sandbox does not allow to read required information from registry.

Also WebKit inplementation is smaller and more readable.

BUG= 152893 ,  108599 ,  133548 
TEST=manual: make sure that main content with or without headers is in the same place (default margin is exception). Make sure that any custom margins and paper layout produce reasonable result. If margins are to small, header and footer should be hidden.

Review URL: https://chromiumcodereview.appspot.com/11359020
------------------------------------------------------------------------

Comment 9 by vitalyb...@chromium.org, Nov 13 2012

Status: Fixed

Comment 10 by vitalyb...@chromium.org, Nov 13 2012

Labels: -Type-Regression -Mstone-24 Type-Bug Mstone-25
If someone believe that we should have this in M24 please comment.

Comment 11 by vitalyb...@chromium.org, Nov 13 2012

 Issue 114285  has been merged into this issue.

Comment 12 by kenjibaheux@chromium.org, Nov 13 2012

Cc: dharani@chromium.org
Labels: -Mstone-25 Mstone-24 ReleaseBlock-Stable
If we can afford it (give it some time to bake in Canary and then merge in time for Stable 24), I surely do as well as our Enterprise folks. From a user/customer perspective, this goes with  Issue 128506 .

Comment 13 by bugdroid1@chromium.org, Nov 14 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=167608

------------------------------------------------------------------------
r167608 | vitalybuka@chromium.org | 2012-11-14T05:32:01.221628Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/print_preview/print_preview_page.html?r1=167608&r2=167607&pathrev=167608

Use 'sans-serif' instead of 'sans' to print headers and footers.

BUG= 160830 ,  152893 


Review URL: https://chromiumcodereview.appspot.com/11275302
------------------------------------------------------------------------

Comment 14 by dharani@google.com, Nov 14 2012

Labels: Merge-Requested

Comment 15 by athigle@chromium.org, Nov 15 2012

Header and Footers in Print Preview are working fine in 25.0.1325.0 (Official Build 167602) canary on Windows 7 and XP. QA is signing off this fix to be merged to M24.

Comment 16 by dharani@google.com, Nov 15 2012

thanks athigle@! Could you please verify fonts change in tomorrow's canary to check if its breaking any layout?

Comment 17 by kenjibaheux@chromium.org, Nov 15 2012

I checked Windows XP with the latest Chrome 25 (167602): fixed.

As dharani@ pointed out, the latest CL above is for r167608 so it's not yet reflected in Canary. So we'll need to check one more time.

Comment 18 by dharani@google.com, Nov 15 2012

Please verify this in 25.0.1326.0 or later build.

Comment 19 by nyerramilli@chromium.org, Nov 16 2012

Cc: nyerramilli@chromium.org
Header and Footers in Print Preview are working fine in 25.0.1326.0 Canary on Windows 7 

Please find the attached screenshot.
152893_Canary.jpg
58.5 KB View Download

Comment 20 by kenjibaheux@chromium.org, Nov 16 2012

Status: Verified
Also verified on Chrome 25.0.1326.0 (167880) with Windows XP.

Comment 21 by kenjibaheux@chromium.org, Nov 16 2012

Status: Started
Putting back to started so it doesn't fall off the radar for the merge-request to 24 in time for stable.

Comment 22 by dharani@chromium.org, Nov 16 2012

Labels: -Merge-Requested Merge-Approved

Comment 24 by bugdroid1@chromium.org, Nov 17 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=168378

------------------------------------------------------------------------
r168378 | vitalybuka@chromium.org | 2012-11-17T04:42:47.035140Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper_mac.mm?r1=168378&r2=168377&pathrev=168378

Merge 165810 - Removed obsolete non skia code.

BUG= 152893 

Review URL: https://chromiumcodereview.appspot.com/11312070

TBR=vitalybuka@chromium.org
Review URL: https://codereview.chromium.org/11417045
------------------------------------------------------------------------

Comment 25 by bugdroid1@chromium.org, Nov 17 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=168379

------------------------------------------------------------------------
r168379 | vitalybuka@chromium.org | 2012-11-17T04:44:27.527594Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/printing/print_job_constants.cc?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/printing/units.cc?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/printing/print_job_constants.h?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/printing/units.h?r1=168379&r2=168378&pathrev=168379
   A http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/browser/resources/print_preview/print_preview_page.html?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper_win.cc?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/browser/browser_resources.grd?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper_linux.cc?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper.cc?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper.h?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/renderer/print_web_view_helper_mac.mm?r1=168379&r2=168378&pathrev=168379
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/printing/print_settings_initializer.cc?r1=168379&r2=168378&pathrev=168379

Merge 167311 - Print headers and footers with WebKit.

Old implementation with gfx::RenderText had issues with fallback fonts. Sandbox does not allow to read required information from registry.

Also WebKit inplementation is smaller and more readable.

BUG= 152893 ,  108599 ,  133548 
TEST=manual: make sure that main content with or without headers is in the same place (default margin is exception). Make sure that any custom margins and paper layout produce reasonable result. If margins are to small, header and footer should be hidden.

Review URL: https://chromiumcodereview.appspot.com/11359020

TBR=vitalybuka@chromium.org
Review URL: https://codereview.chromium.org/11316066
------------------------------------------------------------------------

Comment 26 by bugdroid1@chromium.org, Nov 17 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=168380

------------------------------------------------------------------------
r168380 | vitalybuka@chromium.org | 2012-11-17T04:45:12.689359Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1312/src/chrome/browser/resources/print_preview/print_preview_page.html?r1=168380&r2=168379&pathrev=168380

Merge 167608 - Use 'sans-serif' instead of 'sans' to print headers and footers.

BUG= 160830 ,  152893 


Review URL: https://chromiumcodereview.appspot.com/11275302

TBR=vitalybuka@chromium.org
Review URL: https://codereview.chromium.org/11348114
------------------------------------------------------------------------

Comment 27 by vitalyb...@chromium.org, Nov 17 2012

Status: Fixed
Also merged r165517 and r165810 because main CL depend on them.

Comment 28 by vitalyb...@chromium.org, Nov 19 2012

Cc: manoranj...@chromium.org
 Issue 147349  has been merged into this issue.

Comment 29 by ligim...@chromium.org, Nov 27 2012

Status: Verified
Confirmed that no issue in  24.0.1312.25 i

Comment 30 by ligim...@chromium.org, Nov 27 2012

Confirmed that no issue in  24.0.1312.25

Comment 31 by vitalyb...@chromium.org, Dec 17 2012

 Issue 147349  has been merged into this issue.

Comment 32 by vitalyb...@chromium.org, Dec 18 2012

 Issue 147349  has been merged into this issue.

Comment 33 by vitalyb...@chromium.org, Jan 9 2013

 Issue 135326  has been merged into this issue.

Comment 34 by vitalyb...@chromium.org, Jan 10 2013

 Issue 135326  has been merged into this issue.

Comment 35 by vitalyb...@chromium.org, Jan 11 2013

 Issue 135326  has been merged into this issue.

Comment 36 by vitalyb...@chromium.org, Jan 14 2013

 Issue 135326  has been merged into this issue.

Comment 37 by vitalyb...@chromium.org, Jan 15 2013

 Issue 169835  has been merged into this issue.

Comment 38 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-UI -Feature-PrintPreview -Feature-Printing -Mstone-24 Cr-UI M-24 Cr-Internals-Printing Cr-UI-Browser-PrintPreview

Comment 39 by vitalyb...@chromium.org, Apr 28 2013

Cc: sanjeevr@chromium.org mar...@chromium.org
 Issue 6834  has been merged into this issue.

Sign in to add a comment