Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 151836 chrome.exe does not start UI
Starred by 20 users Reported by vojta.j...@gmail.com, Sep 23 2012 Back to list
Status: Archived
Owner: ----
Closed: Aug 2015
Cc:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
Chrome Version: 24.0.1274.0 canary

Other browsers tested:
IE9 OK
Firefox OK
Opera OK

Spawning a child process ".../chrome.exe" (by nodejs: http://nodejs.org/api/child_process.html#child_process_child_process_spawn_command_args_options) on Windows does:
1/ immediately exit, so you can't kill the browser using the same process
2/ not display the GUI at all (although the browser does start and works, but nothing is visible)

I know, that the browser is hidden, but fully functional, because I'm communicating using web sockets and executing JavaScript unit tests. Browser does communicate and report results.

With all other browsers, you can do:
var p = spawn('binary.exe'); // start the browser
p.kill(); // kill it

It works fine on Ubuntu or Mac.
 
This breaks the Testacular test runner on Windows, as described above by Vota Jina (author of Testacular).

This is a really big deal for anyone trying to automate unit tests against AngularJS for instance.
Comment 2 Deleted
Labels: Action-FeedbackNeeded
Hello Vojta,

Could you please provide us the system details which you are using?

Thanks in advance.
Regards
Anant

Windows 7 Enterprise (service pack 1)
Running on VM (VMWare Fusion) on MacBook Pro.

64b, 1.00GB RAM, Intel Core i7-2635QM CPU @ 2.00 GHz 2.00 GHz

I have reports from pretty much all Win7 users.
Having this problem as well. Windows 7 Enterprise (not sure about service pack though).
64bit 8GB Ram, Inte Core i5. 
Any update on this ?
Same problemi with Windows 8
Labels: -Action-FeedbackNeeded
I'm seeing the same issue. Has there been any movement on this?
What kind of feedback is needed ?
I'm seeing the same issue, been forced to use FF for testing :(
Any plans to implement a fix?
Same here on Windows 8 Pro 64bit, 8GB RAM, Intel Core i7 M640 2.8 GHz.
Any news on this? Can we do anything to help?
For people wanting to debug in chrome, you can still do so by configuring testacular to launch no browser at all, start chrome manually, and go to the testacular server. It takes 10 more seconds, but this way you can use the nice chrome debugging tools.
Btw, I think the issue for Testacular has been solved by adding --start-maximized flag.
Vojta is correct, I've confirmed that using the --start-maximized flag from Testacular resolves the issue in my environment.

Thanks for the followup, all!
Project Member Comment 17 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Undefined
Comment 18 by Deleted ...@, Mar 13 2013
Do I need manually add "--start-maximized" somewhere in my configuration or testacular command call? Or does it just work? I have verified I have the flag in my launchers/Chrome.js file but I'm still not able to launch Chrome from Testacular.
As long as you have `--start-maximized` in launchers/Chrome.js, it should work. Unfortunately, it turned out that this solves the problem only in some cases. I guess on some versions of Windows or on some versions of Chrome. 
Tim,
What version of Chrome are you using?  Windows?
Could you open the task manager, ensure that no chrome.exe processes are running, and try launching via testacular again?  
After launching, are you able to see chrome.exe in the task manager?
Comment 21 by Deleted ...@, Mar 15 2013
An interim solution, if you want to test on chrome and Firefox, is to copy the URL on IE and paste it manually on Chrome and Firefox. This will get connected to testacular.
After having dropped --start-maximized option from karma-chrome-launcher, I am not able to reproduce this issue on Windows 7 with stable Chrome (34.0.1847.131). I even tried by directly spawning Chrome process from node. Chrome window is normally shown (but not maximized of course).

If confirmed, I have made a PR for karma-chrome-launcher on Github (https://github.com/karma-runner/karma-chrome-launcher/pull/12)
Cc: -a deleted user srsridhar@chromium.org
Labels: Needs-Feedback
@vojta.jina..: Please let us know if you are still facing the issue with latest stable channel 34.0.1847.137.
Hello Vojta

Please close for now. I'm not going to be able to verify this in the
short/medium term.
Can any Windows+Karma user on this thread confirm?
I don't have windows right now to confirm.

Julien, I merged your PR for karma-chrome-launcher.


Comment 26 by Deleted ...@, Jul 11 2014
Confirmed as working for me with Chrome 35 / karma-chrome-launcher 0.1.4 / windows 7.
Status: Archived
(Automated-archive) Issue requiring feedback hasn't been modified/ commented on in more than one year, please file a new bug if this is still an issue.
Sign in to add a comment