New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 151716 link

Starred by 19 users

Issue metadata

Status: Fixed
Owner:
Not on Chrome anymore
Closed: Oct 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 1
Type: Bug



Sign in to add a comment

Flash is always reported as out of date

Reported by unlam...@gmail.com, Sep 22 2012

Issue description

Chrome Version       : 23.0.1271.1
OS Version: OS X 10.7.4
URLs (if applicable) :
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 4.x: OK
     IE 7/8/9:

What steps will reproduce the problem?
1. Go to a page that uses Flash, such as any video on YouTube (with HTML5 mode turned off).

What is the expected result?
Can view the Flash video.

What happens instead?
The video is blocked, saying that Flash player is out of date. If I try clicking on the "Update plugin..." button, it brings me to Adobe's site, which tells me that Flash is built into my browser. If I download and install the NPAPI Flash from Adobe, it works fine in Safari and Firefox, but Chrome still complains. If I choose "Run this time", the video is still blocked, saying "Adobe Flash Player is out of date".

Please provide any additional information below. Attach a screenshot if
possible.

If I show details on the "chrome://plugins" page, I see 4 different Flash plugins, and it looks like the 11.1.31.100 PPAPI one is being chosen. If I disable that, the other PPAPI plugin is disabled too, and Flash works again, presumably using the NPAPI plugin. I cannot disable only one of the PPAPI plugins; disabling one of them disables both.

Description:	Shockwave Flash 11.1 r31
Version:	11.1.31.100
Location:	/Users/lambda/Library/Application Support/Google/Chrome/PepperFlash/11.1.31.100/PepperFlashPlayer.plugin
Type:	PPAPI (out-of-process)

Description:	Shockwave Flash 11.4 r31
Version:	11.4.31.102
Location:	/Applications/Google Chrome.app/Contents/Versions/23.0.1271.1/Google Chrome Framework.framework/Internet Plug-Ins/PepperFlash/PepperFlashPlayer.plugin
Type:	PPAPI (out-of-process)

Description:	Shockwave Flash 11.4 r402
Version:	11.4.402.265
Location:	/Applications/Google Chrome.app/Contents/Versions/23.0.1271.1/Google Chrome Framework.framework/Internet Plug-Ins/Flash Player Plugin for Chrome.plugin
Type:	NPAPI

Description:	Shockwave Flash 11.4 r402
Version:	11.4.402.265
Location:	/Library/Internet Plug-Ins/Flash Player.plugin
Type:	NPAPI


UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.1 Safari/537.11


 
Screen Shot 2012-09-21 at 11.08.20 PM.png
22.0 KB View Download
Screen Shot 2012-09-21 at 11.08.47 PM.png
12.3 KB View Download
Screen Shot 2012-09-21 at 11.09.35 PM.png
13.4 KB View Download
Screen Shot 2012-09-21 at 11.22.38 PM.png
101 KB View Download
Screen Shot 2012-09-21 at 11.22.22 PM.png
92.7 KB View Download

Comment 1 by meh...@chromium.org, Sep 22 2012

Labels: -Area-Undefined Area-Internals Feature-Flash Feature-Plugins
I am having this issue as well.

Mac OS X
Version 10.5.8

Flash Player 10.3

Chrome Version 21.0.1180.90
> /Users/lambda/Library/Application Support/Google/Chrome/PepperFlash/11.1.31.100/PepperFlashPlayer.plugin

Did you manually install this? I'm not sure why there is a plugin in Application Support.
> I am having this issue as well.
> Mac OS X
> Version 10.5.8

This is unrelated; for anyone here because they are running 10.5, see  bug 153145 .

Comment 5 by unlam...@gmail.com, Sep 30 2012

No, I did not manually install anything, as far as I know. This did happen shortly after my computer froze up and I had to forcibly reboot it, though I have no idea if that is related.

Comment 6 by Deleted ...@, Oct 1 2012

Same problem as del

Mac OS X 10.7.5
Chrome Version 23.0.1271.10 dev
FLASH.jpg
196 KB View Download

Comment 7 Deleted

Cc: bauerb@chromium.org
Bernhard, FYI.
Not able to repro on 23.0.1271.1,,latest Canary 24.0.1289.1,dev 24.0.1284.2,Beta 23.0.1271.17,Stable 22.0.1229.79

Can you please check again and let us know if the issue still persists.
Cc: sh...@chromium.org cpu@chromium.org yzshen@chromium.org
Status: Available
I think the plug-in in Application support is coming in via the component updater, whereas the one inside the Chrome bundle is bundled with Chrome during installation/updates. Their state is indeed kept in sync, so they are either both enabled or both disabled.

The only question is why the component-updated one has an 11.1 version number whereas the bundled one has 11.4? FYI, the minimum version in our plug-in metadata file is 11.1.102.
(Also, the reason why nyerramilli@ couldn't reproduce this might be because the component updater hadn't kicked in yet).
Yes, the problem still persists. I still see Flash 11.1.31.100 in /Users/lambda/Library/Application Support.

It looks like it hasn't been touched in about a year:

$ ls -al /Users/lambda/Library/Application\ Support/Google/Chrome/PepperFlash/
total 0
drwx------@  3 lambda  lambda  102 Nov 10  2011 .
drwx------  20 lambda  lambda  680 Oct  8 09:38 ..
drwx------@  4 lambda  lambda  136 Nov 10  2011 11.1.31.100


Labels: -Pri-2 Pri-1 Mstone-23
Owner: sh...@chromium.org
We should only load the newer one of the bundled and component-updated PPAPI Flash.
That is what I assumed when making their enable/disable state in sync. And that is the current Windows behavior:
http://code.google.com/searchframe#OAMlx_jo-ck/src/webkit/plugins/npapi/plugin_list_win.cc&exact_package=chromium&q=plugin_list_win.cc&type=cs&l=351

This looks important enough to be a P1 and be merge to milestones that it affects.
Cc: jam@chromium.org
That behavior on Windows is actually breaking some other things (see issue 133330, for example) :-/
Status: Assigned

Comment 16 by kareng@google.com, Oct 8 2012

Labels: ReleaseBlock-Stable

Comment 17 by kareng@google.com, Oct 8 2012

Owner: bauerb@chromium.org
i'm told bernhard is on this.
Cc: jeffreyc@chromium.org
Cc: rsesek@chromium.org jayakrishnat@chromium.org joycel@chromium.org dpete@chromium.org viettrungluu@chromium.org vandanashah@chromium.org kerz@chromium.org srihariraju@chromium.org ranavdk@chromium.org
 Issue 144981  has been merged into this issue.
hey Bernhard, do you think you'll be able to resolve this soon? We want to make a go/no-go decision on Mac Flapper for M23 Stable by Thursday this week.
Status: Started
See http://codereview.chromium.org/11090018/.

Comment 23 by sail@chromium.org, Oct 11 2012

Hi, how can I confirm that this bug is fixed. Do I need to test this on 10.7?
Status: Fixed
You don't necessarily need 10.7, anything greater than 10.5 should do it.

AFAICT, the problem was that Chrome picked up an old version of Flapper that had been installed via the component updater. So, the way to test it would be to copy a Flapper binary to ~/Library/Application\ Support/Google/Chrome/PepperFlash/11.1.31.100 and check that it's *not* loaded. Vice-versa, copying a Flapper binary to a subdirectory with a newer version number (e.g. 11.5.2000) should load that one.

Comment 25 by sail@chromium.org, Oct 11 2012

I just tried the repro steps above. With Chrome Beta I can reproduce the problem. With Chrome Canary I can not.

Comment 26 by unlam...@gmail.com, Oct 11 2012

I've tried Chrome Canary 24.0.1292.1, and do not see the problem. I still see it in 24.0.1290.1 dev. Looks like it's fixed.

Comment 27 by kareng@google.com, Oct 11 2012

Labels: Merge-Approved
ty bernhard pls merge to 1271

Comment 30 by mal@google.com, Oct 13 2012

Labels: -merge-merged-1271
Status: Assigned
I had to revert this because it depends on some PERMISSION_FLASH changes that have *not* been merged to 1271.

Probably need to include just part of the changes from http://src.chromium.org/viewvc/chrome?view=rev&revision=159729 , if that's possible.

Contact chrome-pmo if you want to see the build fail logs from the Beta branch builders.
Ugh. It seems easier to just check for a plug-in that handles application/x-shockwave-flash?
You could look at how plugin_prefs connects the settings of the component-updated and bundled flapper:
http://code.google.com/searchframe#OAMlx_jo-ck/src/chrome/browser/plugins/plugin_prefs.cc&exact_package=chromium&q=plugin_prefs.cc&type=cs&l=80

It is more consistent to let the new code use the same check.
Labels: Merge-Requested
Project Member

Comment 35 by bugdroid1@chromium.org, Oct 13 2012

Labels: merge-merged-1271
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=161763

------------------------------------------------------------------------
r161763 | bauerb@chromium.org | 2012-10-13T16:52:03.919500Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/content/public/browser/plugin_service.h?r1=161763&r2=161762&pathrev=161763
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/content/browser/plugin_service_impl.cc?r1=161763&r2=161762&pathrev=161763
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/chrome/browser/component_updater/pepper_flash_component_installer.cc?r1=161763&r2=161762&pathrev=161763
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/content/browser/plugin_service_impl.h?r1=161763&r2=161762&pathrev=161763

Merge 161210 - Only register the newer one of {bundled, component} Pepper Flash.

We look at the file name to identify Pepper Flash now, so it shouldn't break the compile on the branch.

TBR=bauerb@chromium.org
BUG= 151716 

Review URL: https://codereview.chromium.org/11141011
------------------------------------------------------------------------

Comment 36 by kareng@google.com, Oct 14 2012

Labels: -Merge-Requested Merge-Approved

Comment 37 by sail@chromium.org, Oct 14 2012

Status: Fixed
Marking as fixed now.

Comment 38 by kareng@google.com, Oct 15 2012

Labels: -Merge-Approved Merge-Merged
Project Member

Comment 39 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Flash -Feature-Plugins -Mstone-23 Cr-Content-Plugins Cr-Content-Plugins-Flash Cr-Internals M-23
Project Member

Comment 40 by bugdroid1@chromium.org, Apr 5 2013

Labels: Cr-Blink
Project Member

Comment 41 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash
Project Member

Comment 42 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins Cr-Internals-Plugins

Comment 43 by laforge@google.com, Jul 24 2013

Cc: -jeffreyc@chromium.org

Sign in to add a comment