New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 144863 link

Starred by 69 users

Issue metadata

Status: Verified
Owner:
User never visited
Closed: Oct 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression



Sign in to add a comment

Web spell check works erratically

Reported by rohandhr...@gmail.com, Aug 26 2012

Issue description

Chrome Version       : 22.0.1229.14
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) : http://gmail.com/

What steps will reproduce the problem?
1. Go to gmail.com
2. Compose a new message
3. Type a few words

What is the expected result?
Chrome should underline all words which are misspelled.

What happens instead?
It's very erratic: it works for some words, sometimes .. sometimes it doesn't work. I use the UK English dictionary, and it should mark "color", "favorite", which it doesn't any more. This is a regression.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.14 Safari/537.4



 
Capture.PNG
16.4 KB View Download
Showing comments 19 - 118 of 118 Older
Labels: Mstone-22
Users in the help forum have confirmed that unchecking the web service resolves the issue. 

@odean/hbono, can we have someone look into this as this is affecting Stable users who just updated to M22?

Comment 21 by rlp@chromium.org, Sep 27 2012

Status: Available
I can repro on stable (22.0.1229.79) but not on canary (24.0.1279.0). I'll look into it though. Can I get a bisection for when this started? 
Cc: vivianz@chromium.org
+Vivian, can we get QA to perform a bisect on this issue?

Comment 23 by Deleted ...@, Sep 28 2012

This is a bug with the "ask google for suggestions" option. Disabling that will get spell check back.

Comment 24 by Deleted ...@, Sep 28 2012

Work around worked for me - unchecking use a web service to check spelling...

Comment 25 by dharani@google.com, Sep 28 2012

Labels: Action-BisectNeeded

Comment 26 by k...@google.com, Sep 28 2012

Labels: ReleaseBlock-Stable
Owner: rlp@chromium.org
Status: Assigned

Comment 27 by rlp@chromium.org, Sep 28 2012

Status: Started

Comment 28 by Deleted ...@, Sep 28 2012

unchecking use a web service to check spelling... - worked for me too! yay!
@rlp
I am able to reproduce this after I enable web service for spelling . working on bisect now... let me know if you already know the cause.
I just found out there is not an option in Chromium build for enable web service for spelling, therefore , we won't be able to use the bisect tool for this. will try manual bisect. looks like this issue got in very early stage of M22, was able to reproduce in 22.0.1228.0 build @ 150053

Comment 31 by Deleted ...@, Sep 28 2012

Same here

Google Chrome	22.0.1229.79 (Official Build 158531) m
OS	Windows
WebKit	537.4 (@129177)
JavaScript	V8 3.12.19.11
Flash	11.3.31.331
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4


Comment 32 by rlp@chromium.org, Sep 28 2012

Vivian, there were some recent changes to Google API keys that I suspect
may be the cause. It'd be nice to verify, because then we might be able to
merge in my fix for that instead of the temporary fix I'm working on.

Comment 33 by Deleted ...@, Sep 28 2012

I am currently experiencing this issue as well.

Test: tihs sentancer inst uderlined 
 Issue 152784  has been merged into this issue.

Comment 35 by suprf...@gmail.com, Sep 28 2012

Unchecking the "Ask Google for suggestions" brings back the spelling-checker.

Comment 36 by Deleted ...@, Sep 28 2012

Unchecking seems to bring it back in the rest of chrome but not for the body of a composing email in gmail. That's where I really want it. 
hi, Rachel

I don't think this is a regression issue base on this very strange bisect result I get, my guess is this might be something changed at web service server side or the protocol Chrome use to contact server has changed ?  still it is hard to explain the bisect result below:

build 22.0.1229.79 - bad
build 22.0.1229.7 - bad
build 22.0.1181.0 - bad
build 21.0.1180.89 - good
build 21.0.1180.2 -good
build 21.0.1178.0 -bad
build 21.0.1157.0  -bad
build 20.0.1132.57 -good

any idea what might cause it that it is all good in M21 after branch but not before... etc.

Comment 38 by rlp@chromium.org, Sep 28 2012

Can you send me links to the CLs for those? I'm wondering if something went in and was maybe reverted . . . but that's also why I suspect the API Key changes since those would be server side-ish.

Comment 39 by Deleted ...@, Sep 28 2012

Confirmed: Unchecking "Ask Google for suggestions" has caused spell-check to work again


Test: thsi sentance si RedAndUnderlined 
build 22.0.1229.79 - bad - Build 158531
build 22.0.1229.7 - bad - Build @151630
build 22.0.1181.0 - bad - Build @143152
build 21.0.1180.89 - good - Build @154005
build 21.0.1180.2 -good - Build @143120
build 21.0.1178.0 -bad - Build @142600
build 21.0.1157.0  -bad - Build @139641
build 20.0.1132.57 -good - Build@ 145807


Labels: -Action-BisectNeeded


Comment 42 Deleted

Comment 43 Deleted

142600 is bad 143120 is good: 
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&mode=html&range=142600:143120

some cl in-between above range fixed the issue.

then became bad again in 143152, good again in 145807 and bad again in 151630:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&mode=html&range=143120:143152 

 -- Note links could be bias info since cl cross 2 branches, in M21 could be only few cls are merged , so info here are reference only .

I'm seeing similar in 21 and 22.  Sometimes the spell check stops working.  I have a work around that might indicate the spell checker is crashing.  This resolves the problem every time for me:

Settings > advanced > languages > Languages and Spell Checked Settings
Un-check enable spell checker
Ok
Languages and Spell Checker Settings
Check enable spell checker
Ok

Comment 46 by ad...@yqed.com, Sep 30 2012

I can replicate this issue also in Chrome 22.0.1229.91, once I uncheck the option "Use a web service to help resolve spelling errors", everything works proper.
DxDiag.txt
44.1 KB View Download

Comment 47 by Deleted ...@, Sep 30 2012

- Go to the Chrome menu > Settings > click on Show advanced settings > in the Privacy section, do you have "Use a web service to help resolve spelling errors" checked?

If you do, can you try unchecking the checkbox as a temporary workaround and let us know if that changes things for you?
I just checked and

Menu > Settings > Show advanced settings > Privacy > "Use a web service to
help resolve spelling errors" is not checked on mine, and the spell checked
stopped working this morning.
I just checked and

Menu > Settings > Show advanced settings > Privacy > "Use a web service to help resolve spelling errors" is not checked on mine.

The spell checked stopped working this morning.

Comment 50 by Deleted ...@, Sep 30 2012

did the work around Sie mentioned in a google group (unchecking the use web service to check spelling box in advanced privacy settings) and it works just fine now but 

also there is no star icon to click on, as the blurb by this comment box indicates there should be.
30092012_115303.jpg
247 KB View Download

Comment 51 Deleted

Comment 52 by ad...@yqed.com, Sep 30 2012

Click on the star at the top of this thread.
star.png
18.2 KB View Download

Comment 53 by mega...@gmail.com, Oct 1 2012

I had problems with spell check last week, continuing into this week, when using remote spellcheck was enabled.  Disabling it using the textarea context menu is a workaround.

Comment 54 by mega...@gmail.com, Oct 1 2012

23.0.1271.10 Dev on XP SP3 32-bit.

My symptom: Spellcheck simply doesn't do anything.  No squiggly underlines, no correction options when right-clicking misspelled words.

Comment 55 by Deleted ...@, Oct 1 2012

Same problem here. Un-checking "ask google for suggestions" through right click menu fixes the problem for me, except, it does not ask google for suggestion anymore, of course.

Comment 56 by Deleted ...@, Oct 1 2012

Having same issues with Chrome 22.0.1229.79m for Windows XP 32-bit.

Temporary workaround does fix the issue: Go to the Chrome menu > Settings > click on Show advanced settings > in the Privacy section, uncheck "Use a web service to help resolve spelling errors".

Comment 57 by rlp@chromium.org, Oct 1 2012

We're working on this. Hope to have a fix very soon!
Labels: -Pri-2 Pri-1
Thanks Vivian and Rachel for looking into this!
Adjusting priority based on volume of user feedback that we are seeing from the help forum and Google Feedback.

Comment 59 by b...@bbagnell.com, Oct 2 2012

Gmail (Google Apps) spellcheck works in Firefox, not in Chrome. Proposed workaround to uncheck "ask google for suggestions" does not fix the problem in Chrome. However, spellcheck works when typing in this text box - it just doesn't work when typing in an email.

Comment 60 by b...@bbagnell.com, Oct 2 2012

Update. Maybe someone else noticed this - I didn't read all the postings. Spellcheck works in Chrome gmail if I detach the email into a separate window. Still doesn't work when I compose an email from my inbox.

Comment 61 by Deleted ...@, Oct 2 2012

I noticed this issue started about a week ago when I checked the "ask Google for suggestions"  By un checking it I can confirm the problem does go away. 

Comment 62 by k...@google.com, Oct 2 2012

OK folks, no more comments needed here, we're looking now.

Comment 63 by rlp@chromium.org, Oct 2 2012

Possible fix CL here: http://codereview.chromium.org/10982092/
Thanks -- we're seeing this from Chrome OS users too (same issue-- checking/unchecking spell check seems to resolve)

https://plus.google.com/u/1/100030405042180530507/posts/f4Tn3KUo8pj

Appreciate the fix. It's on R22 and R23. 

Comment 65 by k...@google.com, Oct 3 2012

Understanding now is that we hit an issue with quota, and that spelling should be happier now.  Not going to take a change here for the first stable update.
Yep, it now works with "ask Google for suggestion". Thanks!
Spell checker broke again :( it's still not too stable.

Comment 68 by fnan...@gmail.com, Oct 5 2012

My spell check works, it never broke. What I am experiencing is not being given suggestions for wrongly spelled words. I used to right click on said word and choose from a list of options. Why has this disappeared?
Spel Sug.png
62.7 KB View Download

Comment 69 by fnan...@gmail.com, Oct 5 2012

Can someone working at google please respond as I'm posting everywhere and not receiving any responses!!!!
@fnanfne, Can you try directly right clicking on the red underlined word, _without_ first selecting it?

Attached are suggestions that I get when I don't use the web service, versus when I do use the web service. In both cases, there are suggestions.
Ask Google for Spellcheck suggestions.JPG
27.6 KB View Download
Spellcheck suggestions.JPG
28.2 KB View Download

Comment 71 by fnan...@gmail.com, Oct 6 2012

@Sie thanks for the speedy reply.

To my shock, horror and surprise, this worked.

I was thinking of downgrading chrome but I won't need to do that now. Was this the way to do it in the past? I can't really remember now although I'm pretty sure I had to select the misspelled word first.

Anyway, thanks @Sie.

Regards

Steven
Filed  issue 154424  to also have suggestions display when right click occurs after the red underlined word has been selected/highlighted first.
I get the red underline for misspelled words but I do not get the options for the correct spelling anymore. :(

Comment 74 by fnan...@gmail.com, Oct 8 2012

@Whodidit...

Try merley right clicking on the misspelled word as opposed to selecting it first and then right clicking. See the screenshots/explanations above by Sied.
OMG Duh! That works!!! Thank you so much!!!!!!!!!!!!! :)

Comment 76 by k...@google.com, Oct 9 2012

Labels: -Mstone-22 Mstone-23
Moving to 23 to make sure this gets fixed there.

Comment 77 by Deleted ...@, Oct 10 2012

When I have a misspelling error and it shows the red squiggly line under the work and I right click it, no suggestions come up.  But if I keep right clicking it eventually something will come up. Plus as I am right clicking the option to add it to the dictionary is not there as well until the suggestion shows up.

Comment 78 by Deleted ...@, Oct 10 2012

I found the conflict for my issue, it was this extension "Snap Links Lite" by genesos
https://chrome.google.com/webstore/detail/idmmhhijggcmbeejedibpdcahpkneegg
 

Comment 79 by fnan...@gmail.com, Oct 10 2012

Right click the misspelled word, DO NOT select the word first, just right-click!

Comment 80 by Deleted ...@, Oct 10 2012

Same either way when I right click with that Extension installed.  Removed the extension and it works fine.

Comment 81 by fnan...@gmail.com, Oct 10 2012

I installed that extension so I could replicate the problem. I could not. I could still just right-click any misspelled word and get suggestions. But it may be that in your case, this particular extension was the problem.

I also have the ad-blocker extension installed as mentioned by someone earlier in the thread, with no problems.

Comment 82 by rlp@chromium.org, Oct 11 2012

I've just tested this on mac (23.0.1271.26) and windows (23.0.1271.26) and my personal build (23.0.1271.31) and cannot reproduce this.

Can someone else verify that they are still seeing this?

Comment 83 by rlp@chromium.org, Oct 11 2012

Do I need to force an update in order to see it? My tests are currently on fresh installs.
@rlp, we are no longer seeing new reports of this issue in the help forum, and report volume from the Google Feedback cluster (reference below) has decreased. The few number of reports that continues to come in is likely  issue 154424 

Reference: http://goto.google.com/1222325

Comment 85 by kareng@google.com, Oct 11 2012

so can i close this sie?
Yeap, it's fixed server-side per my conversation with Tyler. Tyler, Rachel, is this accurate?

Comment 87 by rlp@chromium.org, Oct 11 2012

I just sent Tyler a similar question via e-mail. I think so, but will wait for his confirmation.

Comment 88 by odean@chromium.org, Oct 11 2012

To confirm from offline conversation, there was a server side fix (adding quota for the RU service) but there is still a client side change needed to remove the requests for now. So this should not be an open pain point for anyone, but is still an open bug with a fix aimed for M23. 

Comment 89 by rlp@chromium.org, Oct 11 2012

We should have a fix ready to be merged tonight.
Project Member

Comment 90 by bugdroid1@chromium.org, Oct 12 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=161535

------------------------------------------------------------------------
r161535 | rlp@chromium.org | 2012-10-12T08:10:47.019250Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/spellchecker/spelling_service_client_unittest.cc?r1=161535&r2=161534&pathrev=161535
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/spellchecker/spelling_service_client.cc?r1=161535&r2=161534&pathrev=161535

Fix the spelling client not to use the spelling service yet. Also disabling some tests which this breaks that will be fixed when the logic is updated.

(This was already LGTM'd at http://codereview.chromium.org/11092087/ but was on the wrong branch)

BUG= 144863 

TBR=groby@chromium.org


Review URL: https://chromiumcodereview.appspot.com/11113005
------------------------------------------------------------------------

Comment 91 by rlp@chromium.org, Oct 12 2012

Labels: Merge-Requested
Assuming it sticks . . . 

Comment 92 by rlp@chromium.org, Oct 14 2012

This should be fine to merge at this point, assuming I have approval.
verified as fixed in Canary (24.0.1296.0), now with or without web service for spelling enabled. the spell checker works correctly in Gmail and other web input fields.

Comment 94 by kareng@google.com, Oct 15 2012

Labels: -Merge-Requested Merge-Approved
Project Member

Comment 95 by bugdroid1@chromium.org, Oct 15 2012

Labels: -Merge-Approved merge-merged-1271
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=161904

------------------------------------------------------------------------
r161904 | rlp@chromium.org | 2012-10-15T18:40:15.403662Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/chrome/browser/spellchecker/spelling_service_client_unittest.cc?r1=161904&r2=161903&pathrev=161904
   M http://src.chromium.org/viewvc/chrome/branches/1271/src/chrome/browser/spellchecker/spelling_service_client.cc?r1=161904&r2=161903&pathrev=161904

Merge 161535 - Fix the spelling client not to use the spelling service yet. Also disabling some tests which this breaks that will be fixed when the logic is updated.

(This was already LGTM'd at http://codereview.chromium.org/11092087/ but was on the wrong branch)

BUG= 144863 

TBR=groby@chromium.org


Review URL: https://chromiumcodereview.appspot.com/11113005

TBR=rlp@chromium.org
Review URL: https://codereview.chromium.org/11151023
------------------------------------------------------------------------

Comment 96 by kareng@google.com, Oct 15 2012

Status: Fixed
QA confirmed so putting to fixed.

Comment 97 by rlp@chromium.org, Oct 30 2012

 Issue 158412  has been merged into this issue.
I have this similar bug in latest Chromium Version 25.0.1330.0 (168471)

Marks all correct words to incorrect....
Here on latest Dev and Canary Builds #25.0.1331.0 using OS Win 7, the spell check English UK / US selected is working fine. Except the words "Color" and "Favorite" not showing any underlines for them.
Please find the attached screenshot for reference.


spell-chek.png
58.2 KB View Download
Status: Verified

Comment 101 by jmc...@gmail.com, Nov 23 2012

Not sure how I got chrom on my Mac but I hate it. I use Gmail and Lion 10.7 OS.  The spell check in gmail will show words that are spelled correctly as misspelled. When you click to correct, it adds a second first letter making the problem worse.  Example.  Apology aapology 
 Issue 153373  has been merged into this issue.
 Issue 156572  has been merged into this issue.

Comment 104 by Deleted ...@, Jan 7 2013

spell checker not working and I have all the stttings right

Screenshot - 01072013 - 04:30:08 AM.png
190 KB View Download
mrjmandic: Thank you for the screenshot! It's not clear what's going on until you provide more details. Please search for answer on http://productforums.google.com/forum/#!categories/chrome/report-a-problem-and-get-troubleshooting-help. If you do not find an answer there, you can post a question of your own. If you do that, please provide your operating system name, chrome browser version, and screenshots of your language settings in chrome.
Project Member

Comment 106 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Feature-Spellcheck -Mstone-23 Type-Bug-Regression Cr-UI M-23 Cr-UI-Browser-Spellcheck

Comment 107 by Deleted ...@, Mar 22 2013

i am attaching my Settings pic. this issue starts when reinstall chrome.

Mtk667: Thank you for posting your screenshots. May I suggest that we continue this conversation on http://productforums.google.com/forum/#!forum/chrome ? You can link to these screenshots from there, so you don't have to upload them again. There're troubleshooting steps at http://productforums.google.com/d/msg/chrome/1xmXR7vq5to/wl5egFaMc3wJ , but they assume a Windows OS. Given that you're on Linux, your dictionary file location is ~/.config/google-chrome/Dictionaries/ .
 
I have the following message. Unable to connect to google spelling servers. Please check internet connections and try again percyhood@blueyonder.co.uk 
Shallotman: The issue on which you're commenting has been closed for a long time. Please file a new bug for your specific issue.

Comment 111 Deleted

In Mozilla Firefox the spell-checker doesn't stay on, WTF? 
In Mozilla Firefox the spell-checker keeps turning itself on, WTF?
In Mozilla Firefox the spell-checker keeps turning itself on, WTF?
Try deleting your browser cookies then reboot and login and try again
Components: -UI>Browser>Spellcheck UI>Browser>Language>Spellcheck
This still happens.

Use Outlook instead.
It works!
Showing comments 19 - 118 of 118 Older

Sign in to add a comment