Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 141601 Error while trying to connect to a HTTPS website - Error 117 (net::ERR_BAD_SSL_CLIENT_AUTH_CERT)
Starred by 9 users Reported by stefano....@gmail.com, Aug 9 2012 Back to list
Status: Archived
Owner:
Last visit > 30 days ago
Closed: Feb 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
Chrome Version       : 21.0.1180.75
OS Version: 5.1 (Windows XP)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: Not tested
  Firefox 4.x: OK
     IE 7/8/9: OK

What steps will reproduce the problem?
1. Trying to connect in a HTTPS website
2.
3.

What is the expected result?
Simply connect to the website

What happens instead?
Error page
Error 117 (net::ERR_BAD_SSL_CLIENT_AUTH_CERT)

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.75 Safari/537.1


 
error 117.JPG
50.8 KB View Download
Labels: -Area-Undefined Area-Internals Internals-Network-SSL
Status: Untriaged
Thanks for the report!

We'll need some more information to help diagnose the problem.

See http://dev.chromium.org/for-testers/providing-network-details for instructions.

Thanks!
Comment 2 by wtc@chromium.org, Aug 13 2012
Cc: rsleevi@chromium.org agl@chromium.org
Labels: Action-FeedbackNeeded
Owner: wtc@chromium.org
Status: Assigned
stefano.vassena: thank you for the bug report.

In addition to what cbentzel requested in comment 1, please try running
chrome.exe with the command-line option
    --ssl-version-max=tls1

Does that fix the problem?

The screen shot error 117.JPG shows an https://www.facebook.com/ URL
in Chrome's location bar.  I believe Facebook does not use client
certificates.  So there may be an SSL man-in-the-middle proxy device
on your network, and that device is requesting client certificates?
Hi, I've the same problem even with https://www.google.com
any ideas ? 

I need to get this fixed asap.  Mine occurs very randomly.  I can refresh a few times to finally have the page show up.  Everything HTTPS is very random at this point.  How can I contribute to further this issue ? 
Comment 5 by agl@chromium.org, Aug 27 2012
ricardo.angelosanto: if you're seeing client-auth problems then we recently worked around a bug in IIS related to renegotiation in r152116. This should be in the beta channel by now at least.
Comment 6 by e...@pvs.at, Nov 6 2012
Same problem here with "Google Chrome Version 22.0.1229.94 m". The problem occurs with every HTTPS-Site, but as mentioned by ricardo after a few refreshes there is no problem opening the site. But after closing Chrome and opening again or changing the site and come back to the site again, the problem occurs again. Clicking on any link on HTTPS-Sites p.e. https://asmp.a1.net/asmp/LoginMasterServlet/axpaaa1?userRequestURL=https%253A%252F%252Fasmp.a1.net%252Fmsslogin%253FserviceId%253DINVOICE%2526returnId%253Dnull&serviceRegistrationURL=&service=MSSLoginService&cookie=skip&level=10&aaacookie=axpaaa1 Link: "Weiter" results in the same error again. After refreshing I am rerouted to the first site.
To add to this, I have tried the beta route, with no success.  Back to firefox unfortunately...
Comment 8 by Deleted ...@, Dec 21 2012
I am facing this problem from few days, I feel it is an issue regarding firewall which blocks the site from opening with this error message "Error 117 (net::ERR_BAD_SSL_CLIENT_AUTH_CERT): Bad SSL client authentication certificate."
chrome_certificate_issue.png
128 KB View Download
Comment 9 by Deleted ...@, Jan 10 2013
I get the error even when I open google.com. But, when I refresh the page, it works fine. This is very irritating. 

Error 117 (net::ERR_BAD_SSL_CLIENT_AUTH_CERT): Bad SSL client-authentication certificate.



I started having the same problem.
It was working until few days ago. I have Version 23.0.1271.101.
Mozilla keep working fine.
Yesterday chrome was working as well, today no more.

I get "Certificate-based authentication failed", "Error 117 (net::ERR_BAD_SSL_CLIENT_AUTH_CERT): Bad SSL client authentication certificate."
I forgot to add that Safari works fine as well, so it is not a problem with my keychain.

Can people still encountering this issue do two things:

1) Attempt to use the latest Google Chrome Canary version - https://www.google.com/intl/en/chrome/browser/canary.html - and see if the problem still exists.

2) Gather a net-internals log, as described at https://sites.google.com/a/chromium.org/dev/for-testers/providing-network-details
Comment 13 by Deleted ...@, Feb 26 2013
Here is my results with Chrome Canary ( That I downloaded seconds ago. )

The problem still persists with CHROME CANARY.

net-internals-log.json
103 KB View Download
Comment 14 by e...@pvs.at, Feb 27 2013
Tested today with google canary. Same problem.

Enclosed the net-internals-log.json -File
net-internals-log.json
1.8 MB View Download
For comment #14: It appears from Event ID 753 that the browser is sending a client hello to ssl/cdn2.a1.net, and the server is responding with an SSL alert for "Access Denied" (eg: alert 49). Socket #636 shows this same thing, but for asmp.a1.net. Receiving an alert this early suggests a server misconfiguration - the server never even sends the CertificateRequest message needed to indicate that a client cert is required.

For comment #13: Your log does not contain sufficient data. Please make sure carefully follow the steps from https://sites.google.com/a/chromium.org/dev/for-testers/providing-network-details (you can also find instructions at chrome://net-internals/help.html ). This involves closing all instances of Chrome, loading a new instance with a single tab, opening chrome://net-internals, and then in a new tab, reproducing the error.
Project Member Comment 16 by bugdroid1@chromium.org, Mar 9 2013
Labels: -Action-FeedbackNeeded Needs-Feedback
Project Member Comment 17 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Internals-Network-SSL Cr-Internals Cr-Internals-Network-SSL
Comment 18 by b...@chromium.org, Feb 20 2015
Status: WontFix
Closing for lack of feedback.
Comment 19 by b...@chromium.org, Feb 20 2015
Status: Archived
Sign in to add a comment