Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 140451 Embedded fonts not displaying in canvas tag when embedded by CSS
Starred by 4 users Reported by brybut...@gmail.com, Aug 3 2012 Back to list
Status: WontFix
Owner:
User never visited
Closed: May 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug



Sign in to add a comment
OS Version: Windows
Exact GPU vendor/model: Chrome 21.0.1180.60 m
URLs (if applicable): http://www.short999.com/html5/index.html
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
     Firefox 4.x: OK
     IE 7/8/9: N/A - HTML5 not supported

What steps will reproduce the problem?
1. Go to above URL in Chrome and Firefox (to compare)
2. Click Play
3. Observe custom font appears in Firefox but not Chrome, also note that custom font appears in Chrome on normal HTML page <p> above canvas tag, but not in HTML5 game.

What is the expected result?


What happens instead?


Please provide any additional information. Attach a screenshot if
possible.

Please copy the contents of about:gpu (chrome://gpu/) below
 
What is the expected result?
Chrome should display custom font as it does in Firefox (ie. display text on screen and numbers on cans).

What happens instead?
Chrome does not display anything.
Comment 2 by kareng@google.com, Aug 3 2012
Labels: Mstone-21
Owner: vivianz@chromium.org
Status: Assigned
pls repro/bisect.
Cc: vivianz@chromium.org anan...@chromium.org
Labels: -Area-Undefined Area-Internals
Owner: pucchakayala@chromium.org
Owner: ----
Status: Untriaged
Not a regression as it is reproducible on 
19.0.1084.56 (Official Build 140965)
20.0.1132.57 (Official Build 145807) beta-m
21.0.1180.60
22.0.1225.0 (Official Build 149792) canary
140451 FF versus Chrome.PNG
1.1 MB View Download
Labels: -Area-Internals Area-WebKit WebKit-WebApps
Labels: OS-All
Reproducible on Mac osx 10.6.8 & Linux/Ubuntu 10.04
No numbers and text is displayed on mac as well, on Linux text is overlapped. Please find the attached screen shot.

Build Tested --> 21.0.1180.57 (Official Build 148591)
140451 Linux M21.png
265 KB View Download
Comment 7 by kareng@google.com, Aug 6 2012
Labels: checkedk
Comment 8 by brybut...@gmail.com, Aug 15 2012
Bug solved on Chrome.
Strangely it seems to matter how you include Easel JS on the index page.
If you break down the includes into individual elements such as:

<script src="./lib/easeljs/src/display/DisplayObject.js"></script>
<script src="./lib/easeljs/src/display/Bitmap.js"></script>
<script src="./lib/easeljs/src/ui/Touch.js"></script>
...etc...
then it doesn't work. 

But if you include the entire library like:
<script src="./lib/easeljs/easeljs-0.4.2.min.js"></script>
it works fine.

As noted before, it worked in Firefox with the former, so this is odd, as it means there wasn't a library or any display function missing.
Comment 9 by kareng@google.com, Aug 24 2012
Owner: vangelis@chromium.org
Status: Assigned
vangelis this is not gpu is it?
If the problem is fixed by adjusting the script includes then it's most likely not a gpu issue.  I suspect that if you open the developer tools you'll see some JS errors when text doesn't appear.
Project Member Comment 11 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Feature-GPU -Area-WebKit -Mstone-21 -WebKit-WebApps Cr-Content Cr-Internals-GPU Cr-Content-WebApps M-21
Project Member Comment 12 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Labels: GPU-Assign-Over-One-Year-1-28-15
Status: WontFix
Closing based on #10
Sign in to add a comment