Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 140366 Flash videos not longer remaining in fullscreen when clicking a secondary monitor while the video is playing.
Starred by 58 users Reported by neao...@gmail.com, Aug 2 2012 Back to list
Status: Verified
Owner: ----
Closed: Aug 2012
Cc: manoranj...@chromium.org, pavanv@chromium.org, viettrungluu@chromium.org, jsc...@chromium.org, ligim...@chromium.org, brettw@chromium.org
Components:
OS: Windows
Pri: 1
Type: Bug


Sign in to add a comment
Chrome Version       : Google Chrome	21.0.1180.60 (Official Build 149126) m
OS	Windows
WebKit	537.1 (@123707)
JavaScript	V8 3.11.10.17
Flash	11.3.31.222
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.60 Safari/537.1
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:OK
  Firefox 4.x:OK
       IE 7/8/9:OK

What steps will reproduce the problem?
1.Go to youtube, or any other site that uses flash video player.
2.Watch a video and make it fullscreen (the flash player object).
3.Click on a secondary/other monitor (you will need a multi-monitor setup to test this.)

What is the expected result?
If the flash window is playing the video and not just buffering it should remain fullscreen.

What happens instead?
The flash window exits fullscreen, regardless if the video is playing or not.

Please provide any additional information below. Attach a screenshot if
possible.
 
Labels: Feature-Flash
Comment 2 by kareng@google.com, Aug 3 2012
Owner: viettrungluu@chromium.org
Status: Assigned
vtl is this a dupe of 137523?
Cc: jsc...@chromium.org brettw@chromium.org viettrungluu@chromium.org
Labels: OS-Windows Feature-Plugins-Pepper
Owner: jsc...@chromium.org
@2: No, not a dupe of issue 137523.

This is probably due to Chrome/Pepper being stricter/different about leaving fullscreen when it loses focus.

Justin, could you please take a look at this?
(To be clear, some people in issue 137523 have mentioned this issue. But this one I bet we can reproduce....)
Issue 139465 has been merged into this issue.
Yes, Chrome/Pepper always drops fullscreen when we lose focus (until recent versions, Flash did as well). Maybe we should just have Chrome not drop fullscreen on focus change in the multi-monitor case?
Issue 139465 has been merged into this issue.
Labels: -Pri-2 Pri-1
@6: Could you check what current NPAPI Flash does? (Is it possible to check whether the window we're losing focus to is on a different monitor?)

Note that issue 139465 has received a decent amount of attention and *is* a duplicate of *this* bug (or vice versa, I guess), so I'm going to bump the priority of this.
As I remember, NPAPI ignored whether or not the Window was on the same monitor (e.g. it could be fullscreen with another window in front). In the multi-monitor case I'm fine with that behavior, since the fake desktop threat is negligible.
SGTM in that case.
Comment 11 Deleted
Not sure if this was made clear in any of the other merged issues but NPAPI flash will still lose fullscreen if the video is not actually *playing* (i.e it is paused or in the process of initial buffering)

I'm not a expert in Flash but this implies to me that the NPAPI flash is making a decision to maintain fullscreen or not rather than just ignoring any loss of focus all the time.
Comment 13 by Deleted ...@, Aug 3 2012
Stats for pepper player and my system. I too am having issues with fullscreen minimizing after focus changes to separate monitor. Disabling this plug-in does fix the problem though.

Name:	Shockwave Flash
Description:	Shockwave Flash 11.3 r31
Version:	11.3.31.222
Location:	C:\Users\Admin\AppData\Local\Google\Chrome\Application\21.0.1180.60\PepperFlash\pepflashplayer.dll

GeForce GTX 470 - Graphics Driver Version: 301.42
Windows 7 Home Premium x64 - Version 6.1 (Build 7601:Service Pack 1)
Comment 14 Deleted
Issue 140661 has been merged into this issue.
Comment 16 by kareng@google.com, Aug 6 2012
Issue 140436 has been merged into this issue.
Comment 17 by kareng@google.com, Aug 6 2012
Labels: Mstone-21 ReleaseBlock-Beta
Comment 18 by kareng@google.com, Aug 6 2012
Issue 140426 has been merged into this issue.
Status: Fixed
Fix in and merged for the next stable update.
Comment 20 by kareng@google.com, Aug 7 2012
Issue 140769 has been merged into this issue.
Cc: ligim...@chromium.org manoranj...@chromium.org pavanv@chromium.org
Issue 140734 has been merged into this issue.
Issue 139995 has been merged into this issue.
Project Member Comment 23 by bugdroid1@chromium.org, Aug 7 2012
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=150162

------------------------------------------------------------------------
r150162 | jschuh@chromium.org | 2012-08-06T22:54:58.423138Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/render_widget_host_view_win.cc?r1=150162&r2=150161&pathrev=150162
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/render_widget_host_view_win.h?r1=150162&r2=150161&pathrev=150162

Prevent Flash from dropping focus on fullscreen change

This is basically a revert of half of this CL:
https://chromiumcodereview.appspot.com/10779023/

BUG= 140366 
TBR=viettrungluu@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10830187
------------------------------------------------------------------------
Project Member Comment 24 by bugdroid1@chromium.org, Aug 7 2012
Labels: merge-merged-1180
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=150175

------------------------------------------------------------------------
r150175 | jschuh@chromium.org | 2012-08-06T23:39:57.967911Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/content/browser/renderer_host/render_widget_host_view_win.h?r1=150175&r2=150174&pathrev=150175
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/content/browser/renderer_host/render_widget_host_view_win.cc?r1=150175&r2=150174&pathrev=150175

Merge 150162 - Prevent Flash from dropping focus on fullscreen change

This is basically a revert of half of this CL:
https://chromiumcodereview.appspot.com/10779023/

BUG= 140366 
TBR=viettrungluu@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10830187

TBR=jschuh@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10826176
------------------------------------------------------------------------
Owner: ----
Status: Verified
verified on a dual monitor setup that, the full screen video doesn't stop/pause/resize when user switches the focus to secondary monitor

Tested with Pepper and NPAPI flash plugins
Issue 140985 has been merged into this issue.
Was this resolved recently? It works as intended now but the bug is still marked as only "verified"
Verified means "verified fixed"
Comment 29 by testb...@gmail.com, Aug 13 2012
Yes, now OK!
V.: 21.0.1180.75 (Официальная сборка 150248) m
 22.0.1229.79 still has this problem in Linux.

Fedora 17 x64.
This is still occurring for YouTube Flash videos for me on Arch Linux x64 with Chrome 24.0.1312.5 (Official Build 166104) beta.


Google Chrome	24.0.1312.5 (Official Build 166104) beta
OS	Linux 
WebKit	537.17 (@133514)
JavaScript	V8 3.14.5
Flash	11.5.31.101
User Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.5 Safari/537.17
Command Line	 /usr/bin/google-chrome --disable-application-cache --flag-switches-begin --flag-switches-end
Executable Path	/opt/google/chrome/google-chrome
Profile Path	/home/<my user>/.config/google-chrome/Default
Variations	5666f941-fd526c81
b03ddc1f-2d9ef0cc
4dcb0cd6-d31c4ca1
f9b252d0-fd526c81
ccee547a-766fa2d
571ffcab-766fa2d
60f3499f-766fa2d
76b86d80-766fa2d
ffbe45b6-cebb5dfe
75f7fb7e-766fa2d
24dca50e-837c4893
ca65a9fe-91ac3782
9c097cbc-d00c3f8d
3028188e-b9bbd1b6
df910896-3d47f4f4
5a3c10b5-e1cc0f14
244ca1ac-4ad60575
246fb659-5c63917a
f296190c-b52e3392
4442aae2-e1cc0f14
75f0f0a0-d7f6b13c
e2b18481-a90023b1
e7e71889-e1cc0f14
980cfc4b-c5cc9a0a


Adobe Flash Player (2 files) - Version: 11.5.31.101
Shockwave Flash 11.5 r31
Name:	Shockwave Flash
Description:	Shockwave Flash 11.5 r31
Version:	11.5.31.101
Location:	/opt/google/chrome/PepperFlash/libpepflashplayer.so
Type:	PPAPI (out-of-process)
 	 Disable
MIME types:	
MIME type	Description	File extensions
application/x-shockwave-flash	Shockwave Flash	.swf
application/futuresplash	FutureSplash Player .spl

Project Member Comment 32 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Feature-Flash -Feature-Plugins-Pepper -Mstone-21 M-21 Cr-Content-Plugins-Flash Cr-Content-Plugins-Pepper
Project Member Comment 33 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-Undefined
Project Member Comment 34 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Blink
Project Member Comment 35 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash
Project Member Comment 36 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Internals-Plugins
Project Member Comment 37 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Plugins-Pepper Cr-Internals-Plugins-Pepper
Comment 38 by Deleted ...@, Nov 4 2013
I am still affected by this issue, using Chrome Version 32.0.1685.0 dev, under Ubuntu 13.04, using the pepper flash plugin (11.9 r900 according to chrome://plugins). What could be causing this?
Comment 39 by styr...@gmail.com, Nov 8 2013
I am also still having this issue with Chrome Version 30.0.1599.114 under Ubuntu 13.10 with the version 11.9 r900 of pepper flash.
Comment 40 by Deleted ...@, Nov 27 2013
This issue has come back sometime in November for me. I cannot keep YT fullscreen if I poll focus from Chrome window.
Yes, this bug has definitely resurfaced. I was affected by the original bug and now it has cropped up again with losing full screen with multi-monitor setups.

Windows 8.1 Pro x64
Version 33.0.1720.0 canary
Could you please file a new bug with your system details? It's likely not the same issue, but a similar new issue related to the switch to Aura on Windows.
This bug just showed up recently for me.
Specific to flash, not necessarily youtube. (Works correctly on I.E. and Firefox)

Was a new bug filed yet? Should I do that? (My search failed)

Chrome: Version 32.0.1700.41 beta-m Aura
Video: NVidia 9800 GT
Windows Vista
Comment 44 by Deleted ...@, Dec 14 2013
This error began when I upgraded to the latest Flash Player 11.9

Flash videos not longer remaining in fullscreen when clicking a secondary monitor while the video is playing.
Comment 45 by Deleted ...@, Dec 14 2013
Same Issue Showed up within the last few weeks - Flash video will not remain fullscreen when the window loses focus. It makes chromecast impossible to use fullscreen while still using the PC.
Chrome 32.0.1700.41 m Aura
Windows 7 Home and Windows 8.1
Flash 11.9.900.170

Comment 46 by Deleted ...@, Dec 15 2013
Yes this bug is back. It wasn't a couple of days ago.
Confirm. This bug is back. Manjaro/Arch, latest Chrome, dual monitor setup.
Comment 48 by Deleted ...@, Feb 1 2014
I can confirm this bug is back for me too on Arch with Chromium and pepper flash
Sign in to add a comment