New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 47 users

Issue metadata

Status: Fixed
Owner:
User never visited
Closed: Aug 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
link

Issue 140044: Print preview takes forever on Win XP

Reported by cary.bu...@gmail.com, Aug 1 2012

Issue description

Chrome Version       : 21.0.1180.60
OS Version: 5.1 (Windows XP)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
IE 7/8/9:

What steps will reproduce the problem?
1.
2.
3.

What is the expected result?


What happens instead?


Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.60 Safari/537.1
 

Comment 1 by kareng@google.com, Aug 1 2012

Owner: vivianz@chromium.org
Status: Assigned

Comment 2 by vivianz@chromium.org, Aug 1 2012

Cc: anan...@chromium.org vivianz@chromium.org
Owner: athigle@chromium.org
Aditya,

could you try see if you can reproduce this issue on a winxp. I tested on win7, it was not reproducible there.

Comment 3 by athigle@chromium.org, Aug 1 2012

Labels: Action-FeedbackNeeded
I am able to load Print Preview on Google Calendar page in 21.0.1180.60 on Windows XP

Please describe your issue in more detail.

Comment 4 by vivianz@chromium.org, Aug 1 2012

Status: Unconfirmed

Comment 5 by cary.bu...@gmail.com, Aug 2 2012

when I click print, the print preview window is empty and and it displays "loading" but it won't load

Comment 6 by vivianz@chromium.org, Aug 2 2012

Labels: -Area-Undefined Area-UI Feature-PrintPreview
Owner: ----
@cary.budin

were you able to view print preview in other web page, like gmail inbox page...etc? did this work before with older version of Chrome on your win xp? 

thanks for your feedback!

Comment 7 by athigle@chromium.org, Aug 3 2012

 Issue 140206  has been merged into this issue.

Comment 8 by abodenha@chromium.org, Aug 3 2012

Owner: abodenha@chromium.org
Status: Assigned
@cary.budin

There's an issue we're investigating where some WinXP users are seeing the print preview hang as you describe.  Re-installing Microsoft's XPS essentials pack seems to fix it.

Comment 9 by abodenha@chromium.org, Aug 5 2012

 Issue 140226  has been merged into this issue.

Comment 10 by abodenha@chromium.org, Aug 6 2012

Labels: -Pri-2 Pri-0

Comment 11 by abodenha@chromium.org, Aug 6 2012

Owner: gene@chromium.org

Comment 12 by jtan@chromium.org, Aug 7 2012

Cc: karen@chromium.org
Labels: Hotlist-ConOps
CC'ing Karen as FYI. Also reference http://b/6930881

Comment 13 by kareng@google.com, Aug 8 2012

Labels: ReleaseBlock-Stable Mstone-21

Comment 14 by abodenha@chromium.org, Aug 8 2012

Labels: -Pri-0 -ReleaseBlock-Stable Pri-1

Comment 15 by abodenha@chromium.org, Aug 8 2012

jtan@ This seems to be triggered by a misbehaving print system in WinXP.  Reinstalling the XPS pack or .Net 3.0+ on the machine sorts out the issue.  We've discussed with angelaam@ and others in ConOps internally.

We're going to try to get a workaround together asap and we'd like to cherry pick that into M21 if it's simple/safe enough, but this shouldn't block anything already planned.

Thanks.

Comment 16 by jtan@chromium.org, Aug 8 2012

@abodenha - Understood. I've also been in touch with Angela on this issue. I cc'ed Karen as FYI only since it's a noteworthy issue but I agree it's not a blocker for anything already in motion (we chatted about this offline as well). Sorry for any confusion!

Comment 17 by bugdroid1@chromium.org, Aug 9 2012

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=150683

------------------------------------------------------------------------
r150683 | gene@chromium.org | 2012-08-09T02:09:40.244324Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/printing/print_system_task_proxy.cc?r1=150683&r2=150682&pathrev=150683

Fixed issue displaying print preview on Windows XP.
Lack of XPS system on XP caused problems getting printer capabilities.
Use default settings for print preview in this case.

BUG= 140044 
TEST=On Windows XP (vanila install, no extras) go to a webpage and press Ctrl-P to bring up print preview. It should work.

Review URL: https://chromiumcodereview.appspot.com/10825256
------------------------------------------------------------------------

Comment 18 by abodenha@chromium.org, Aug 9 2012

Labels: -Type-Bug Type-Regression Mstone-22 Merge-Requested
Status: Fixed
Just verified in this morning's canary.

This is our top user issue in Chrome 21 right now.  I'd like to merge the change to 21 and 22.

Comment 19 by k...@google.com, Aug 9 2012

Labels: Merge-Approved-1229
Status: Started
Approved for 22.

Comment 20 by gene@chromium.org, Aug 9 2012

Status: Fixed
Merged to 22. Issue fixed, please verify.

Comment 21 by bugdroid1@chromium.org, Aug 9 2012

Project Member
Labels: merge-merged-1229
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=150860

------------------------------------------------------------------------
r150860 | gene@chromium.org | 2012-08-09T19:07:59.802527Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1229/src/chrome/browser/printing/print_system_task_proxy.cc?r1=150860&r2=150859&pathrev=150860

Merge 150683 - Fixed issue displaying print preview on Windows XP.
Lack of XPS system on XP caused problems getting printer capabilities.
Use default settings for print preview in this case.

BUG= 140044 
TEST=On Windows XP (vanila install, no extras) go to a webpage and press Ctrl-P to bring up print preview. It should work.

Review URL: https://chromiumcodereview.appspot.com/10825256

TBR=gene@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10827255
------------------------------------------------------------------------

Comment 22 by gene@chromium.org, Aug 9 2012

Status: Assigned
Keeping open for m21 push

Comment 23 by abodenha@chromium.org, Aug 9 2012

Summary: Print preview takes forever on Win XP
Clarifying title

Comment 24 by abodenha@chromium.org, Aug 9 2012

 Issue 141479  has been merged into this issue.

Comment 25 by abodenha@chromium.org, Aug 10 2012

 Issue 141479  has been merged into this issue.

Comment 26 by abodenha@chromium.org, Aug 10 2012

Cc: athigle@chromium.org
 Issue 141683  has been merged into this issue.

Comment 27 by k...@google.com, Aug 12 2012

Labels: -Mstone-22

Comment 28 by abodenha@chromium.org, Aug 14 2012

Cc: ranavdk@chromium.org srihariraju@chromium.org arsids@chromium.org joycel@chromium.org dpete@chromium.org mnarula@chromium.org vandanashah@chromium.org nikhilalm@chromium.org
 Issue 140648  has been merged into this issue.

Comment 29 by abodenha@chromium.org, Aug 14 2012

 Issue 140648  has been merged into this issue.

Comment 30 by abodenha@chromium.org, Aug 14 2012

 Issue 141458  has been merged into this issue.

Comment 31 by abodenha@chromium.org, Aug 14 2012

 Issue 142182  has been merged into this issue.

Comment 32 by abodenha@chromium.org, Aug 14 2012

 Issue 142182  has been merged into this issue.

Comment 33 by abodenha@chromium.org, Aug 14 2012

 Issue 142174  has been merged into this issue.

Comment 34 by abodenha@chromium.org, Aug 14 2012

 Issue 140648  has been merged into this issue.

Comment 35 by kareng@google.com, Aug 15 2012

Labels: -Merge-Requested Merge-Approved

Comment 36 by gene@chromium.org, Aug 15 2012

Status: Fixed
Merged to M21. Marking as Fixed.

Comment 37 by bugdroid1@chromium.org, Aug 15 2012

Project Member
Labels: -Merge-Approved merge-merged-1180
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=151719

------------------------------------------------------------------------
r151719 | gene@chromium.org | 2012-08-15T18:51:16.100278Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/browser/printing/print_system_task_proxy.cc?r1=151719&r2=151718&pathrev=151719

Merge 150683 - Fixed issue displaying print preview on Windows XP.
Lack of XPS system on XP caused problems getting printer capabilities.
Use default settings for print preview in this case.

BUG= 140044 
TEST=On Windows XP (vanila install, no extras) go to a webpage and press Ctrl-P to bring up print preview. It should work.

Review URL: https://chromiumcodereview.appspot.com/10825256

TBR=gene@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10829343
------------------------------------------------------------------------

Comment 38 by robert_s...@fastmail.fm, Aug 16 2012

When is the release going to be for this bug fix -- we have 200 Google Chrome users with this issue which is impacting our business.  Ctrl-p does not work we have tried.
We are now in process of downgrading to an older version and blocking auto updates in GP.  Please note we are major retail brand in the UK and we do not want to go to IE or Firefox.

Comment 39 by abodenha@chromium.org, Aug 16 2012

I can't give a release date.  We're going to get it out as soon as we can.

Robert, as mentioned in earlier comments, reinstalling MS's XPS Essentials pack or .Net 3.0 or greater will workaround the issue.

Comment 40 by Deleted ...@, Aug 16 2012

Hopefully the fix is released soon... we really don't want to junk up PCs with MS's XPS Essentials pack or .Net 3.0 or greater

Comment 41 by robert_s...@fastmail.fm, Aug 16 2012

I just cannot instruct my team to reinstall xps or net.3 -- there are other dependancies on this applications and we have 200 users -- what are your timescales on a release?

Comment 42 by jeff.w.l...@gmail.com, Aug 17 2012

I don't think this is just a Windows XP issue as this it affecting me as well on Windows 7.

Comment 43 by abodenha@chromium.org, Aug 17 2012

jeff.w.lawson@, The issue happens when print preview requests info from the print system but never gets a response.  It CAN happen on Win 7, but we've only ever seen it if some other problem caused the Windows print system to not respond.

Please test with the Canary build from https://tools.google.com/dlpage/chromesxs/.  If the issue is resolved there, it's related to this issue.  If not, something else is up.  Please file a new bug if that's the case.

Comment 44 by jeff.w.l...@gmail.com, Aug 17 2012

This issue was resolved for me with the Canary build on Windows 7.

Comment 45 by gymtrai...@gmail.com, Aug 19 2012

Still does not work on Win XP Sp2

Comment 46 by Deleted ...@, Aug 19 2012

Sill does not work for me Windows Vista Home Premium.  Hangs at Print Preview.  CTRL+Shift+P only works once every 4-5 tries.

Comment 47 by yukio.ka...@gmail.com, Aug 21 2012

Still does not work on not only Win XP SP2 but also Win XP SP3.
*The version of Google chrome is "210.1180.79".

Comment 48 by thestig@chromium.org, Aug 21 2012

The fix is in 21.0.1180.81 or newer, which has not been released yet. There will very likely be a release this week with the fix. As always, Google Chrome release announcements will be posted to http://googlechromereleases.blogspot.com/ .

Comment 49 by Deleted ...@, Aug 21 2012

Awesome it's released now!  :-)

Comment 50 by vitalyb...@chromium.org, Sep 8 2012

 Issue 140648  has been merged into this issue.

Comment 51 by miika.ah...@gmail.com, Sep 11 2012

I have 21.0.1180.89 and the preview gets stuck (on Win7 tho, not XP) :\

Comment 52 by miika.ah...@gmail.com, Sep 11 2012

Actually nevermind, it just doesn't start the print spooler service that's been set to manual.

Comment 53 by brian.pa...@gmail.com, Sep 14 2012

Chrome Version       : 21.0.1180.89
OS Version: Windows XP SP3
URLs (if applicable) : FedEx Print Label page https://www.fedex.com/shipping/shipAction.handle?method=doContinue
Other browsers tested: NONE

What steps will reproduce the problem?
1. Choosing Print button provided by web page.
2. Right-click and choose Print...
3. Click 'view' to view the receipt. Opens new window. Print from there.

What is the expected result?
Expecting two-page document to print.

What happens instead?
Nothing.

Please provide any additional information below. Attach a screenshot if
possible.
I've had problems with the FedEx page and Chrome ever since I switched a few years ago.  So, I've usually figured they don't play well together, and I try multiple things to work around the issue, including printing the label and receipt separately, or finding the label on a 'history' list, and printing from there. Printing suddenly worked again until a month or two ago.  I resorted to Printing to PDF and going from there. Today, I decided to see if others had the same problem, and came across this bug page.

Today, the Save to PDF option wasn't even working.  I also tried clicking the 'Print Using System Dialog...' option, but nothing happened.  I also tried using Cloud Print to a printer in the office, as well as to print directly to that other printer.  None of the choices mattered.  At one point, I did manage to get a 'Printing...' message in the upper left corner of the window, but the document preview remained, and nothing came out.  Of possible interest is the fact that the Preview page displayed the 'Loading...' spinning circle for several minutes on several of my tries.

After reading your bug report, it seems that some suggested were to reinstall the XPS Essentials, Net 3.0, or Net 3.5 packages.  I also saw someone mention that their Print Spooler Service was set to manual.  Mine was set to automatic.  Nevertheless, I restarted the Print Spooler Service and was able to Print normally, not even having to resort to the Print to PDF option.  To be clear, I did NOT install the suggested packages; restarting the Print Spooler Service fixed the problem...for now. Thank you.

Comment 54 by abodenha@chromium.org, Sep 17 2012

brian.papocchia@ What you're seeing is unrelated to this issue.  I suspect you might be hitting a variant of  issue 65469  or possibly some other issue.

Comment 55 by Deleted ...@, Oct 25 2012

Same desktop computer, using chrome version  22.0.1229.94, same email, some of gmail accounts can print preview but some account, the print preview window is empty and and it displays "loading" but it won't load. The computer already is installed .Netframework 3.5. Any advise, thanks.

Comment 56 Deleted

Comment 57 by nellana...@gmail.com, Dec 13 2012

The fixes listed on http://productforums.google.com/forum/#!topic/chrome/4tf4W9eSGFE%5B1-25%5D of installing the XPS Essentials pack, .Net 3.0, and .Net 3.5 don't work for Windows 7 because they are built in features and can't be installed from a MSI. I tried turning off the features and turning them back on but it didn't help.

Comment 58 by vitalyb...@chromium.org, Dec 13 2012

Labels: Restrict-AddIssueComment-Commit
The topic is XP here, please file new issue with detailed description.

Comment 59 by bugdroid1@chromium.org, Mar 9 2013

Project Member
Labels: -Action-FeedbackNeeded Needs-Feedback

Comment 60 by bugdroid1@chromium.org, Mar 9 2013

Project Member
Labels: -Type-Regression -Area-UI -Feature-PrintPreview -Mstone-21 Type-Bug-Regression Cr-UI M-21 Cr-UI-Browser-PrintPreview

Comment 61 by bugdroid1@chromium.org, Mar 14 2013

Project Member
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Comment 62 by laforge@google.com, May 16 2015

Labels: -Merge-Approved-1229

Sign in to add a comment