New issue
Advanced search Search tips

Issue 139071 link

Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 74699
Owner: ----
Closed: Mar 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

cursor: -webkit-grabbing; is not working on Windows

Reported by vje...@gmail.com, Jul 26 2012

Issue description

Chrome Version       : 20.0.1132.57 (Official Build 145807)
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) : http://jsfiddle.net/BZtMc/1/
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: FAIL
  Firefox 4.x: N/A
     IE 7/8/9: N/A

What steps will reproduce the problem?
1. Go to http://jsfiddle.net/BZtMc/1/
2. Mouse over the result section

What is the expected result?
It should update the cursor

What happens instead?
It uses the default cursor

Please provide any additional information below. Attach a screenshot if
possible.

Both -webkit-grab and -webkit-grabbing are not working on Windows but correctly on both Mac and Linux.
 

Comment 1 by vje...@gmail.com, Jul 26 2012

Safari has the exact same behavior of Chrome. It also fail on Windows while working on Mac

Comment 2 by tkent@chromium.org, Jul 26 2012

Labels: -Area-Undefined Area-WebKit WebKit-CSS

Comment 3 by vje...@gmail.com, Jul 26 2012

This is the commit that introduced the cursor. It looks like there's only WebCore/platform/mac/CursorMac.mm modified and not the Windows one.

https://bugs.webkit.org/attachment.cgi?id=19473&action=edit
Project Member

Comment 4 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -WebKit-CSS Cr-Content Cr-Content-CSS
Project Member

Comment 5 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink
Project Member

Comment 6 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-CSS Cr-Blink-CSS

Comment 7 by robwu...@gmail.com, Sep 12 2013

This issue appears to have been fixed in Chrome 22.

Tested in Chrome 20, 21: bug shows up.
Tested in Chrome 22, 23, 25, Canary: Cursor is correctly displayed.

Comment 8 by robwu...@gmail.com, Sep 12 2013

This bug was fixed via  issue 74699 .
Mergedinto: 74699
Status: Duplicate

Sign in to add a comment