New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 137690 link

Starred by 6 users

Issue metadata

Status: Verified
Owner:
Last visit > 30 days ago
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Can't press Enter to save to PDF

Project Member Reported by paulherzlich@google.com, Jul 17 2012

Issue description

Chrome Version       : 21.0.1180.41
OS Version: OS X 10.6.8
URLs (if applicable) : All
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 4.x:
     IE 7/8/9:

What steps will reproduce the problem?
1. Go to any webpage.
2. Press Apple+P to bring up the Print menu.
3. Change the Destination to "Save as PDF."
4. Press Enter to attempt to save as PDF.

What is the expected result?
Chrome should move on to the next step of determining the location for where to save the PDF.

What happens instead?
Nothing happens. Only clicking on the "Save" button will work; pressing Enter does not (in previous Chrome versions, pressing Enter did work).

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.41 Safari/537.1



 
Cc: kmadhusu@chromium.org
Labels: -Area-Undefined Area-UI Feature-PrintPreview Action-BisectNeeded
Cc: rltoscano@google.com
Labels: -OS-Mac OS-All
Happens on Linux too.
Labels: -Type-Bug Type-Regression
It is a regression caused by refactoring.

Comment 5 by jeffreyc@google.com, Jul 17 2012

Cc: akshayk@chromium.org pawli...@chromium.org odean@chromium.org
Can anyone from the print team take this on?

Comment 6 by jeffreyc@google.com, Jul 17 2012

Cc: jeffreyc@chromium.org
Labels: -Pri-2 -Action-BisectNeeded Pri-1 Feature-Printing Mstone-22
Owner: rltoscano@google.com
Status: Assigned
Robert, can you look at this? 

It's pretty likely this was caused by the new UI work, so no need for a bisect.
rltoscano: We also regressed  bug 107583 . Please make sure we also fix that issue.

Thanks.

Labels: -Mstone-22 Mstone-21
I think the repro steps are not 100% correct. Even when I go back to Chrome 19, if I try to follow your instructions, after step 3, the destination field has focus. As such, pressing enter in step 4 will activate the destination field drop down box, and not actually save to pdf.

Instead, if you already saved to pdf, then the next time you print, the print dialog will remember save to pdf as the previously destination. In this case, the save button has focus and you can just press enter. This is where the UI has changed subtlely. In Chrome 20, the save button had focus by default, but in Chrome 21, it does not.

Let's try to fix this for M21 before it goes to stable. If it's just fixing the default focused element, that shouldn't be too hard, right?
To note, I filed this before saving to PDF (i.e., before the print dialog remembered to save as PDF). Interestingly though, even though it now remembers to save as PDF, I STILL have the enter button not working; it LOOKS like the save button has focus, but pressing enter does nothing.
Sounds like changing the default focused element as thestig@ recommends should restore the previous behavior. I'll fix that.

kmadhusu@, the bug you reference is already fixed, are you just noting it here so that it gets merged into the beta?
rltoscano: The bug was fixed before the UI changes. It is regressed during refactoring. When an user presses an enter key while the "pages" text field is focused, we should initiate printing. I just want to make sure we also fix that regression. 

Project Member

Comment 13 by bugdroid1@chromium.org, Jul 18 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=147143

------------------------------------------------------------------------
r147143 | rltoscano@google.com | 2012-07-18T00:38:13.377798Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/print_preview/print_header.js?r1=147143&r2=147142&pathrev=147143
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/print_preview/print_preview.js?r1=147143&r2=147142&pathrev=147143

Makes dialog print on ENTER key press.


BUG= 137690 
TEST=

Review URL: https://chromiumcodereview.appspot.com/10778041
------------------------------------------------------------------------
Status: Fixed
Cc: karen@chromium.org
Labels: Merge-Requested
Status: Started
Still need to merge to M21.
Cc: songsuk@chromium.org jasneet@chromium.org
 Issue 137916  has been merged into this issue.
 Issue 137916  has been merged into this issue.

Comment 18 by kareng@google.com, Jul 19 2012

looks ok on canary?
Confirm: issue is resolved on canary

Comment 20 by kareng@google.com, Jul 23 2012

Labels: -Merge-Requested Merge-Approved

Comment 21 by kareng@google.com, Jul 23 2012

Labels: -Merge-Approved Merge-Merged merge-merged-1180
Project Member

Comment 22 by bugdroid1@chromium.org, Jul 24 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=147898

------------------------------------------------------------------------
r147898 | abodenha@google.com | 2012-07-23T19:29:37.004064Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/browser/resources/print_preview/print_preview.js?r1=147898&r2=147897&pathrev=147898
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/browser/resources/print_preview/print_header.js?r1=147898&r2=147897&pathrev=147898

Merge 147143 - Makes dialog print on ENTER key press.


BUG= 137690 
TEST=

Review URL: https://chromiumcodereview.appspot.com/10778041

TBR=rltoscano@google.com
Review URL: https://chromiumcodereview.appspot.com/10796094
------------------------------------------------------------------------
Status: Fixed
Status: Verified
Verified as Fixed with 21.0.1180.55
Project Member

Comment 25 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 26 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-UI -Type-Regression -Feature-PrintPreview -Feature-Printing -Mstone-21 Type-Bug-Regression M-21 Cr-UI Cr-Internals-Printing Cr-UI-Browser-PrintPreview
Project Member

Comment 27 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Comment 28 by laforge@google.com, Jul 24 2013

Cc: -jeffreyc@chromium.org

Sign in to add a comment