New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 137336 link

Starred by 3 users

Issue metadata

Status: Verified
Owner:
Email to this user bounced
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Regression: Websites do not render completely in Presentation Mode

Project Member Reported by meh...@chromium.org, Jul 13 2012

Issue description

Chrome Version       : Version 22.0.1205.0 canary
URLs (if applicable) :
OS version               : Mac OS 10.6.8 & 10.7.4
Behavior in Chrome for Windows: not tested

What steps will reproduce the problem?
1. Be sure 'Show Bookmarks Bar' is **enabled**.
2. Press SHIFT-CMD-F to switch to Presentation Mode.
3. Click on a bookmark on the bar, which is *NOT* in a folder
4. Do not move the mousecurser after you click the bookmark, so that the complete toolbar is still visible
5. Wait until the progress spinner on the tab goes away.
6. You see a blank page below the toolbar - move the cursor away, so that the toolbar disappears

What is the expected result?
To see the complete page.

What happens instead?
You see only fragments of the page where the toolbar was before.

Looks like a regression.

Thanks and regards
Mehmet


 

Comment 1 by meh...@chromium.org, Jul 13 2012

Labels: Mstone-22
Works fine in Version 22.0.1201.0 dev it is broken in Version 22.0.1205.0 canary

Some screenshots are attached.
Bildschirmfoto 2012-07-14 um 01.29.09.png
33.6 KB View Download
Bildschirmfoto 2012-07-14 um 01.28.43.png
23.4 KB View Download
Bildschirmfoto 2012-07-14 um 01.25.02.png
38.4 KB View Download

Comment 2 by meh...@chromium.org, Jul 13 2012

Labels: Feature-GPU
GPU compositing on all pages is the culprit :-(

Disabling it (from default to disabled) fixes the problem.

Comment 3 by meh...@chromium.org, Jul 14 2012

I can reproduce it also on Beta 21, when I enable it in about flags. So please feel free to reduce the Mstone label.

Comment 4 by mark@chromium.org, Jul 16 2012

Owner: kbr@chromium.org
Status: Assigned

Comment 5 by kbr@chromium.org, Jul 16 2012

Cc: kbr@chromium.org wiltzius@chromium.org nduca@chromium.org enne@chromium.org
Labels: ReleaseBlock-Stable
Owner: jbates@chromium.org
Bisecting with --force-compositing-mode gives this regression range:

You are probably looking for a change made after 134023 (known good), but no later than 134033 (first known bad).
CHANGELOG URL:
  http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=134023%3A134033

It's probably an unintended side-effect of http://src.chromium.org/viewvc/chrome?view=rev&revision=134033 . Only happens with --force-compositing-mode, so it's related to turning on the compositor very early.

Simpler reproduction steps:

1. Open Chrome and close all tabs.
2. Open a new window.
3. Go full screen with Cmd-F.
4. Hover near the top of the screen and type a URL into the Omnibox.

After navigation completes, only the area underneath the top of the window will be redrawn. (Move the mouse away from the top of the screen to confirm this.)

This will have to block stable so that we don't turn on force-compositing-mode without a fix.

Comment 6 by jbates@chromium.org, Jul 17 2012

Specifically, this is repro'd by navigating from a software-rendered URL (ex: NTP) to a accelerated URL. And, only when --force-compositing-mode is enabled for some reason.
Project Member

Comment 8 by bugdroid1@chromium.org, Jul 17 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=147077

------------------------------------------------------------------------
r147077 | jbates@chromium.org | Tue Jul 17 13:12:24 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/render_widget_host_view_mac.mm?r1=147077&r2=147076&pathrev=147077

Always invalidate whole NSView when switching to GPU mode

Otherwise, some cases can leave opaque white in parts of the NSView that obscures the GL content.

R=sky@chromium.org
BUG= 137336 


Review URL: https://chromiumcodereview.appspot.com/10793022
------------------------------------------------------------------------

Comment 9 by jbates@chromium.org, Jul 17 2012

Labels: -Mstone-22 Mstone-21 Merge-Requested
Status: Fixed
Ideally this should merge to all branches that got http://src.chromium.org/viewvc/chrome?view=rev&revision=134033

Which would include 20, but I guess that has sailed. It appears this only happens with --force-compositing-mode enabled, which is not the default on 20 so is probably OK. Let's just get it on 21.
Status: Started
Fixed bugs don't get looked at for merges I think.

Comment 11 by kareng@google.com, Jul 19 2012

Status: Fixed
they do :) just waiting for confirmation that this is working as expected in canary and that there are no surprises/crashes.
Status: Verified
Verified as fixed in 22.0.1211.0 build@147395

web pages are completely rendered either with or without --force-compositing-mode enabled. 

Comment 13 by kareng@google.com, Jul 23 2012

Labels: -Merge-Requested Merge-Merged merge-merged-1180
Project Member

Comment 14 by bugdroid1@chromium.org, Jul 24 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=147883

------------------------------------------------------------------------
r147883 | jbates@chromium.org | 2012-07-23T17:50:50.388773Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/content/browser/renderer_host/render_widget_host_view_mac.mm?r1=147883&r2=147882&pathrev=147883

Merge 147077 - Always invalidate whole NSView when switching to GPU mode

Otherwise, some cases can leave opaque white in parts of the NSView that obscures the GL content.

R=sky@chromium.org
BUG= 137336 


Review URL: https://chromiumcodereview.appspot.com/10793022

TBR=jbates@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10817010
------------------------------------------------------------------------
Project Member

Comment 15 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 16 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-UI -Type-Regression -Feature-FullScreen -Feature-GPU -Mstone-21 Type-Bug-Regression Cr-Internals-GPU M-21 Cr-UI Cr-UI-Browser-FullScreen
Project Member

Comment 17 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment