New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 137024 link

Starred by 7 users

Issue metadata

Status: Fixed
Owner:
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

[Regression] Youtube Drag & Drop Upload Not Working

Reported by alin0ste...@gmail.com, Jul 12 2012

Issue description

Chrome Version       : 21.0.1180.15
OS Version: OS X 10.7.4
URLs (if applicable) :http://www.youtube.com/my_videos_upload
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:PASS
  Firefox 4.x: UNKNOWN
     IE 7/8/9: UNKNOWN

What steps will reproduce the problem?
1. go to above page
2. attempt to upload video per video's protocol
3.

What is the expected result?
Drag and Drop should FUNCTION

What happens instead?
no function

Please provide any additional information below. Attach a screenshot if
possible.

Screen Recording attached.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.15 Safari/537.1


 
Screen Recording1.mov
4.2 MB View Download

Comment 1 by bauerb@chromium.org, Jul 12 2012

Labels: -Area-Undefined Area-UI
FWIW, I can't reproduce this on Chrome 22.0.1201.0 dev, Mac OS 10.6.8.

Interestingly, the area that says "Drag and drop videos anywhere on this page to start uploading." is permanently gray in the screen capture. For me, it only turns gray when I drag files over it.
im on beta here. so then you guys need to roll the dev out to beta
Cc: alek...@chromium.org vfedorov@chromium.org
I'm on Linux with gc: Version 22.0.1205.0 
Drag and drop .ogv file, worked fine - unable to reproduce 
guys your all on the wrong version is why!!!

Version 21.0.1180.41 beta
you guys seem to be on dev versions im in beta if this makes it to stable we all may kiss chrome's reliability  goodbye.

Comment 6 by alekyoo@google.com, Jul 16 2012

I've tested on Mac, gc: Version 21.0.1180.38 - able to upload video. no problems. 
Labels: -Pri-2 -Type-Bug Pri-1 Type-Regression Action-BisectNeeded
Status: Untriaged
Summary: [Regression] Youtube Drag & Drop Upload Not Working
Reproducible in 21.0.1180.41 on Mac OS

Comment 8 Deleted

Owner: rayanna@chromium.org
Cc: athigle@chromium.org
Labels: -Area-UI -Action-BisectNeeded
Owner: ----
Please find the bisect result:

You are probably looking for build 137702.
WEBKIT CHANGELOG URL:
http://trac.webkit.org/log/trunk/?rev=117456&stop_rev=117232&verbose=on
CHANGELOG URL:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=137695:137702
Built at revision:
http://src.chromium.org/viewvc/chrome?view=rev&revision=137702
Cc: karen@chromium.org
Labels: ReleaseBlock-Stable Area-UI
Labels: -OS-Mac OS-All

Comment 13 by laforge@google.com, Jul 17 2012

Labels: Mstone-21

Comment 14 by kareng@google.com, Jul 17 2012

Owner: tony@chromium.org
Status: Assigned
tony this looks like http://trac.webkit.org/changeset/117327/trunk/Source

Comment 15 by kareng@google.com, Jul 17 2012

Owner: varunjain@chromium.org
i meant varun!!
Owner: kinuko@chromium.org
Hi Karen, this is not caused by my patch at all. I have bisected it to webkit r117432. I think kinuko fixed it in r118907 (hence people do not see the issue in newer builds).

Kinuko, please check if thats correct. If so, all you need to do is merge r118907 into M21.
Cannot repro this on Linux using build 137702... let me try on Mac.
I could repro this on Mac using build 137702, but with or without r118907.  I'll double check tomorrow (if someone in PDT can check this again it'd be really helpful).
Cc: varunjain@chromium.org
I do not think it is related to r118907.

I tried on the following Win and Mac builds and could repro the problem:
  Windows: 21.0.1180.41 (Official Build 146467) beta-m     WebKit: 537.1 (@122379)
  Mac:     22.0.1210.0 (Official Build 147188) canary      WebKit: 537.2 (@122872)

It seems that this is still broken with the latest build.
Just to be clear, I have not actually tested r118907. It seemed like the right CL which is why I asked kinuko to check. Sorry if I led people on the wrong path.
I manually reverted r117432 in my private build and still have this bug reproed. It seems that the problem probably lies in drag-and-drop layer.

Comment 23 by kareng@google.com, Jul 18 2012

Owner: dcheng@chromium.org
daniel said he'll take a look. ty daniel!
It's almost certainly the WebKit roll. From my bisect:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=137700%3A137702

There are three likely candidates:
http://trac.webkit.org/changeset/117249/trunk
http://trac.webkit.org/changeset/117327/trunk
http://trac.webkit.org/changeset/117383/trunk (I'd say this one isn't likely though).

I'll start rolling out patches locally to test.

Comment 25 by Deleted ...@, Jul 19 2012

whoa! I dont know how my bisect resulted in 117432. Daniel, if its easy for you to try, I would bring webkit to 117431 and see if the issue is there.
varunjain, your bisect still falls within the parameters of my bisect.

... and as it turns out, http://trac.webkit.org/changeset/117432/ does seem to be the one causing the breakage. It's clearly not fixed with r118907 though, since it's broken at HEAD.
Labels: WebKit-ID-91702
Project Member

Comment 28 by bugdroid1@chromium.org, Jul 19 2012

Labels: -WebKit-ID-91702 WebKit-ID-91702-NEW
https://bugs.webkit.org/show_bug.cgi?id=91702
Project Member

Comment 29 by bugdroid1@chromium.org, Jul 24 2012

Labels: -WebKit-ID-91702-NEW WebKit-ID-91702-RESOLVED
https://bugs.webkit.org/show_bug.cgi?id=91702

Comment 30 by kareng@google.com, Jul 25 2012

daniel can u check this on canary?

Comment 31 by kareng@google.com, Jul 25 2012

talked to daniel, once he checks we will merge.

Comment 32 by kareng@google.com, Jul 25 2012

talked to daniel, once he checks we will merge.
Aditya,

please verify the webkit fix on today's canary.thanks!
Working fine in 22.0.1217.0 (Official Build 148295) canary on Windows 7
Rayanna, could you check this on Mac . thanks!
Working fine with today's canary 22.0.1217.0 (Official Build 148295) canary on Mac 10.7.4.

Comment 37 by kareng@google.com, Jul 25 2012

Labels: Merge-Merged merge-merged-1180
http://trac.webkit.org/changeset/123495 

i committed to m21 
URL: https://chromiumcodereview.appspot.com/10821032
Committed revision 123677

pls confirm the merge was ok and I'll close the bug. ty! :)
Cc: -alek...@chromium.org

Comment 39 by kareng@google.com, Jul 26 2012

Status: Fixed
when will i see the fix in my chrome.
Tested this issue with 21.0.1180.56 (Official Build 148472) on Win7, MAC 10.7 and Linux 10.0 and it is working fine. 

I am able to Drag and Drop the videos to respective locations.
Draganddrop.swf
2.2 MB Download
Cc: rponnada@chromium.org
Project Member

Comment 44 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 45 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Mstone-21 Type-Bug-Regression Cr-UI M-21
Project Member

Comment 46 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment