New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 136958 link

Starred by 3 users

Issue metadata

Status: Verified
Owner:
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Calendar picker for <input type=date> is garbled in HiDPI

Project Member Reported by tkent@chromium.org, Jul 12 2012

Issue description

Chrome Version       : 22.0.1203.0
OS Version: OS X 10.7.4
URLs (if applicable) : data:text/html,<input type=date>
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: N/A
  Firefox 4.x: N/A
     IE 7/8/9: N/A

What steps will reproduce the problem?
1. Click on ▼ to open a calendar picker

What is the expected result?
Nice calendar picker is shown, and can operate it.

What happens instead?
Garbled calendar picker is shown.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/22.0.1203.0 Safari/537.1


 
スクリーンショット 2012-07-12 14.00.56.png
79.9 KB View Download

Comment 1 by tkent@chromium.org, Jul 24 2012

Labels: WebKit-ID-92177
Owner: kevers@chromium.org
Status: Assigned
Project Member

Comment 2 by bugdroid1@chromium.org, Jul 25 2012

Labels: -WebKit-ID-92177 WebKit-ID-92177-NEW
https://bugs.webkit.org/show_bug.cgi?id=92177
Project Member

Comment 3 by bugdroid1@chromium.org, Jul 25 2012

Labels: -WebKit-ID-92177-NEW WebKit-ID-92177-RESOLVED WebKit-Rev-123619
https://bugs.webkit.org/show_bug.cgi?id=92177
http://trac.webkit.org/changeset/123619

Comment 4 by kevers@chromium.org, Jul 25 2012

Labels: Mstone-22
Status: Fixed

Comment 5 by kevers@chromium.org, Jul 25 2012

Fix landed in ToT WebKit.

Comment 6 by girard@chromium.org, Jul 25 2012

Issue 138968 has been merged into this issue.

Comment 7 by thakis@chromium.org, Jul 25 2012

Cc: tkent@chromium.org thakis@chromium.org
Should we merge this to m21? Will m21 have date pickers? It looks like a very safe fix.

Comment 8 by kevers@chromium.org, Jul 25 2012

Don't believe we have high DPI devices in the field for M21.

Comment 9 by thakis@chromium.org, Jul 25 2012

Retina macs launched a couple weeks ago. If input type=date is active in m21, we should probably merge.

Comment 10 by tkent@chromium.org, Jul 26 2012

The calendar picker is available since M20.  I'll verify the fix on OS X HiDPI, and request to merge to M21.


Comment 11 by tkent@chromium.org, Jul 26 2012

Labels: -Mstone-22 Mstone-21 Merge-Requested
Verified the fix with http://commondatastorage.googleapis.com/chromium-browser-continuous/index.html?path=Mac/148447/

Comment 12 by kareng@google.com, Jul 26 2012

Labels: -Merge-Requested Merge-Approved

Comment 13 by tkent@chromium.org, Jul 26 2012

Labels: -Merge-Approved Merge-Merged
Merged to M21: http://trac.webkit.org/changeset/123707

Status: Verified
Verified fixed with 21.0.1180.57 on retina MBP using http://www.w3schools.com/html5/tryit.asp?filename=tryhtml5_input_type_date (from duped issue 138968)
Project Member

Comment 15 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 16 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -WebKit-Forms -Mstone-21 Cr-Content Cr-Content-Forms M-21
Project Member

Comment 17 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 18 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink
Project Member

Comment 19 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Forms Cr-Blink-Forms

Sign in to add a comment