New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 136864 link

Starred by 5 users

Issue metadata

Status: Verified
Owner:
Email to this user bounced
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux , Chrome
Pri: 1
Type: Bug-Regression

Blocking:
issue 127194

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Multiple options Disabled in the Certificate Manager

Project Member Reported by bmahadev@chromium.org, Jul 11 2012

Issue description

Chrome Version: 2585.0.0
Chrome OS Version: 22.0.1203.0
Chrome OS Platform: x86
Network info: <network, encryption type, router model (if known)>

Please specify Area-* of the system to which this bug/feature applies (add
the label below).

Steps To Reproduce:
1.Open Certificate Manger and select any cert

Expected Result:
Options to View, Edit, Export, Delete should be enabled.

Actual Result:
All of the above, except cert Import have been disabled

How frequently does this problem reproduce? (Always, sometimes, hard to
reproduce?)
Always

What is the impact to the user, and is there a workaround? If so, what is
it?
Can't work with certs

Please provide any additional information below. Attach a screen shot or
log if possible.
May be related to  issue #130396 

 
Status: Untriaged
screenshot1.png
291 KB View Download

Comment 2 by krisr@chromium.org, Jul 11 2012

Labels: -Area-Undefined Area-UI
Labels: -Type-Bug Type-Regression

Comment 4 by mattm@chromium.org, Jul 13 2012

Labels: OS-Linux Feature-Preferences
Owner: mattm@chromium.org
Status: Started

Comment 5 by mattm@chromium.org, Jul 13 2012

Labels: Mstone-22

Comment 6 by r...@chromium.org, Jul 13 2012

Cc: scr@chromium.org viralmodi@chromium.org saintlou@chromium.org csilv@chromium.org mattm@chromium.org
 Issue 130396  has been merged into this issue.
Labels: ReleaseBlock-Beta
Issue also seem with 2465.62.0,R21.
Cc: r...@chromium.org

Comment 9 by krisr@chromium.org, Jul 16 2012

Labels: Mstone-21
Project Member

Comment 10 by bugdroid1@chromium.org, Jul 16 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146920

------------------------------------------------------------------------
r146920 | mattm@chromium.org | Mon Jul 16 16:08:09 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/webui/options2/certificate_manager_browsertest.js?r1=146920&r2=146919&pathrev=146920
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/options2/certificate_tree.js?r1=146920&r2=146919&pathrev=146920
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/options2/certificate_manager.js?r1=146920&r2=146919&pathrev=146920

Fix certificate manager buttons never becoming clickable.

Add some simple tests.

BUG= 134519 , 136864 
TEST=open cert manager, select a cert, try to view/delete/etc

Review URL: https://chromiumcodereview.appspot.com/10700195
------------------------------------------------------------------------
Labels: -ReleaseBlock-Beta ReleaseBlock-Stable
Moved to releaseblock-stable as per email with zel

Comment 12 by kareng@google.com, Jul 18 2012

are these linux specific?

Comment 13 by kareng@google.com, Jul 18 2012

are these linux specific?

Comment 14 by r...@chromium.org, Jul 18 2012

At least on Linux and ChromeOS; not sure about other platforms.

Karen: This issue is probably present on all platforms that use Views (so that excludes Mac). Or have a native control (so that excludes Windows). I therefore expect that this would be true for both Linux and ChromeOS.
So it is not so much Linux specific, rather it is not present on Mac and Windows :-)

Comment 16 by kareng@google.com, Jul 19 2012

ok so how about we wait until Linux Dev goes out then and confirm this fix works. Or were you able to confirm on cros that the fix works?

Comment 17 by kareng@google.com, Jul 19 2012

Labels: -Mstone-22
Blocking: chromium:127194
Labels: Merge-Requested
the fix seems to be working on CrOS canary

Comment 20 by kareng@google.com, Jul 23 2012

Labels: -Merge-Requested Merge-Approved

Comment 21 by mattm@chromium.org, Jul 24 2012

I'm not sure my CL actually is needed for m21, but the one from the other bug that was duped with this one probably is.  I'm OOO at the moment so someone else should double check and do whichever merges are necessary.
Issue also seen with the latest R21 build which is 2465.96,21.0.1180.54.
Owner: gspencer@chromium.org
Assigning to myself for merging.
Project Member

Comment 24 by bugdroid1@chromium.org, Jul 24 2012

Labels: -Merge-Approved merge-merged-1180
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=148230

------------------------------------------------------------------------
r148230 | gspencer@chromium.org | 2012-07-24T22:34:56.579212Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/browser/resources/options2/certificate_manager.js?r1=148230&r2=148229&pathrev=148230
   M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/browser/resources/options2/certificate_tree.js?r1=148230&r2=148229&pathrev=148230

Merge 146920 - Fix certificate manager buttons never becoming clickable.

MERGE NOTE: This patch was merged manually, not using drover because
the original patch included a change to the matching browser test that
didn't exist when M21 was branched.  The patch is otherwise unchanged.

Add some simple tests.

TBR=mattm@chromium.org
BUG= 134519 , 136864 
TEST=open cert manager, select a cert, try to view/delete/etc
Review URL: https://chromiumcodereview.appspot.com/10808114
------------------------------------------------------------------------
Status: Fixed
Cc: -mattm@chromium.org gspencer@chromium.org
Owner: mattm@chromium.org
Not able to test this bug as the certificate file is not imported properly.

gspencer-cert.pem
2.5 KB View Download
Sorry, that was the wrong kind of file to test.  You need a .p12 file to test client certificates.

Use the attached certificate with the password "tomten;"
gspencer.p12
1.6 KB Download
Status: Assigned
We tested this on R21 build 2465.97.0 with build 21.0.1180.55 and we see that the buttons are enabled, but we still can't delete the installed certificates ( issue #130396 )
OK, I just tried this too.  Two things: 1) ignore the password I put in above, there's no password on the supplied .p12 file (just hit "OK" when asked), and 2) After import, it is indeed not possible to delete the certificate.  The console prints:

[16149:16149:191427402834:ERROR:CONSOLE(1538)] "Uncaught TypeError: Cannot read property 'pageDiv' of undefined", source: chrome://settings-frame/options_bundle.js (1538)

Every time delete is attempted.  This works on ToT.
Rahul says he already fixed it on ToT: http://codereview.chromium.org/10680010

So we probably just need to merge that change to M21...
Labels: -merge-merged-1180 Merge-Requested
Owner: gspencer@chromium.org
I'm going to go ahead and take this back and request a merge for Rahul's fix:

http://src.chromium.org/viewvc/chrome?view=rev&revision=144536

It's been on ToT since Jun 27, and is a very limited change (only affects web UI on ChromeOS).

Comment 33 by kareng@google.com, Jul 30 2012

can someone confirm it's fixed? happy to merge if it is.
Yes, it's fixed.

Comment 35 by kareng@google.com, Jul 30 2012

Labels: -Merge-Requested Merge-Approved
Labels: -Merge-Approved merge-merged-1180
Status: Fixed
Merged to M21 (1180) in CL https://chromiumcodereview.appspot.com/10830075
and svn revision: https://src.chromium.org/viewvc/chrome?view=rev&revision=149046
Status: Verified
Verified that all the cert options are enabled and certificate deletion works.
Tested on 2465.105.0,R21.
Project Member

Comment 38 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 39 by laforge@google.com, Oct 17 2012

Labels: -Feature-Preferences Feature-Settings MovedToSettings
Project Member

Comment 40 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Mstone-21 -Feature-Settings Type-Bug-Regression Cr-UI-Settings Cr-UI M-21
Project Member

Comment 41 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment