New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 135342 link

Starred by 75 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

"Your Profile Could not be opened correctly" (due to AVG antivirus; see comment 74)

Reported by f3nc3p...@gmail.com, Jun 30 2012

Issue description

Chrome Version       : 20.0.1132.47
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 4.x: OK
     IE 7/8/9: OK

What steps will reproduce the problem?
1. Shows the message "Your profile could not be opened correctly" Everytime i load google chrome
2.
3.

What is the expected result?
Shows the windows everytime i load google chrome didn't do it before i updated, Uninstalled an reinstalled and tried the Chrome Beta which brings the same result

What happens instead?


Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11



 
Untitled.jpg
30.8 KB View Download
 Issue 135395  has been merged into this issue.
Cc: vivianz@chromium.org anan...@chromium.org jeffreyc@google.com
Labels: Feature-Profiles Hotlist-ConOps
Users are reporting in the Chrome help forum that after updating to Stable (20.0.1132.47), they encounter a corrupt profile error. See screenshot above by original poster. 

Some users have mentioned that creating a new browser user profile resolves the issue (albeit temporarily), and they are able to close and restart Chrome without the error message. 
However, after a restart of the computer, the error message occurs again. 

The workaround above seems to works while the computer is not restarted.

Reference: https://productforums.google.com/forum/#!topic/chrome/qMxWTALeZIQ
https://productforums.google.com/forum/#!topic/chrome/K8HtZ6Xg0Y4
Labels: -Area-Undefined Area-Internals Action-FeedbackNeeded
I'm not able to reproduce this issue on my win vista box, tested update from M19 build to 20.0.1132.47 and from 20.0.1132.28 to 47. I saw this error message before when I try to uninstall chrome while some files in Chrome program directory still in use. and when I reinstall newer version of Chrome again, I will get this message in my Windows Vista. I was not able to delete the old default profile directory, have to  restart computer in order to delete it and start fresh.

this could be a different issue though.

@f3nc3po5t

do you know your previous Chrome version before you update to stable build 20.0.1132.47?

thanks for your feedback!
No I don't.  I didn't even know there was an update. Also, this does not
happen when I sign in using another laptop. I just tried it before sending
this email.

Tina Boyd
mrstinaboyd@gmail.com
(936) 931-7470
Cc: jayakrishnat@chromium.org joycel@chromium.org arsids@chromium.org mnarula@chromium.org ranavdk@chromium.org nikhilalm@chromium.org dpete@chromium.org vandanashah@chromium.org
Version: 20.0.1132.47
750+ users have reported this issue in 'GoogleFeedback' in last two days.

For more details, refer the report URLs below:
http://goto.google.com/332806748
http://goto.google.com/328504461
http://goto.google.com/334272531
http://goto.google.com/332154760
http://goto.google.com/333315059

For more user reports, refer the cluster URL below:
http://goto.google.com/1015824

Additional Information:
75% (550+) of the reports are from Windows Vista and remaining are from Windows XP.
Few users have tried reinstalling Chrome, but the problem still persists. Majority of the reports are from locales EN (350+), PT-BR (50+) and ES (50+).
Labels: GoogleFeedback

Comment 7 by dhasd...@yahoo.com, Jul 2 2012

It's early to be certain, and I am not one of life's optimists where computers are concerned, but the problem seems to have gone away. I had it on both desktop and laptop (which updated an infected itself when I tried to check the version of Chrome), both Windows 7, and tried the suggested fixes, including a reinstall, on the desktop only but with no luck. Now both seem to run Google Chrome ok, if a little bit more slowly.

dhasdell
Attached small window opens every time I open Chrome. I have to close this window before I use the browser normally. And my Profile then seems to work normally. Only different thing I did today was a rare update of my profile.
google.PNG
17.9 KB View Download
Labels: -Pri-2 Pri-1 Mstone-20
Bumping to P1 given the volume that we have received from users in the Chrome Help Forum, and Google Feedback. 

Comment 10 by kareng@google.com, Jul 2 2012

we think it might likely be http://code.google.com/p/chromium/issues/detail?id=127607 which is fixed just not pushed out yet.

Comment 11 Deleted

Thanks for everyone's comments and help glad I'm not the only one
Labels: Action-BisectNeeded
Owner: rlp@chromium.org
Status: Assigned
The change mentioned in  bug 127607  is already part of M20. This issue might be different or the fix isn't working. Assigning to rlp@ for now.
Labels: -Action-FeedbackNeeded
bisect is not possible at this point since we have not been able to reproduce the issue yet.

Comment 15 by Deleted ...@, Jul 2 2012

I also get this same message every time i start Google chrome, started about 2 days ago if there is a fix please email me thanks.

The problem occurs when Chrome is updated from v 19.0.1084.56 TO v 20.0.1132.47 which occurred on July 1, 2012.

Something IN v 20.0.1132.47 is corrupting the profile data.


This is what I HATE about Chrome automatically updating itself without giving the user the option to NOT update ...

Comment 17 by Deleted ...@, Jul 3 2012

Have been running Chrome v 20.0.1132.47 since May 2010, recent update occurred on 28 June, app folder from Start>Run>%userprofile%\AppData\Local\Google\Chrome\Application showing 'old chrome' from the 28th, when error began. Originally, was only receiving error when using pinned task bar icon or desktop shortcut icon, now receiving through primary Google application folder through Windows applications/program menu.  Screenshot attached showing permissions coding error.  Have additionally unpinned task bar icon and desktop icon without resolving issue.  Have also rebooted without resolution. Only receiving read and write permissions error.  Am able to click OK and continue through using Win 7 64-bit SP1 and regularly navigate Chrome (using it now), auto-fill working, sites resolving, history clearing, able to modify extensions.  Error message does not seem to actually indicate coding perms are truly failing.
ChromeError.jpg
94.2 KB View Download
I was afraid I was being too optimistic. It's started doing it again!

dhasdell
Comment 8 describes my experience exactly. (My 'workaround' is to minimize Chrome while not in use.)
Cc: bauerb@chromium.org
In one of the other forum it says this problem will be solved with the next update for Google Chrome. When can we expect this to happen?
Could someone run Chrome with logging enabled (see http://www.chromium.org/for-testers/enable-logging) and paste the last couple of lines of log output? Thanks!
Re comment 22 - have done that... now where does the log output appear to mail to you?
All that is a little to technical for me.

Tina Boyd
mrstinaboyd@gmail.com
(936) 931-7470
On Windows, it should appear in a file called chrome_debug.log in your User Data directory (i.e. the one above the profile directory; see http://dev.chromium.org/user-experience/user-data-directory).
I forgot to mention that I removed Ad Blocker right before this started
because it was blocking frequently used websites.

Tina Boyd
mrstinaboyd@gmail.com
(936) 931-7470
Answer to comment 25/bauerb: Sorry - I can't find, perthaps it failed to create log file, BUT I'm operating out of my normal depth here. Will try once more.  
Think I've found file, bauberb.... sorry if not exact lines, but might make sense to you!
chrome_debug.log
302 KB View Download
Cc: pkasting@chromium.org rlp@chromium.org
Owner: ivankr@chromium.org
Thanks, that's very helpful! 

For those following at home, the interesting lines from the log file are:

[6440:4600:15970134:ERROR:keyword_table.cc(430)] Can't get keywords backup data
[6440:4600:15970134:ERROR:keyword_table.cc(479)] Failed to create keywords_backup table.
[6440:4600:15970134:WARNING:web_database.cc(45)] Unable to update web database to version 44.
[6440:4600:15970134:ERROR:web_data_service.cc(646)] Cannot initialize the web database: 1

The fact that we can't update the web database to version 44 and the error in keyword_table point to http://crrev.com/125423 and related commits. Ivan, I believe those were yours? Peter also might know stuff.
I am having the same problem and not very technologically proficient! Should the problem go away when fixed centrally or is there something users must do to fix the browser? 
It would be very helpful if someone experiencing this problem could attach the Web Data file in the profile directory.

The failure in ERROR:keyword_table.cc(479) means the CREATE TABLE keywords_backup AS SELECT ... FROM keywords ... query fails. keywords_backup is dropped right before, so this means the fields in keywords table don't match the query.
I looked at a Web Data file, and it seems that the "autogenerate_keyword" and "logo_id" columns in the table are missing from the schema, but are referenced in |kKeywordColumnsVersion44|. http://crrev.com/136402 removed those.
What's the table version number set to?  I'm wondering if this could be from running the profile on a newer Chrome version and then going back to an older one (although I thought that should have left the version number at 45).
sqlite> select * from meta;
version|40
last_compatible_version|45
Default Search Provider ID|2
Builtin Keyword Version|39
Default Search Provider ID Backup|2
Default Search Provider ID Backup Signature|

Comment 35 by Deleted ...@, Jul 3 2012

Ao clicar no navegador uma mensagem aparece: "Seu perfil não pode ser aberto corretamente. Alguns recursos podem não estar disponíveis. Verifique se o perfil existe e se você tem permissão para ler e escrever seu conteúdo." O meu SO é Windows 7, a versão atual é 20.0.1132.47. Já desinstalei e reinstalei , mas não resolveu, a mensagem some a princípio e volta novamente ao reiniciar. Aguardo uma solução. Meu e-mail é: costta2@gmail.com
-Grato.  
After peering around some at the code I have no idea how that could happen.  None of (trunk, 1132, 1084) should be able to set the version number to 40 but leave the compatible version at 45 in any circumstance.

We could write some sort of special-case code that assumes that the version number should be the max of (version, compatible version), but without understanding how this could have happened in the first place, I worry about that.

For users who can repro this problem after creating a new profile and then doing some restarts, I'd really love to see copies of this file in all those stages (i.e. after creating the new profile, and then after restarting and seeing problems).
I also get the error your profile could not be opened correctly and it started two 
days ago. Looks like Google Chrome updated on July 1 which is when it started, can someone tell me if this is going to be corrected and does it have a bad effect on the computer???I don't want to stop using Google Chrome but this is very annoying .....

Re comment 33: I only went back to older version of Chrome briefly to find if fault still occurred - it did - made no difference. - Tony
So what do we do about the error? Is this going to be corrected:
I've posted three times over the last 2 days and tried all the self fix ideas. My operating system is windows7 same small window pops up...please could the professionals fix this problem.

Comment 41 by Deleted ...@, Jul 3 2012

I fixed it on my computer by following these instructions:

Exit Google Chrome completely.

Go to the Start menu > Run.

Enter one of the following directories in the text field, then press OK.
Windows XP: %USERPROFILE%\Local Settings\Application Data\Google\Chrome\User Data\
Windows Vista/ Windows 7: %LOCALAPPDATA%\Google\Chrome\User Data\

Locate the folder called "Default" in the directory window that opens and rename it as "Backup default."

Try opening Google Chrome again. A new "Default" folder is automatically created as you start using the browser.

If you wish, you can transfer information from your old user profile to your new one. However, this action is not recommended, since a part of your old profile was corrupt. With that in mind, to transfer your old bookmarks, copy the "Bookmarks.bak" file from the "Backup default" folder to your new "Default" folder. Once moved, rename the file from "Bookmarks.bak" to "Bookmarks" to complete the migration.

Comment 42 by na5...@gmail.com, Jul 3 2012

I've tried your suggestion misty.kr but didn't work for me. Also tried deleting the 'web data' file but that didn't work either. I'm using windows xp.
Hope they fix this soon, or Google are going to loose an awful lot of users back to internet explorer.

Comment 43 Deleted

I have already done that went in and renamed the file as Backup default and
once
I got off the computer and shut it off and came back on it was doing it
again...
have you fixed your computer, or do we have to wait until Google Chrome is
corrected?? I am not a computer person and all of this I don't understand...
I just don't want something to go wrong with my computer.....

Judy

Comment 45 by Deleted ...@, Jul 3 2012

I am experiencing the same issue with the message.I attempted going to a restore point prior to when the message began with no luck. I dont remember doing anything unusual and I attempted to uninstall then reinstall chrome and still got the message only now my chrome wont load at all it just has a blank screen. If i attempt to click on the wrench icon and choose any of the items listed. it give me a blank screen also.I am using Windows 7
I did try the system restore, to no avail. It only started happening for me
this morning. I haven't loaded any new software, programs, drivers or
anything. It must be something taking place on Google's end. I saw where
someone tried uninstalling chrome and then reinstalling - that didn't work
for them either. I think I'll just use a different browser until Google
fixes the problem or notified us all of a fix.
From what I have read Google Chrome did an update on there program
on July 1st and that is when my issue started...It seems awful funny
that you cannot reinstall Chrome unless they are working on the
problem and don't want anymore people getting on until it is corrected..
It has to be on there side that this started, but not being a computer
person it makes me nervous that I get this error. I did to both of the
things people suggested and renamed the file and also went in and
deleted the web data file..Did not make a bit of a difference the only
thing was when I renamed the file the first time it worked until I shut
off my computer last night and came back on today...You would think
Chrome would be sending out a message that they are working on it...
Judy
I also have windows 7, but it seems like some are still using XP
Judy
rosebud.963, we are working on it.
Labels: Restrict-AddIssueComment-Commit
Note that you have to shut down Chrome completely (as in, use Task Manager to make sure there are no running chrome.exe processes) before touching anything in your profile, and leave it off until you've made your changes.  Otherwise those changes may have no effect.

If nuking the Web Data file (or the whole profile) while Chrome is completely shut down does not fix your problem, then please nuke it again, restart Chrome, copy the Web Data file it creates to somewhere else, restart again (or whatever other steps are needed) until the problem reproduces, copy the Web Data file out again, and send me an email with both copies attached, your precise version string from about:version, and the exact list of steps you took between the two copies.

Temporarily closing comments so people see this message and follow it rather than posting more "this is also happening to me" or "when is this fix coming" posts (which don't help us fix).

Comment 51 by szym@chromium.org, Jul 5 2012

 Issue 135375  has been merged into this issue.

Comment 52 by szym@chromium.org, Jul 5 2012

 Issue 135471  has been merged into this issue.

Comment 53 by szym@chromium.org, Jul 5 2012

 Issue 135594  has been merged into this issue.

Comment 54 by szym@chromium.org, Jul 5 2012

 Issue 135696  has been merged into this issue.

Comment 55 by szym@chromium.org, Jul 5 2012

 Issue 136025  has been merged into this issue.

Comment 56 by szym@chromium.org, Jul 5 2012

 Issue 136030  has been merged into this issue.

Comment 57 by szym@chromium.org, Jul 5 2012

 Issue 136031  has been merged into this issue.

Comment 58 by szym@chromium.org, Jul 5 2012

 Issue 135617  has been merged into this issue.
Ivan, the interesting part about this is that if I compare a working profile from a brand new launch of Chrome to a broken profile once Chrome is restarted again (using data sent to me by users), there are only two differences in the Web Data meta table:

version is changed from 45 to 40
Default Search Provider ID Backup Signature is changed from a non-empty string to what looks like an empty string (or else is a string with just an embedded \0?  I'm not sure whether that's possible and how to definitively tell)

The code in keyword_table.cc avoids writing that second key with an empty string value, so if the string is really empty, I'm wondering how this can happen.  Could this be an external program manipulating things?
Yes, this definitely looks like a third-party software manipulation. 40 is the first version when protector was introduced, and there are examples of malware that try to circumvent protection by simply "downgrading" the database version. This would work until version 45, when the first non-protector change happened.

Comment 61 Deleted

One possible solution is to look at the database schema to determine the actual DB version, but that seems kind of hackish. Making the backup update non-fatal wouldn't help because the latter migration steps will fail anyway.
Labels: -Restrict-AddIssueComment-Commit
OK, reopening comments.

Does anyone experiencing this bug have an idea of something on your machine that might be doing this?  For example, any toolbars or search assistant software, or any times in the past when you've seen your default search engine changed away from your normal default to something else unexpectedly?

Ivan, I'm leaving it in your hands to work with the other protector folks to figure out what the correct response should be on the Chrome side to malware that does this.  The current effect is pretty deleterious :(
Silverlight just showed up on my machine again, somewhat out of the blue. 
This is happening on my parents computer, something I did notice is that AVG Free was updated, which replaced the default search engine in the omnibar to AVG google search (a legitimate one, so not malware pretending to be avg)

Apart from that, I'm not aware of any other changes that happened
Nice that you finally decided to open the comments. I suspect that AVG antivirus is  causing all this problems. One more weird thing: I solved this issue with the following steps:
I clicked delete profile in Settings, and chrome asked me to sync the new profile with gmail. I have never done that before. After entering password it showed two users as people using chrome. I don't know how and why this happend. I deleted this two, and a third user was created with the folder name 'profile3' instead of 'default'. I restarted the computer, and the issue is solved. There is no window with the error message.

Comment 67 by Deleted ...@, Jul 5 2012

This issue also began on my laptop after an AVG Free update
Summary: "Your Profile Could not be opened correctly" (due to AVG antivirus?)
Are there folks having these symptoms that do NOT have AVG antivirus?  (And if so, are there other things you've seen that fit the descriptions in comment 63?)
Installed and active: AVG Safe Search, IBA Opt-out, Send from Gmail,
Shortcuts for Google, StumbleUpon, Totemo, Wolf Toss, Google Voice, Google
Calendar, Orcs Attack,
Installed and Not Active: Arcade-Web, Ask Toolbar (There are warnings when
trying to install this extension: Permission 'chrome-internal://newtab/'is
unknown or URL pattern is malformed.), Disconnect, Edit This Cookie,
Facebook Disconnect, SiteAdvisor (There were warnings when trying to
install this extension: Permission 'chrome://*' is unknown or URL pattern
is malformed.), SweetIM for Facebook,
JUST NOW: Tried to go to Your Apps at the Chrome Store to see if there were
a list of Apps I had uninstalled but I am not able to view this page.
Chrome takes me to a sign in screen when I click on Your Apps and then
loops back to the sign in screen. No error, No wrong password or user name.

Tina Boyd
mrstinaboyd@gmail.com
(936) 931-7470
AVG - before reading recent comments I was wondering what outside programs could interact with my Chrome - and if any such program might be used by others experiencing this problem. I wondered about the map on profile (where I've lived) or the date-of birth which I'd just changed (I hate that and change it from 1 Jan to 31 Dec in all sorts of years) - but more seriously thought about AVG. I have that (free version) block various things via Chrome - my wife uses AVG and Chrome (and no profile) and doesn't currently have any problems. So, one more thought.
 
Comment #71 Worked for me. We no longer get the error.  The only problem I
had was seeing the folder AppData.  This must be a hidden file. When
searching in C: I searched for AppData and was able to follow the path
provided.

Thank you, Let me know if this is not a permanent fix.

Tina Boyd
mrstinaboyd@gmail.com
(936) 931-7470
Yes indead this is a bug of version 20.0.1132.47. Removing and reinstalling Chrome does not fix the problem. After rebooting, the message 
"Your profile could not be opened correctly" is back!
Solution:
The error is ALWAYS displayed when you use the Chrome "Default"-profile !!. 
If you create a new profile, e.g. "Profile 1", AND switch to profile 1, the messge is gone. That’s it - the bug is fixed for practical use. But if you switch back to "Default"-profile, the message is back. So use only the new created "Profile 1" !

If you want to know, how to create and switch between Chrome profiles, follow e.g. these links: 
"https://support.google.com/chrome/bin/answer.py?hl=en&answer=2364824"  or "http://geekitdown.com/blog/how-to-create-profiles-in-google-chrome/" .

In Windows 7 the location of the profile-folder is "C:\Users\User>\AppData\Local\Google\Chrome\User Data\Default". 
So you are able to import your (saved) bookmarks.  Copy the "Bookmarks" file from the "Default"-folder to your new "Profile 1"- folder.

Best luck.
Labels: Restrict-AddIssueComment-Commit
Summary: "Your Profile Could not be opened correctly" (due to AVG antivirus; see comment 74)
Comment 71 is the same thing I was asking people to do in comment 50.  It doesn't permanently solve the problem unless you've also uninstalled AVG.  See below.

@73: Uninstalling and reinstalling Chrome will almost never fix any problem of any kind, because if the problem is tied to profile data, reinstalling won't fix it.  I suspect the "rename your profile" workaround fixes things because AVG is hardcoded to try and modify the data inside a folder named "Default".

At this point it seems like the problem is almost certainly that AVG is acting like malware and directly manipulating people's Chrome profiles in an invalid way that breaks Chrome 20.  This is a scummy practice, and so I suggest uninstalling AVG and using a different security product, such as the free Microsoft Security Essentials.  Once that's done, nuking your Web Data file (or your entire Chrome profile) should eliminate the problem permanently.

Re-locking so this answer will be the most visible comment.  Ivan, over to you guys to figure out what else we can do here.  (Can we reach out to AVG and tell them to stop trying to do evil things to people's Chrome profiles?)
Cc: sky@chromium.org dpolukhin@chromium.org
Labels: Feature-Protector
Status: Started

Comment 77 by dhw@chromium.org, Jul 6 2012

 Issue 136106  has been merged into this issue.

Comment 78 by dhw@chromium.org, Jul 7 2012

 Issue 136183  has been merged into this issue.

Comment 79 by dhw@chromium.org, Jul 7 2012

 Issue 136216  has been merged into this issue.
Submitting a hotfix that will force database version to max(version, compatible version) prior to migration. This should fix the issue with AVG (as they leave compatible version with old value, which is 45).

As suggested by Peter, we might want to add a help topic about profile corruption and third-party software, and link to it in the error dialog.

Project Member

Comment 81 by bugdroid1@chromium.org, Jul 9 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145665

------------------------------------------------------------------------
r145665 | ivankr@chromium.org | Mon Jul 09 07:36:31 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/webdata/web_database.cc?r1=145665&r2=145664&pathrev=145665
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/webdata/web_database_migration_unittest.cc?r1=145665&r2=145664&pathrev=145665
 A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/data/web_database/version_45_compatible.sql?r1=145665&r2=145664&pathrev=145665 (from /trunk/src/chrome/test/data/web_database/version_45.sql revision 145664)

Force WebDatabase version to max(version, compatible version) before migration.


BUG= 135342 
TEST=WebDatabaseMigrationTest.*


Review URL: https://chromiumcodereview.appspot.com/10696127
------------------------------------------------------------------------
Cc: willhsiao@chromium.org
Adding Will who can help with the help article, per comment #80, if we decide to go with it. Let us know if it's decided, and we can proceed with drafting it up.
Ivan, can you also get this merged to M20 and M21?
Labels: Merge-Requested
Labels: -Merge-Requested Merge-Approved
Please merge it in 1132 branch.
Labels: -Merge-Approved Merge-Merged
Project Member

Comment 87 by bugdroid1@chromium.org, Jul 9 2012

Labels: merge-merged-1132
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145730

------------------------------------------------------------------------
r145730 | ivankr@chromium.org | Mon Jul 09 12:59:22 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1132/src/chrome/browser/webdata/web_database.cc?r1=145730&r2=145729&pathrev=145730

Merge 145665 - Force WebDatabase version to max(version, compatible version) before migration.


BUG= 135342 
TEST=WebDatabaseMigrationTest.*


Review URL: https://chromiumcodereview.appspot.com/10696127

TBR=ivankr@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10754005
------------------------------------------------------------------------
Project Member

Comment 88 by bugdroid1@chromium.org, Jul 9 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145792

------------------------------------------------------------------------
r145792 | ivankr@chromium.org | Mon Jul 09 16:41:38 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/webdata/web_database.cc?r1=145792&r2=145791&pathrev=145792

Fix incomplete WebDatabase migration from downgraded version.


BUG= 135342 
TEST=WebDatabaseMigrationTest.*


Review URL: https://chromiumcodereview.appspot.com/10754006
------------------------------------------------------------------------
Project Member

Comment 89 by bugdroid1@chromium.org, Jul 10 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145848

------------------------------------------------------------------------
r145848 | ivankr@chromium.org | Tue Jul 10 00:50:42 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1132/src/chrome/browser/webdata/web_database.cc?r1=145848&r2=145847&pathrev=145848

Merge 145792 - Fix incomplete WebDatabase migration from downgraded version.


BUG= 135342 
TEST=WebDatabaseMigrationTest.*


Review URL: https://chromiumcodereview.appspot.com/10754006

TBR=ivankr@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10693124
------------------------------------------------------------------------

Comment 90 by dhw@chromium.org, Jul 10 2012

 Issue 136409  has been merged into this issue.
Status: Fixed
Marking fixed, as users in the help forum have confirmed this is fixed in 20.0.1132.57

Comment 92 by dhw@chromium.org, Jul 14 2012

 Issue 136130  has been merged into this issue.

Comment 93 by dhw@chromium.org, Jul 14 2012

 Issue 136237  has been merged into this issue.
Project Member

Comment 94 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Action-BisectNeeded Needs-Bisect
Project Member

Comment 95 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Profiles -Mstone-20 -Feature-Protector Cr-Internals M-20 Cr-UI-Browser-Profiles Cr-UI-Browser-Preferences-Protector
Project Member

Comment 96 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Comment 97 by laforge@google.com, Jul 24 2013

Cc: -jeffreyc@google.com

Sign in to add a comment