New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 9 users

Issue metadata

Status: Duplicate
Merged: issue 152893
Owner:
User never visited
Closed: Jan 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 135326: Header and footer partly cut-off when printing

Reported by mow...@gmail.com, Jun 30 2012

Issue description

Chrome Version       : 20.0.1132.47
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) : Any
Other browsers tested:
     Safari 5: Not Tested
   Firefox 14: OK
         IE 9: OK

What steps will reproduce the problem?
1. Print a web page from Chrome, leaving header and footer enabled

What is the expected result?
1. Header and footer are complete on printed page(es)

What happens instead?
1. Header and footer are partially cut-off on left and right

The preview shows the expected result, only the final printed page has the header and footer cut-off.  Attached to this message are:
save_as_pdf.pdf - Printed using Save as PDF
real_printed_page.pdf - A scan of a printed page

Windows 7 x64 SP1
Brother HL-2280DW - Firmware G, Driver B1, Network Printer

UserAgentString: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11
 
real_printed_page.pdf
19.0 KB Download
save_as_pdf.pdf
50.9 KB Download

Comment 1 by julian.h...@gmail.com, Jun 30 2012

Unable to reproduce on 22.0.1190.0 Canary on Windows 7 Ultimate with a networked Samsung CLP-510 series. Is this a regression (ie it used to work properly but doesn't in a recent version) or has it always been an issue?

Comment 2 by mow...@gmail.com, Jul 1 2012

This has always been an issue.  Occurred with driver version A1 for the printer as well.

Comment 3 by tkent@chromium.org, Jul 4 2012

Labels: Feature-Printing

Comment 4 by thestig@chromium.org, Jul 10 2012

You can try Chrome Canary and see if behaves better there.

Is print scaling turned on in the printer preferences?

Comment 5 by mow...@gmail.com, Jul 10 2012

The above report is for Print Scaling: Off

Stable Channel: When I set Page Scaling: Fit to Paper Size "Letter", the results are the same.

Canary: The footer is not even at the bottom of the page, it is too high and shifted left (like the whole page is detected to be shifted northwest). The results are the same with page scaling on and off.  See attachment.

I was careful to restart the browser after each default printer setting change.  Without the browser restart, the header and footer sometimes didn't even print.
canary.pdf
15.7 KB Download

Comment 6 by bugdroid1@chromium.org, Aug 10 2012

Project Member
Labels: Action-NeedsReview
There were at least 5 stars on this issue, in the last 90 days, we should review.

Comment 7 by mow...@gmail.com, Aug 10 2012

I understand this can be difficult to test without hardware on hand (HL-2280DW and possibly others?).  PLEASE let me know if I can be of assistance in testing; I am still paying attention to this issue.

Comment 8 by byron.jo...@shawinc.com, Aug 13 2012

Having same problem as well.  I can provide scanned images of printed files if needed.

Comment 9 by abodenha@chromium.org, Aug 14 2012

Labels: -Area-Undefined Area-UI
Thanks for the offers of help folks.  Images of how it's getting cut off would be very helpful.  Our best guess so far is that the margin info we're getting from Windows doesn't match what the printer can actually do.

Comment 10 by byron.jo...@shawinc.com, Aug 14 2012

I have attached a scan of a printed page that shows the issue (truncated
areas circled in red)

Comment 11 by abodenha@chromium.org, Aug 17 2012

It doesn't look like the file attached to the bug Byron.  Can you email it to me directly at abodenha@chromium.org?

Comment 12 by abodenha@chromium.org, Aug 17 2012

Owner: abodenha@chromium.org
Status: Assigned

Comment 13 by mow...@gmail.com, Aug 18 2012

Here's a new round of page scans:
Chrome Stable 21.0.1180.79
Canary 23.0.1238.0
Both printouts are with Page Scaling Off.

Also included are screenshots of the print dialog which shows the header and footer properly.

Canary's print dialog was a bit buggy: unchecking then checking the "Headers and Footers" option didn't always bring all of the headers and footers back. Sometimes the url or date would be missing, for instance.
23Canary-Dialog.png
49.4 KB View Download
Canary-23.0.1238.0.pdf
20.6 KB Download
21Stable-Dialog.png
41.3 KB View Download
Stable-21.0.1180.79.pdf
22.2 KB Download

Comment 14 by dwhitevi...@gmail.com, Aug 31 2012

It's not just Windows. My Mac does the same thing printing to a Brother MFC-7820N printer.

Comment 15 by abodenha@chromium.org, Sep 4 2012

Owner: gene@chromium.org
Assigning to gene since he's working on a change that might fix this.

Comment 16 by lawte...@gmail.com, Sep 9 2012

There seems to be a change to the Header between 17 Aug 2012 and 9 Sep 2012.
It was working nicely when I printed on the 17 Aug 2012 (see screenshot Printout_17Aug2012.jpg).

When I tried to print the same page on the 9 Sep 2012, the Header has shifted left and got truncated as well as overlayed with the date. (see screenshot Printout_9Sept2012.jpg)

Wonder if default margin settings as well as Header Footer settings can be saved as a CSS style sheet in one of the Chrome directory so that we can modify them ourselves?

That would help those who wants to persist the margin setting between browser sessions as well as other "heavy users" to tweak the print out accordingly.

If that is done, I would hope that there is a "Reset to Default" button to restore thing to norm if the user messes things up beyond repair.
Printout_17Aug2012.JPG
19.8 KB View Download
Printout_9Sep2012.JPG
20.1 KB View Download

Comment 17 by calor...@gmail.com, Jan 9 2013

Having the exact same issue with Windows XP and an HP DeskJet 810C using Chrome 23.0.1271.97 m. Although I'm not seeing a footer at all for some reason, even though it shows up in the preview.

Comment 18 by vitalyb...@chromium.org, Jan 9 2013

Mergedinto: 152893
Status: Duplicate
Please try https://www.google.com/intl/en/chrome/browser/canary.html and file new bugs if it still does not work.

Comment 19 by calor...@gmail.com, Jan 10 2013

Canary fixes the cut-off-on-left issue, but the footer is still not printing for me.

Comment 20 by vitalyb...@chromium.org, Jan 10 2013

Do you see footer in print preview?
Can you try to set margins to "custom" and increase bottom margin (with Canary) ?

Comment 21 by calor...@gmail.com, Jan 10 2013

I can see the footer in print preview.
I set the bottom margin to 1" and the footer still does not show up (although the bottom margin is indeed bigger).

Comment 22 by vitalyb...@chromium.org, Jan 11 2013

Can you please do the following:
1. measure actual paper size (width and height) and report here
2. Open print preview
3. Right click on preview and select "inspect element"
4. you should see something like:
<embed id="pdf-viewer" class="preview-area-plugin" type="application/x-google-chrome-print-preview-pdf" src="chrome://print/1/0/print.pdf" aria-live="polite" aria-atomic="true">
5. Right click on chrome://print/1/0/print.pdf and open in new tab
6. Safe PDF and attach here

Comment 23 by byron.jo...@shawinc.com, Jan 14 2013

When I first encountered this, my only problem was header/footer being truncated.  Now I am also getting some kind of irregular font conversion in the header/footer as well.  Example is attached.
print.pdf
213 KB Download

Comment 24 by vitalyb...@chromium.org, Jan 14 2013

Please file new bug with more details, including versions and locales of Chrome and OS.

Comment 25 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-UI -Feature-Printing Cr-Internals-Printing Cr-UI

Sign in to add a comment