New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 134959 link

Starred by 8 users

Issue metadata

Status: Verified
Owner:
Last visit 26 days ago
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 1
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Legitimate Pop Up is blocked when Pepper Flash is used

Project Member Reported by progame@chromium.org, Jun 28 2012

Issue description

Version: 21.0.1180.11 (Official Build 143993) dev-m
OS: Windows 7

What steps will reproduce the problem?
0. Use Pepper Flash
1. Enter http://www.ynetnews.com/ (its Hebrew version is one of the most popular sites in Israel)
2. Click one of the titles in the scrolling news (below the word Updates)
3. The news item will be blocked from showing by the popup blocker


Works fine if I disable the Pepper Flash plugin.

This was an issue up until a few years ago... I don't remember/know if it was a change in Ynet or in Chrome that fixed it. It returned now with the move to Pepper Flash
 
Cc: jochen@chromium.org
Labels: -Pri-2 Pri-1 ReleaseBlock-Stable Mstone-21 Feature-Plugins-Pepper
Status: Available
Functionality broken on large site, marking as M21 blocker.

Jochen: cc-ing you since I seem to remember you recently made a change to the popup blocker, guessing this is unrelated - but on the off-chance that it is.
sorry, no idea

My guess would be that the user-action information is lost somewhere. The pop-up blocker mainly works by disallowing popups outside of user actions

Comment 3 by kareng@google.com, Jul 9 2012

Owner: yzshen@chromium.org
Status: Assigned
I will look into it. Thanks!
Project Member

Comment 5 by bugdroid1@chromium.org, Jul 10 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145992

------------------------------------------------------------------------
r145992 | yzshen@chromium.org | Tue Jul 10 16:41:40 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/plugins/ppapi/ppb_var_deprecated_impl.cc?r1=145992&r2=145991&pathrev=145992

Fix user gesture for scripting calls from Pepper plugins.

BUG= 134959 
TEST=None


Review URL: https://chromiumcodereview.appspot.com/10693130
------------------------------------------------------------------------
Status: Started

Comment 7 by kareng@google.com, Jul 11 2012

did this make canary?

Comment 8 by yzshen@chromium.org, Jul 11 2012

Labels: Merge-Requested
Yes, it made 1203.

Comment 9 by prog...@gmail.com, Jul 11 2012

surprisingly my test shows intermittent result: sometimes the popup (described above) in ynetnews.com is blocked and sometimes it can pass

couldn't find a pattern to it, when the first click is blocked a second click on the same title might pass
I haven't met this issue. Are you using 1203 canary?
Could you give me more detailed repro steps?
Thanks!

Comment 11 by prog...@gmail.com, Jul 11 2012

yes i conducted the test using
Google Chrome	22.0.1203.0 (Official Build 146062) canary
OS	Windows XP
WebKit	537.1 (@122287)
JavaScript	V8 3.12.10
Flash	11.3.31.217

since it's intermittent, repro steps is a bit of a problem
but in general i launched canary build with ynetnews.com and tried to click on a few scrolling titles (around 3), closed canary and tried again.
Not sure but it's possible i had more chances to see a blocked popup after clearing the cache.
...probably not because now i was able to see this when clicking on the same title over and over again (hitting Ctrl+W when a popup did appear).

Comment 12 by prog...@gmail.com, Jul 11 2012

a complete guess: maybe it's just about some busy thread/weak CPU, causing a delay that makes the algorithm think the popup isn't user initiated.

i confirmed again that using the dev build it was always blocked and that without pepper flash it can always pass (as far as i can tell)
Thanks!

After I Ctrl+W to close the popup, if I don't move the cursor, I will need to click twice: first seems to get the focus onto that page, and then the second will trigger the popup.

Is that what you saw?

If the popup is blocked, you will see an icon at the right side of the address bar. In this case, I won't see the icon.

This is probably not a bug related to user gesture detection. It might be a separate issue.

Thanks!
Clarification to comment #13:

"After I Ctrl+W to close the popup, if I don't move the cursor," should be:
"After I click to open the popup, make sure the cursor is not moved, use Ctrl+W to close the popup"

Comment 15 by prog...@gmail.com, Jul 11 2012

hmmm not exactly, i think you are right about some of my Ctrl+W tests being no good
i probably saw an old popup blocked icon and assumed that it's related to the popup not appearing... but that old popup blocked icon was there from a previous successful test.

also, i saw this more than a few times in the first try (making the popup blocked animation appear) by following the steps i described before the CTRL+W sentence, where i clicked on 3 different titles.
tested on Chrome 22.0.1203.0, with the fix sometime the popup will show, but out of 7 try, it was still blocked 2 times, and the last time render crashed. did not enable crash report at the time. will try again to reproduce the crash.
popup_block.png
605 KB View Download

Comment 18 by prog...@gmail.com, Jul 11 2012

Thanks vivian!
(it's 2am here and i really wanted to go to sleep, but couldn't leave this issue this way with only me hallucinating the problem ;) )

btw, my current "strategy" is loading ynetnews.com, click on the first title, if not blocked, close it using the mouse, if needed hover the scrolling news for a bit to make it scroll again, try the second title...
Thanks, Yair and Vivian! :)
Now that you observed the same problem, I will continue investigating and fix it.
np:)

btw, the crash is likely not related to this issue, I can not reproduce it anymore

but I can reproduce the popup block issue pretty consistent now with the following repro steps:

1. load ynetnews.com
2. at the live update news scroll screen, click a news item
3. hover over click next news item to trigger scrolling again
4.repeat step 2-3 three times

it always happen at the third try for me.
Project Member

Comment 21 by bugdroid1@chromium.org, Jul 13 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146513

------------------------------------------------------------------------
r146513 | yzshen@chromium.org | Thu Jul 12 20:27:52 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/plugins/ppapi/ppapi_plugin_instance.cc?r1=146513&r2=146512&pathrev=146513

Don't close pending user gesture when PluginInstance receives ACKs for input events.

Because plugins might respond to input events asynchronously. We just wait until kUserGestureDurationInSeconds expires.

BUG= 134959 
TEST=None


Review URL: https://chromiumcodereview.appspot.com/10736062
------------------------------------------------------------------------
Works great using the latest canary build (under Windows XP), Thanks :)

The tested version was:
Google Chrome	22.0.1206.0 (Official Build 146722) canary
OS	Windows XP
WebKit	537.1 (@122613)

Comment 23 by kareng@google.com, Jul 16 2012

Labels: -Merge-Requested Merge-Approved
Labels: -Merge-Approved Merge-Merged
Status: Fixed
Project Member

Comment 25 by bugdroid1@chromium.org, Jul 16 2012

Labels: merge-merged-1180
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146820

------------------------------------------------------------------------
r146820 | yzshen@chromium.org | Mon Jul 16 10:23:05 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1180/src/webkit/plugins/ppapi/ppb_var_deprecated_impl.cc?r1=146820&r2=146819&pathrev=146820

Merge 145992 - Fix user gesture for scripting calls from Pepper plugins.

BUG= 134959 
TEST=None


Review URL: https://chromiumcodereview.appspot.com/10693130

TBR=yzshen@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10783021
------------------------------------------------------------------------
Project Member

Comment 26 by bugdroid1@chromium.org, Jul 16 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146821

------------------------------------------------------------------------
r146821 | yzshen@chromium.org | Mon Jul 16 10:25:11 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1180/src/webkit/plugins/ppapi/ppapi_plugin_instance.cc?r1=146821&r2=146820&pathrev=146821

Merge 146513 - Don't close pending user gesture when PluginInstance receives ACKs for input events.

Because plugins might respond to input events asynchronously. We just wait until kUserGestureDurationInSeconds expires.

BUG= 134959 
TEST=None


Review URL: https://chromiumcodereview.appspot.com/10736062

TBR=yzshen@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10780017
------------------------------------------------------------------------
Status: Verified
verified as fixed in 21.0.1108.49 as fixed. trigger many news popup windows, popup blocker no longer appear.
Following the release of 21.0.1180.60 on Windows, this issue seems to have reoccurred. 

We have it failing consistently on our site. 
To reproduce, 

0. Use pepper flash...

1. go to http://www.bet365.com/ and click the "Sports" link at the top of the page - You will be taken through to our flash site (screenshot attached).

2. Any links that cause a popup window to open will get blocked. Try clicking "Join Now" or "Contact Us" in the header section of the website.

We are using ExternalInterface.call in flash to call into a javascript method which then calls window.open. All done in the user interaction call stack.

Obviously we are worried about this as Chrome now holds the highest market share amongst our user base. 

Thanks
screenshot...
bet365.jpg
194 KB View Download
As of last night, we released a workaround for our site by utilising navigateToURL in flash. We're having to do a chrome check because the workaround doesn't work in all browsers. 

The method I described in the above comment (ExternalInterface) will still cause the popup blocker to fail in any test cases though.
what is your workaround with navigateToURL? (I know `javascript:myFunction()` like urls doesn't work with navigateToURL...)

I'm issuing the same problem, all works while pepper flash is disabled
Actually it was the "javascript:" syntax we ended up using for chrome. Have you tried passing "_self" as the second parameter?

Comment 33 by Deleted ...@, Aug 2 2012

Still having this issue with legitimate calls being blocked despite eliminating external calls (already passed _self). Any advice?
Cc: yzshen@chromium.org
Owner: brettw@chromium.org
Hi, Brett.

Would you please take a look at the issue described in comment #28 (and below)?

Thanks! :)
Hi all,
We also have an isuue with the new chrome version(21) pop up blocker - can you tell me why?
link:
http://platform.mediamind.com/Eyeblaster.Preview.Web/AdPreview.aspx?reportinteractions=1&adid=10407947

Thanks
kungfusheep, thanks, the "_self" way worked... still waiting for a solution for the original problem,

thanks!
Kungfusheep: Can you please file a new bug and paste the number here, then we can track the issue from there.

Comment 38 by Deleted ...@, Aug 8 2012

I too am having popups blocked by Pepper Flash Player in Chrome 21 on Windows 7.
Any flash content using ExternalInterface (triggered via user interaction) which calls a JS function (or even inline) which makes use of window.open targeting "_blank" is blocked.
This definitely needs to be fixed promptly in the next version of Chrome/Pepper.
Project Member

Comment 40 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 41 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Flash -Feature-PopupBlocker -Mstone-21 -Feature-Plugins-Pepper M-21 Cr-Content-Plugins-Pepper Cr-Content-Plugins-Flash Cr-Internals Cr-UI-Browser-PopupBlocker
Project Member

Comment 42 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 43 by bugdroid1@chromium.org, Apr 6 2013

Labels: Cr-Blink
Project Member

Comment 44 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Flash Cr-Internals-Plugins-Flash
Project Member

Comment 45 by bugdroid1@chromium.org, Apr 6 2013

Labels: Cr-Internals-Plugins
Project Member

Comment 46 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Pepper Cr-Internals-Plugins-Pepper

Sign in to add a comment