New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 134311 link

Starred by 10 users

Issue metadata

Status: Fixed
Owner:
Closed: Jul 2012
Cc:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Blocked on:
issue 131682

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

With parental controls enabled, cannot run chrome on the mac.

Reported by jgugge...@gmail.com, Jun 23 2012

Issue description

Chrome Version       : 19.0.1084.56
OS Version: OS X 10.6.8

What steps will reproduce the problem?
1. Enable parental controls on a managed account
2. Allow Chrome to be run

What is the expected result?

Chrome to work on that managed account.


What happens instead?

Chrome starts but displays "Aw Snap" and pops up the parental control that says that you do not have permission to execute "Chrome Helper" and "Chrome Helper EH". These pop up repeatedly - sometimes just sitting there you'll see the "Chrome Helper EH" dialog pop up again and again.

Even if I click "Always Allow" and put in authorized credentials, it keeps popping up and popping up. The browser itself never displays anything but the Aw Snap page.


Please provide any additional information below. Attach a screenshot if
possible.

This used to work until very recently (this last upgrade?). It has worked for at least a year.


UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5



 

Comment 1 by jgugge...@gmail.com, Jun 23 2012

Also note that Chrome was working fine for these accounts (ie, it was already allowed). I restarted Chrome this afternoon and suddenly it needed permission for Chrome to run first, then the continuous stream of Chrome Helper / Chrome Helper EH dialogs appeared.

Comment 2 by meh...@chromium.org, Jun 24 2012

Cc: meh...@chromium.org
Labels: -Area-Undefined Stability-Crash Action-FeedbackNeeded
Thanks for the report. Is there a crash id to find at chrome://crashes ?

Comment 3 by jgugge...@gmail.com, Jun 24 2012

Thanks for getting back to me.

No - I cannot get the browser to do anything. Anything entered in the URL bar, including chrome://... urls, just brings up the permission dialog again. This includes preferences or the "about" page.

Comment 4 by meh...@chromium.org, Jun 24 2012

Cc: -meh...@chromium.org
Labels: -Action-FeedbackNeeded

Comment 5 by Deleted ...@, Jun 27 2012

the same thing just started happening to me. I am going nuts. I think there was a recent Chrome update perhaps?

Comment 6 by Deleted ...@, Jun 29 2012

The same thing is happening for me on my Mac and I get the same error with Firefox as well.
My daughter just showed me this same problem. Can't seem to get this resolved. Anybody has a solution aside from permanently disabling parental controls for her account?
Seeing identical behavior as initial reporter: existing accounts with parental controls had Chrome working fine, but in the last several days it has started launching with the Aw Snap screen and raising dialog boxes for Chrome Helper and Chrome Helper EH. Manually updated my Chrome version to 20.0.1132.47 and problem persists. Also running on OS X 10.6.8.

Comment 9 by pe...@youdocs.com, Jul 2 2012

I found on one machine exhibiting this behavior that clicking "Ok" the first time the dialogue box appears and then the next time "always allow" seemed to work. I have another one exhibiting this behavior that I cannot get to until next week. Might be a possible solution. Saw this for a ksadmin issue reported back in '09.
Cc: rsesek@chromium.org
Owner: mark@chromium.org
Mark, could you take a look? thanks!

Comment 11 by mark@chromium.org, Jul 3 2012

This was probably caused by the certificate change.

Can someone who’s having this problem tell us how Parental Controls is configured? Specifically, is Limit Applications on? Which applications are in the Allowed Apps list?

Comment 12 by pe...@youdocs.com, Jul 3 2012

Limit Applications is on. 

The Following Enabled:
Address Book
App Store
Calc
Chart Converter (Excel)
Chrome
ClamXav
Dashboard
Dictionary
Excel 
Face Time
FontCacheTool
Google Software Agent
Google Software Agent
Graph
iTunes
ksadmin
Launchpad
LogmeinHamachi
LogmeinHamachi Menubar
Microsoft AU Daemon
Office Reminders
Office System Setup
Open XML for Excel Apps
PowerPoint
Preview
SyncServices Agent
System Info
Text Edit


Comment 13 by mark@chromium.org, Jul 3 2012

Status: Assigned
This may be related to  bug 131682 .

Comment 14 by mark@chromium.org, Jul 3 2012

Cc: anan...@chromium.org vclarke@chromium.org
Labels: Action-BisectNeeded
Actually, it’d be great if we could bisect to figure out when this started.

Victoria or Anantha, could you bisect officially-released builds, or have someone do it?

Comment 15 by mark@chromium.org, Jul 3 2012

Actually, it’d be great if we could bisect to figure out when this started.

Victoria or Anantha, could you bisect officially-released builds, or have someone do it?
Cc: vivianz@chromium.org
Vivian, could you please bisect it? Victoria and Anantha are OOO

Comment 17 by mark@chromium.org, Jul 3 2012

Labels: -Action-BisectNeeded
I take that back, I just did up a test CL for  bug 131682  and I’m reasonably certain that fixes it.

Comment 18 by mark@chromium.org, Jul 3 2012

Blockedon: chromium:131682
Project Member

Comment 19 by bugdroid1@chromium.org, Jul 3 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=145370

------------------------------------------------------------------------
r145370 | mark@chromium.org | Tue Jul 03 13:35:49 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/installer/mac/sign_versioned_dir.sh.in?r1=145370&r2=145369&pathrev=145370

Supply an explicit designated requirement for all internal components during
signing.

The implied designated requirement produced when signing on Lion cannot be
satisfied on pre-Lion systems. This was already addressed by providing an
explicit designated requirement for the outer .app bundle. This change also
provides an explicit designated requirement for inner components.

The Parental Controls feature apparently requires an application to meet its
designated requirement. Since the requirement for inner components such as
the helper would never be met on 10.6 (or presumably 10.5), it was impossible
to launch such inner components. This prevented any renderer processes from
ever starting up. The user would only see sad tabs and endless OS prompts, and
the browser would effectively be useless.

BUG= 131682 ,  134311 
TEST=Turn on Parental Controls and set it to limit applications. Launch Chrome.
     After a possible initial prompt asking whether Chrome should be permitted
     (authenticate and say yes), Chrome should function normally. There should
     be no prompts about Chrome Helper, Chrome Helper EH, or Chrome Helper NP.
     Web pages should load normally. There should be no sad tabs. Note that
     there may still be a prompt about ksadmin.
Review URL: https://chromiumcodereview.appspot.com/10696101
------------------------------------------------------------------------

Comment 20 by mark@chromium.org, Jul 3 2012

Status: Untriaged
In to triage to assign an mstone and possibly merge this.

Comment 21 by mark@chromium.org, Jul 16 2012

Labels: Mstone-20 Merge-Requested
Status: Assigned

Comment 22 by dharani@google.com, Jul 16 2012

Labels: -Merge-Requested Merge-Approved
Project Member

Comment 23 by bugdroid1@chromium.org, Jul 16 2012

Labels: merge-merged-1132
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146848

------------------------------------------------------------------------
r146848 | mark@chromium.org | Mon Jul 16 12:04:46 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1132/src/chrome/installer/mac/sign_versioned_dir.sh.in?r1=146848&r2=146847&pathrev=146848

Merge trunk r145370 to the 20.0.1132 branch.

Supply an explicit designated requirement for all internal components during
signing.

The implied designated requirement produced when signing on Lion cannot be
satisfied on pre-Lion systems. This was already addressed by providing an
explicit designated requirement for the outer .app bundle. This change also
provides an explicit designated requirement for inner components.

The Parental Controls feature apparently requires an application to meet its
designated requirement. Since the requirement for inner components such as
the helper would never be met on 10.6 (or presumably 10.5), it was impossible
to launch such inner components. This prevented any renderer processes from
ever starting up. The user would only see sad tabs and endless OS prompts, and
the browser would effectively be useless.

BUG= 131682 ,  134311 
TEST=Turn on Parental Controls and set it to limit applications. Launch Chrome.
     After a possible initial prompt asking whether Chrome should be permitted
     (authenticate and say yes), Chrome should function normally. There should
     be no prompts about Chrome Helper, Chrome Helper EH, or Chrome Helper NP.
     Web pages should load normally. There should be no sad tabs. Note that
     there may still be a prompt about ksadmin.
Review URL: https://chromiumcodereview.appspot.com/10696101
Review URL: https://chromiumcodereview.appspot.com/10785021
------------------------------------------------------------------------

Comment 24 by mark@chromium.org, Jul 16 2012

Labels: -Mstone-20 -Merge-Approved -merge-merged-1132 Mstone-21 Merge-Requested
Merged to 20.0.1132 at r146848. Now for 21.0.1180.

Comment 25 by kareng@google.com, Jul 16 2012

Labels: -Merge-Requested Merge-Approved
Project Member

Comment 26 by bugdroid1@chromium.org, Jul 16 2012

Labels: -Merge-Approved merge-merged-1180
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=146851

------------------------------------------------------------------------
r146851 | mark@chromium.org | Mon Jul 16 12:11:16 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1180/src/chrome/installer/mac/sign_versioned_dir.sh.in?r1=146851&r2=146850&pathrev=146851

Merge trunk r145370 to the 21.0.1180 branch.

Supply an explicit designated requirement for all internal components during
signing.

The implied designated requirement produced when signing on Lion cannot be
satisfied on pre-Lion systems. This was already addressed by providing an
explicit designated requirement for the outer .app bundle. This change also
provides an explicit designated requirement for inner components.

The Parental Controls feature apparently requires an application to meet its
designated requirement. Since the requirement for inner components such as
the helper would never be met on 10.6 (or presumably 10.5), it was impossible
to launch such inner components. This prevented any renderer processes from
ever starting up. The user would only see sad tabs and endless OS prompts, and
the browser would effectively be useless.

BUG= 131682 ,  134311 
TEST=Turn on Parental Controls and set it to limit applications. Launch Chrome.
     After a possible initial prompt asking whether Chrome should be permitted
     (authenticate and say yes), Chrome should function normally. There should
     be no prompts about Chrome Helper, Chrome Helper EH, or Chrome Helper NP.
     Web pages should load normally. There should be no sad tabs. Note that
     there may still be a prompt about ksadmin.
Review URL: https://chromiumcodereview.appspot.com/10696101
Review URL: https://chromiumcodereview.appspot.com/10704231
------------------------------------------------------------------------

Comment 27 by mark@chromium.org, Jul 16 2012

Labels: -Mstone-21 -merge-merged-1180 Mstone-20 Merge-Merged-1132 Merge-Merged-1180
Status: Fixed
Verified fixed on 21.0.1180.49 (although it did take a few authentications the first 2 times Chrome launched and as mentioned in the CL it still prompts about ksadmin, but this can be ignored).

Will need to verify on M20 when next official build is released.
Project Member

Comment 29 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 30 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Mstone-20 M-20
Project Member

Comment 31 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment