New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 134285 link

Starred by 6 users

Issue metadata

Status: Duplicate
Owner:
Email to this user bounced
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Blocking:
issue 130323

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Flapper does not render correctly in HiDPI mode when in full screen

Project Member Reported by abarth@chromium.org, Jun 23 2012

Issue description

Chrome Version       : 22.0.1183.0

What steps will reproduce the problem?
1. Use Chrome on a Retina Macbook
2. Go to Hulu
3. Watch a video
4. Make it fully screen

What is the expected result?

The video show display full screen.

What happens instead?

The video displays in the upper left quarter of the screen instead.  The other three quarters of the screen are white.

Please provide any additional information below. Attach a screenshot if
possible.

I'm not sure whether I'm using NPAPI flash or Pepper flash.  I've attached a screenshot of my about:plugins page in case that helps sort out that issue.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/22.0.1183.0 Safari/537.1



 
Screen Shot 2012-06-22 at 8.28.29 PM.png
148 KB View Download

Comment 1 by thakis@chromium.org, Jun 23 2012

Cc: sh...@chromium.org viettrungluu@chromium.org sail@chromium.org
Can you try on the dev channel?

(+mac flapper crew)

Comment 2 by thakis@chromium.org, Jun 23 2012

Looks fine on the dev channel (i.e. with normal flash). Not a release blocker for m21 then.

Comment 3 by thakis@chromium.org, Jun 25 2012

Summary: Fullscreen videos on Hulu only display in upper left quarter with flapper in hidpi mode

Comment 4 by abarth@chromium.org, Jun 28 2012

Sorry, I don't have dev channel on this machine.
I have the same issue with my Retina. I do not think the problem is specific to Hulu, but any website that provides a fullscreen button. This problem only occurs on Google Chrome Canary; Google Chrome works fine for video. I have attached a screenshot of what a video looks like in fullscreen mode. If it matters, the video controls do not work where they are displayed-- the buttons are actually on the bottom right corner of the screen where they should be, albeit invisible. 
Screen Shot 2012-06-29 at 10.44.15 AM.png
1.0 MB View Download

Comment 6 by tjgo...@gmail.com, Jun 29 2012

I'm finding these results on Youtube, vimeo and all other fullscreen flash videos

I've attached a screenshot below.

Note that this does not happen when the video is HTML5 instead of flash, such as when you enable the HTML5 lab for youtube.
Screen Shot 2012-06-29 at 2.38.06 PM.png
959 KB View Download
Status: Untriaged
 Issue 135382  has been merged into this issue.
Summary: Flapper does not render correctly in HiDPI mode
The dupe is about flapper in extension popups.
See issue 130323 for the ChromeOS side of this.

Comment 11 by sail@chromium.org, Jul 13 2012

Cc: ihf@chromium.org
Owner: sail@chromium.org
Status: Assigned
I'll grab this incase ihf@ doesn't fix it for Mac too.

Comment 12 by ihf@chromium.org, Jul 13 2012

See comments 8,9 and 19 in issue 130323.
Status: Started
Summary: Flapper does not render correctly in HiDPI mode when in full screen
Blocking: chromium:130323

Comment 15 by sail@google.com, Jul 18 2012

So my comment above was wrong. This isn't a bug in the flash code. The reason this didn't reproduce in the mouse lock sample is because the mouse lock code uses 2D drawing code.

We have a sample plugin that uses 3D drawing code, gles2.cc. I updated it to use flash full screen and I can reproduce this bug.

I've attached that patch I used to reproduce this bug.
gles2.diff
3.0 KB View Download

Comment 16 by sail@chromium.org, Jul 19 2012

Mergedinto: 130323
Status: Duplicate
Project Member

Comment 17 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:130323
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 18 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Plugins-Pepper Cr-Content-Plugins-Pepper Cr-Internals
Project Member

Comment 19 by bugdroid1@chromium.org, Apr 6 2013

Labels: Cr-Blink
Project Member

Comment 20 by bugdroid1@chromium.org, Apr 6 2013

Labels: Cr-Internals-Plugins
Project Member

Comment 21 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins-Pepper Cr-Internals-Plugins-Pepper

Sign in to add a comment