New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 13290 link

Starred by 20 users

Issue metadata

Status: Fixed
Owner:
User never visited
Closed: Aug 2009
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

User scripts not working

Reported by cera...@gmail.com, Jun 4 2009

Issue description

Chrome Version       : 3.0.184.0 (Developer Build 17539)
URLs (if applicable) : n/a
Other browsers tested: n/a

What steps will reproduce the problem?
1. Download .user.js files into the "User Scripts" folder in the Chromium 
profile folder.
2. Run Chromium with the --enable-user-scripts command switch.

What is the expected result?
User scripts are activated.

What happens instead?
User scripts have no effect.

Please provide any additional information below. Attach a screenshot if
possible.
Tested with AdSweep and Flashblock from www.adsweep.org
 
Chrome version: 3.0.182.3 (17055)
Works fine for me. Using serveral userscripts from userscripts.org, such as Any 
Remover, Youtube Downloader, Greased Lightbox and more.

Comment 2 by cera...@gmail.com, Jun 4 2009

Please verify that the issue does not exist in 3.0.184.0 (Developer Build 17539).
.
cerados, what platform are you on? I see the same problem on trunk (3.x) builds on
Linux. Maybe only broken on this platform?

Comment 4 by cera...@gmail.com, Jun 4 2009

Platform is Windows Vista SP1.

Comment 5 by Deleted ...@, Jun 4 2009

Does not work for me on XP SP3
Google Chrome	3.0.183.1 (Official Build 17570)

" --enable-user-scripts" doesn't work

System: xp sp2
Chromium: 3.0.184.0
Same problem here, started with 3.0.183.1 update.
Win XP SP3
3.0.183.1

" --enable-user-scripts" doesn't work

At least Yahoo Mail now works... 2 steps forward / 1 step back

Comment 9 by aa@chromium.org, Jun 5 2009

 Issue 13448  has been merged into this issue.

Comment 10 by aa@chromium.org, Jun 5 2009

Status: Available

Comment 11 by aa@chromium.org, Jun 5 2009

Labels: -Area-Misc Area-Extensions
Add label: Assigned.

Comment 13 by aa@chromium.org, Jun 5 2009

Status: Assigned
"content scripts" doesn't work either, for example, the sample code in your site 
"Subscribe in Google Reader" doesn't work.
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=17898 

------------------------------------------------------------------------
r17898 | aa@chromium.org | 2009-06-08 14:01:53 -0700 (Mon, 08 Jun 2009) | 6 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/extensions_service.cc?r1=17898&r2=17897
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/extensions_service_unittest.cc?r1=17898&r2=17897
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/renderer_host/browser_render_process_host.cc?r1=17898&r2=17897
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/testing_profile.h?r1=17898&r2=17897

Fix user scripts not getting initialized.

BUG= 13290 , 13128 
TEST=Add --enable-user-scripts to command line without --enable-extensions or --load-extension. Start Chrome, user scripts should work. Also run ui tests with --enable-extensions.

Review URL: http://codereview.chromium.org/119256
------------------------------------------------------------------------

Comment 16 by aa@chromium.org, Jun 8 2009

Status: Fixed

Comment 17 by cmro...@gmail.com, Jun 16 2009

i am able to reproduce this problem on 3.0.189.0 (18456) on linux.
 Issue 13522  has been merged into this issue.

Comment 19 by cmro...@gmail.com, Jun 18 2009

my user scripts are executing as of 3.0.190.0 (18673) on linux.
Somebody managed to break userscripts once again (tested with r18695)...

Comment 21 by aa@chromium.org, Jun 18 2009

@sandshrew: What platform are you testing on?
Userscripts are broken again in the latest release for Windows.

I just upgraded to 3.0.189.0
Win XP SP2

This is getting pathetic.
@aa
Linux. Next time please "don't fix what ain't broken" or at least CAREFULLY test the 
changes before submitting.

Comment 24 by aa@chromium.org, Jun 18 2009

Status: Available
Blech. Reopening.

I don't repro this on Windows, but several people have reported it now.

@sandshrew, thanks for the information.

Comment 25 by norm...@gmail.com, Jun 18 2009

FYI: I could repo it, and then I installed an extension, which magically made all my 
user-scripts work.  So I'd guess it's some sort of user-scripts don't work unless you 
have extensions installed bug.

Comment 26 by cera...@gmail.com, Jun 18 2009

@sandshrew,

"Next time please "don't fix what ain't broken" or at least CAREFULLY test the 
changes before submitting."

How about next time, please don't use unstable nightly builds if you can't stand bugs?

Comment 27 by igi...@gmail.com, Jun 18 2009

I think adding --enable-extensions (in addition to --enable-user-scripts) to Chrome's 
parameters is a work-around.

Hear hear @cerados!
@cerados
There are no stable builds for linux.

@igitur
This doesn't seem to help in linux.

Comment 29 by aa@chromium.org, Jun 18 2009

Status: Assigned
Ok, thanks to the helpful information from cerados, I see the issue.

This was busted (again) @18397 and then fixed (again) @18661. The issue (again) was that 
UserScriptMaster is relying on ExtensionsService to tell it when to start, and we keep breaking the 
code that guarantees that will happen under all circumstances. In this case, it doesn't happen if 
the extensions node in the preferences file doesn't exist.

If you install at least one extension, the node will be created. Another way to create would be to 
add this entry under the root node of your Preferences file in <user data dir>/Preferences:

"extensions": {
  "settings": {
  }
},

This has already been fixed on trunk, but I'm leaving this bug open on myself to add more tests for 
this area.
Thank you AA.

Confirmed on my end that it works.  I had --enable-extensions already there when it 
was not working, but I did not have any extensions installed.

I added AniWeather extension just now and all of my user scripts have started working 
again.

@Sandshrew
I am with you.  Lately the builds seem more sloppy than before (eg, user scripts 2 
times, yahoo mail not working, etc...). This time however, I see why it would be 
unlikely to be discovered in a dev build before pushing out to users.  Yahoo Mail 
issue on the other hand should never have happened.  Too popular of a site to not 
check with a dev build.

Comment 31 by cera...@gmail.com, Jun 18 2009

Off-topic, but I'm afraid I'll have to agree that the builds seem to be getting more 
and more unstable even though I understand they're supposed to be. Chromium was more or 
less usable as my main browser a few months ago, but lately I'm finding an average of 
1-2 bugs every week, and waiting for ages before my bug reports get noticed, and even 
longer for the fix to arrive.

Minefield and WebKit nightlies seem rock-stable compared to the current state Chromium 
is in.

Comment 32 by cmro...@gmail.com, Jun 18 2009

Thank you all for your attention to this issue.
extensions are still not working for me in 3.0.189.0 (Official Build 18569), with --
enable-user-scripts and --enable-extensions, even after adding the extensions node to 
my preferences file.

Comment 34 by aa@chromium.org, Jun 21 2009

@hotaru.firefly: You need to add the settings child, too. If that doesn't work, please 
try installing one extension from the samples page and uninstalling it. This should 
kick things into the right state. Otherwise, just wait for the next build.
i had added the settings child when i added the extensions one, i copied and pasted it 
from your (aa@chromium's) comment.
installing an extension fixed it, thanks.

Comment 36 by dhw@chromium.org, Jun 22 2009

 Issue 14650  has been merged into this issue.

Comment 37 by webi...@gmail.com, Jul 9 2009

When I --enable-user-scripts and go to any page, the browser crashes.  I'm on windows 7 
with build 3.0.193.0 (20255)
webiest, what do you mean by "browser crashes"? is this the aw snap page reported in  
 Issue 16421  ?

Comment 39 by webi...@gmail.com, Jul 22 2009

Yes it is.  I get an aw snap page on every tab opened.

Comment 40 by aa@chromium.org, Aug 16 2009

Status: Fixed
Since at least one version of 'user scripts not working' has been fixed, I'm going to 
close this. If it reoccurs, let's try and open new bugs to track particular causes.
User scripts are not woking in 4.0.249.78 (36714) build.
I tried different combinations:
chrome.exe
chrome.exe --enable-user-scripts
chrome.exe --enable-user-scripts --enable-extensions
Nothing works.
Previous stable release did not have any problems with user scripts.
How to fix this issue?
Thanks.
@sergei.polishchuk: User Scripts are now automatically converted into extensions. 
Simply drag the .user.js file into Chrome and it should install properly.

 Bug 22103  refers to this.
Labels: Feature-Extensions

Comment 44 by Deleted ...@, Jul 24 2012

MLB Jerseys, NFL Jerseys, NHL Jerseys, NBA Jerseys, Nike NFL Jerseys, MLB Baseball Jerseys, Cheap MLB Jerseys, 
Cheap NFL Jerseys, Cheap NHL Jerseys, Cheap NBA Jerseys, Cheap Nike NFL Jerseys, Cheap MLB Baseball Jerseys, Cheap Jerseys, 
Cheap Jerseys.com, Cheap Jerseys.com Cheap Authentic Jerseys, Cheap Authentic NFL Jerseys, Cheap Authentic NHL Jerseys, 
Cheap Authentic MLB Jerseys, Cheap Authentic NBA Jerseys, Authentic NFL Jerseys, Authentic Nike NFL Jerseys, Authentic MLB Jerseys, Authentic MLB Baseball Jerseys, Authentic NHL Jerseys, Authentic NBA Jerseys, China Jerseys, Cheap China Jerseys

http://www.authenticmlb-cheapjerseys.com
Project Member

Comment 45 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 46 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Feature-Extensions Cr-Platform-Extensions

Sign in to add a comment