Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 128870 Pepper flash broken audio
Starred by 35 users Project Member Reported by f...@sofaraway.org, May 19 2012 Back to list
Status: Duplicate
Merged: issue 116435
Owner: ----
Closed: Jan 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment
When using the Pepper Flash plugin on Ubuntu, the sound of most flash videos is broken (all jerky, kind of metallic and sometimes going twice as fast as expected).

In the console, i always get a few:
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream

I can reproduce with most youtube videos, and on different computers.
Also reproducible with Chromium trunk.

I notice that when it's broken, the stream/app is not visible in the Gnome Sound Settings / Applications tab. It's supposed to be called "ALSA plug-in [chromium-browser]" in there. It's sometimes appears very briefly (or flashing very fast).

If i disable the Pepper flash (it's a 11.2.* btw) and use the system flash instead (NPAPI, also 11.2.*), it's all fine for the same videos.

 
Comment 1 by piman@chromium.org, May 19 2012
Cc: viettrungluu@chromium.org
Comment 2 by rktes...@gmail.com, May 27 2012
I seem to be having the same problem. Specifically, my issue is similar to what was reported in  Issue 54224 . That is, the problem disappears when I disable the integrated Flash plugin. It may not be the same problem (that issue is form 2010), but the symptoms and workaround are similar.
Comment 3 by rktes...@gmail.com, May 27 2012
Some info I forgot to put in my comment:
Operating System: Ubuntu 12.04
Google Chrome version 20.0.1132.17 beta
PulseAudio version: 20.0.1132.17 beta

I exactly have the same issue :(
google-chrome 20.0.1132.17 beta
flash-plugin 11
Ubuntu 11.10 with gnome-shell
Same here. I have actually had this issue for a few weeks now. Temporary workaround for me is to disable the PepperFlash under chrome://plugins and go back to the stand-alone libflashplayer.so from Adobe.

Xubuntu 12.04 LTS

$ google-chrome --version
Google Chrome 20.0.1132.27 bet
$ pulseaudio --version
pulseaudio 1.1

Comment 6 by pde...@gmail.com, Jun 14 2012
Disabling PepperFlash fixed it for me too

$ cat /etc/issue.net 
Ubuntu 12.04 LTS
$ pulseaudio --version
pulseaudio 1.1
$ google-chrome --version
Google Chrome 20.0.1132.27 beta

I also disabled PepperFlash through chrome://plugins
It works fow now :)
Comment 8 by rhudd...@gmail.com, Aug 6 2012
i'm running a system halfway upgraded from ubuntu-lucid to ubuntu-precise, but all the sound libs are precise

i'm seeing a ton of these lines in xsession-errors
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream

perhaps this might help, i don't believe chrome should be using any alsa components when running through pulseaudio.  

when playing an mp3 with vlc, i get
sudo lsof +D /usr/lib | grep -i vlc | grep -e pulse -e alsa
vlc       16374   mem    REG  252,0   385240  663060 /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
vlc       16374   mem    REG  252,0   294704  663061 /usr/lib/x86_64-linux-gnu/libpulse.so.0.13.5

but chrome is doing this
sudo lsof +D /usr/lib | grep -i chrome | grep -e pulse -e alsa
chrome    10644   mem    REG  252,0    27248  917575 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
chrome    10644   mem    REG  252,0   385240  663060 /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
chrome    10644   mem    REG  252,0   294704  663061 /usr/lib/x86_64-linux-gnu/libpulse.so.0.13.5

i don't think chrome should be accessing libasound_module_pcm_pulse.so
Comment 9 by rhudd...@gmail.com, Aug 8 2012
this might also explain why i get a line 
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
written to my .xsession-errors every second or so
Comment 10 by Deleted ...@, Aug 10 2012
Another vote for disabling PepperFlash. Worked for me. 
Ubuntu 12,04
Chrome Version 21.0.1180.75 

Enabled:
Version:	11.2 r202
Location:	/usr/lib/flashplugin-installer/libflashplayer.so

Disabled:
Version:	11.3.31.225
Location:	/opt/google/chrome/PepperFlash/libpepflashplayer.so

Comment 11 by mbl...@mbligh.org, Aug 13 2012
Broken for me too. Please turn off Pepper by default until it's better tested.
I am also affected by this; disabling pepperflash stopped the clicking noise.

$ google-chrome --version
Google Chrome 21.0.1180.89 

$ uname -a
Linux nc10 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:54:40 UTC 2012 i686 i686 i386 GNU/Linux

I seem to be affected by this same problem: a "click" sound (or gentle "pop") every second or two whenever I have Gmail open in a Chrome tab. If I close my Gmail tabs, I hear nothing.

Disabling /opt/google/chrome/PepperFlash/libpepflashplayer.so and restarting Chrome seems a valid workaround so far.

I'm running the Chrome beta channel updates on Xubuntu 11.10:

$ google-chrome --version
Google Chrome 22.0.1229.91 beta

$ uname -a
Linux jkrug-laptop 3.0.0-26-generic #42-Ubuntu SMP Wed Sep 5 08:37:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
I have this same audio distortion / Sound Settings issue. Here's a wav recording of the audio as I hear it for http://www.youtube.com/watch?v=MSanNzzKphQ.
MSanNzzKphQ_popping.wav
1.4 MB Download
Comment 16 by piman@chromium.org, Oct 10 2012
Disabling PulseAudio helped a lot for me.
Comment 17 by mbl...@mbligh.org, Oct 11 2012
What are the chances of waking up the people on the Pepper team to actually fix this?

It seems like it's been broken since before it was released, and nobody is doing anything.
Comment 18 by gps@google.com, Oct 17 2012
I just upgraded from ubuntu Lucid to Precise and am seeing the same damn thing running Google Chrome Version 23.0.1271.26 beta.

This is the Chrome out of box experience on Precise?  WTF.  Completely Broken and unusable.
Cc: scherkus@chromium.org
Labels: Feature-Media-Audio
Since Pepper Flash just goes through Chrome's stack, it's a pure Chrome problem.
Cc: dalecur...@chromium.org
+dalecurtis knows the latest status on Chrome+Alsa+PulseAudio interactions
Hmm, I had a similar (same?) problem locally that xians fixed recently, issue 152323:

http://codereview.chromium.org/11019010/

@gps, that patch resolved all the gPrecise issues I was seeing (and should be in the M23 beta you listed).  Are you using a custom audio configuration?
Comment 22 by devuran...@gmx.net, Oct 31 2012
I have the same issue on Gentoo/Linux with www-client/google-chrome-23.0.1271.40_beta162221 and media-sound/pulseaudio-2.1-r1 on Kernel 3.6.4. I also had the same distorted audio with older versions of Chrome, PulseAudio and Linux. YouTube/HTML5 and www-plugins/adobe-flash-11.2.202.243 work without issues. See also:  bug #136624 
Comment 23 by gps@google.com, Oct 31 2012
My issue appears to go beyond Chrome and PepperFlash.  I can reproduce it using the flash plugin in Mozilla Firefox as well.   It sounds like there are multiple issues piling on one another here.
Comment 24 by piman@chromium.org, Oct 31 2012
Cc: -piman@chromium.org
Comment 25 by Deleted ...@, Nov 12 2012
Workaround which works for me:

1) Create an ~/.asoundrc with selects your _real_ soundcard for alsa. http://alsa.opensrc.org/FAQ026

2) Use "pasuspender -- google-chrome" to suspend pulseaudio while chrome is running. Chrome will now fall back to alsa, and avoid the pulseaudio-alsa-bridge since you set your real hw as default in 1).

While chrome will play music well, no other application using pulseaudio (which is suspended/muted) will play sound.
Comment 26 by mbl...@mbligh.org, Nov 13 2012
Why not just turn off pepper? Seems much easier.
Comment 27 by devuran...@gmx.net, Dec 10 2012
Re: comment #22:
This might have some relation to PulseAudio's tsched=0, which I now found I had enabled in my /etc/pulse/default.pa. (I don't remember when I did this - whether before or after I reported this bug). I removed tsched=0 and my Chrome PepperFlash sound distortion problem is gone.
Mergedinto: 116435
Status: Duplicate
Project Member Comment 29 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Feature-Plugins-Pepper -Feature-Media-Audio Cr-Content-Plugins-Pepper Cr-Internals-Media-Audio
Comment 30 by Deleted ...@, Mar 24 2013
Re: Comment #27

I can confirm that removing tsched=0 from default.pa in /etc/pulse solves this issue.
Thanks for the hint.

This obviously does not work for people which require tsched=0 because of driver/hardware bugs.
Project Member Comment 31 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Blink
Project Member Comment 32 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Internals-Plugins
Project Member Comment 33 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Plugins-Pepper Cr-Internals-Plugins-Pepper
Comment 34 by Deleted ...@, Jan 22 2014
I can no longer create ecards on jibjab website which I am subscribed to and love using!  
When will this be resolved??



Huh, my symptoms stopped a long time ago. In fact, Pepper flash seems to be the only one that works anymore. I had to disable the Adobe libflashplayer.so because Flash videos would blank out and become unclickable every time I switched away to a different tab.

Are you sure you have Pepper flash enabled and the other plugin disabled? What version of Ubuntu are you running?
I have recently been experiencing problems viewing Jib Jab ecards using Chrome.  I have not been able to view them if they are posted on Facebook either.  The picture shows up but when the play button is clicked the screen turns black - the sound works but not picture.  If I switch to Safari, I find that it works.

I am running OS X 10.9.1 on a Mac Book.  I just upgraded my OS but Chrome flash didn't work prior to the upgrade either.

How might I resolve this?
@#34 and #36
This bug referred to Ubuntu Linux. It sounds like you are having a different problem. Could you file a new bug at:
crbug.com/new
?
That will automatically put information about your version of Chrome in the bug. When you've done that, you can comment again here with that issue number, and I'll triage it.

Thanks for reporting!
Sign in to add a comment