Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 126629 Multiple 'Utility' processes running under in-browser Task Manager
Starred by 22 users Reported by tayre...@bridgelearningcampus.com, May 8 2012 Back to list
Status: Duplicate
Owner:
Closed: Nov 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug



Sign in to add a comment
Chrome Version       : 18.0.1025.168
OS Version: 5.1 (Windows XP)
URLs (if applicable) : N/A
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     IE 7/8/9: OK

What steps will reproduce the problem?
1. Use browser
2. Check Task Manager

What is the expected result?

Just the open tabs, plug-ins and browser should be listed.

What happens instead?

Completely randomly, anything between 1 and 7 or 8 processes called 'Utility' with the default logo appear in the task manager, each one using what seems like as much CPU as possible. They usually use around 4Mb RAM each.

The end result is that the machine basically crawls to a stop until the processes are killed in the in browser task manager.

Please provide any additional information below. Attach a screenshot if
possible.

We're using the MSI edition, installed on around 600 PCs and see it randomly on any and all of them. Some users are administrators, some are locked down via group policy. Some have their own add-ons installed, some don't. Some have sync set up with Google Apps, some don't. All use a http proxy.

UserAgentString: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19


 
Google-utilities.jpg
21.0 KB View Download
This bug is seriously limiting Chrome's usefulness in multiple schools that I know of - some are having to revert to Internet Explorer or Mozilla Firefox as students aren't knowledgeable to use the task manager to kill processes.
Comment 2 by marja@chromium.org, May 14 2012
Labels: -Area-Undefined Area-Internals
Comment 3 by marja@chromium.org, May 15 2012
Cc: eroman@chromium.org
Eric, do you happen to know what might be wrong here / how to debug this further?
i have the same problem... especially on slow computers, i notice ~ 10 processes of "utility" and my extension messaging becomes slower (using chrome msgs api)
it cleans itself after 4-5 minutes but if trying to use the extension while i have a lot utility processes it doesn't look good
Cc: bauerb@chromium.org
Labels: Feature-Plugins not-sync
I have this same issue.  It disappeared one day, for reasons unknown.  And then it came back.  I THINK that it may have something to do with AVG Virus Protection, since the disappearance and reappearance seemed to coincide with AVG updates.
We run ESET Nod32 4.2 here, so it wouldn't be specific to AVG. Also, myself and my colleague have now migrated our 2 workstations from XP to Windows 7. I'm using 64bit and he's using 32bit, all with the latest updates and this problem doesn't occur, so it appears to be limited to Windows XP.
Comment 9 by Deleted ...@, Aug 30 2012
Ditto on issues seen when using on XP. We're on Sophos antivirus. Don't see issue using same deployment on Windows 7.
Project Member Comment 10 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Feature-Plugins Cr-Internals Cr-Content-Plugins
I've got problem, except it's happening for me on multiple Linux machines, including a Chromebook.
Sounds like no one is bothering to fix this...  Epic fail, Google!
I have the same problem too, any idea?
Project Member Comment 14 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Blink
Project Member Comment 15 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Plugins Cr-Internals-Plugins
Comment 16 by bdue...@gmail.com, Apr 12 2013
I am also having this issue with a windows 8 build
Comment 17 by Deleted ...@, May 22 2013
same issue on my windows 7, i only see 3 though and had to take the battery out because holding the power button wasnt working...
Comment 18 by Deleted ...@, Jul 14 2013
this also happen to me.. win xp... the mystery 'utility' process take up almost cpu usage... 

Comment 19 by Deleted ...@, Oct 28 2013
I have the same problem... win xp.. 30.0.1599.101 chrome vers. two 'utility process' %60-80 cpu usage :(
Comment 20 by Deleted ...@, Nov 25 2013
Have the same issue on Windows 8.1 Pro, Chrome 31.0.1650.57 m, some Web sites will load indefinitely and a lot of Utility processes will spawn until the tab is closed (either by Close button or forcefully from Chrome's Task Manager). From the samples of Web sites that trigger this behavior (e.g. YouTube, Yahoo! Mail, my forum), I suspect the culprit is Shockwave Flash plugin (my forum has a Flash-based chatbox). Forcefully close the plugin then opening the same Web sites will not spawn Utility processes anymore.
Comment 21 by tonyg@chromium.org, Jan 11 2014
Labels: Performance-Battery
Comment 22 by Deleted ...@, Jan 26 2014
I have it on my machine, linux, and the utility process can't be terminated.
Labels: Performance-Power
This issue is affecting multiple PCs at my workplace, all XP. I have one Win7 machine that doesn't have any problems with chrome. Tried disabling all extensions, plugins, and themes - no change. Even tried installing a copy for the first time on another XP machine and got the same problem, as you can see from the screenshot. Utility process can be terminated, but often return, and they almost always render the browser unusable. I have also noticed the Shockwave Flash plugin exhibit the same behaviour, where I have to terminate it to make the browser work. I suspect that it may have something to do with security software installed on these PCs.
ChromeGoneBad.bmp
4.1 MB Download
I have the issue too, with chromium code tracking, found that 'utility' processes are working for manifest parsing of extension upgrade, and the process is not released correctly.
Comment 26 by Deleted ...@, Mar 2 2014
Updated to v. 33.0.1750.117 on Linux and that process goes haywire, maxes out CPU in cycles, which is very frustrating... Lags... Don't lag... Lags... and so on..

I killed flash (the first thing everyone should do when Chrome misbehaves, solves it 99% of times), disabled all extensions, no change...

Dirty trick "solves" it: while true; do pkill -f "/opt/google/chrome/chrome --type=utility*"; sleep 0.2; done


Labels: -Cr-Blink
Chrome uses utility processes for many different things, including but not limited to decoding images in some scenarios. If you are having this problem and you can catch it in the act, try going to chrome://tracing/ and record a 10-30 second trace. Then save it and email it to me.

Because utility processes can run many different tasks, your complains about the same symptom may actually be due to different underlying problems. I'd be happy to look at your traces and try to diagnose them.
Labels: -OS-Windows OS-All Performance
Owner: erikc...@chromium.org
Status: Assigned
#26 reports seeing the problem on Linux. https://code.google.com/p/chromium/issues/detail?id=367593#c79 reports seeing the problem on Mac.

This problem is particularly egregious on Mac, because the default user process limit is 709 on OSX 10.9, and Chrome will orphan hundreds of utility processes, effectively taking down the entire machine. It sounds like #26 is seeing the same problem on Linux.

This is a utility process that is getting no CPU time, and it's pretty clearly getting orphaned. I count exactly 14 new processes in each minute period, so it's happening about once every 4 seconds, and it's incredibly regular, if that rings a bell.

[username]     1232   0.0  0.0   812368   1156   ??  S    12:26PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.167.1687817812 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1229   0.0  0.0   813116   1128   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.166.1284002460 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1227   0.0  0.0   813576   1112   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.165.1997474852 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1225   0.0  0.0   813800   1136   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.164.1001704772 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1222   0.0  0.0   811472   1168   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.163.1805252 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1220   0.0  0.0   811860   1108   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.162.1362778400 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1218   0.0  0.0   813660   1132   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.161.2055668937 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1216   0.0  0.0   812700   1144   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.160.1538635216 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1214   0.0  0.0   813508   1112   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.159.188975994 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1212   0.0  0.0   811772   1148   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.158.1397623181 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1210   0.0  0.0   812568   1140   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.157.92409156 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1208   0.0  0.0   813276   1144   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.156.1436437324 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1206   0.0  0.0   813128   1148   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.155.1412006969 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1204   0.0  0.0   812872   1120   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.154.1504130105 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1202   0.0  0.0   813620   1156   ??  S    12:25PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --channel=680.153.1323865415 --lang=en-US --no-sandbox --enable-crash-reporter=BEB4D516-1369-5457-2C8A-5922676189F8
[username]     1199   0.0  0.0   812824   1152   ??  S    12:24PM   0:00.00 /Applications/Google Chrome.app/Contents/Versions/38.0.2125.111/Google Chrome Helper EH.app/Contents/MacOS/Google Chrome Helper EH --type=utility --
The histogram ChildProcess.DisconnectedAlive2 doesn't have an OWNER, so there aren't any histograms being generated for it. A dremel query shows that for 10-30-2014, on OSX, utility processes are being disconnected 4x more often than all other processes combined. Expanding the dremel query to all OSes, the utility and nacl_broker processes outweigh all other processes by an order of magnitude.

If you can repro this, look into what the utility processes are being used for. It would be interesting to see what's launching them.
Cc: tomhanson@google.com
I cannot reproduce this problem, but Tom can. 

Tom, if you can follow the steps in https://code.google.com/p/chromium/issues/detail?id=367593#c76 and get us a couple of traces via chrome://tracing, we would be much obliged.
Oh, and just for reference, the utility processes outlived the browser process itself. :(
There are 4 utility processes that disable the sandbox on Mac:

src/chrome/browser/component_updater/component_patcher_operation_out_of_process.cc (1 occurrence)
     57 host->DisableSandbox();
src/chrome/browser/extensions/api/image_writer_private/image_writer_utility_client.cc (1 occurrence)
     97 utility_process_host_->DisableSandbox();
src/chrome/browser/importer/external_process_importer_client.cc (1 occurrence)
    315 utility_process_host_->DisableSandbox();
src/content/browser/plugin_loader_posix.cc (1 occurrence)
    136 process_host_->DisableSandbox();

One of these is being leaked.
The only process that allows heap execution is the plugin_loader_posix.
Cc: cosminc@google.com
I've seen a new case with this and tried to capture a trace, but was unable to as clicking the record button would not do anything.
After some time (and repeated clicks) I got this error: https://screenshot.googleplex.com/04eYmeYRAF (error occurred at /json/categories at chrome://tracing.js:5573:22)
Tried to restart browser, restart computer, tried in Incognito, made new profile and I got the same behaviour.

Google Chrome v38
We have saved the process list (ps aux) which after closing Chrome was showing more than 300 Chrome Helper processes. Also some Chrome log files.  If anyone thinks these might be useful we could attach them here.
cosminc: Yes, both the ps aux and the log files would be useful. Can you try to grab a trace shortly after opening Chrome?
The plugin loader issue is bug 417467.

If you go to about:plugins and have NetscapeSecurityWrapper.plugin installed, try disabling that and see if the problem goes away.
Mergedinto: 417467
Status: Duplicate
Comment 40 by Deleted ...@, Nov 11 2014
I've check chrome://plugins and there is no NetscapeSecurityWrapper.plugin installed.
I went again to chrome://tracing and there was the same behaviour.

The issue (exhausting processes hasn't  appeared since on that machine).
Google Chrome-macbookpro.wakeups_resource.zip
103 KB Download
Chrome.fork.ps
117 KB Download
Comment 41 by Deleted ...@, Jan 16 2015
I have the same exact issue. I've tried removing chrome multiple times, and I also turned off all plugins and extensions. Still, when the chrome starts, there would be 1 or 2 utility process that will each take up about 12% of CPU. These processes continuously pop up and eat the CPU, sometimes when I run cisco webex, the entire pc completely comes to a stop. I used to think this is due to some conflict with chrome and TOAD, but it is not. It is the chrome itself needlessly taking up CPU and not releasing resource, to a point that makes computer simply stop. This has been progressively worse ever since Sept. 2014, and this is very easy to reproduce on my PC (happens 100%). When the chrome starts, Utility process starts and stays there... until I remove them from chrome task manager

Then it does not show back up...
Comment 42 by Deleted ...@, Jan 16 2015
I uninstalled chrome, and opened up the registry and deleted everything that has chrome. After that re-installed chrome, and it no longer launches utility process when opening chrome. Some of the registry entries I remember, were something to do with intellimouse and intellikeyboard from MS. 
Comment 43 by Deleted ...@, Jan 22 2015
Nevermind, it still pops up. This is really debilitating as a browser. I may have to switch browsers now that this is not really working...
dongwoochang:

There are many different problems being reported on this thread. If you can take a trace of the problem and upload it, either myself or thestig can take a look.

Quoting thestig from earlier in the thread:
"""
Chrome uses utility processes for many different things, including but not limited to decoding images in some scenarios. If you are having this problem and you can catch it in the act, try going to chrome://tracing/ and record a 10-30 second trace. Then save it and email it to me.

Because utility processes can run many different tasks, your complains about the same symptom may actually be due to different underlying problems. I'd be happy to look at your traces and try to diagnose them.
"""
Sign in to add a comment