New issue
Advanced search Search tips
Starred by 10 users
Status: Duplicate
Merged: issue 140779
Owner: ----
Closed: Oct 2012
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
Chrome fails to launch.
Reported by nic...@gmail.com, May 1 2012 Back to list
Chrome Version       : chrome.exe has version number as 18.0.1025.162, folders titled 18.0.1025.152, 18.0.1025.162 are in Chrome\Application dir.
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
IE 7/8/9:

What steps will reproduce the problem?
Just closed chrome browser, now it fails to launch. (this is the second time I've had this problem, one was prior to formatting just a few weeks ago) Restarting does nothing, I end up having to re-install chrome to get it to work again.

What is the expected result?
Launch Chrome

What happens instead?
Nothing

Please provide any additional information below. Attach a screenshot if
possible.

From debug.log

[0501/231113:ERROR:client_util.cc(311)] Failed to load Chrome DLL from 005CFC20
[0501/231113:ERROR:client_util.cc(352)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0501/231119:ERROR:client_util.cc(311)] Failed to load Chrome DLL from 0040F758
[0501/231119:ERROR:client_util.cc(352)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0501/231512:ERROR:client_util.cc(311)] Failed to load Chrome DLL from 003AFC08
[0501/231512:ERROR:client_util.cc(352)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

 
Comment 1 by rabb...@gmail.com, May 3 2012
I have a similar issue, at least the debug log is the same: 

[0503/125622:ERROR:client_util.cc(394)] Failed to load Chrome DLL from C:\Users\Administrator\AppData\Local\Google\Chrome\Application\20.0.1123.1\chrome.dll
[0503/125622:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded


But, my chrome starts, it's just that I can not open any tab, either with content or with options. All of them show "something went wrong page". 
Rebooting, deleting, etc doesn't seem to work. 

Chrome Version       : 20.0.1123.1
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

What steps will reproduce the problem?
Start the broswer. 

What is the expected result?
See any content. 

What happens instead?
N ( last tabs ) load with " something went wrong " description. 


Comment 2 by Deleted ...@, May 9 2012
Same for me. I am trying to run it off a flash drive when I get this error. Exact same error messages in the debug file too.
Comment 3 by Deleted ...@, May 14 2012
so I have this problem too.  Other browsers are ok.  Is google planning on fixing this?
Comment 4 by kid...@gmail.com, May 21 2012
Same issue here, Chrome fail and the debug.log is : 
[0521/102905:ERROR:client_util.cc(227)] Failed to load Chrome DLL from 0018F7D0
[0521/102905:ERROR:client_util.cc(268)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0521/103421:ERROR:client_util.cc(227)] Failed to load Chrome DLL from 0014FB90
[0521/103421:ERROR:client_util.cc(268)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

Beside this, everything run OK on the computer.
Comment 5 by vabr@chromium.org, May 21 2012
Labels: -Area-Undefined Area-Internals Internals-Install
I am having this issue, 
trying to launch chrome canary from C:\Users\max\AppData\Local\Google\Chrome SxS\Application 

(21.0.1151.0) and getting
 
[0525/105721:ERROR:client_util.cc(394)] Failed to load Chrome DLL from C:\Users\max\AppData\Local\Google\Chrome SxS\Application\19.0.1084.52\chrome.dll
[0525/105721:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

why is canary looking for the old version of chrome.dll?

if I copy the 19... folder into Chrome SxS it gets removed and the same error is spit out

workaround: uninstall chrome and canary, delete registry keys 

HKEY_CURRENT_USER\Software\Google\Update\ClientState\{4EA16AC7-FD5A-47C3-875B-DBF4A2008C20}
HKEY_CURRENT_USER\Software\Google\Update\Clients\{4ea16ac7-fd5a-47c3-875b-dbf4a2008c20}
Same issue. Closed Chrome, couldn't reopen. Uninstalled, rebooted reinstalled Chrome Beta, same issue. Will try workaround above. 

Error Message:[0606/091827:ERROR:client_util.cc(394)] Failed to load Chrome DLL from C:\Users\My Account\AppData\Local\Google\Chrome\Application\19.0.1084.52\chrome.dll
[0606/091827:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
Comment 8 by ildar...@gmail.com, Jun 27 2012
i have the same issue:

[0627/125448:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0627/125448:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

Canary doesnt started
Windows-8
Compartible Mode Doesnt helped me

Comment 9 by ildar...@gmail.com, Jun 27 2012
but in windows-7 everything is ok
Comment 10 by utu...@gmail.com, Jul 3 2012
same exact problem here, on windows 2003 server. just recently had uninstalled google chrome and google chrome frame in a (successful) attempt to get GCF to work (again) after it inexplicably stopped working. 

GCF correctly installed, but after clicking download and install of google Chrome itself I am now getting this error in my debug.log
Comment 11 by Deleted ...@, Jul 10 2012
Same here.  Installed chrome and it worked fine for days - multiple launches and sessions.  Rebooted the laptop and chrome runs and quits with no user interaction.

this is the debug.log
[0709/231401:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231401:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231425:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231425:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231458:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231458:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231511:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231511:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231519:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231519:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231540:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231540:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231558:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231558:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231611:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231611:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded
[0709/231620:ERROR:client_util.cc(384)] Could not get Chrome DLL version.
[0709/231620:ERROR:client_util.cc(442)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

This is the relevant directory listing:
 Directory of E:\Users\xxxxx\AppData\Local\Google\Chrome\Application

07/09/2012  11:14 PM    <DIR>          .
07/09/2012  11:14 PM    <DIR>          ..
07/09/2012  11:26 PM    <DIR>          20.0.1132.47
06/28/2012  06:28 AM         1,250,328 chrome.exe
07/09/2012  11:26 PM             2,535 debug.log
07/09/2012  09:32 AM    <DIR>          Dictionaries
07/09/2012  03:20 AM                 0 First Run

Tried fixing the PATH variable mentioned here ( http://www.google.com/url?sa=t&rct=j&q=&esrc=s&frm=1&source=web&cd=1&ved=0CFEQFjAA&url=http%3A%2F%2Fj2eespot.blogspot.com%2F2012%2F02%2Fcould-not-get-chrome-dll-version.html&ei=p5_7T6qKOIm1qAGE5omMCQ&usg=AFQjCNGIkbRRndkVmZh9o5k4SSeNjXGcMw ) 
with no luck.

Copied chrome.exe to the 20.0.1132.47 directory and it worked fine.

Fix this please - what a rookie bug.
Mergedinto: 140779
Status: Duplicate
Project Member Comment 13 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Internals-Install Cr-Internals-Install Cr-Internals
Project Member Comment 14 by bugdroid1@chromium.org, Apr 5 2013
Labels: -Cr-Internals-Install Cr-Internals-Installer
Sign in to add a comment