Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 12478 No way to disable autoscroll
Starred by 39 users Reported by kassie...@gmail.com, May 22 2009 Back to list
Status: WontFix
Owner: ----
Closed: Jun 2009
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
The middle click AutoScroll function seems alot more finicky then other 
browsers for some reason, and there needs to be an option either in 
preferences or some about page to disable that functionality, as it can 
often be a major frustration to suddenly be scrolling a page when you missed 
a hyperlink by one pixel, or you have a sensitive middle mouse button.
 
Labels: -Type-Bug -Area-Misc Type-Feature Area-BrowserUI
ccing to make a decision.

-Venkat.
Comment 2 by glen@chromium.org, May 28 2009
There should be a fix, rather than an option.
Labels: -Type-Feature Type-Bug Area-WebKit
Status: Untriaged
+1 to glen

It might make sense to introduce a delay so that autoscroll didn't trigger unless the 
click was held down for a few hundred milliseconds. I think any such changes would have 
to be in our WebKit port, but I'm not sure how we pass mouse click events to WebKit.
Comment 4 by glen@chromium.org, May 29 2009
I'm wary of changing the definition of click just for autoscroll; I'd actually be more 
open to making it drag-only, given the incidence of accidents.
Sure, middle-click-drag makes a lot more sense. 
Comment 6 by kassie...@gmail.com, May 29 2009
I think drag would work ok as long as the drag is at least like 8-10px, 5 at the very 
minimum, before it will activate. I think that would solve it, or of course an option 
to disable as mentioned before. It's just so terribly frustrating to miss a link by a 
few pixels, or your mouse moves slightly just by the act of middle clicking and then 
you miss it, and your page goes flying away. Until this problem came up in the new 
Chrome release I think Chrome was perfect (aside of course from not being able to play 
Quake Live in it just yet, without some javascript hassle), so I hope something is 
done about this soon so it can be perfection again :)
Fixing https://bugs.webkit.org/show_bug.cgi?id=21794 could help some here.  Otherwise I 
feel like this is a dupe of  issue 5162 .  Glen asked for my opinion regarding supporting 
only springloaded autoscroll and I noted that the original use case for autoscroll 
(constant scrolling at a fixed rate) is broken by forcing autoscroll to be only-
springloaded.

We also should tweak the sensitivity curve on autoscroll so that it's not very 
sensitive when the drag is small, which would also help this issue.
Status: WontFix
Comment 9 by kassie...@gmail.com, Jun 10 2009
IMO it shouldn't activate unless the user middle-click-drags for at least 20px or so, 
then it's only going to do it if the user wants to do that. Either that or an option 
to disable it altogether, it's extremely frustrating to middle click a link expecting 
a new tab and then the page heads off to the races, alot of times the page won't even 
scroll when that problem occurs because the distance of the unintended cursor 
movement is too small, so you get no feedback except the changed cursor, and 
generally if you open a new tab via middle clicking a link, you're going to be 
looking up at the tab bar as you click it expecting the new tab to appear so you can 
move the cursor up to activate it, but then you do that of course, off goes the page.  
Really this could just be enabled/disabled with some about:config page with unexposed 
options, you don't need something visible to the user for it in the preferences menu 
because it's probably not a huge percentage of users that has this problem 
frequently, but, I can tell you, this almost never happens to me in any other 
browser. But it's quite frequent in Chrome so I hope something can be done to address 
it.
 Issue 14358  has been merged into this issue.
 Issue 13737  has been merged into this issue.
Comment 12 by zr40...@gmail.com, Jun 18 2009
Why is this closed as WontFix?
Comment 13 by zr40...@gmail.com, Jun 19 2009
I would like to add that with most older or cheaper mice it's really easy to trigger an 
accidental wheel scroll when you're trying to middle-click a link. That's because as 
the mouse ages, the scroll ticks can become misaligned with the physical ticks. When 
you then try to middle-click a link, the scroll wheel gets triggered and the page 
scrolls just before the actual middle click happens.

This issue is becoming increasingly annoying. Please reconsider either adding an option 
to disable autoscroll (hidden, if needed), or make it not trigger when unwanted (yes, 
that's vague, I'm afraid).

I would hate to revert to a different browser because of this issue.
Won't Fix? So what, we're all supposed to put up with this crap? This happens to me at 
least 20 times a day and I really get tired of having to middle click 3 times for 1 
link. The first one misses, then you click again to disable the stupid autoscroll, and 
then the third time you try again. And someone thinks this isn't a problem? Hell just 
put some obscure way to disable it if you want to keep it quiet, like a command line 
option -noautoscroll or something. This IS an issue affecting many users and it NEEDs 
to be resolved.
Comment 15 by cmro...@gmail.com, Jun 23 2009
i absolutely despise autoscroll and cannot use the browser if it cannot be disabled
maybe someone could make a fork and disable it? it's so annoying... and I guess the 
devs here don't care.
To clarify, WontFix meaning that we are not going to add a preference menu option to
disable autoscroll.  That said, I'm inclined to create a different feature request in
the vein of comment #7.
The issue just needs to be fixed, or be able to be disabled, it doesn't have to be 
some preference menu option, it could be in some about:tweak page or a command line 
switch, or maybe it could be a option in the document menu under a section for tweaks 
or something or interface options > Use Autoscroll. That way it's not obtrusive, and 
if somebody in the unlikely event *wants* to disable it, they have a way to, and you 
don't have to complicate the preferences dialog.
Comment 19 by cmro...@gmail.com, Jun 24 2009
personally i wouldn't mind even having to compile it from source to disable 
autoscroll. i understand that adding interface options without a strong reason 
significantly complicates automated testing, but i've never seen an implementation of 
autoscroll that made scrolling easier for me.

thankfully the feature has not turned up in linux builds yet, because if it did it 
would be unexpected and seem out of place (the default behavior of linux browsers is 
that autoscroll is either unimplemented or disabled by default). i hope that this 
feature remains restricted to windows, where it seems to be the default behavior for 
middle-button dragging in browsers.
Comment 20 Deleted
Comment 21 by goo...@0x3d.lu, Jul 5 2009
Please give us a possibility to disable this really annoying feature. Chrome NOT having 
this was one of the TOP-5 reasons I made it my primary browser half a year ago.

about:tweaks or --disable-autoscroll, whatever, just give experts the opportunity to do 
so if they'd like to. Listen to your users, they are the ones using your products and 
making you money!
Comment 22 by Deleted ...@, Jul 10 2009
Hi Guys, just got a new Dell Inspiron 15 Laptop (and installed Chrome .. both are 
great. 

However Autoscroll is driving me up the wall .. it is too fast. Can I add my voice to 
this request to make it an option to turn on/off please.

Thansk,
Matt
Comment 23 by Deleted ...@, Jul 10 2009
WontFix - bye bye Chrome, see you next year.
Pete
Labels: Restrict-AddIssueComment-Commit
 Issue 69378  has been merged into this issue.
Project Member Comment 26 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-WebKit Cr-Content
Project Member Comment 27 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Sign in to add a comment