New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 121 users

Issue metadata

Status: Duplicate
Merged: issue 114985
Owner: ----
Closed: Sep 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 1
Type: Bug-Regression

Blocked on:
issue 122789



Sign in to add a comment

[Linux] REGRESSION: Ubuntu 12.04 Unity 2D, cannot merge a single tab back into another tab or tab group

Reported by fbg...@gmail.com, Apr 24 2012

Issue description

Chrome Version       : 18.0.1025.162
OS Version: Ubuntu 12.04 final beta x64 desktop (Unity 2D)
URLs (if applicable) : NA
Other browsers tested: Chrome current stable maintained by Google Chrome repo (http://dl.google.com/linux/chrome/deb stable), Chromium current stable (http://ppa.launchpad.net/chromium-daily/stable/ubuntu precise)

  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: NA
  Firefox 4.x: NA
     IE 7/8/9: NA

What steps will reproduce the problem?
1.  Ubuntu 12.04 final beta x64 Desktop [1]
2.  Install latest stable Chromium or Chrome from repo
3.  Open a new Chrome/ium window
4.  Open another new new window
5.  Try to drag merge the second tab/window into first, it doesn't 'hook'.
6.  Also, open a single window with multiple tabs, then drag one tab out into its own window, then back into its 'parent' window.  It won't hook here either.  You can drag it out, release, and re-drag it back, or never release your drag, either way it won't merge back into parent window.  Once separated from parent window, can't merge it back.

What is the expected result?

Tabs should unmerge and remerge when dragged individually.

What happens instead?

Won't hook and remerge, remains a separate window no matter where you drag the tab over the parent window.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.162 Safari/535.19

[1] Distro version:
$> uname -a
Linux hp-dm1-4050us 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu 12.04 release is expected soon.  If the bug no longer exists in release version, I'll close this ticket.  If it does, will update it.
 
Using Chrome Version 19.0.1084.36 beta on the Ubuntu 12.04 final release still exhibits this behavior.

Comment 2 Deleted

Comment 3 by fbg...@gmail.com, Apr 27 2012

Upgraded Ubuntu from 12.04 final beta to release, issue still exists, details unchanged.

Comment 4 by mbollu@chromium.org, Apr 27 2012

Labels: -Area-Undefined Area-UI Feature-TabStrip
OS: Linux Ubuntu 10.04 
uname -a: Linux mbollu.dls.corp.google.com 2.6.38.8-gg662-ganetixenu #1 SMP Tue Oct 25 03:51:24 PDT 2011 x86_64 GNU/Linux
Chrome: 18.0.1025.162 (Official Build 131933)

Findings: I am unable to reproduce the bug on above chrome version. Tab can be moved back-and-forth between tabs and windows.

Comment 5 by mbollu@chromium.org, Apr 28 2012

Labels: Action-FeedbackNeeded

Comment 6 by mbollu@chromium.org, Apr 28 2012

Labels: -Action-FeedbackNeeded

Comment 7 by fbg...@gmail.com, Apr 28 2012

Fwiw, this was never a problem on 10.04, 11.04, or 11.10 (all Desktop x64), all of which I've used in the past year with Chrome or Chromium as the primary browser.  

It only started occurring when I upgraded 11.10 to 12.04 final beta a week ago, and remained after upgrading from 12.04 final beta to release a few days ago.

Comment 8 by ojiido...@gmail.com, Apr 28 2012

Same issue after upgrading from Ubuntu 11.10 final to 12.04 final (x64). Using chrome 18.0.1025.162. It should be noted that I use unity2d, not unity3d. 
I can reproduce the issue in Unity2D, but not for Unity "3D".
OS: Ubuntu 12.04 (final release, fresh install)
uname -a: Linux [machine] 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i386 GNU/Linux
Browser: Google Chrome 18.0.1025.162

Comment 10 by Deleted ...@, May 2 2012

I can reproduce with:
Ubuntu 12.04
Chrome 18.0.1025.168
I confirm on 
20.0.1115.1 dev
Ubuntu 12.04
Unity 2D

Comment 13 by Deleted ...@, May 3 2012

After a vanilla upgrade to 12.04 which exhibits this problem, it goes away when I use a dwm session. dwm is a minimalist window manager that has no drag-and-drop functions of its own. I'm *not* suggesting this as an acceptable workaround. It does perhaps suggest an interoperability issue with Unity.

http://dwm.suckless.org/

Comment 14 Deleted

Comment 15 by Deleted ...@, May 5 2012

I can reproduce with:

Chromium 18.0.1025.151 (Developer Build 130497 Linux) Ubuntu 12.04
Ubuntu 12.04 Unity 2D
I am using Ubuntu 12.04 with Unity 2D
Google Chrome is 18.0.1025.168 and I cannot merge the tabs again.

I used Unity 2D also in 11.10 and I didn't experience the problem.

Comment 17 by rick...@gmail.com, May 8 2012

I'm also running the Ubuntu 12.04 / Unity 2D combination and experience the same problem with merging a tab back into a different window.

Comment 18 by Deleted ...@, May 9 2012

I have the same issue with Unity 2D (3D works fine) on Ubuntu 12.04 x64, latest updates, and Chrome 18.0.1025.168.
I can not even move tabs within the same window, they are always detached into a new window. Very annoying!
I have the same problem as well. Ubuntu 12.04 LTS with Unity 2D and Chrome 18.0.1025.168.

Comment 21 by dhw@chromium.org, May 11 2012

Cc: evan@chromium.org est...@chromium.org
Labels: -Type-Bug -Pri-2 Type-Regression Pri-1 Feature-Browser Feature-OSIntegration
Status: Untriaged
Summary: [Linux] REGRESSION: Ubuntu 12.04 Unity 2D, cannot merge a single tab back into another tab or tab group

Comment 22 by fazz...@gmail.com, May 11 2012

I also have this problem with Ubuntu 12.04 LTS with Unity 2D and Chrome 18.0.1025.168.
I confirm this issue with Ubuntu 12.04 LTS, Unity 2D, and Chrome 20.0.1130.1.

Also note that this affects reordering tabs within a single window (ie. tab detaches immediately and won't reattach even if you only wanted to drag the tab to reorder without detaching).
 Issue 127773  has been merged into this issue.
Cc: -evan@chromium.org e...@chromium.org
Labels: -Feature-Browser
1) "me too" comments are not useful and just adds more noise.

2) I'm not convinced this should be labeled as a regression. It could be that this never worked right in Unity 2D.

3) It's also not obvious if this is a bug in Chromium, or a bug in Unity 2D.

Comment 26 by e...@chromium.org, May 15 2012

I've seen this bug for a very long time. I'm not convinced that it's a regression, and given that this only shows up in one desktop environment, I'm not sure if this is a bug in chrome.
I used Unity 2D in Ubuntu 11.10 and I didn't have that problem.
I don't know the changes between that version and the one in 12.04 so yes, it could be a regression in Unity 2D.

Are there any programs using the same method for the tab merge as Chrome?
I mean, gnome-terminal works fine and it allows the merge/detach tabs but it may use a different process.
Happens to me in Ubuntu 12.04 and Chrome Version 19.0.1084.46

# uname -a
Linux trantor 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i386 GNU/Linux

Comment 29 by bog...@yurov.me, May 18 2012

Also affects me, Dell XPS 17 l702x, on vmware or directly.
Chrome 19.0.1084.46
Unity 3D
Tabs works in others applications for me, like in SublimeText2

Comment 31 by Deleted ...@, May 18 2012

Please see:

  https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/944456.

There the Ubuntu folks are saying that Chromium is making the wrong X calls.

Comment 32 by Deleted ...@, May 18 2012

Rather, _someone_ there is saying Chromium is doing it wrong (not necessarily the Ubuntu developers--sorry).

Comment 33 by fbg...@gmail.com, May 18 2012

Tested this problem with Firefox 12 on Ubuntu 12.04 x64 Unity 2D, it works fine.  Can both rearrange tabs via drag-n-drop, and hook and merge two separate windows with no problems.  
Blockedon: 122789

Comment 35 by dhw@chromium.org, May 24 2012

 Issue 129384  has been merged into this issue.
I can confirm that switching to unity 3D work ok.
It works as a workaround for me.

Comment 37 by dhw@chromium.org, May 28 2012

 Issue 128860  has been merged into this issue.

Comment 38 by dhw@chromium.org, May 28 2012

 Issue 124209  has been merged into this issue.

Comment 40 by ama...@gmail.com, Jun 2 2012

Same issue for Ubuntu 12.04LTS fresh install using Chrome Version 19.0.1084.52
Chromium  issue #114985  also appears to be describing the same problem.
Same issue for Ubuntu 12.04 LTS 64bit fresh install using Chrome Version 20.0.1132.47
Same here: Ubuntu 12.04 LTS 64bit with Chrome Version 20.0.1132.42 beta, been like this for at least a month now, was hoping for a fix but decided that you guys need some encouragement to fix this bug.  C'mon, this is a great feature that needs to work.
A small workaround could be the Ctrl+Shift+PgUp and PgDown which move the current tab left or right. It is useful if you really don't want deattach and attach the tab, but only repositioning it.

But this bug always makes me frustrated...
Another (much more more drastic) workaround is to run "sudo apt-get install xubuntu-desktop" and login with Xubuntu instead of Unity. It's lightweight like Unity 2D. Unfortunately, it uses Thunar instead of Nautilus and has a couple other quirks too. Just a thought.
This does not fix the bug.

Comment 47 by ama...@gmail.com, Jul 6 2012

Recently I have been able to start dragging tabs in and out of Chrome without any issues... 

I installed CCSM or CompizConfig Settings Manager. In there, I enabled several fancy eye candy stuff, too many to list... ?! maybe, just maybe a collateral side effect corrected for this? I'm too GUI dependent to debug or understand everything just yet, so I am just newb reporting it as it happens :-)

Ubuntu GNOME 12.04 32-bit
Chrome Version 20.0.1132.47 , 
graphics: IntelĀ® Sandybridge Desktop x86/MMX/SSE2 
3.2.0-26-generic-pae (#41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012)
Xorg version: 1.11.3 (07 May 2012  11:39:37PM)

I will play with the compiz settings CCSM to see if I can isolate the "cure" and get a workaround or easy fix on the way.

Comment 48 by ama...@gmail.com, Jul 6 2012

I hit reset to global default in CCSM (see above #47) system fully functional but desktop environment was completely unusable, had to use shortcut keys to log out and back in. upon logging back in (switched to 2D) same dragging and merging issue as before... updates to follow if I am able to isolate the fix.

Comment 49 by zigo...@gmail.com, Jul 6 2012

It is known that issue exists just for Ubuntu2D session.

Comment 50 by ama...@gmail.com, Jul 6 2012

it's been and again happening on my ubuntu NOT 2D, since I reset Compiz. Yet to re-find correct settings...

Comment 51 by rlla1...@gmail.com, Jul 19 2012

I think the problem is Metacity it does not support tabbed windows, that's why this issue affects just Unity-2D, look at Wikipedia.

I'm in Kubuntu Now, full of eyecandy, an Utity-like desktop and with tabs working as they should.
http://code.google.com/p/chromium/issues/detail?id=114985
> The Ubuntu 2D session uses a shell whose window is fullscreen but XShaped (see http://www.x.org/releases/X11R7.6/doc/libXext/shapelib.html) to only cover expected parts of the screen. It seems that when dragging tabs, Chromium doesn't query the X server for the XShape of the window and that results in it thinking the tab was dragged outside of its own window and opens a new window with that tab when dropped.
If this is metacity-only problem doesn't mean this is not chromium bug. 
How can I help get this bug out of the un-triaged state? 
This is a duplicate of the "Unconfirmed" http://code.google.com/p/chromium/issues/detail?id=114985

Comment 55 by Deleted ...@, Jul 26 2012

Also happend to me on Google Chrome, Ubuntu 12.04LTS

Comment 56 by Deleted ...@, Aug 8 2012

confirm bug, 12.04LTS

Comment 57 Deleted

Comment 58 by Deleted ...@, Aug 16 2012

Confirmed bug. 12.04LTS. Tabs doesn't hook back to their windows. 
Google Chrome 21.0.1180.79

Comment 59 by Deleted ...@, Aug 24 2012

Confirmed bug, google chrome 21.0.1180.81, ubuntu 12.04 LTS

Comment 60 by Deleted ...@, Aug 29 2012

Confirmed, and really annoying :(
I noticed that this issue was resolved after a fresh install of ubuntu 12.04 when I reset unity with the command "unity --reset"
Unity 2d + chrome have this bug

Comment 63 by gua...@gmail.com, Sep 4 2012

Does some developer has taken a look at comment 52?:

Comment 52 by daniil...@gmail.com, Jul 19, 2012
http://code.google.com/p/chromium/issues/detail?id=114985
> The Ubuntu 2D session uses a shell whose window is fullscreen but XShaped (see http://www.x.org/releases/X11R7.6/doc/libXext/shapelib.html) to only cover expected parts of the screen. It seems that when dragging tabs, Chromium doesn't query the X server for the XShape of the window and that results in it thinking the tab was dragged outside of its own window and opens a new window with that tab when dropped.
If this is metacity-only problem doesn't mean this is not chromium bug. 
Blockedon: -chromium:122789 chromium:122789
Mergedinto: 114985
Status: Duplicate
Faced the same issue. When i drag a tab it is separated into a separate window and does not stick back.
Ubuntu 12.04 x64, latest updates
Unity 2D
Chromium 20.0.1132.47 Ubuntu 12.04 (144678)

I have this problem also unfortunately. 
Running 12.04
I have this problem also unfortunately. 
Running 12.04
Mergedinto: 114985
"Me too" comments aren't super helpful at this stage - if you are interested in the status of the bug please go to http://code.google.com/p/chromium/issues/detail?id=114985 and click the "star" icon.  You'll get an email when the bug is updated.
I made an interesting observation related to this. If you set the Unity sidebar to auto-hide, then, while dragging a tab, move your mouse to the corner to show it, then once it's showing you can drag the tab into another window -- until the Unity sidebar hides itself again (a second or two.)

...might help discover the root cause of the problem. It's 100% repeatable on my machine.
Project Member

Comment 70 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-UI -Type-Regression -Feature-TabStrip -Feature-OSIntegration Type-Bug-Regression Cr-UI-Browser-TabStrip Cr-UI-OSIntegration Cr-UI
Confirming this issue
* Chrome 23.0.1271.97
* Chromium 25.0.1364.160
* Ubuntu 12.04 LTS 32 Bit with Unity 2D
This seems to be happenging again. My info:

Google Chrome	27.0.1453.47 (Official Build 193194) beta
OS	Linux 
WebKit	537.36 (@147958)
JavaScript	V8 3.17.6.4
Flash	11.7.700.169
User Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.47 Safari/537.36
Command Line	 /opt/google/chrome/google-chrome --flag-switches-begin --sync-keystore-encryption --flag-switches-end
Executable Path	/opt/google/chrome/google-chrome
Profile Path	/usr/local/google/home/danielwong/.config/google-chrome/Default
Variations	853359fa-f7de5af1
5f9f065f-15eb91be
717f26fa-91bf853e
6dcb530d-91bf853e
b03ddc1f-2d9ef0cc
f9b252d0-fd526c81
ca6785ad-766fa2d
ff3fc1a6-766fa2d
7f6da4bf-6ed9dfc1
75f7fb7e-611a9f49
24dca50e-837c4893
ca65a9fe-91ac3782
82d91892-3d47f4f4
3028188e-b9bbd1b6
43cd08ac-ca7d8d80
5a3c10b5-e1cc0f14
244ca1ac-e1cc0f14
5e29d81-cf4f6ead
246fb659-a90023b1
f296190c-7158671e
4442aae2-a90023b1
75f0f0a0-4ad60575
e2b18481-92bb99a9
e7e71889-e1cc0f14

Comment 73 by Deleted ...@, Jul 10 2013

I have always had this issue in every environment I've ever used Chromium, including Awesome WM, Unity2D, and Unity3D. Very annoying.
I confirm it on Gnome Shell as well. System details are as follows:
Chromium	31.0.1650.63 (Developer Build 31.0.1650.63-0ubuntu0.12.04.1~20131204.1) Ubuntu 12.04
OS	Linux 
Blink	537.36 (@163124)
JavaScript	V8 3.21.18.13
Flash	11.2 r202
User Agent	Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/31.0.1650.63 Chrome/31.0.1650.63 Safari/537.36
Command Line	 /usr/lib/chromium-browser/chromium-browser --flag-switches-begin --flag-switches-end
Executable Path	/usr/lib/chromium-browser/chromium-browser

Comment 75 by Deleted ...@, Jul 9 2014

When all window are not maximize, it can be remerge by dragging a tab.

OS UBUNTU 14.04 LTS

Google Chrome	33.0.1750.152 (Official Build 256984) 
OS	Linux 
Blink	537.36 (@169182)
JavaScript	V8 3.23.17.23
Flash	12.0.0.77
User Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.152 Safari/537.36
Command Line	 /usr/bin/google-chrome-stable --flag-switches-begin --enable-accelerated-filters --enable-deadline-scheduling --enable-experimental-canvas-features --force-compositing-mode --ignore-gpu-blacklist --enable-threaded-compositing --flag-switches-end
Executable Path	/opt/google/chrome/google-chrome
Profile Path	/home/taufik/.config/google-chrome/Default
Variations	c70841c8-4866ef6e
3664a344-be9e69ba
24dca50e-837c4893
8d790604-9cb2a91c
5a3c10b5-e1cc0f14
244ca1ac-4ad60575
5e29d81-cf4f6ead
3ac60855-486e2a9c
246fb659-5c63917a
f296190c-48a2334a
4442aae2-75cb33fc
ed1d377-e1cc0f14
75f0f0a0-e1cc0f14
e2b18481-7564fb06
e7e71889-4ad60575
Components: -UI>OSIntegration Internals>PlatformIntegration

Sign in to add a comment