New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Archived
Owner: ----
Closed: Mar 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 3
Type: Bug



Sign in to add a comment

currentTime moves backwards during video play shortly after play is fired.

Reported by schran...@gmail.com, Mar 29 2012

Issue description

Chrome Version       : 18.0.1025.142
OS Version: OS X 10.7.3
URLs (if applicable) : http://scotland.proximity.on.ca/~mjschranz/STR/chromeCurrentTime.html
Other browsers tested: 
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:
  Firefox 4.x:
     IE 7/8/9:

http://scotland.proximity.on.ca/~mjschranz/STR/chromeCurrentTime.html

What steps will reproduce the problem?
1. Press play on the video in the provided URL
2. Pause after a 2+ seconds
3. Scroll down through the reported text and you will see currentTime jump backwards before continuing to move forward.

What is the expected result?
The currentTime advanceds forward.

What happens instead?
At some point it moves backwards in time and then continues forward.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.142 Safari/535.19


 

Comment 1 by schran...@gmail.com, Mar 29 2012

Forgot to write this in the bug but the problem doesn't occur in FF, Safari or Opera.
Cc: alek...@chromium.org
I can't repro on Mac 10.7, gc: Version 19.0.1085.0 canary, I scrolled down through the reported text and I see the currentTime increments as it should. 

schranz.m@ 
- can you attack a screenshot? 
- also, can you try to repro on stable and canary? 

thank you 


Comment 3 Deleted

Comment 4 by schran...@gmail.com, Mar 29 2012

It definitely doesn't seem to be consistent on Canary. I have had it not happen at all, and then have seen it happen like in the two screenshots below.

Either way, I have one provided for stable and 2 for canary.

Hope this helps.
currentTimeChromeStable.png
177 KB View Download
currentTimeChromeCanary1.png
128 KB View Download

Comment 5 Deleted

Comment 6 by schran...@gmail.com, Mar 29 2012

Second screenshot for Canary was incorrect. Playing around with it more and it definitely isn't consistent with the issue.
currentTimeChromeCanary2.png
168 KB View Download
i've tried and tried, but still unable to reproduce the issue. 
do you have another url i can try it on? 
thank you 

Comment 8 by schran...@gmail.com, Mar 29 2012

No I don't as that is a specific test case I wrote to try and separate out the issue from the application I am working on that is experiencing the problem.

I'm wondering if it is a hardware issue then. I'll try to get someone to try it on Canary and see if it persists.

Comment 9 by schran...@gmail.com, Mar 30 2012

Updated the test to make the erroneous results more obvious.
Cc: tweisberg@chromium.org imasaki@chromium.org
Status: Untriaged
schranz.m@ thank you very much for modifying the test, I was able to reproduce the issue on Ubuntu 10.04 stable and canary builds, so is on Mac 10.7 with stable and canary builds. 

This is not a regression. 

Labels: -Area-Undefined Feature-Media
Screenshot-5.png
82.3 KB View Download
Labels: -Pri-2 -Action-FeedbackNeeded Pri-3
Status: Available
Cc: -alek...@chromium.org
Cc: -tweisberg@chromium.org
Cc: -imasaki@chromium.org
Project Member

Comment 17 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Feature-Media Cr-Internals-Media
Labels: Needs-Feedback
Status: Unconfirmed
Is this still an issue? The repro link is down.
Status: Archived
Archiving as the repro link is no longer reachable. If this issue is still repro'ing for you, schranz.m@, please activate & post latest chrome version (ideally M33 or M34) and repro link.

Sign in to add a comment