New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 118715 link

Starred by 11 users

Issue metadata

Status: Fixed
Owner:
Closed: Apr 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug-Regression



Sign in to add a comment

Regression - Can't drag-n-drop Bookmarks in Bookmark Manager

Reported by nunomigu...@gmail.com, Mar 17 2012

Issue description

Chrome Version       : 19.0.1068.1
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
IE 7/8/9:

What steps will reproduce the problem?
1. Open chrome://bookmarks/
2. Try to drag bookmarks to other folders

What is the expected result?
Be able to move bookmarks as usual

What happens instead?
Nothing.

UserAgentString: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/536.3 (KHTML, like Gecko) Chrome/19.0.1068.1 Safari/536.3


 
Mergedinto: 119136
Status: Duplicate
You marked 118715 as duplicate of 119136, but I don't agree. 119136 talks about two windows, and 118715 talks about not being able to drag on Bookmark Manager. Current Dev and Canary have the problem I referred on 118715. I try to drag-n-drop bookmarks there (to move into folders) and I can't. I need to use the Bookmark Bar, and that is inconvenient to me.
Labels: -Area-Undefined Area-UI Feature-Bookmarks
Mergedinto:
Status: Available
Unmerging - I agree this is a separate issue.

I just verified that I can reproduce this (bookmark dragging completely broken) on current Windows canary builds (20.0.1086.0) but not on current Mac dev channel builds (19.0.1084.1).
Cc: ligim...@chromium.org
Labels: -Pri-2 Pri-1
Summary: Regression - Can't drag-n-drop Bookmarks in Bookmark Manager
This seems bad - bookmark dragging is an important feature and it appears to be broken completely on Windows in M19.
Labels: ReleaseBlock-Beta

Comment 6 by laforge@google.com, Apr 2 2012

Cc: pavanv@chromium.org
Owner: anan...@chromium.org
Status: Assigned
Hey Anantha, a regression range here would be very helpful.

Comment 7 by laforge@google.com, Apr 2 2012

Labels: Mstone-19
Labels: -Type-Bug Type-Regression
bisect output for reference -

Revision 125870 is [(g)ood/(b)ad/(q)uit]: b
You are probably looking for build 125870.
CHANGELOG URL:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk
/src&range=125844:125870
Built at revision:
http://src.chromium.org/viewvc/chrome?view=rev&revision=125870

Comment 9 by laforge@google.com, Apr 2 2012

Owner: jhawkins@chromium.org
Hey James, could you take a look at this?
pavanv: Can you please use git bisect to find the regression commit?  No one currently owns bookmark manager, so it would be extremely valuable to know the bad commit.
Cc: arv@chromium.org
@jhawkins, not sure what you mean by git bisect. I don't have chromium built on my machine. 

Additional Note: http://code.google.com/p/chromium/issues/detail?id=117081 - this bookmark manager related issue got fixed very recently. Not sure if its relevant.
Cc: bshe@chromium.org zelidrag@chromium.org
Hey zel@/@bshe, could you perhaps lend a hand w/ this issue?  I see bshe@ recently did a patch recently http://src.chromium.org/viewvc/chrome?view=rev&revision=129962 that affected both the JS and bookmark maanger.  I understand that probably was not the cause of the regression, however it looks like Biao probably has the expertise to quickly debug the issue.
Owner: rbyers@chromium.org
Status: Started
I can look into this if there's no owner.  I recently got bookmark manager DnD working on CrOS (first thing I did is verify this broke on Windows before I made any of the CrOS changes <grin>).
I can look into this if there's no owner.  I recently got bookmark manager DnD working on CrOS (first thing I did is verify this broke on Windows before I made any of the CrOS changes <grin>).
Cc: jam@chromium.org
Looking at the revision range, I strongly suspect this regression was caused by:
r125869: Enable TabContentsViewWin by default on Windows.  There is a bunch of complicated DnD-specific plumbing in TabContentsView* that is used ONLY by the bookmarks manager, and apparently no tests that validate bookmark DnD.

I'm getting a windows dev environment setup now to debug further.  John, to what extent is it reasonable to consider TabContentsViewWin back off for M19 at this point?

Comment 17 by jam@chromium.org, Apr 3 2012

Owner: jam@chromium.org
(just saw this after rybers alerted me to it; I don't read bug mail because of the huge volume of email that I get)

I'll take a look at this since it's my fault.

Comment 18 by jam@chromium.org, Apr 3 2012

Labels: Merge-Requested
Status: Fixed
Labels: -Merge-Requested Merge-Approved
Project Member

Comment 21 by bugdroid1@chromium.org, Apr 4 2012

Comment 22 by dhw@chromium.org, Apr 7 2012

In Windows Canary 20.0.1092.0 (Official Build 130835), using Bookmark Manager to drag a
bookmark to a new location, and then releasing the left-mouse button to drop the bookmark,
that bookmark URL is automatically loaded into the current/Bookmark Manager tab.  Instead,
the bookmark should be redrawn in its new position, and the page should not auto-load.

Re-open or open new bug?

Comment 23 by dhw@chromium.org, Apr 11 2012

Comment 22 is now tracked in  Issue 123051 

Comment 24 by Deleted ...@, May 21 2012

FYI - here too we are observing this problem on a MacBook running OSX 10.6.8, Chrome version 19.0.1084.46, whereby Chrome's bookmark Manager is copying the bookmark rather than moving the item when you drag and drop it.
Cc: mbollu@chromium.org
@Mrudula .. Can u confirm this in Mac 10.6

OS: Mac 10.7.3
Chrome 21.0.1145.0 dev

Findings: Unable to reproduce Comment 22 & 24 on above chrome version and will update the bug with results for Mac 10.6.8 in few min's.
OS: Mac 10.6.8
Chrome: 21.0.1145.0 canary

I am unable to reproduce it on above chrome version.

Comment 28 by Deleted ...@, Aug 4 2012

I'm getting this problem in verison - 21.0.1180.60

Comment 29 by k...@google.com, Aug 8 2012

Labels: -Merge-Approved
Remove merge approval label, this release has passed.

Comment 30 by Deleted ...@, Aug 12 2012

Can not to organize bookmarks using drag-drop in 21.0.1180.75. No drag-drop function in bookmarks manager nor bookmark bar

Comment 31 by Deleted ...@, Oct 1 2012

I cannot organize my favorites in Chrome. When you drag and drop a bookmark it snaps back to the original location. Also there is no sort by name function so I have folders sitting in the middle of normal bookmarks on the drop down its annoying
Project Member

Comment 32 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Type-Regression -Area-UI -Feature-Bookmarks -Mstone-19 Type-Bug-Regression Cr-UI-Browser-Bookmarks Cr-UI M-19

Comment 33 by qubo...@gmail.com, May 27 2015

This issue is present in Chromium	43.0.2357.65 (Developer Build) (64-bit)
Revision	bbd9270c4234d436bb05bd4502b230fc17887d08
on Arch Linux.

Sign in to add a comment