Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 80 users
Status: Fixed
Owner:
Closed: Apr 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
HTTPS/Certificate websites always have "Invalid Server Certificate" Error
Reported by b...@kulbertis.org, Mar 16 2012 Back to list
Chrome Version       : 19.0.1068.1 (Official Build 126852) dev-m
URLs (if applicable) : https://google.com/
https://facebook.com/
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: Untested
  Firefox 4.x: Ok
       IE 7/8/9: Ok

What steps will reproduce the problem?
1. Request any webpage using https

What is the expected result?
The browser would accept the certificate because it actually is valid and the page would load normally.

What happens instead?
Chrome displays an error claiming the website's certificate in invalid (see attached screenshot)

Please provide any additional information below. Attach a screenshot if
possible.

 
invalidservercertificate.PNG
64.4 KB View Download
Cc: palmer@chromium.org
Labels: -Type-Bug -Area-Undefined Type-Security Area-Internals Internals-Network-SSL
Hi ben, thanks for filing this report.

The screenshot you provided has the error for google.com, so thanks for including that. I had a question about the Facebook error you're reporting, and wanted to see if it's the same as the google.com error or something different.

Could you see if Issue 117834 / http://code.google.com/p/chromium/issues/detail?id=117834 matches what you're seeing? Or are you indeed seeing the "Invalid Server Certificate" error when you try to access https://facebook.com / https://www.facebook.com ?
Comment 2 by b...@kulbertis.org, Mar 17 2012
The Facebook error is identical to the Google one. All sites I have tried so far that use https have the same "Invalid Server Certificate" error. That issue you linked, Issue 117834, is not the same as the issue I am experiencing.
Comment 3 by jsc...@chromium.org, Mar 18 2012
Labels: -Type-Security Type-Bug Feature-Security
Comment 4 by palmer@chromium.org, Mar 19 2012
Ben, could you please send us details on the certificate chain you're seeing? Click on the padlock (in the Omnibox/URL bar) that has the red X on it. That will bring up a pop-up screen that tells you about the certificate and its problem. You can then click on "Certificate Information" to get more information. If you could send us that information, it would help.
Comment 5 by b...@kulbertis.org, Mar 20 2012
I'm not sure of the best way to send you this information, but I've included the certificate files if that helps. The errors I am seeing throughout this process says things such as:

On the "red x" popup:
- Server's certificate is invalid
- The server certificate contains a weak cryptographic key.

On the the certificate information screen:

General Section:
- The integrity of this certificate cannot be guaranteed. The certificate may be corrupted or may have been altered.

Certification Path:
- This certificate has an invalid digital signature. (On all three certificates)

Please let me know if I can provide any more information.
Google.cer
805 bytes Download
Facebook.cer
976 bytes Download
Comment 6 by palmer@chromium.org, Mar 20 2012
Cc: rsleevi@chromium.org
Hi Ben, Yes, attaching the .cer files is perfect for us. Thank you!

Your certs are byte-for-byte identical to the ones I am seeing for https://www.google.com and for https://www.facebook.com, but I don't get an error. Therefore, I suspect the error is higher up in the chain of certificates. Could you please send us all the certificates in the chains you are seeing?

Are you on a network that is managed by some kind of data-loss prevention system, IDS, or the like?
Additionally, do you have any trouble when you use Internet Explorer?
Comment 8 by b...@kulbertis.org, Mar 20 2012
Google Certs:
- Google Internet Authority
- Geotrust or Equifax Secure Certificate Authority

Facebook Certs:
- VeriSign Class 3 Public Primary CA 1 (Directly above *.facebook.com)
- VeriSign Class 3 Public Primary CA 2 (Directly above VeriSign Class 3 Public Primary CA 1)

The network I am having this issue on is a standard home network configuration, so nothing out of the ordinary like data-loss prevention system or IDS.

I have no issues with Internet Explorer. All https sites I have tried including google.com and facebook.com have no issues in it.

Thanks for your continued help on this!
Geotrust_or_Equifax Secure Certificate Authority.cer
804 bytes Download
VeriSign Class 3 Public Primary CA 2.cer
576 bytes Download
VeriSign Class 3 Public Primary CA 1.cer
903 bytes Download
Google Internet Authority.cer
692 bytes Download
Thanks for the additional info Ben.

Two follow-ups:
1) Which version of Windows are you on?
2) It sounds like you may possibly be running into a variation of http://crbug.com/117834

Could you see the diagnostic steps in that bug? Note it makes references a previous version of the issue, Issue 114709, which also had some diagnostic steps (Comments #1, #34, and #38 also have some steps)


Comment 10 by agl@chromium.org, Mar 20 2012
All those certificates appear to be fine so I can't think why we would think that they are invalid. Could I ask you to get a net-internals log?

First, please read chrome://net-internals/help.html to understand a bit about the process that we'll be using.

As it notes, it's possible for private information to appear in the log, but the following steps are designed to minimize this. Feel free to edit the final logs to remove any private information; however, please realize that removing some information (such as certificates or the IP addresses of servers) may make it difficult to diagnose the problem.

1) Close all Chrome tabs and windows. This will close Chrome (and these instructions, if viewing in Chrome).
2) Launch Chrome. You should only have a single tab open at this time. This is important, because in order for these tests to get the information they need, you should not load Facebook yet. If your homepage is Facebook, you may need to temporarily change it so that Facebook does not load when you start Chrome.
3) In a new tab, enter chrome://net-internals
4) On the left-hand side, click Capture
5) Click the checkbox "Include the actual bytes sent/received (may result  
in huge logs)."
6) Click "Delete all captured data".
7) In a new tab, load https://www.google.com
8) Go back to the chrome://net-internals tab and click "Export" on the left-hand side.
9) Enter "crbug.com/118706" in the text box (any text will do)
10) Click "Dump to file".
11) A file will have been "downloaded". Please attach it to this bug. 
Note: As of the Chrome 19 Dev Channel (which you indicated you were on), you no longer need to do step 5 in agl's comment #10. This should make it much easier to capture and attach the data.
Comment 12 by b...@kulbertis.org, Mar 21 2012
I am running Windows 7 x64

Attached is my net-internals log.
a6a4f9a8-23bc-421b-a4e4-7a101b160da3
103 KB View Download
Thanks Ben!

One more follow-up, before you try the steps from Issue 117834

Can you attach the data (either copy/paste or as a new file) the results from chrome://view-http-cache/sslhostinfo:www.google.com (you will need to paste that URL/enter it directly)
Oh, also chrome://view-http-cache/sslhostinfo:ssl.gstatic.com
Comment 15 by b...@kulbertis.org, Mar 21 2012
Attached is the sslhostinfo:www.google.com results.

chrome://view-http-cache/sslhostinfo:ssl.gstatic.com returned "no matching cache entry for: sslhostinfo:ssl.gstatic.com"

I attempted the steps from Issue 117834 and none were able to fix the issue. I did, however, install the canary build (19.0.1075.0 canary) and the issue was not present, https://google.com and https://facebook.com/ loaded normally.
sslhostinfo www.google.com.htm
9.7 KB View Download
Thanks for your continued patience in trying to identify and resolve this issue, Ben.

While I'm glad to hear that Canary is not demonstrating any problems, I'm still rather concerned about what you're experiencing with Dev, and that it consistently happens. I would love to be able to identify the fix and resolve it for both you and any other affected Chrome/Chromium users.

I was hoping I might try one further step of diagnostics. Unfortunately, this is a bit of Windows' diagnostics, rather than Chrome, so it's not exactly pretty or easy.

Microsoft has provided a document describing how to enable CryptoAPI 2.0 diagnostic logging at http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18844 . If you can enable logging as described on Pages 9 and 10, that would be fantastic. Please see the note about increasing the log size - I'd suggest 4 - 10 MB.

Even better would be if you could enable Level 5/Verbose debugging (described on Page 14), but I understand if you don't have sufficient privileges.

After you enable logging, repeat steps 1, 2, and 7, as agl@ documented in comment #10. After doing this, save the Windows log as described on Pages 9 and 10 of that document. For size reasons, please feel free to e-mail directly to rsleevi@chromium.org if it ends up being too large to attach - although I believe up to 10 MB is permitted as a bug attachment.

Again, sorry you're having this issue, and hopefully we'll be able to trace it down! Thanks!
I just had this issue (with any site over HTTPS). Removing then installing the Dev channel version again from the web resolved it.
Canary began experiencing this issue yesterday for me.
Hmmm, happened again after reboot. Remove, install again and the problem goes away. 
Downloaded offline installer if this keeps happening.

Dev build 1068.1, Win 7.
To pinpoint the cause of the problem a bit more... 
After I get "Invalid Server Certificate" message for any HTTPS site, I uninstall Chrome but keep profile data. Reinstall from offline installer and everything is fine until Chrome pulls some data from the Internet. It usually syncs my profile at this point so it is not obvious what else it is downloading.
I could use Fiddler or something similar to see what's going on. Happens every time, though.
Comment 21 by agl@chromium.org, Mar 23 2012
alen.siljak: please see #16 for how to collect debugging information from CryptoAPI. We would be very happy to see this from someone who can reproduce this bug.
I did a fresh install of Dev build and the issue is reproducible again. The first run, right after the browser is installed ran just fine. Here are the logs for comparison. 
Attachments are limited to 10MB per post so the second run comes next.
1st run, d6211c94-6d29-4a45-b207-76029a3637db
5.1 MB View Download
first run. works fine.evtx
1.1 MB Download
After the first run I closed Chrome, opened again and did exactly the same steps, as outlined in #10.
Btw, I left the CAPI logs at default 1MB. If that turns out to be a problem, let me know. 

Attached are all logs, this time compressed with 7 Zip.
BothRuns.7z
2.1 MB Download
Thanks for providing this, alen. This is incredibly helpful in trying to determine the root cause!

A follow-up question for you: If you run Chrome with "--user-data-dir", as described on http://www.chromium.org/user-experience/user-data-directory, and point it to a separate directory, does that resolve the issue (even if temporarily)?

And am I correct in understanding that IE and other Windows applications show no signs of having issues?
Just a quick answer to your second question. You are right regarding other
browsers not having issues. I used Firefox in parallel without any issues.
Also, everything is fine with current Chrome Beta. Beta required a fresh
user profile, of course. So, I noticed the issue only with upgrade to Dev
1068.1.

As for your first question, I'll answer that a bit later when I get to a PC.
rsleevi, your guess was spot on. Switching user directory (to c:\temp, for example) does provide a solution. I can open web sites via HTTPS.
Close Chrome, reopen. 
Trying to access https://www.google.com results in Invalid Server Certificate.

Clearing the profile directory (c:\temp) fixes the problem.

This happens on Dev 19.0.1077.3.
When I say that "clearing the profile directory fixes the problem", I mean that it goes back to the initial state. The issue with 'invalid certificate' appears again after browser restart.
I can confirm I have the same problem

It appears that if I delete "chrome_shutdown_ms.txt" from the User Data folder then all websites open correctly (gmail, etc).  However, the problem reappears upon restarting the browser since the file is recreated on exit.
Confirmed here. If there is no chrome_shutdown_ms.txt on browser start, loading sites via HTTPS works fine. If the file is there, the issue appears.

Tried with a blank new profile as well as copying the profile from Beta version that had the .ms file in it. Also tried playing around with the values inside the file manually but that did not make a difference.
alen, vdesai: Thank you for that very interesting piece of information. I'm guessing both of you have restarted your computers at some point since first discovering this issue?

If not, could you try rebooting your machines completely (eg: not hibernating/suspend), and let me know if removing chrome_shutdown_ms.txt still causes corruption?
I rebooted again.  Once without deleting the file and then after deleting the file.  No luck with either attempt.  
vdesai: Thanks. I just wanted to make sure I understood you correctly. You're saying now that you've rebooted, deleting the file makes no difference, and sites consistently return errors, is that correct?

Or is it still working as you described in comment #28?
sorry for the confusion.  it is occurring exactly the same as comment 28 (nothing changed with rebooting the computer)
vdesai: And what version of Chromium and Windows are you running?
vdesai: Thanks for your continued help in investigating this. This is a very strange bug, and it's a bit baffling why chrome_shutdown_ms.txt should have any effect on how SSL is working.

I'm wondering, with the chrome_shutdown_ms file in place, do the following:
1) Start a new command prompt (on Windows 7, Start then search for "Command Prompt". On earlier versions, Start -> Run -> "cmd")
2) type "set CHROME_ALLOCATOR=winheap" (without quotes) and press Enter/Return
3) Launch Chrome by typing in the full command (eg: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" - this time, WITH quotes). You can determine the path by right clicking on the Chrome shortcut, clicking Properties, and on the "Shortcut" tab, copying all of the text from the "Target" - including any quotes or command-line parameters.

With this, please let me know if you still have trouble browsing, if Chrome crashes, and if deleting the file and repeating Steps 1-3 make any difference.
I did steps 1-3 and the problem still occurs just as before.

I switched to the canary build in hopes of a quicker fix (19.0.1084.1 canary).  Win 7 x64.
It seems the stable build (v18) of chrome does not have this problem.  It happens with the dev and canary channels as far as I can tell.  Perhaps there is some sort of added security check or bug in v19
Hi,

I also did the steps from #35 and can confirm that the browser behavior after setting the CHROME_ALLOCATOR and running from the same context is the same as before. The Invalid Server Certificate error pops up when trying to access https://google.com.
Deleting the chrome_shutdown_ms file and running the browser in the same manner as earlier (same command prompt) fixes the issue. The site opens with HTTPS immediately.

Chrome did not crash at any occasion.

vdesai: I noticed the bug right after the update from the previous version of Dev channel to the one reported in the initial post (1068.1). Literally after restarting the browser to upgrade I started noticing this behavior.

I am currently on 1077.3. Deleting the chrome_shutdown_ms.txt file prior to running the browser makes it work ok. The fact that this text file has anything to do with accessing sites via HTTPS sure is weird. :)

Don't know if this will help but it sure won't hurt. These are the contents of my console window after running the above test. In between the two invocations of Chromium, I ran my batch file that deletes the mentioned text file.


Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Alen Siljak>set CHROME_ALLOCATOR=winheap

C:\Users\Alen Siljak>"C:\Users\Alen Siljak\AppData\Local\Google\Chrome\Applicati
on\chrome.exe"

C:\Users\Alen Siljak>"C:\Users\Alen Siljak\AppData\Local\Google\Chrome\Applicati
on\chrome.exe"

C:\Users\Alen Siljak>
Project Member Comment 40 by bugdroid1@chromium.org, Mar 29 2012
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=129725

------------------------------------------------------------------------
r129725 | rsleevi@chromium.org | Thu Mar 29 16:38:27 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate_openssl.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate_mac.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/http/http_response_info.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate_nss.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate_win.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate_unittest.cc?r1=129725&r2=129724&pathrev=129725
 M http://src.chromium.org/viewvc/chrome/trunk/src/net/base/x509_certificate.h?r1=129725&r2=129724&pathrev=129725

Cache certificates as DER on all platforms.

With the exception of Windows, every other platform was
already serializing as a DER chain. Update Windows to no
longer serialize in a proprietary format - use DER on all
platforms.

BUG=118706
TEST=existing unit tests

Review URL: https://chromiumcodereview.appspot.com/9808094
------------------------------------------------------------------------
Comment 41 by Deleted ...@, Apr 6 2012
I'm having the exact same issues (i have read whole thread) and can also confirm that deleting chrome_shutdown_ms.txt before launching chrome fixes the problem until next restart.

I just don't know what to do with post #40. Is this a fix? Or just a confirmation that there is a bug?
Comment 42 by Deleted ...@, Apr 6 2012
i'm having same issue. i use google chrome and i can't get any access to google related website including gmail.
Comment 43 by Deleted ...@, Apr 6 2012
i'm having same issue. i use google chrome and i can't get any access to any https site.
please advise
Comment 44 by Deleted ...@, Apr 6 2012
I am also having the same issue as everyone
Comment 45 by Deleted ...@, Apr 6 2012
OS Windows 7 x64
Chrome Version 18.0.1025.151

I am getting a similar issue with version 18 of chrome. Following comment 24 has resulted in apparent success and I haven't progressed further.
I have attached my results below.
Chrome Certificate.cer
805 bytes Download
Chrome Certificate Working.cer
810 bytes Download
Comparing --user-data-dir on left.png
249 KB View Download
Comment 46 by Deleted ...@, Apr 6 2012
I may have been premature: https certificate failure was replicated.
Chrome Certificate Broken.cer
889 bytes Download
Comment 47 by Deleted ...@, Apr 6 2012
i just started having this issue 10 min ago out of the blue, now i'm in the red ;(
Comment 48 by Deleted ...@, Apr 6 2012
Having this issue as well. Installed latest Chrome version(18.0.1025.151 m), problem still exists. Removed all Chrome chache, problem still exists.
Comment 49 by Deleted ...@, Apr 6 2012
Uninstalled Chrome, reinstalled, no issue at this moment.
Comment 50 by Deleted ...@, Apr 6 2012
Jeese... closed and restarted Chrome just 30 seconds later and the issue is back.
Comment 51 by gon...@gmail.com, Apr 6 2012
Having the same problem, running Chrome version 18 on Windows 7 64-bit. Comment 24 solves it in the short term, but the problem comes back after a restart.
Cc: -rsleevi@chromium.org rvargas@chromium.org
Labels: -Pri-2 Pri-1 OS-Windows
Owner: rsleevi@chromium.org
Status: Assigned
We suspect that http://src.chromium.org/viewvc/chrome?view=rev&revision=114740 and http://src.chromium.org/viewvc/chrome?view=rev&revision=129725 (comment #40) resolve this bug, but are not yet sure.
For everyone who just started encountering this issue: In order to be able to identify and quickly resolve, can you please list the following:
1) The contents of chrome://version (you can copy and paste here or attach a saved copy)
2) What version of Windows you're running (Windows XP? Vista? 7?)
3) If there are any conflicts listed under chrome://conflicts
  a) Can you also attach your copy of Chrome conflicts to this bug (Right Click the page -> Save As / click the Wrench -> Save Page As / Press Control and S keys at the same time)
4) If removing "chrome_shutdown_ms.txt", as described in comments #28 and #29 has any effect.
Comment 54 Deleted
Comment 55 by blur...@gmail.com, Apr 6 2012
1) Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\Phil\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\Phil\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Phil\AppData\Local\Google\Chrome\User Data\Default

2) Windows 7 Ultimate 64bit

3) No conflicts listed, my conflicts.html page is attached

4) I'm actually running Chrome not chromium, but I understand the build should be the same...? I don't have the .ms file in my user data folder.
conflicts.htm
239 KB View Download
Comment 56 by Deleted ...@, Apr 6 2012
1) 
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\Windows\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\Windows\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Windows\AppData\Local\Google\Chrome\User Data\Default

2) Windows 7 Ultimate 64bit

3) Modules (101) - No conflicts detected

4) I confirm that removing "chrome_shutdown_ms.txt" does in fact fix the issue. Also it does not matter what is written in the .txt even if I delete the text in it to nothing or write something like "I like pie" it still has the issue.


Comment 57 by Deleted ...@, Apr 6 2012
bluremi, the reason you cannot find the "chrome_shutdown_ms.txt" is because chrome does not create the file until it is closed/shutdown. Try closing chrome and then open up your User Data folder. You should be able to find it then.
Comment 58 by Deleted ...@, Apr 6 2012
1)
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\Kiwtu\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\Kiwtu\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Kiwtu\AppData\Local\Google\Chrome\User Data\Default

2) Windows 7 Ultimate 64bit

3) No conflicts, File attached anyway.

4) Confirmed, deleting "chrome_shutdown_ms.txt" solves the issue, but once chrome is closed the file reappears.

conflicts.htm
237 KB View Download
Comment 59 Deleted
Comment 60 by Deleted ...@, Apr 6 2012
Hi I started to have the same problems few hours ago. 

1)
Google Chrome	18.0.1025.151 (Virallinen koontiversio 130497) m
Käyttöjärjestelmä	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,228
User agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Komentorivi	"C:\Users\Otto\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Suoritettavan tiedoston polku	C:\Users\Otto\AppData\Local\Google\Chrome\Application\chrome.exe
Profiilin polku	C:\Users\Otto\AppData\Local\Google\Chrome\User Data\Default

2) Windows 7 Ultimate 64-bit

3) No conflicts

4) Removing chrome_shutdown_ms.txt helped.
Comment 61 by gon...@gmail.com, Apr 6 2012
1) Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\172659\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\172659\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\172659\AppData\Local\Google\Chrome\User Data\Default

2) Windows 7 64-bit.

3) No conflicts, file attached.

4) Yes, that fixed it. As does temporarily changing the user root directory as directed in Post 24.
conflicts.htm
253 KB View Download
Cc: kareng@google.com
The really strange thing about the chrome_shutdown_ms.txt file is that it should be completely unrelated to the problem here. However, if the file does exist on startup, the browser FILE thread will be delayed for a small time while the shutdown file is read. If the file doesn't exist, things on the FILE thread might be fractionally quicker on startup ... hmmmmm.
Comment 64 by Deleted ...@, Apr 6 2012
I noticed the same thing. What is the point of the chrome_shutdown_ms.txt file any way?
Cc: -kareng@google.com karen@chromium.org
Comment 66 by Deleted ...@, Apr 6 2012
I can confirm deleting chrome_shutdown_ms.txt temporally solves the issues.

Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\foocampo\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\foocampo\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\foocampo\AppData\Local\Google\Chrome\User Data\Default

Windows 7 64 bits

No conflicts

Deleting chrome_shutdown_ms.txt fixes the issue, but must be deleted everytime I want to start chrome.
Labels: Hotlist-ConOps
We are getting an increase of these reports in the Chrome help forum and are collecting the information as listed in #53 above from users. I'll post back here with what we hear from users.

Ryan, 
Is there more information (apart from #53) that we should get to help investigate?

Here are some of the forum threads for reference:
https://groups.google.com/a/googleproductforums.com/forum/#!topic/chrome/_GXgRj0b56g
https://groups.google.com/a/googleproductforums.com/forum/#!msg/chrome/yHclY2CexIE/9xlLnavEGnAJ
https://groups.google.com/a/googleproductforums.com/forum/#!topic/chrome/1alZsHEeprc
Comment 68 Deleted
Sie (and everyone encountering these problems who has already provided the information from Comment #53. If you haven't done #53 yet, please do that first)

Can you please try the steps from this bug: http://code.google.com/p/chromium/issues/detail?id=73243 / Issue 73243, which involves disabling certain shell extensions. After you have disabled all third-party shell extensions, can you please retry steps comment #53?
Issue 122341 has been merged into this issue.
http://code.google.com/p/chromium/issues/detail?id=118706#makechanges

Ryan,

I also get no conflicts listed. Attached are the conflicts (conflicts.htm) and version files.
19.0.1084.15 (Official Build 130829) dev-m
Windows 7, Ultimate edition, 64-bit

And, yes, I'm still using the workaround with deleting the ms file and everything works just fine that way.

I have also tried disabling 3rd party shell extensions. In that case I get "Error 7 (net::ERR_TIMED_OUT): The operation timed out." Reloading the page brings back the Invalid Server Certificate. Trying a different site brings the Invalid Server Certificate the first time.
Attaching conflicts file (conflicts2.htm) when the extensions are disabled.
Just noticed that one extension can't be disabled: Bluewire General Property Sheet, C:\Windows\system32\BWContextHandler.dll. No idea what that is or what it belongs to.

Conflicts3 is after enabling the extensions and deleting the ms file.
conflicts3.htm
233 KB View Download
About Version.htm
7.9 KB View Download
conflicts.htm
278 KB View Download
conflicts2.htm
235 KB View Download
Comment 72 by Deleted ...@, Apr 7 2012
Been having this same problem since this morning.
Windows 7
Chrome 18.0.1025.151
Message: Invalid Server Certificate 
No problems with IE or Firefox.
Message appears for all secure sites. Cannot access igoogle, gmail, yahoo mail, etc.
Having the same issue as everyone else here:
1) 
Google Chrome	19.0.1084.15 (Official Build 130829) dev-m
OS	Windows
WebKit	536.5 (@113215)
JavaScript	V8 3.9.24.7
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.15 Safari/536.5
Command Line	"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Matt Materniak\AppData\Local\Google\Chrome\User Data\Default

2) Win 7 Ultimate x64

3) Modules (119) - No conflicts detected

4) Removing chrome_shutdown_ms.txt fixes
Comment 74 Deleted
Comment 75 Deleted
Comment 76 Deleted
Comment 77 by Deleted ...@, Apr 7 2012
Same issue here...it started a few hours ago. 
Read this hole thread...half of it could't understand but still made an idea over the bug. I don't know how to use the fix provided in #40, could you detail that a little, please?
Google Chrome: 18.0.1025.151 (Official Build 130497)
OS: Windows 7 Ultimate x64
WebKit: 535.19 (@113052)
JavaScript: V8 3.8.9.16
Flash: 11,2,202,229
No conflicts
removing the txt file fixes
To all the ideas I might add that I tried to manually export/import all the trusted certificates from my laptop (which doesn't encounter this problem (yet)) to my PC and when I tried to install the certificates everything went OK, it said that import was finished but when I looked in the trusted certificates tab in Chrome there were NONE. After reinstalling several times, I noticed that on chrome's first run all trusted certificates are present, after restarting (Chrome) they're all gone. Using the "deleting txt file" solution brings them back until next restart when they're gone.
Comment 78 by Deleted ...@, Apr 7 2012
Hey, I came up with an idea. I'm not really good at programming but I reminded how to create a batch file that deletes any file you point it at doing so. The tricky part now, is, I don't know how to edit chrome.exe or to make another batch that runs both my "deleting batch" and chrome after that. I think this could be an "easy" patch, since deleting that text file solves the actual problem. The developers should cover the rest. Is there anybody here that knows how to make my idea work? I tried google-ing it but I ended up reading smartasses' comments on how dangerous this is...bla bla
While I loathe to recommend this action, I notice that everyone who is running who has been kind enough to attach their chrome://conflicts (please follow that step in #3 and attach, it's very helpful in trying to identify commonalities), would someone be willing to try and upgrade to Windows 7 SP1? You can do this by clicking Start -> All Programs -> Windows Update ( https://www.update.microsoft.com ). 

While I continue to investigate the commonality between people reporting this, and have not yet been able to reproduce under a variety of test environments running a variety of Windows 7 x64 versions - both flavours like Home vs Professional and versions like RTM vs SP1, it would be very useful to eliminate Windows 7 SP1 from the candidate list. Windows 7 SP1 has a number of very important security fixes for Windows, so you're generally doing yourself a favour by running the free security update.

I appreciate everyone's patience as we try to understand what is affecting users machines and what can be done to work around it. Please continue to star this bug for updates, and your continued assistance is most helpful in identifying the root of this.
Comment 80 by Deleted ...@, Apr 7 2012
having the same issues here with getting onto all web sites its giving me this security error  and it was okay last night here at work but I guess after you're new upgrade and me just signing on here today for the first time I'm seeing this problem need fixed cause I need this browser for work too..thanks
securityissue.bmp
2.3 MB Download
Comment 81 by Deleted ...@, Apr 7 2012
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Documents and Settings\tech271\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Documents and Settings\tech271\Local Settings\Application Data\Google\Chrome\Application\chrome.exe
Profile Path	C:\Documents and Settings\tech271\Local Settings\Application Data\Google\Chrome\User Data\Default


windows XP version 5.1 service pack 3


Modules (148) - No conflicts detected
conflicts.htm
217 KB View Download
Hi Darlene, thanks for attaching your details. It's possible that you may be running into http://code.google.com/p/chromium/issues/detail?id=117834 / Issue 117834 instead.

To determine if that's the case, can you follow the steps from http://code.google.com/p/chromium/issues/detail?id=114709#c1 and follow-up here? Thanks!

Comment 83 by Deleted ...@, Apr 7 2012
rsleevi, I don't know if this has anything to do with this issue, but there's a chance that it might. Right before this started occuring, I could not log onto my university's wireless network from my laptop. It always connected automatically, but suddenly it was not. I checked that it was not a signal issue and that it was not an issue with the adapter or anything - I could still log onto my home wireless network and log onto my university's wireless through my phone. Windows kept asking me for my username and password, and did not accept it after multiple attempts. I tried removing and adding the wireless network, which did not solve the issue. The point I am trying to make is that my school uses a certificate for authentication for that network so it could actually be related to this issue with Chrome. I am running on Windows 7 and IE is having no issues. My school's network is called Purdue University's airlink or PAL 2.0 so you can look up the specifics of the certificate. If these turn out to be related, then the issue may not affect only Chrome but wireless network authentication too.
Comment 84 by Deleted ...@, Apr 7 2012
Just an addition to my previous post, my university's wireless uses a Thawte Premium Server CA as a trusted root certification authority to validate the server certificate.
Comment 85 by Deleted ...@, Apr 7 2012
okay here are my screen prints for what you asked but i did not do that enable logging thing since this is my work computer n not home
certpath.bmp
2.3 MB Download
Comment 86 by Deleted ...@, Apr 7 2012
here's the 2nd one
certinfo.p7b
659 bytes Download
Hi Darlene,

What you're encountering appears to be http://code.google.com/p/chromium/issues/detail?id=120715 / Issue 120715 . While I can understand the similarity to this issue, you're in luck, as Issue 120715 is a well understood issue. Please see that bug and post any questions you may have to it, but the summary is that the location you're at appears to have an SSL filter in place that does things insecurely. The systems/network administrator should  upgrade the proxy to a secure version to resolve this.

Cheers!
Comment 88 by Deleted ...@, Apr 7 2012
well then i may be shit out of luck here then with that..lol

Hi I am also facing the same issue as mentioned in above posts. meanwhile am not able to find that "chrome_shutdown_ms.txt" file also in user data. so not even getting the temporary resolution. could anyone please help!!!1
Comment 90 by Deleted ...@, Apr 7 2012
I'm having this exact issue also.  Working fine last night when I shut down, now can't get to anything https including all Google sites, Facebook, Twitter, etc.

- Version: 18.0.1025.151
- OS: Windows 7 64bit 
- No conflicts listed in "chrome://conflicts"
- "chrome_shutdown_ms.txt" does not exist in user profile
- cleared cache and cookies did not help
- other browsers running just fine

I have also tried disabling all Extensions (AdBlock and AVG Safe Search) to no avail.  I have another computer, same OS, same network, same browser version, working fine with Chrome on the same sites.
Hi.I'm also having the same issue.
Deleting of the "chrome_shutdown_ms.txt" fixes it.
So I created a tiny batch file. If someone needs it, you should just put it into the "c:\Users\%USERNAME%\AppData\Local\Google\Chrome SxS\Application\" and start it instead of chrome.exe.
It will remove txt at first and then launch chrome.
del_bug.bat
59 bytes View Download
I think I might be the first to report into this thread using Mac OSX (unless I searched this thread using bad keywords)- I was sent here by https://groups.google.com/a/googleproductforums.com/forum/#!msg/chrome/_GXgRj0b56g/gPOn5gCijwEJ 

To answer rsleevi's questions (comment #53):
1) Google Chrome	18.0.1025.151 (Official Build 130497)
OS	Mac OS X
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11.2.202.229
User Agent	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	 /Applications/Google Chrome.app/Contents/MacOS/Google Chrome -psn_0_7288563 --flag-switches-begin --enable-experimental-extension-apis --flag-switches-end
Executable Path	/Applications/Google Chrome.app/Contents/MacOS/Google Chrome
Profile Path	/Users/craigflannagan/Library/Application Support/Google/Chrome/Default

2) System Version:	Mac OS X 10.6.8 (10K549)
  Kernel Version:	Darwin 10.8.0

3) chrome://conflicts does not seem to do anything for me, I only get "Error 300 (net::ERR_INVALID_URL): Unknown error."

4) I don't think I actually have that text file on Mac OSX (I tried spotlight search, nothing turned up)

Additional Notes: 
This issue only happens for me when visiting http://penfed.org. 
UNLIKE OTHERS, I'm able to visit https://www.facebook.com and https://www.google.com with NO issues.





Screen shot 2012-04-07 at 7.30.51 AM.png
105 KB View Download
Screen shot 2012-04-07 at 7.30.20 AM.png
58.6 KB View Download
Forgot to mention that the issue when visiting penfed.org occurs only with Chrome. No issue if using Firefox. 
Comment 94 by Deleted ...@, Apr 7 2012
1: 
Google Chrome	20.0.1093.0 (Officiële build 131102) canary
Besturingssysteem	Windows
WebKit	536.6 (@113380)
JavaScript	V8 3.10.0.5
Flash	11,2,202,229
User-agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.6 (KHTML, like Gecko) Chrome/20.0.1093.0 Safari/536.6
Opdrachtregel	"C:\Users\Serge\AppData\Local\Google\Chrome SxS\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Uitvoerbaar pad	C:\Users\Serge\AppData\Local\Google\Chrome SxS\Application\chrome.exe
Profielpad	C:\Users\Serge\AppData\Local\Google\Chrome SxS\User Data\Default

2. Windows 7 ultimate 64bit

3. Modules (115) - no conflicts

4. removing the file solves the problem until i restart the browser again

-------------------------------------------------------

1: Google Chrome	18.0.1025.151 (Officiële build 130497) m
Besturingssysteem	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User-agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Opdrachtregel	"C:\Users\Serge\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Uitvoerbaar pad	C:\Users\Serge\AppData\Local\Google\Chrome\Application\chrome.exe
Profielpad	C:\Users\Serge\AppData\Local\Google\Chrome\User Data\Default

2: Windows 7 ultimate 64bit

3; Modules (106) - no conflicts detected

4: deleting the file resolves the problem until i restart the browser



conflicts canary.htm
241 KB View Download
conflicts.htm
242 KB View Download
Comment 95 by Deleted ...@, Apr 7 2012
I have found that this can be temporarily fixed if, after opening Chrome and getting the errors, open Task Manager.  On the Processes tab, find the Chrome.exe process using the highest amount of memory.  Right-click that process and choose End Process TREE.  Confirm and wait for all Chrome.exe processes to disappear, then open Chrome and it works fine.  Sadly, if you close and reopen it again, the error returns, but can be fixed again with that same trick.
@rockto: This is merely killing Chrome and therefore preventing the creation of the mentioned ms text file.

Quick workaround for those who just want Chrome to work (until a proper fix has been found) - put the next two line in a batch file (.cmd) and run when you want to run Chrome. Or download the attached file.

del "%LOCALAPPDATA%\Google\Chrome\User Data\chrome_shutdown_ms.txt"

start "" "%LOCALAPPDATA%\Google\Chrome\Application\chrome.exe"

run_chrome.cmd
145 bytes View Download
I have found the same thing as rockto, it's a fairly easy temporary fix as i could not find the txt. file that was specified earlier on.

I was trying to contribute to this discussion prior to my discovery of the "end process tree" method, however i had to access it in incognito and as a result i was signed out. I could then not sign in due to the Invalid server certificate, it was frustrating. 

I'm curious to see what is found to be the problem as it seems to be a very random select few who have experienced it, though all roughly at the same time by the looks of things so far.
@rockto, @jamie: are you saying that there is no chrome_shutdown_ms.txt file in your profile directory once you *close* Chrome?
My profile (the default, I guess) is listed at the location specified in #96 so yours might be the same.
Comment 99 by Deleted ...@, Apr 7 2012
I also have the same problem, it seems to affect Twitter.com,  google.com and us.army.mil. Pretty much any https site. 
Can someone post a simple easy to understand fix for the error to correct the "Invalid Server Certificate" Error.  I have downloaded the security certificate file which fixes the problem to run one session of Chrome, but needs to be run again next time I open it.  
coronabeach25, as far as I know this is a open, live issue being worked on. 
Comment 102 by Deleted ...@, Apr 7 2012

Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\CP\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\CP\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\CP\AppData\Local\Google\Chrome\User Data\Default


Windows Version: Windows 7


3) No conflicts

4) Oddly I this file didn't exist when I looked.

Chrome Conflicts.htm
281 KB View Download
Comment 103 by dhw@chromium.org, Apr 7 2012
Issue 122539 has been merged into this issue.
Comment 104 by Deleted ...@, Apr 8 2012
Having same issues since yesterday..

Has anyone consider this a symptom of re-direct virus, or is this just a sure thing chrome issue?

I as with most only experienced the issue with google sites, but only in chrome, not firefox.

I uninstalled Chrome, including all my data.. rebooted and reinstalled.. seems to be working fine now.. fingers crossed
1. Windows 7 ultimate (64bit)
2. 
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\Jonathan\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\Jonathan\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Jonathan\AppData\Local\Google\Chrome\User Data\Default

3. Modules (109) - No conflicts detected

4. the File was not there

5. I would like to Point out that if you Uninstall chrome and reinstall it.. it will fix the problem untell you close it out completly then you're back where you started... also I don't know if this will help at all but if you download something thought an SSL Connection thats over 150 MB it sends Chrome into a Loop after a Reinstall although I don't know if this was an app problem seeing as I was useing Internel SSL certificet Between my android cellphone and chrome.

6.I get all the sites to work just fine In firefox, IE, Opra, and Deadfuly enuff the AOL Browser (I found it on one of my backup Hard Drive). It seems to be with almost anysite that using HTTPS or SSL

@alen.siljak: sad to say it but it worked. by Deleting the txt file after Chrome closes fixed the problem 

Odd part is the txt file only had the numbers 1434 nothing ells in the chrome_shutdown_ms.txt file at all
Comment 107 by Deleted ...@, Apr 8 2012
I have this issue too. I reset windows7 64 to an earlier time, Chrome opened google sites fine for a few hours before the bug resurfaced. As with others, IE Firefox etc work fine.
happened to me as well it wouldnt even let me go to the google support page
1. windows 7
2. google chrome 18.o.1025.151
3. invalid server certificate you attempted to reach www.google.com but the server presented an invalid certificate. you cannot proceed because the website operator has requested heightened security for this domain
4. the identity of this website could not be verified, Server Certificate can not be checked, Server Certificate is invalid, the Server Certificate contains a weak cryptographic key
5. modules (98) no conflicts detected
6. looked but cannot see a file named chrome_shutdown_ms.txt
Everyone: In order to assist in resolving this, please attach your chrome://conflicts, as described in 3a from comment 53 - http://code.google.com/p/chromium/issues/detail?id=118706#c53

This is vital to be able to determine commonalities between the systems of affected users. 
cflannigan/comment #92/93: Your issue is completely different than this one. Please star http://code.google.com/p/chromium/issues/detail?id=122500 / Issue 122500 for your issues with penfed.org.
Please explain how to get to chrome conflicts to report/paste issues
Comment 112 by Deleted ...@, Apr 8 2012
Google Chrome: 18.0.1025.151 (Official Build 130497)
OS: Windows 7 Ultimate x64
WebKit: 535.19 (@113052)
JavaScript: V8 3.8.9.16
Flash: 11,2,202,229
Removing txt file helps. 
I actually used the batch uploaded by alen.siljak, and I'd like to thank him for that. I'm 80% satisfied on how that works...I recommend using that solution until a real one comes out.
conflicts.htm
258 KB View Download
Comment 113 by Deleted ...@, Apr 8 2012
just upgrade chrome from V 17 to 18 and got the same errors for goole.com & Gmail.

chrome - V 18.0.1025.151 m
W7 Ent. 64 bit.
conflicts.htm
198 KB View Download
chrome-google_8-4-2012.cer
688 bytes Download
81983ee9-5d64-48e2-8579-a27405428a5a
703 KB View Download
About Version.htm
7.9 KB View Download
Comment 114 Deleted
Comment 115 Deleted
Comment 116 Deleted
Comment 117 Deleted
I've started getting "The site's security certificate is not trusted!" for https://twitter.com , but only when using chrome.  

Chromes : vsn 18.0.1025.151 m 
OS :Windows XP service pack 3.  
chrome://conflicts reports :  Modules (157) - No conflicts detected

it was working yesterday, and the site works fine in firefox.

With IE I get : 
The security certificate presented by this website was not issued by a trusted certificate authority.

but at least with IE I get the option to continue on to the site.
so it must be something to do with the certificate issued to twitter.com 
I attache an export of the certificate. 

other https sites DO seem to work including gmail , my work connection, facebook 

I cannot find the chrome_shutdown_ms.txt  file anywhere. 

is there anyway to check what version of Google chrome I was running yesterday ? 

twitter.cer
2.3 KB View Download
One extra comment I just tried to login to my Lloyds bank online account https://www.golloyds.com/index/en

and I get the same error : 
The site's security certificate is not trusted!
BUT, for this site I get : 

You should not proceed, especially if you have never seen this warning before for this site.

with two buttons : 

'Proceed anyway'  'Back to safety'

and I see the same issue with IE : 'the certificate is not valid', but it lets you proceed to the site successfully. 

Also get the same the for Lonely Planet thorn tree website:  
https://secure.lonelyplanet.com
certificate attached. 

At least with these 2 sites the you can get around the error, but with twitter.com you are not able to proceed further. 

thorntree.cer
1.2 KB View Download
lloyds.cer
1.9 KB View Download
Comment 120 by Deleted ...@, Apr 8 2012
I don't understand how these forums work. This morning on here:
http://groups.google.com/a/googleproductforums.com/forum/#!msg/chrome/1alZsHEeprc/fCeAmA9WOrQJ
someone explained a workaround. But now the latest posts on that thread have disappeared. The workaround is as follows. Open chrome, then close it using the tab on the upper left, NOT the browser x on the upper right. Then reopen it. When I tried this, several times, then the bug went away. But of course it is not gone, just lurking. Where are all the chrome techs, eating blood of the lamb?
Comment 121 by Deleted ...@, Apr 8 2012
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\The Belanger Family\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\The Belanger Family\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\The Belanger Family\AppData\Local\Google\Chrome\User Data\Default

Windows 7 Home Premium Build 7600, 64-bit. 

chrome://conflicts show no conflicts.

Removing chrome_shutdown_ms.txt works initially, but on shutdown/restart, the issue re-appears.

PS - to all of you people crapping on Google for this issue - can I ask how much you paid for this product? Oh, you got it for free. I see. How much are you paying the G team to troubleshoot this issue over a holiday weekend? Oh, nothing again? I see. So please quit your complaining about a bug in a free product that is also being supported for free. I'm using Firefox for the duration of this bug, and when it's resolved, I'll switch back to the Chrome that I love and adore. First world problems, right? Go bite the ears off a few chocolate bunnies to make yourself feel better.

conflicts.htm
243 KB View Download
Comment 122 by Deleted ...@, Apr 8 2012
My browser fixed itself I guess. For some reason I am not having this issue anymore.
Comment 123 by Deleted ...@, Apr 8 2012
The following workaround resolved problem for me:

1)Open Google Chrome
2)Press Control-W. Google Chrome should close itself.
3)Open Google Chrome once again. It should work fine now.
4)Exit Google Chrome only using Control-W
  If you’ll close it using any other way, repeat steps 1)-3).

@1900geek: Which version of Chrome are you running?
Comment 125 by Deleted ...@, Apr 8 2012
Comment # 123 by dmitry.m is an incredibly simple fix and it does work for me. Thanks
What happens with #123 could be another bug in Chrome. :)
When the last window is closed the ms file is not created in the user's profile directory. Hence starting Chrome the next time works OK. 
Which is the same as if you delete the file prior to starting the browser.
Comment 127 by Deleted ...@, Apr 8 2012
I can confirm that Comment 123 resolves the issue for me as well
Comment 128 Deleted
Deleting "chrome_shutdown_ms.txt" after shutting down Chrome nor shutting down with Ctrl+W doesn't fix the problem for me, I still can't found "Proceed anyway" button when I open Twitter.

Currently I'm switching to Opera until this problem resolved. 

Google Chrome	18.0.1025.151 m
Windows XP Professional SP3

IE / Firefox / Opera : no problem opening twitter, no warning appeared about rejected certificate
certificate-no-proceed.jpg
47.4 KB View Download
Comment 130 by Deleted ...@, Apr 9 2012
Another way to solve the problem, although temporarily (each time you close it you have do repeat the setp), is one posted on other forum:
1. Open Task Manager
2. Select each Chrome.exe process and end it until Chrome closes
3. Open Chrome once again, it shows the message of restore last session, clic on restore and pages open normally.
Comment 131 Deleted
Comment 132 by Deleted ...@, Apr 9 2012
Google Chrome	18.0.1025.151 m
Windows 7 Home 64 bit
99 Modules no conflicts detected
Cannot find chrome_shutdown_ms.txt in user data or anywhere else
Ctrl+w does not do anything

conflicts.htm
224 KB View Download
Comment 133 by Deleted ...@, Apr 9 2012
Hi there.
I am having the same problem. It started 06 APR 2012 and It's just with Chrome. I am now using chrome after deleting the _ms.txt file each time before I open. Thanks to you all guys who are working on solving this problem. As far as I know a lot of ppl are issuing this and not many of them aren't competent enough to look for solving it in google or anywhere. They just prioritize IE or Mozilla to be their main internet browser. Whatever... I'm posting all the info for my issue:

- Machine: HP Pavillion Dv6-3010US
- OS: 64bit Win 7 Home Premium
- Chrome version: 18.0.1025.151 m
- Chrome://conflicts - NO CONFLICTS (attachment with screenshots below
- deleting the chrome_shutdown_ms.txt - WORKS
- closing with Ctrl+W - WORKS

If you need any additional information I will provide it.

chrome bug.rar
774 KB Download
Comment 134 by Deleted ...@, Apr 9 2012
Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Command Line	"C:\Users\juliew\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\juliew\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\juliew\AppData\Local\Google\Chrome\User Data\Default

Windows: Windows 7 Enterprise

No conflicts (attached)

Deleting the chrome_shutdown_ms.txt works (as does Ctrl+W)


conflicts.htm
239 KB View Download
Comment 135 Deleted
Comment 136 by agl@chromium.org, Apr 9 2012
Issue 122508 has been merged into this issue.
Comment 137 by Deleted ...@, Apr 9 2012
I didn't find a file named chrome_shutdown_ms.txt on my filesystem... but using "Clear Browsing Data..." (from beginning of time) seems to have resolved the issue. I've closed and opened Chrome several times over the last few hours, no repeat of the error yet. 
Comment 138 by Deleted ...@, Apr 9 2012
Still having issues here this morning.  Win7-64 Enterprise.  Cleared all browsing data, no luck. Reinstalled Chrome, no luck. Ctrl-W cleared it though, everything is fine now.

Google Chrome	18.0.1025.151 (Official Build 130497) m
OS	Windows
WebKit	535.19 (@113052)
JavaScript	V8 3.8.9.16
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19

Comment 139 Deleted
Comment 140 by Deleted ...@, Apr 9 2012
Same issue as everyone else is reporting.

Found out I had a rootkit virus that was causing me the same grief - I ran almost everything against it, but it would not remove. I then ran combofix against it and now my https certificate issues are gone.

http://www.techspot.com/vb/topic178245.html

Labels: ReleaseBlock-Stable Mstone-18
One more follow-up question as we continue to investigate things:

Can a few people post the contents of chrome://gpu. Please save the file (the same way described in 3a of http://code.google.com/p/chromium/issues/detail?id=118706#c53 ) and attach it to this issue?

Thanks
Comment 143 Deleted
Comment 144 Deleted
Comment 145 by Deleted ...@, Apr 9 2012
chrome://gpu output attached... still having the issue 
chrome-gpu.txt
3.3 KB View Download
Attached is my Chrome GPU info.

Please, guys, don't post the whole info page as a message text here in thread. The best way is to save the page as html and attach as a file to your message. Please do help others who are reading this thread that way.

Cheers
chrome gpu.htm
76.6 KB View Download
Comment 147 by Deleted ...@, Apr 9 2012
gpu attached
chrome gpu.htm
125 KB View Download
Comment 148 by Deleted ...@, Apr 9 2012
chrome gpu.htm
72.8 KB View Download
Same here.
Deleting the "chrome_shutdown_ms.txt" file got me running for now.
See attached info, good luck and thanks in advance.
chrome_gpu.htm
125 KB View Download
system_info.png
204 KB View Download
chrome_version.htm
8.0 KB View Download
Comment 150 Deleted
They were captured after deletion, in a working state.
I'll try to break it and post back.

Ok, I have some fresh captures from both states.
Version (obviously?) stayed the same.
GPU has different info in the log between the two captures.
Conflicts shows a different number of modules loaded between the two captures.
chrome_conflicts_broken_state.htm
247 KB View Download
chrome_conflicts_working_state.htm
222 KB View Download
chrome_gpu_broken_state.htm
124 KB View Download
chrome_gpu_working_state.htm
125 KB View Download
Comment 153 by Deleted ...@, Apr 9 2012
Hello, have you noticed any CAPI2 Errors in Event Viewer of your PC? 

I had the same behaviour for https sites in chrome and got it fixed. (OS: Windows 7 x64bit).  

I am copy-pasting from my response on google groups:(https://groups.google.com/a/googleproductforums.com/forum/#!msg/chrome/1alZsHEeprc/jf6sC5bdHNMJ)

I don't know if this helps. I have two tcp dumps (with wireshark). 

- The one is with the problem that we are discussing with the invalid certificate. In this tcp dump i see that chrome is downloading "http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab" . So i downloaded it manualy and the results is in the images attached. 

- The second tcp dump was done after closing chrome with Ctrl+w, reopened it, visited gmail.com and everything worked as it was supposed to. In this tcpdump there was no visiting in the MS website (windowsupdate.com). 

I managed to fix it on my PC!!! :-)

Have you guys checked your Event Viewer under Administrative Tools? I realized that i had a lot of CAPI2 Errors with the message "Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The specified procedure could not be found.
."

Actually, that one reminded me, that i had turned off Windows Updates. After enabling and did some updates, chrome started working again!!! (even if i close it from the X button and restart, all https sites are working)

So check your Event Viewer and do your updates. One good reason that i am thinking is that the local certificate of my PC were expired after a long period of no MS updates. I don't know why this happens to Chrome but i can think that chrome is using System Network Settings.

Waiting for your input as well. Right now i am doing a lot of updates, so I will come back in a while...

@ram...

I also have many CAPI2 errors in the event viewer.
My corporate security policy does not allow me to do updates.

I tried getting the authrootstl.cab file and installing it manually per MS' instructions, but that had no effect.
J.Cl... (and everyone who has commented so far): Was this record from chrome://gpu before or after you deleted the text file?

Sorry, it completely slipped my mind to indicate both states; a chrome://gpu log when the error happens (eg: chrome_shutdown_ms.txt is present) and a chrome://gpu log when the error is "fixed" (eg: chrome_shutdown_ms.txt isn't created / is manually deleted)
Comment 156 by Deleted ...@, Apr 9 2012
RSleevi - The chrome_shutdown_ms.txt file has never existed anywhere in my user profile directory, but the error still exists. 

Like J.Clay, I also have a large number of CAPI2 errors in the Event Log, but no pending Windows Updates (I just forced it to check, no updates available.) 
chrome gpu.htm
72.8 KB View Download
@shane...

Forgive me if this sounds patronizing.

Are you looking for it after launching chrome or while chrome is running?

If so, it disappears when you start chrome. I couldn't find it at first either.
Close chrome and refresh the appdata\local\google\chrome\user data directory. Delete chrome_shutdown_ms.txt before starting chrome.
Comment 158 by Deleted ...@, Apr 9 2012
RSleevi -

  No worries about patronizing. :) I was looking in the wrong place (and, oddly, windows search didn't find it either.) 

  I just tried deleting it prior to starting up - and was able to hit a few HTTPS addresses. However, once I shutdown the browser and restarted, the issue returns. I've attached the GPU output following the delete. 
chrome gpu_2.htm
72.8 KB View Download
Comment 159 by Deleted ...@, Apr 9 2012
@J.Cl... As i can see from your system info screenshot you dont have sp1 for win7 . Maybe you can get the offline installer of service pack1 for win7. Check http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5842

I have also found an old thread here: http://code.google.com/p/chromium/issues/detail?id=5313

updating my system worked for me...

ram...: Issue 5313 is unrelated.

However, thanks for confirming what I mentioned in http://code.google.com/p/chromium/issues/detail?id=118706#c79 . It appears that this only affects users who are not running Windows 7 SP1. While this is very useful information (as mentioned in comment #79), we'd still like to get to the root of this issue to understand what sort of adverse reaction is going on here.
@shane...

Yep, that's the same behavior I have. I just delete it before starting every time until this gets fixed.

@ram...

Thanks I wasn't aware there was one out yet. I'll give that a shot.
The standalone x64 SP1 didn't work... goin' for the full ISO!

Comment 162 Deleted
Comment 163 by Deleted ...@, Apr 9 2012
I downloaded sp1 for windows 7 and now it works for me . Thanks, I have been trying to figure our forever why my desktop worked fine but my laptop would not access the web pages.
Comment 164 by Deleted ...@, Apr 9 2012
Wait....are we saying that Google Chrome now requires SP1 on Win7 to function correctly with secure sites??
Comment 165 by Deleted ...@, Apr 9 2012
@rsleevi indeed 5313 is unrelated. 

If you need this, I've got two wireshark dumps - one session with the problem - and another without the https problem (closed tabs, restarted chrome and worked). Both are b4 updating to sp1 and the https site i was visiting is gmail.com.

Good luck with the root cause. Still very curious...

If it would help, I can abstain from installing SP1 for the moment to do some more prodding if needed.
J.Cl...: At the risk of punishing the helpful users, it would be rather helpful if you could abstain, just so we have a control.

I've spent quite a bit of time this past week/weekend/day trying to synthesize the failure, based on the information coming from chrome://conflicts and chrome://gpu, and have been unable to do so successfully so far. Having one or two controls will help us resolve this issue much quicker.

That said, once this issue is resolved, you definitely should consider upgrading to SP1. Lots of quality security fixes in there from Microsoft that you wouldn't want to be without =)
Comment 168 by Deleted ...@, Apr 9 2012
gpu not working.htm
124 KB View Download
gpu working.htm
124 KB View Download
My previous GPU info was for the case with deleted ms file and SSL sites loading fine.

Attached now is the one after I got the error. Comparing the two shows only two differences. Besides the date/time when the report was exported, the other one is 

Driver Information
Initialization time	174
in the no-problem case vs 176 in the case when there was the certificate error.

I am also one of those who can not update at the moment. But that's OK for now, it seems. 
GPU.7z
4.1 KB Download
Comment 170 by Deleted ...@, Apr 9 2012
Seems like a lot of people are working on this issue.

Is there any way the rest of us can be put on a "notification list" to find out when/how this issue is resolved?

Thanks!
-Jason
jason, if you star this bug, I will update it the minute we have a fix out the door.
@rsleevi

Sounds good, I'm fine just deleting the file to get it working for the moment.
Just let me know how I can help.
Hi jas...: Starring this bug is the best way to get continued updates as well as requests for further information.

One thing that would help is if you could save and attach copies of chrome://gpu and chrome://conflicts (as described in http://code.google.com/p/chromium/issues/detail?id=118706#c142 ), first without making any changes (eg: while it's broken), and then after deleting the file and relaunching chrome (eg: after it's fixed)

Thanks!
Comment 174 by kareng@google.com, Apr 10 2012
here you go: http://googlechromereleases.blogspot.com/2012/04/stable-channel-update.html

please let us know if you continue to see the issue once you upgrade to 18.0.1025.152

thank you so much for all the information and help!
Comment 175 by Deleted ...@, Apr 10 2012
Chrome auto-updated itself to the newest release and all seems well with the SSL issue; I can access most *.google.com sites now as well facebook.com among others.

Brilliant work, folks. It feels good to get back to using Chrome as my primary browser.

All - note Comment 174, which indicates 117371 may have regressed in this release. http://code.google.com/p/chromium/issues/detail?id=117371
Comment 176 by Deleted ...@, Apr 10 2012
This issue has hit me today. Never once had this problem.  I unistalled Chrome and reinstalled.  It worked for a few hours and now has happened again. 

What is causing this? 
Comment 177 by kareng@google.com, Apr 10 2012
bobduffy5 - which version of chrome are you using? we just pushed a fix and it's slowly making its way. 
Comment 178 by Deleted ...@, Apr 10 2012
I just received the auto update - everything seems to be working fine now. 

Great work, Google team! It's nice to have Chrome back...
Comment 179 by Deleted ...@, Apr 10 2012
Update has fixed my issue too - Win7 64bit, occurring on most but not all secure sites.
FYI. updating my status on 129

I've tried reinstalling Chrome, upgrading, the problem remains. 
And my PC at work are all installed Windows XP Professional SP3 so no Windows 7.
ele...: Given that the issue fixed by .152 should only have affected Windows 7 without any service packs, it's likely you're running into Issue 120715 / http://crbug.com/120715 or Issue 117834 / http://crbug.com/117834 . My instinct is that it is Issue 117834. To best determine this, please follow the steps from http://code.google.com/p/chromium/issues/detail?id=114709#c1 and report your results on Issue 117834. Thanks!
Comment 182 by Deleted ...@, Apr 10 2012
Thank you, update worked for me.
Comment 183 by Deleted ...@, Apr 10 2012
I'm good after update...thanks.
@rsleevi: will the update be pushed to the dev branch as well? I'm on 19.0 and having the same issue.
netman85am: We're currently looking at a different fix for the Dev branch, so I can't give a concrete ETA.

One thing that would be helpful would be trying the current Google Chrome Canary ( http://tools.google.com/dlpage/chromesxs ). This can run side-by-side with your existing (Stable/Beta/Dev) version, with a completely separate profile and settings. If you were to install the canary right now, you will likely find the issue exists there as well. However, as soon as the next canary is released (typically, nightly), you should hopefully find the issue resolved, without regressing Issue 117371.

If you (or anyone else currently running Dev) would give that a try, we'd love to hear your results and if you still continue to see the issue over the next day or two.
@rsleevi
Just installed canary 20.0.1096.1 and have no issues so far. Will keep you updated if it reappears in canary.
c186: Note, because Canary operates with a separate profile directory, you will need to exit and relaunch Chrome at least one (so that chrome_shutdown_ms.txt is created). Note that you will need to do the /opposite/ of the previous workaround, which is, make sure you close it via the red x in the top-right corner of the window, and NOT by pressing Control-W.

Certainly though, if you have any issues, please let us know.
Right. So far still happening, will let you know if next update fixes.
Comment 189 by Deleted ...@, Apr 10 2012
I'm working fine again after update to 152....thanks guys !
Comment 190 by Deleted ...@, Apr 10 2012
In continue to Comment #113: 

http://code.google.com/p/chromium/issues/detail?id=118706#c113

Upograde to V 18.0.1025.152 m did NOT help.
W7 SP1 64B

Comment 191 by Deleted ...@, Apr 10 2012
the .152 update seems to have fixed this for me as well.  Thanks for getting on top of this so quickly.  Great work!
18.0.1025.152 did NOT fix the issue.  Exact same SSL message still appear.  I'm on Windows XP.
Comment #190 (nam...) and Comment 192 (jca...)

Please see comment #181 ( http://code.google.com/p/chromium/issues/detail?id=118706#c181 ) and follow those steps. We'd love to be able to get you working as well. This applies to anyone else who is running Windows XP, as this issue only deals with Windows 7 64-bit.
Comment 194 by Deleted ...@, Apr 10 2012
In reply to #149 http://code.google.com/p/chromium/issues/detail?id=118706#c149

Unrelated to topic but your Windows product key is visible in that screenshot. Just thought I'll have you know...
OK, I submitted the information as you asked.  Interesting though that that bug was listed as being in Chrome 17, under which I saw no problem.
I just updated and the issue appears to be resolved for me as well.
Thank you for all your hard work Chrome Team!
@rsleevi, would you still like us to remain on the non-SP1 systems? I just got an offline installation of SP1 for Win7 64 but have no special preferences regarding updating the system just yet.

Just to report that 20.0.1096.1 dev-m, which just updated and relaunched the browser, still has the same issue. In case you were wondering. 
alen: If you can hold out a little bit longer, that'd be great.

My tentative fix just missed the cut-off window for the latest Dev. However, if you try the canary version (See comment #185), you shouldn't see the problem (after restarting Chrome appropriately to ensure chrome_shutdown_ms.txt is created)
Good. Testing with 20.0.1097.0 canary. The user profile created with chrome_shutdown_ms.txt file in it.
Getting Invalid Server Certificate on https://www.google.com
Testing with Facebook & Yahoo results in the same error message.

Were you referring to this version of Canary? 
Downloaded from http://tools.google.com/dlpage/chromesxs
Also to confirm that the trick with deleting the txt file works on the above version of Canary. Opening sites without problem in that case.
The .152 update seems to have solved the problem for me.Good work by the team.
Cc: rsleevi@chromium.org
Issue 122930 has been merged into this issue.
Comment 203 by Deleted ...@, Apr 11 2012
Add me to the list of woe but I'm not on Windows, I'm on crunchbang linux. When I just now tried getting the .152 update with 'apt-get update', it does not seem to be available.  I currently have version 18.0.1025.151.
rid...: Then could you file a different issue? This issue only affects Windows 7 64-bit users who are not running SP1.

Including the information requested in http://code.google.com/p/chromium/issues/detail?id=118706#c181 in the new bug will be the best way to get you sorted.
Comment 205 by Deleted ...@, Apr 11 2012
Version 18.0.1025.152 seems to have fixed this problem for me. Thank you!
Cc: -rsleevi@chromium.org
alen.../c#200: Thanks for your continued patience and assistance while we investigate this.

I was hoping to do some further follow-up steps to work on resolving this bug completely. While we've already gone through some crazy steps, what I'm about to propose has a bit more technical complexity, and a lot more words, and unfortunately no pretty Microsoft documents to describe the process like there were in comment 16 / http://code.google.com/p/chromium/issues/detail?id=118706#c16




The steps I'm going to be following are taken largely from http://www.chromium.org/developers/testing/page-heap-for-chrome . However, because this page is targeted more towards Chromium developers, I'm going to reproduce the steps below with hopefully as much detail as needed to walk through the steps and fill in the gaps.

Before we begin, close all instances of "Chrome Canary" / Chrome SxS that you may have running.

1) First, we'll need to install the 32-bit Windows Debugging Tools.
  a) Visit http://msdn.microsoft.com/en-us/windows/hardware/gg463009
  b) Select "Install Debugging Tools for Windows as a Standalone Component", and follow the download directions
  c) As noted on the page from 1.a), during the installation wizard, you must select JUST "Debugging Tools", and should deselect everything else. There should only be five checkboxes, but only "Debugging Tools for Windows" needs to be checked.

2) At the end of the installation, you should have the Debugging Tools for Windows installed in a path such as "C:\Program Files (x86)\Debugging Tools for Windows (x86)". Please make sure such a path exists before continuing, and that within that folder there is a file called "gflags.exe"

3) You will need to add the Debugging Tools to your PATH. To do this, do the following steps:
  a) Click Start/Windows Icon, then Right-Click "Computer" and choose "Properties"
  b) From the left-hand side, click "Advanced System Settings". This requires administrative access.
  c) This will launch the "System Properties" dialog, with the "Advanced" tab selected. From this tab, click the "Environment Variables" button
  d) This will launch the "Environment Variables" dialog. Under the "User variables for <your username here>", there will likely be a variable called "PATH" already. Click "Edit". If there is not, click "New" instead. Note this is under "User Variables", not "System Variables"
  e) If there was one already (and you clicked "Edit"), at the beginning of "Variable Value" add the path from Step 2, followed by a semi-colon (eg: "C:\Program Files (x86)\Debugging Tools for Windows (x86);", without the quotes). If there wasn't one, for the variable name, enter "PATH" (without the quotes) and for the variable value enter the path from Step 2.
  f) Click OK to dismiss the "Edit/Add User Variable" dialog
  g) Click OK to dismiss the "Environment Variables" dialog
  h) click OK to dismiss the "System Properties" dialog.

4) Log out of your computer and log back in. This will make sure the settings take effect.

5) Similar to Comment #35 ( http://code.google.com/p/chromium/issues/detail?id=118706#c35 ), we're going to start a new "Command Prompt" by clicking Start/Windows Icon and searching for "Command Prompt". However, instead of left-clicking the icon in the start menu, Right Click, and choose "Run as Administrator"

6) In the new command prompt, type the following commands, without the "a)", "b)", etc. However, for commands in quotes, include the quotes. Do not close this window, we'll be coming back to it continuing through these steps.
  a) set CHROME_ALLOCATOR=winheap
  b) gflags /p /enable chrome.exe /full
  c) "%LocalAppData%\Google\Chrome SxS\Application\chrome.exe" --no-sandbox

7) Note that in 6c, we're launching Chrome Canary, not your normal chrome. This is because you indicated in comment #200 that Canary still demonstrates the problem. You should have a new Chrome Canary window open (although it may take some time, because of step 6b.

8) Hopefully, at this point, or close to it, Chrome will crash ;-) If it never loads, that may be OK too. Just wait a little.

9) If Chrome launches successfully, please save a copy of your chrome://version to attach or paste into this bug. Can you browse HTTPS sites ok?

10) Click the Red X to close the window, not the tab (so that Chrome creates the "chrome_shutdown_ms.txt file"). Then repeat step 6c), relaunching Chrome.

10) Does Chrome crash? If not, try navigating to an HTTPS site again. Can you browse OK?

11) Close Chrome again (it doesn't matter how)

12) In the Command Prompt, run the following command to reset Chrome to its default (and non-slow/non-crashy) behaviour. This is important, as forgetting to do this can make Chrome unbearably slow
  a) gflags /p /disable chrome.exe

13) You can now close the command prompt.

14) You can now undo the changes done in Step 3, by following the same steps, except deleting the variable (if added) or editing it to remove the changes (if edited)

15) Launch Chrome Canary one last time. Load chrome://crashes , and report back any crash IDs you have that have been within the past week.

Phew! That's it (hopefully!). Thanks very, very much if you're able to complete these steps, but I understand if they're a bit complex.

As I mentioned, we're pursuing a different solution for Canary and future versions of Chrome, one that we believe will be the best of both worlds, but in the mean time, we'd like to gather more data from users who encountered this, to see if there are new or interesting third-party modules that may be misbehaving or bugs in the OS to work around.

Thanks again for your continued patience and assistance.
Hi Ryan,

Attached is the log of the debugging session. I installed the Debugging Tools, set the path manually and ran Canary according to instructions. Attached is the About Version HTML file at this point.
No crashes. Can not open HTTPS sites. 

After closing the browser I confirmed that the ms file is in the profile directory (sxs, as opposed to the dev profile). Relaunching does not make a difference. At this point I assume that the first run was intended for a clean installation of Canary? Does that make any difference?
Just to confirm to myself, I deleted the ms file, ran Canary in the same manner and successfully opened https://www.google.com.
Closing Canary created the ms file again.

Disabled page heap. Now ran Canary by using the program shortcut pinned in the windows taskbar.
Saving chrome crashes. Please note that there aren't any in the previous week (?!). 

OK, that it is according to instructions. Please do let me know if we missed anything. Thanks for the very detailed instructions. However, I see no useful information in here. Everything seems to work as expected and there are no any errors in any of the logs.
I am attaching all the commands executed and their logs. This message is the chronological log of events with files being extracted at specified positions in the message.

Hope this is useful.
Cheers
log.7z
6.7 KB Download
Windows Application Event Log is full of errors:
"Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: -1073741702 (0xc000007a)."
These were mentioned before in this thread. 
Running .152 and issue is not fixed (Win7 wSP1)
doing comment #206 not possible on work-pc
comment #209: Please comment 193 for further steps -  http://code.google.com/p/chromium/issues/detail?id=118706#c193
alen: Thanks very much for doing this, and attaching the log of the commands.

From your invocation, it appears you used the 64-bit debugger toolkit ("C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64"). That's likely why there weren't any crashes - as the 32-bit version of gflags needs to be used with Chrome (as it runs as a 32-bit exe).

Would it be possible to ask one more test run, this time indicating "C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x86" (if memory serves) as the path to the debugging tools?

Cheers
Hi, Ryan,

Not a problem. Here goes again. This time with 32-bit debugger.
Steps:
Prepare environment (same as before). Canary starts quickly again. No crashes. Invalid server certificate.

Closing the browser (x), relaunching. Invalid server certificate.

Closing the browser (x), deleting ms file, relaunching. Opening https://www.google.com works.
Closing the browser (x).

Stopping debugging options.

Launching via shortcut. Opening chrome://crashes. The results are the same as before - no recent crashes.

Attaching all log files. This time the debugger issued a message:
"Warning: pageheap.exe is running inside WOW64.
This scenario can be used to test x86 binaries (running inside WOW64)
but not native (IA64) binaries."

As you will see in the PATH, there is only path to x86 debugger listed. To confirm, here is the copy of running gflags, from Process Explorer - "C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x86\gflags.exe". 
So, this time a correct debugger ran but the results are the same. Canary has not crashed once. Everything seemed pretty much the usual. I have not tried any extras apart from opening www.google.com via HTTPS.

Do let me know if there is anything else I can do to help. 
Cheers
log2.7z
6.1 KB Download
Cc: eroman@chromium.org
Knowing the internals of the browser code, do you think any of this could be caused by security software like Avira Antivirus or Comodo Firewall with Defense?
I have not seen any warnings in their logs, though. There are only two notification flags "Access Memory" for Canary for the time I was running it.
[as in http://help.comodo.com/topic-72-1-284-2975-View-Defense+-Events.html]
I can't see them in the more detailed view. 
Anyway, nothing seems to have been blocked as far as I can tell.
Comment 215 by Deleted ...@, Apr 13 2012
Open "chrome://conflicts" and check for conflict with "rlvknlg.exe" - an Adware/Spyware named "RelevantKnowledge". Uninstall and reboot:)
Comment #215: As demonstrated by the number of users who included their chrome://conflicts, that isn't this issue. However, that is at least partially suspect for Issue 117834, so I'm glad you were able to resolve your issue.
Comment 217 by Deleted ...@, Apr 14 2012
Just got back from a week away to see that I've still got this issue, even after a upgrade. Is there anything you'd like me to do before going to sp1 - Win7 64bit?
chrome://conflicts: Modules (98) - No conflicts detected

Google Chrome	19.0.1084.24 (Official Build 131971) beta-m
OS	Windows
WebKit	536.5 (@113812)
JavaScript	V8 3.9.24.12
Flash	11,2,202,229
User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.24 Safari/536.5
Command Line	"C:\Users\A&E\AppData\Local\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Executable Path	C:\Users\A&E\AppData\Local\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\A&E\AppData\Local\Google\Chrome\User Data\Default
Comment 218 by Deleted ...@, Apr 15 2012
I realize this thread relates to Windows 7 users.  Where can I find a thread addressing this issue (https: invalid certificates) for Windows XP users? The ones I've found related to Facebook and Twitter but they're not a problem for me.  Lots of https sites work but it seems that banking and government sites in particular have invalid certificates according to Chrome (but not according to Firefox or Internet Explorer).
I have this problem with Chrome 18.01025.162 on Mac OS X 10.6.8. Only when going to Penfed.org. Works fine using Safari. It started 10 days ago or so. 
comment #217: This is not yet fixed in 19/20, as we're investigatinge a different fix. Going to SP1 is a reasonable fix as well.

comment #218: Follow the steps in http://code.google.com/p/chromium/issues/detail?id=114709#c1 and attach to Issue 117834. That will help determine what your issue is, but it's not this issue.

Comment #219: Please see Issue 122500 / http://code.google.com/p/chromium/issues/detail?id=122500 
Comment 221 by Deleted ...@, Apr 15 2012
RE: #220 (comment #218)  Thanks for the reply.  Will do, but I don't understand attaching it to issue 117834 since my problem seems to me to be in no way to be related to issue 117834.  That issue relates to Facebook logon and "weak signature algorithm" error messages. I have no problem logging on to Facebook, and get NO error message(s) when I do. 

Mine problem relates to invalid site certificates (and failure to successfully logon to https sites.)
Comment 222 by Deleted ...@, Apr 17 2012
Re #217 & #220, SP1 installed (after an evening backup) - everything fine now with v19.0.1084.24
comment #210: files are attached :)
Windows7 wSP1 running .162
google_Certificate.p7b
2.2 KB Download
CertificationPath.png
26.3 KB View Download
error.jpg
117 KB View Download
Labels: GoogleFeedback
The below data is provided based on user reports in 'GoogleFeedback'.
Chrome Versions		: 18.0.1025.162 

300+ users have reported this issue in GoogleFeedback since 4/12

What steps will reproduce the problem?
1. Try browsing web pages in Chrome browser

What is the expected result?
Web pages should render the sites normally

What happens instead?
Page displays "Invalid Server Certificate" for some websites. 

Most of the users have reported this issue while login to facebook.com

For more details, refer the report URLs below:
http://goto.google.com/220307679
http://goto.google.com/220184459
http://goto.google.com/156333571

For more user reports, refer the Cluster URL below:
http://goto.google.com/1012637

NOTE: We are unable to reproduce this issue across different versions of Chrome 

300+ users have reported this issue in GoogleFeedback since 4/12
Comment 225 by sleevi@google.com, Apr 18 2012
ranavdk: We should probably track those in a new bug. .162 should not be affected by this issue (laforge reverted on M18, this should be resolved, was left open for M19). Sounds like there's some sort of new regression?
@Sleevi - Created new bug - http://goto.google.com/124111.

250 reports for v18.0.1025.162 
Comment 227 by Deleted ...@, Apr 19 2012
It's been happening to me for 4 weeks now.
@comment 226: I cannot even open your link :-)
Can you post the full one?
error2.jpg
106 KB View Download
Comment 229 by Deleted ...@, Apr 20 2012
Same error for me with the lastest version. I cannot even log into Google Mail - I have to use FireFox instead (I am behind a proxy).


Security Error - Google Chrome_2012-04-20_09-07-00.png
94.6 KB View Download
Comment 230 by fja...@gmail.com, Apr 20 2012
Encountered this today when accessing http://www.intax.in.gov/
(which SOMETIMES says Invalid Server Certificate when it redirects to the https:// version of the site)

This is Chrome 19 beta on OS X Lion.

It also happens on Chrome 18 stable on my mom's iMac (running OS X Lion). She called me this morning asking me about the error. She had to use Safari to work around the problem.

Apparently Mac Chrome doesn't have chrome://conflicts/ because it says invalid URL when I go there.

Google Chrome	19.0.1084.24 (Official Build 131971) beta
OS	Mac OS X
WebKit	536.5 (@113812)
JavaScript	V8 3.9.24.12
Flash	11.2.202.229
User Agent	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.24 Safari/536.5
Command Line	 /Applications/Google Chrome.app/Contents/MacOS/Google Chrome --flag-switches-begin --flag-switches-end
Executable Path	/Applications/Google Chrome.app/Contents/MacOS/Google Chrome
Profile Path	/Users/mday/Library/Application Support/Google/Chrome/Default


invalidserver.png
155 KB View Download
Labels: Restrict-AddIssueComment-Commit
Status: Fixed
Marking this particular issue fixed, as the common root issue has been resolved on M18 and M19.

For any new users encountering this, please submit new bugs using the New Issue template - http://code.google.com/p/chromium/issues/entry - being careful to fill out all requested/available details. I'll be watching and duplicating common roots, but given that different users experience this for different reasons, I want to be sure that every bug is being kept separate and not lost in the noise.

Comment #228 - #230: Thanks for reporting this. To make sure your issues are not lost, I'd ask if you can file a new issue with the information requested on the new issue template.

Thanks!
Project Member Comment 232 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Internals-Network-SSL -Feature-Security -Mstone-18 Cr-Security M-18 Cr-Internals Cr-Internals-Network-SSL
Project Member Comment 233 by bugdroid1@chromium.org, Mar 13 2013
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Labels: hasTestcase
Sign in to add a comment