New issue
Advanced search Search tips
Starred by 7 users

Issue metadata

Status: Duplicate
Merged: issue 112983
Owner: ----
Closed: Mar 2012
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 117163: Crash when trying to play music from my ftp

Reported by nikita.c...@gmail.com, Mar 7 2012

Issue description

Chrome Version: 17.0.963.66
OS:Windows
Crash ID: I hadn't any crashes on crash page

URL (if applicable) where crash occurred: ftp://ciuclea.zapto.org/mp3/Gorillaz%20-%2054.mp3

Can you reproduce this crash?

What steps will reproduce this crash (or if it's not reproducible,
what were you doing just before the crash)?
1. Enter on my ftp in folder ftp://ciuclea.zapto.org/mp3/
2. Try to open any .mp3 file
3. You obtain crash

*Please note that issues filed with no information filled in above
will be marked as WontFix*
 

Comment 1 by rvargas@chromium.org, Mar 7 2012

Labels: Internals-Network-FTP Action-FeedbackNeeded
Please follow

http://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug

Is the whole browser crashing, or just that page?

Comment 2 by cem.koca...@gmail.com, Mar 7 2012

The whole browser crashes.

I can reproduce on Stable but not Canary. Perhaps already fixed?

Comment 3 Deleted

Comment 4 by nikita.c...@gmail.com, Mar 7 2012

This bug causes many troubles, for example if I had many important tabs opened in chrome and opened link with this mp3 I need to restart chrome and try to close tab with mp3 very fast.

Comment 5 by nikita.c...@gmail.com, Mar 7 2012

I followed your instructions and obtained this: http://paste.org.ru/?69on1l

Comment 6 by rvargas@chromium.org, Mar 7 2012

Labels: -Action-FeedbackNeeded
Status: Untriaged
http://crash/reportdetail?reportid=19e443049d857a91

Thread 12 *CRASHED* ( EXCEPTION_ACCESS_VIOLATION_READ @ 0x00000000 )

0x024f1b12	 [chrome.dll	 - url_request_ftp_job.cc:73	net::URLRequestFtpJob::StartTransaction()
0x0246ea43	 [chrome.dll	 - url_request.cc:490	net::URLRequest::StartJob(net::URLRequestJob *)
0x0246e7eb	 [chrome.dll	 - url_request.cc:435	net::URLRequest::Start()
0x0229ad46	 [chrome.dll	 - resource_queue.cc:67	ResourceQueue::AddRequest(net::URLRequest *,ResourceDispatcherHostRequestInfo const &)
0x0225cf53	 [chrome.dll	 - resource_dispatcher_host.cc:1661	ResourceDispatcherHost::InsertIntoResourceQueue(net::URLRequest *,ResourceDispatcherHostRequestInfo const &)
0x0225cf32	 [chrome.dll	 - resource_dispatcher_host.cc:1655	ResourceDispatcherHost::BeginRequestInternal(net::URLRequest *)
0x0225ae51	 [chrome.dll	 - resource_dispatcher_host.cc:670	ResourceDispatcherHost::BeginRequest(int,ResourceHostMsg_Request const &,IPC::Message *,int)
0x0225a6e7	 [chrome.dll	 - resource_dispatcher_host.cc:437	ResourceDispatcherHost::OnRequestResource(IPC::Message const &,int,ResourceHostMsg_Request const &)
0x02261171	 [chrome.dll	 - resource_messages.h:180	ResourceHostMsg_RequestResource::Dispatch<ResourceDispatcherHost,ResourceDispatcherHost,int,ResourceHostMsg_Request const &>(IPC::Message const *,ResourceDispatcherHost *,ResourceDispatcherHost *,void ( ResourceDispatcherHost::*)(IPC::Message const &,int,ResourceHostMsg_Request const &))
0x0225a404	 [chrome.dll	 - resource_dispatcher_host.cc:406	ResourceDispatcherHost::OnMessageReceived(IPC::Message const &,ResourceMessageFilter *,bool *)
0x022a8acd	 [chrome.dll	 - resource_message_filter.cc:40	ResourceMessageFilter::OnMessageReceived(IPC::Message const &,bool *)
0x022595e4	 [chrome.dll	 - browser_message_filter.cc:88	BrowserMessageFilter::DispatchMessageW(IPC::Message const &)
0x02259510	 [chrome.dll	 - browser_message_filter.cc:74	BrowserMessageFilter::OnMessageReceived(IPC::Message const &)
0x02417e2b	 [chrome.dll	 - ipc_channel_proxy.cc:90	IPC::ChannelProxy::Context::TryFilters(IPC::Message const &)
0x02417e56	 [chrome.dll	 - ipc_channel_proxy.cc:104	IPC::ChannelProxy::Context::OnMessageReceived(IPC::Message const &)
0x01c3ef92	 [chrome.dll	 - ipc_channel_win.cc:298	IPC::Channel::ChannelImpl::ProcessIncomingMessages(base::MessagePumpForIO::IOContext *,unsigned long)
0x01c3f24c	 [chrome.dll	 - ipc_channel_win.cc:389	IPC::Channel::ChannelImpl::OnIOCompleted(base::MessagePumpForIO::IOContext *,unsigned long,unsigned long)
0x01cf0c08	 [chrome.dll	 - message_pump_win.cc:514	base::MessagePumpForIO::WaitForIOCompletion(unsigned long,base::MessagePumpForIO::IOHandler *)
0x01cf0b4e	 [chrome.dll	 - message_pump_win.cc:477	base::MessagePumpForIO::DoRunLoop()
0x01cf05cd	 [chrome.dll	 - message_pump_win.cc:51	base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate *,base::MessagePumpWin::Dispatcher *)
0x01cf048e	 [chrome.dll	 - message_pump_win.h:64	base::MessagePumpWin::Run(base::MessagePump::Delegate *)
0x01cd7222	 [chrome.dll	 - message_loop.cc:459	MessageLoop::RunInternal()
0x01cd71a7	 [chrome.dll	 - message_loop.cc:432	MessageLoop::RunHandler()
0x01cd712a	 [chrome.dll	 - message_loop.cc:342	MessageLoop::Run()
0x0265eeca	 [chrome.dll	 - thread.cc:126	base::Thread::Run(MessageLoop *)
0x0265efb8	 [chrome.dll	 - thread.cc:161	base::Thread::ThreadMain()
0x01cde81b	 [chrome.dll	 - platform_thread_win.cc:58	base::`anonymous namespace'::ThreadFunc(void *)
0x7c80b728	 [kernel32.dll	 + 0x0000b728]	BaseThreadStart

Comment 7 by rvargas@chromium.org, Mar 7 2012

Labels: Area-Internals

Comment 8 Deleted

Comment 9 by di...@gelios.net, Mar 10 2012

Probably a dupe of  Issue 116960 

Comment 10 by phajdan.jr@chromium.org, Mar 10 2012

 Issue 116960  has been merged into this issue.

Comment 11 by phajdan.jr@chromium.org, Mar 10 2012

Mergedinto: 112983
Status: Duplicate

Comment 12 by bugdroid1@chromium.org, Oct 13 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:112983
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 13 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Internals-Network-FTP -Area-Internals Cr-Internals-Network-FTP Cr-Internals

Sign in to add a comment