New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 117027 link

Starred by 7 users

Issue metadata

Status: Fixed
Owner:
Closed: Mar 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

REGRESSION: Existing NewTabPage in Incognito window is not updating when a new theme is applied

Project Member Reported by mbollu@chromium.org, Mar 6 2012

Issue description

Chrome Version (from the about:version page): 19.0.1061.0 dev
Is this the most recent version: Yes
OS + version: Linux Ubuntu 10.04 Lucid Lynx, Win7, Mac 10.7.3
CPU architecture (32-bit / 64-bit): 64-bit
Window manager:
URLs (if relevant):
Behavior in Linux Firefox:
Behavior in Windows Chrome (if you have access to it): Issue happens on Win7

What steps will reproduce the problem?
1. Start chrome.
2. Have Normal and Incognito Window open.
3. Open couple of new tabs in both windows.
4. Install new theme.
5. Observe if the new theme gets installed in existing NTP.

What is the expected result?
Theme installed should be applied to existing NTP on normal/incognito windows.

What happens instead?
New Theme will not be installed in existing NTP in Incognito window.
New Theme will be installed in existing NTP in Normal window.
New Theme will be installed in newly created NTP in Normal/Incognito window.

Note: This issue is not reproducible on 19.0.1055.1 dev.

Please provide any additional information below. Attach a screenshot
and backtrace if possible.

 
Cc: ligim...@chromium.org anan...@chromium.org
Labels: ReleaseBlock-Dev
This issue is not reproducible on 18.0.1025.45 beta.


Labels: -ReleaseBlock-Dev ReleaseBlock-Beta
regression window please.
Regression window: This issue is reproducible on 19.0.1056.0 dev.
Here are the Bisect Results:
---------------------------

Trying revision 124034...
Revision 124034 is [(g)ood/(b)ad/(q)uit]: b
CHANGELOG URL:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk
/src&range=124016:124034
Built at revision:
http://src.chromium.org/viewvc/chrome?view=rev&revision=124034
Labels: Mstone-19
Owner: est...@chromium.org
Status: Assigned
Hey Evan,

It looks like http://src.chromium.org/viewvc/chrome?view=rev&revision=124021 caused a regression.  Could you take a look?

Comment 7 by dbeam@chromium.org, Mar 27 2012

Owner: dbeam@chromium.org
Status: Started
If I had to guess, I'd say this also affects the position of background images in themes when the bookmarks bar is attached / detached.

Anyways, here's a prospective fix: https://chromiumcodereview.appspot.com/9861016/

Comment 8 by est...@chromium.org, Mar 27 2012

laforge: sorry for missing this one.

Comment 9 by dbeam@chromium.org, Mar 27 2012

Labels: Merge-Requested
Project Member

Comment 10 by bugdroid1@chromium.org, Mar 27 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=129301

------------------------------------------------------------------------
r129301 | dbeam@chromium.org | Tue Mar 27 16:31:34 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/new_incognito_tab_theme.css?r1=129301&r2=129300&pathrev=129301
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/webui/ntp/ntp_resource_cache.cc?r1=129301&r2=129300&pathrev=129301
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/incognito_tab.html?r1=129301&r2=129300&pathrev=129301

[NTP4] Fix theme and bookmarks bar notifications.

R=estade@chromium.org
BUG= 117027 
TEST=Change theme with incognito browser open.

Review URL: https://chromiumcodereview.appspot.com/9861016
------------------------------------------------------------------------

Comment 11 by dbeam@chromium.org, Mar 27 2012

Status: Fixed

Comment 12 by laforge@google.com, Mar 29 2012

Labels: -Merge-Requested Merge-Rejected
We cut 1084 at r129376, so no merge should be needed for this.

Comment 13 by kareng@google.com, Mar 30 2012

Labels: -Mstone-19 -Merge-Rejected Mstone-18 Merge-Approved
please merge to M18 since it's a regression and broken there.

Comment 14 by dbeam@chromium.org, Mar 30 2012

Labels: -Merge-Approved Action-FeedbackNeeded
mbollu: Changing theme then with an incognito window open, clicking "Undo", and clicking "Reset to default theme" all work for me as expected in 18.0.1025.142 on Mac, Linux, and Windows. Are you sure this is an issue on this version? This was broken in 19, but that was a different issue.

Comment 15 by kareng@google.com, Mar 30 2012

Cc: mbollu@chromium.org

Comment 16 by Deleted ...@, Apr 1 2012

asd
Project Member

Comment 17 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 18 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Action-FeedbackNeeded Needs-Feedback
Project Member

Comment 19 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-UI -Type-Regression -Feature-Themes -Mstone-18 Type-Bug-Regression Cr-UI-Browser-Themes M-18 Cr-UI
Project Member

Comment 20 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment