New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 102 users
Status: Fixed
Owner:
Closed: Mar 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Unable to register protocol handlers in Chrome on Windows Consumer Preview
Reported by will.bou...@gmail.com, Mar 1 2012 Back to list
Chrome Version       : 19.0.1055.1
OS Version: 6.2
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
  Firefox 10.0.2: OK
     IE 10.0.8250.0: OK
	 Opera11.61:  OK
	 Opera Next 12.00:  OK

What steps will reproduce the problem?
1. Navigate to any page that contains links with non http URI schemes
2. Click non http URI scheme link

What is the expected result?
The browser should prompt the user, asking if they want to use an installed program to handle the link (the first time the user clicks that type of link).  The user should be able to set a program as the default handler for a specific protocol, or to be prompted each time they click that type of link.


What happens instead?
Apparently, nothing.  The refresh button momentarily changes to the stop button, but for less than half a second.

Please provide any additional information below. Attach a screenshot if possible.
Examples of non http URI scheme links that I am referring to can be found on many sites, including last.fm (lastfm:), steampowered.com (steam:), bittorrent sites (magnet:), gog.com (not sure of protocol syntax), Itunes (itms:), etc..  In general, I am referring to a link that appears on a web page that is intended to launch a program on the user's computer.

The area in settings that seems to relate to this does not give the option to add a protocol handler:
chrome://chrome/settings > Advanced settings... > Content settings... > Manage handlers...


UserAgentString: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/535.24 (KHTML, like Gecko) Chrome/19.0.1055.1 Safari/535.24
 
Cc: benwells@chromium.org
Comment 3 by jtan@chromium.org, Mar 14 2012
Labels: -Area-Undefined Area-UI Hotlist-ConOps
Status: Untriaged
Forgot to add that most reports right now are also from users running Stable 17.0.963.78 on Win 8 & Win7. 

@benwells - Are you the right person to look into this?
Comment 4 by jtan@chromium.org, Mar 14 2012
Cc: jtan@chromium.org
Getting the same error here on 19.0.1068.0 dev-m Win 8
same prob

Seeing the same issue on Linux, specifically Ping Eee 11.04, based on Ubuntu.
Comment 8 by Deleted ...@, Mar 18 2012
same here, Win8 CP - Chrome 17.0.963.79
Comment 9 by jtan@chromium.org, Mar 19 2012
Cc: koz@chromium.org
@Koz - Are you the right person to look into this issue? 
Comment 10 by Deleted ...@, Mar 20 2012
Same here, win8 CP 17.0.963.79 too
Owner: benwells@chromium.org
I've been on vacation and just saw this. I'll take a look.
Status: Assigned
I can't reproduce this on Windows 7, steam links are handled properly.

As Windows 8 has made changes to default programs, and there is only one report of it happening on Windows 7 on the forum threads but many on Windows 8, I'm assuming it is a Windows 8 only problem and that one report is a mistake.

Please let me know if anyone sees it on Windows 7.
Comment 13 by Deleted ...@, Mar 21 2012
im having this issue on windows 7 using latest version of Google chrome
duncan4000: This is what I did using Chrome 19.0.1068.1 dev-m

1. install Steam and set it up
2. go to the steam web site and find a steam link
3. tell the web site i have steam installed
4. I get a dialog asking me if I want to run the external application Steam, with a checkbox about whether I should ask again.

Could give the Chrome version you're using and the steps you use to reproduce?
Comment 15 by Deleted ...@, Mar 21 2012
The following steps fixed the issue for me (running "17.0.963.79 m" on Win7 Enterprise):
1) Quit Chrome. This is important as changes you make to the "Local State" file won't be saved if it is still running.
2) Browse to C:\Users\(YOUR USER NAME)\AppData\Local\Google\Chrome\User Data. Open the "Local State" file in notepad or any other clear text editor.
3) Search for a line with "magnet" in it. On that line, change 'true' to 'false' so that the line now reads "magnet": false. Save. 
4) Open Chrome and test.
I'm guessing there are two issues here:

1. On Windows 8, Chrome never thinks there is an external application to launch as the APIs have changed. This is a bug to be fixed.

2. On Windows 7, if you have in the past selected 'no, do nothing' at the prompt, and asked Chrome to remember this choice, you will never see the dialog again and this will appear broken.

As there is no user setting to change this you are stuck like this unless you edit your settings manually as alexdglover describes. This is doubly confusing as there is a section in settings for protocol handlers, but it is about sites handling schemes internal to Chrome, not external applications which this bug is about.

Does that match what you're seeing?
Regarding the previous comment:
Issue 1 is what I have noticed on every installation of Windows 8 (since starting with Dev. Preview in October) that I have observed.  The area in settings that you referred to has definitely caused me confusion when troubleshooting this issue.

I saw the same fix that alexdglo... posted; that is one of the first things that I tried.  Editing the line referring to 'magnet:' links (or adding a line for any other protocol) has no noticeable effect when running on Windows 8.
 http://crbug.com/119438  created for the UI confusion. I'll look into the Windows 8 issue in the coming week or two.
Project Member Comment 19 by bugdroid1@chromium.org, Mar 29 2012
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=129557

------------------------------------------------------------------------
r129557 | benwells@chromium.org | Wed Mar 28 18:59:45 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/shell_integration_win.cc?r1=129557&r2=129556&pathrev=129557

Allow external protocol handlers to open in Windows 8.

This was broken due to changes to the Windows 8 APIs around default
handlers. Chrome checks if it is the default handler for the protocol
before launching any external program. Prior to this change the check
on Windows 8 would always return success. This change makes it return
UNKOWN instead.

BUG= 116452 
TEST=Tested external handlers work on Win 7 and Win 8. Checked register
     protocol handler still works on Win 8.


Review URL: http://codereview.chromium.org/9863026
------------------------------------------------------------------------
Status: Fixed
Comment 21 Deleted
I just updated to 19.0.1084.1 dev-m, and I do not see any change regarding this issue.  All external protocols seem to be ignored still.
Comment 23 Deleted
Try moving your profile and trying again. Also, this might not yet be in the dev build. 
The fix isn't in 19.0.1084 (dev channel), but it is in 19.0.1085 (canary build). It should make it through to the dev channel in the next few days.
Comment 26 by Deleted ...@, Apr 7 2012
Thank you Ben.
Comment 27 by Deleted ...@, Apr 7 2012
Two dev channels have been release since your comment and this still doesn't work.
gmottac: That's strange. Have you tried moving / removing your profile?

If you have, please give more details about what types of links aren't working and what programs you have installed that should hancle the links.
Comment 29 by unde...@gmail.com, Apr 10 2012
19.0.1085 still hasn't been released on dev channel yet, those two updates only changed the version from 19.0.1084.1 to 19.0.1084.15 so far.
Perhaps you should try the canary build.
Comment 31 by sagi...@gmail.com, Apr 10 2012
Hi. I am now using 20.0.1096.1 with the win 8 consumer preview and still no
go
Comment 32 by unde...@gmail.com, Apr 11 2012
Using the dev channel version 20.0.1096.1 and Windows 8 Consumer Preview, I do not have this issue anymore, magnet:// and steam:// links both work perfectly now.
Comment 33 by sagi...@gmail.com, Apr 11 2012
Well, for some reason it doesn't work on mine,
I tried the canary build and it is working, I tried re-installing the dev
build and still no go
any ideas?
Comment 34 by Deleted ...@, Apr 11 2012
Using dev channel 20.0.1096.1 and it's working!! Thanks for fixing it guys.
After upgrading to 20.0.1096.1 this is working for me.  Thank you so much for resolving this issue!  It is great to have this functionality back after being without it for over five months.
Once allow a protocol to be handled by a local program, I still have no way to change the relation in Chrome's settings.  Is this being addressed in  issue 119438 ?   http://crbug.com/119438 
Comment 36 by Deleted ...@, Apr 13 2012
Worked on Canary 20.0.1099.1 (Canary), Windows 8 consumer preview! Didn't work on 20.0.1096.1 (Dev), nor on 19.0.1084.15 (Beta).
The fix should be in 20.0.1096.1.

If anyone still has the problem, please do the following:
- uninstall chrome and select yes to remove your browsing history
- install chrome
- give more details about what is going wrong
  - the version of chrome
  - a link you're trying to open
  - what program you have installed to handle it

If you know how you can replace the first steps with deleting your profile folder or manually editing your preferences as described earlier in the bug.

will.bou...: I'll try to get some eyes on that bug.
Comment 38 by Deleted ...@, Apr 16 2012
I have the same symptoms in Chrome on a Mac also.
Your mac issue is probably separate from this issue. 
I am running Chrome version 19.0.1084.52 m on Windows 8 Developer Preview and I have installed a test protocol which just launches notepad.exe, it still does not work for me, we do not use the Canary versions for testing, code must run on normal Chrome before it is released.  The chrome external protocol handler is definitely not working. Completely broken. Please fix it in stable versions!!. It works on FF and even IE QUIRKS mode.
And also the "Settings" > "Content Settings" > "Manage Handlers" > "Active Protocol Handlers" is always just blank - with an OK button.  "Manage" creates the impression you should be able to "Add", "Modify" or "Delete" something - or do I have this wrong? 
I can confirm its working in Canary 21.0.1150.0
As Windows 8 is not yet released we would not risk merging this issue into stable. Perhaps you can use the beta or dev channel (see http://www.chromium.org/getting-involved/dev-channel).

Also, about the confusing interface, there is a separate bug logged for that,  issue 119438 .
Thank you for this information
I'm on MacOS, I want to change the app magnet: links open with.  I looked at my "Local State" file, but it already has "magnet": false, under protocol_handler/excluded_schemes.
patriss...: Chrome will open whatever is the operating system default. Assuming chrome is calling one app, to change it to a different app you will need to do that in Mac OS or the app itself, not chrome.

I'm not a heavy mac user and don't know how to do that.
Comment 47 by Deleted ...@, Aug 18 2012
I'm using Chrome version 21.0.1180.79 m on Win 7 64 bit and this bug appears active again. 
Comment 48 by bkle...@gmail.com, Aug 20 2012
Same issue - unable to register any handlers, never prompted by Chrome and unable to add manually. Running OSX Mountain Lion and Chrome 21.0.1180.79.
Cc: gbillock@chromium.org
This bug was for not being able to register handlers on Windows 8, and has been fixed for that OS. If there are new issues please log new bugs with steps to reproduce the problem, and cc the same people on this bug. 
Project Member Comment 50 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 51 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-UI Cr-UI
Sign in to add a comment