New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 26 users

Issue metadata

Status: WontFix
Owner: ----
Closed: Jan 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 114871: Chrome doesn't recognise .url files properly

Reported by contaegi...@gmail.com, Feb 18 2012

Issue description

Chrome Version       : 19.0.1041.0
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 4.x: OK
     IE 7/8/9: OK
     Opera 11: OK

What steps will reproduce the problem?
1. Set other browser as default browser (thus changes default program for .url files to other browser)
2. Load Chrome. When prompted to make it the default browser, say yes.
3. Chrome doesn't automatically register .url files as a supported file type. [This is the first issue]
4. Manually set .url files to open with Chrome.
5. Click on .url file

What is the expected result?

Page loads properly

What happens instead?

Chrome displays .url file as a text file in the browser and doesn't read the link.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.21 (KHTML, like Gecko) Chrome/19.0.1041.0 Safari/535.21
 

Comment 1 by contaegi...@gmail.com, Feb 18 2012

chrome.JPG
45.8 KB View Download

Comment 2 Deleted

Comment 3 Deleted

Comment 4 Deleted

Comment 5 Deleted

Comment 6 by dhw@chromium.org, Apr 30 2012

Cc: ben@chromium.org
Labels: -Area-Undefined Area-UI Feature-Browser Feature-OSIntegration
Status: Untriaged

Comment 7 by Deleted ...@, Jun 5 2012

I have this behavior as well

Comment 8 by kabakov...@gmail.com, Jul 3 2012

Problem exists in Chromium 18.0.1025.168 (Developer Build 134367 Linux)

Comment 9 by contaegi...@gmail.com, Jul 20 2012

Okay, so in the last 2 days my laptop crashed and I had a fresh OS installation, so all programs were reinstalled. Oddly enough, this problem doesn't exist anymore for me. URLs are properly assigned to Chrome and they open to the proper page.

Can others please confirm if this problem still exists?

Comment 10 by contaegi...@gmail.com, Jul 30 2012

Using Version 22.0.1215.3 dev-m now.

Comment 11 by Deleted ...@, Aug 2 2012

I still have this issue. On Windows 7 Enterprise SP1 64bit, Chrome says it is up to date with version 21.0.1180.60.

Comment 12 by Deleted ...@, Aug 2 2012

Workaround: 
If you right-click to Properties on the URL file and change the "Opens with:" to "Internet Browser," the file opens with the app specified in your system setting for default browser. If your default browser is Chrome, the URL file opens properly in Chrome.

However, if you have another browser set as default browser, manually setting a specific URL file to open with Chrome still does *not* read the link and displays the file contents as text in the browser. I just noticed that this feature might be a Windows issue, not a Chrome issue. Setting the browser on the URL file to Firefox is having the same issue. 

OKAY--After I wrote all that, my system changed. Now file type is listed as 'Internet Shortcut' instead of 'URL' and when i right-click on properties, there is no option to change the "Open with:" setting for this type of file. Instead, there is a Web Document tab where you can modify the URL. 

An alternative workaround is here: http://blog.scoopz.com/2008/02/25/create-shortcut-to-open-url-in-non-default-browser/. Scroll down to Staci's tip on July 24, 2012. It seems convoluted, but it works.

Comment 13 by kareng@google.com, Aug 6 2012

Labels: checkedk

Comment 14 by mark.w...@gmail.com, Sep 3 2012

I've created a Chrome extension to get around this problem until the issue is fixed properly. It is called whenever a *.url file gets loaded directly (in plain text), detects the URL it should be linking to and then redirects the user automatically.

https://chrome.google.com/webstore/detail/nhmccpjmdhejpfhafcfajkgifkmjhkgf

Comment 15 by Deleted ...@, Sep 12 2012

To: mark.w...@gmail.com, re. Comment 14, Sep 3, 2012. I just posted this at https://chrome.google.com/webstore/detail/nhmccpjmdhejpfhafcfajkgifkmjhkgf:

'Excellent! And thanks. I had added "C:\Documents and Settings\<user>\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" -- "%1" to a new context menu item for .url files in Folder Options on my XP system, but to no avail: Chrome just read file's text innards. With your add-on, text appears briefly, to be replaced by the web page. First class. But, what a business!'

No further comment required!

Comment 16 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-UI -Feature-Browser -Feature-OSIntegration Cr-UI-OSIntegration Cr-UI Cr-UI-Browser-Core

Comment 17 by Deleted ...@, Jun 8 2013

I have a huge problem with this issue and Steam.  Chrome doesn't set the icon correctly, opens text in a tab every time I open a game (even after installing the extension, though at least the program loads), and I'm having issues with games crashing.

The easy solution is to let IE handle ".url" files so Steam shortcuts will work, but this is not acceptable to me.  I keep IE locked in a dungeon chained to the registry where it belongs.  If you have any suggestions, please advise...

Comment 18 by Deleted ...@, Nov 12 2013

Having this issue in Windows 8.1, Version 30.0.1599.101 m of Chrome

Comment 19 by Deleted ...@, Dec 6 2013

I have the same problem

Comment 20 by djee...@gmail.com, Dec 6 2013

It's still not fixed.
And nothing more or less!

Comment 21 Deleted

Comment 22 by rolandma...@gmail.com, Oct 14 2014

I could confirm with GChrome version 38.0.2125.101 (64-bit) - it still not handled, just opens a download dialog!

Comment 23 by Deleted ...@, Apr 6 2015

The Chrome extension does not work on my machine, presumably because the extension is now .website? Is there a fix for this?

Comment 24 by Deleted ...@, May 21 2015

Hi, I distributed this extension with group policy. My question is: is possible set hide the extension button, by ADM or registry? Thanks for reply.

Comment 25 by Deleted ...@, Jul 20 2015

Per the reviews of the extension:  You need to "Manage Extensions" find .URL Handler and check the box for "Allow Access to file URLs" in order to get this to work.

Once you do that, it does work for me using Chrome 43 on a Mac.

Thanks for the extension, Mark W.!

Comment 26 by Deleted ...@, Aug 6 2015

I dont think this is the correct place to ask, but i have been redirected to this page from the ".URL handler" chrome extension chrome webstore support page: https://chrome.google.com/webstore/detail/url-handler/nhmccpjmdhejpfhafcfajkgifkmjhkgf/support?hl=en-GB

Question: any way to make the extension work on linux? (debian 8 kde)

Comment 27 by salva...@gmail.com, Aug 9 2015

I use still WXP SP3 (for many years I hope). I was working around this issue some time because my Chrome V.44 (NOT my default browser) that have this behavior and for what the URL Hadler ext works fine, didnĀ“t recognize the char spaces of the Internet shortcuts. That is shortcuts with a name of 4 words opens 4 pages with DNS error.
I solved this issue "deleting" the quotation marks in the "command" line of the shell from the register (incomprehensible!). Now Chrome opens the URL as file:///C... in plain text, but SURPRISE! the URL Handler does not work for these URLs (continues working fine for shortcuts without spaces).
Anybody can confirm that this extension works Ok for shortcuts whith spaces in the name?

Comment 28 by Deleted ...@, Sep 22 2015

Hi all,

suffering this. If you have tampermonkey, see https://github.com/sweavo/chrome_open_url_files for a workaround.

Comment 29 by jason.gr...@gmail.com, Sep 24 2015

.URL Handler extension does NOT work for URLs with spaces in the name. The underlying issue is still present in Chrome 45 as well.

Comment 30 by mcmlxxii...@gmail.com, Dec 6 2016

So this started happening for me with the clean install of Windows 10 Pro x64 Insider Preview Build 14965. When I change the default to other browsers the page opens as expected. When I change it back to Google Chrome Version 55.0.2883.75 m (64-bit), it opens as file:/// instead of http://

Comment 31 by mlmason9...@gmail.com, Dec 22 2016

Ever since the last few builds of Windows 10 Insider Previews including 14986 I have been having this same issue!

When I double click a url file on my desktop or in a folder Chrome does not open the web site correctly. 

Here is a video of the issue!
https://www.youtube.com/watch?v=ZU8B_5Bvqws&feature=youtu.be 

And the topic is being discussed here as well.

https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/chrome/kneNTBOAo34/hu1MMjceEAAJ

Comment 32 by datkin...@gmail.com, Dec 31 2016

I'm seeing this behavior in the new insider preview of Win 10 as well.  This happens for me in Firefox also it's got to be a MS bug.  I did find a workaround for this.  Go into Control Panel -> Default Programs -> Associate a file type or protocol with a program.  Look for the .url extension and it's probably set to "Internet Browser".  Change it to Chrome (might have to browse to the .EXE) and hit OK.

Comment 33 by kwr...@geeqs.net, Dec 31 2016

Datkin, doing that for me causes this problem. Chrome ends up viewing the contents of the .url file in the Chrome browser window for me.

Comment 34 by lafo...@chromium.org, Jan 2 2017

Components: -UI>OSIntegration Internals>PlatformIntegration
Deprecating UI>OSIntegration in favor of the more generic Internals>PlatformIntegration

Comment 35 by bsep@chromium.org, Jan 26 2017

Status: WontFix (was: Untriaged)
It looks like Chrome opens .url files just fine on Windows 10, both by double-clicking it and by dragging onto Chrome.

If you're having this problem, check your settings. Open "Start>Settings>System>Default apps" and check that "Google Chrome" is listed under Web Browser. Also open up "Choose default apps by file type", scroll down to .url file and ensure that "Internet Browser" is listed next to it. As far as I can tell "Internet Browser" is correct for that setting.

Comment 36 by robexter...@gmail.com, Jan 30 2017

This has also been an issue now with an updated version of Chrome - we are in an Active Directory environment and Chrome is set as a default by Group Policy. Exporting the settings using DISM from a working PC does not solve the problem.

Is there some other way to set "Internet Browser" as the default?

Comment 37 by mlmason9...@gmail.com, Feb 2 2017

This issue at least for me anyway is now fixed with new Windows 10 insider Preview Build 15025!!!

Comment 38 by ndel...@cedarburg.k12.wi.us, May 30 2017

Seeing this URL file behavior across multiple version of Windows 10 in our environment. The Windows 7 workstations have no issues and only the Win 10 ones are affected.

Originally posted the issue here:
https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/chrome-admins/YlSH0PNKIfg/P9WI-l6pCAAJ

Comment 39 by i...@zane.it, Oct 7 2017

As of october 2017, I can confirm that this bug is not fixed yet.

For the ITALIAN-speaking people: I've documented the solution here https://turbolab.it/1450

Sign in to add a comment