New issue
Advanced search Search tips
Starred by 9 users
Status: Duplicate
Merged: issue 120336
Owner: ----
Closed: May 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
optimizeLegibility breaks font substitution on Windows
Reported by jklan...@gmail.com, Feb 17 2012 Back to list
Chrome Version       : 17.0.963.56 (Official Build 121963) m
URLs (if applicable) : http://mountaincat.org/font-fail.html
Other browsers tested:
  Safari 5.1.2: OK
  Firefox 10.0: OK
  IE 9: OK

The URL has a reduced test case. A paragraph uses the Georgia font, with optimizeLegibility. Apparently Georgia has been included with Windows since the Win2k days. Having the font installed is necessary to reproduce the bug.

The Georgia font does not have Japanese Glyphs. Hence font substitution should be used for Japanese text in the paragraph. But what happens is that no Japanese text is displayed at all. No Unicode substitution characters are displayed either. It is rendered as though the text is simply not in the source document.

 
Comment 1 by jklan...@gmail.com, Feb 17 2012
I forgot to note that I am running Vista x64 with Office 2007 and IE 9 installed, in case that makes any difference in reproducing the bug.
Labels: -Area-Undefined Area-WebKit WebKit-Fonts
Comment 3 Deleted
I've run into similar problems using Chrome 21 on Windows XP. With text-rendering: optimizeLegibility or geometricPrecision the last word of the title will display the missing character box:

http://jsfiddle.net/acdha/GRYdL/3/

This also shows another problem - the overlapping text before "(Recension" - but I'll open a second issue for that
I've run into a similar problem in Chrome 22 where unicode characters display the missing character box if accompanied by additional text of any kind. See this jsFiddle: http://jsfiddle.net/arXeh/8/

Removing optimizeLegibility or overriding with auto causes the unicode star to display properly once again.

This issue happens, as far as I can tell, regardless of font. This doesn't happen in Mozilla Firefox 17.0 or IE10, so it looks to be a Chrome-specific bug.
Project Member Comment 6 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-WebKit -WebKit-Fonts Cr-Content Cr-Content-Fonts
Project Member Comment 7 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Project Member Comment 8 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Fonts Cr-Blink-Fonts
Confirmed that this still happens using Chrome 26.0.1410.64 m on Windows XP.
Comment 10 by vboya@google.com, May 10 2013
This issue is not reproducible on Linux chrome Version:27.0.1453.81,
Win8 chrome:26.0.1410.64 
Mac OS X(10.8.3) chrome:26.0.1410.64.

  Opened a URL  "http://mountaincat.org/font-fail.html",It displayed the Japanese text :"There should be Japanese text between the arrows ---> 日本語 <---"
Labels: Needs-Feedback
Status: Untriaged
Comment 12 by jklan...@gmail.com, May 11 2013
I tested Chrome version 26.0.1410.64 m on several versions of Windows.

Case 0: http://mountaincat.org/font-fail.html

This is the original test case.

WinXPx32 -- PASS

WinVistax64 -- FAIL

Win7x64 -- PASS

Win8x64 -- PASS

Case 1: http://mountaincat.org/font-fail2.html

This is an updated test case that shows various combinations of font-family and text-rendering settings.

WinXPx32 -- PASS

WinVistax64 -- FAIL

The Japanese text on Vista is completely missing, with no placeholder boxes or other substitution characters. The only row that has the problem is the row with both the Georgia font (which does not have Japanese glyphs) and optimizeLegibility turned on. To verify this isn't a problem with my Vista install, I checked IE 9, which works correctly.

Win7x64 -- PASS

Win8x64 -- PASS

I also tested the two jsfiddle cases others posted.

Case 2: http://jsfiddle.net/GRYdL/21/

WinXPx32 -- FAIL

A blank box is displayed as the first character of the word "Ṭūsi" in the title "The Elucidation of the Memoir on Astronomy by Ṭūsi". When a manual rule is created via the developer console to force text-rendering: auto on that element, the text is displayed as intended. It is unclear why this test fails and the WinXP test for Case 1 passes.

WinVistax64 -- FAIL

The first character of the word Ṭūsi is completely missing, as in Case 1.

Win7x64 -- PASS

Win8x64 -- PASS

Case 3: http://jsfiddle.net/arXeh/8/

WinXPx32 -- FAIL

When the star appears by itself, as on the first line, it displays correctly. However if it appears with another star or other text, as on the subsequent lines, it is rendered as a blank box.

WinVistax64 -- FAIL

Same behavior as WinXP for this case.

Win7x64 -- FAIL

Same behavior as WinXP for this case.

Win8x64 -- FAIL

Same behavior as WinXP for this case.

*** Summary of Tests ***

Whether you get correct rendering, missing text, or boxes depends on the version of Windows and other unknown factors. The problem has not been completely fixed on any version of Windows tested, although some test cases pass for some versions of Windows. No version of Windows passed case 3.

Mergedinto: 120336
Status: Duplicate
Let me merge all the threads on "vista=>blank, {xp,7}=>rectangle characters" problem on font fallback with optimizeLegibility.
Sign in to add a comment